Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-01-2022 17:57:53

Akephalos
Membre
Inscription : 30-01-2022

Problème de carte graphique

Bonjour tout le monde,

j'ai un PC portable doté de deux cartes graphiques, l'une intégrée, et l'autre dédiée.

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1)



Le tout n'est pas tout jeune, certes, mais je n'arrive pas à utiliser le driver propriétaire nvidia. À savoir que c'est un système qui normalement utilise la technologie Optimus (si j'ai bien compris) qui est censée permettre de choisir avec quel carte graphique lancer tel programme. À la base, j'avais essayé avec Bumblebee, et constatant que ça ne fonctionnait pas, j'ai essayé avec Switcheroo.

Pour l'installation des drivers propriétaires, j'ai bien sûr activé les dépôts non-free, puis utilisé nvidia-detect qui m'a donné ce résultat :

Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1)

Checking card:  NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)
Your card is only supported up to the 390 legacy drivers series.
It is recommended to install the
    nvidia-legacy-390xx-driver
package.



J'ai donc installé celui-ci. Déjà à l'installation, j'ai eu un message d'erreur dans la console m'indiquant que le pilote était incompatible avec ma carte, et me demandant si je souhaitais poursuivre l'installation... J'ai répondu "oui", parce que le message ne faisait pas mention de nvidia-legacy-390xx.

Bref, suite à un redémarrage, switcherooctl me donne :

Device: 0
  Name:        Intel® HD Graphics 3000
  Default:     yes
  Environment: DRI_PRIME=pci-0000_00_02_0

Device: 1
  Name:        NVIDIA Corporation GF108M [GeForce GT 540M]
  Default:     no
  Environment: __GLX_VENDOR_LIBRARY_NAME=nvidia __NV_PRIME_RENDER_OFFLOAD=1



ce qui semble être plutôt encourageant. Malheureusement, si je lance __GLX_VENDOR_LIBRARY_NAME=nvidia __NV_PRIME_RENDER_OFFLOAD=1 glxinfo -B, j'obtiens un triste :

name of display: :1
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  39
  Current serial number in output stream:  40



Je ne sais pas si ça a une importance, mais j'utilise wayland. Cependant, j'ai essayé avec un environnement sous X et je n'ai pas eu plus de chance.

J'espère que vous pourrez m'aider.

Hors ligne

#2 30-01-2022 18:33:51

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème de carte graphique

Bonjour


À savoir que c'est un système qui normalement utilise la technologie Optimus
 


si cela était le cas tu aurais ce retour


00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
01:00.0 3D compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1)
 



la manière de configurer cela commencer par le gpu intel pris en natif par debian
commencer a vérifier si il a besoin d'un firmware (firmware-misc-nonfree)
ensuite vérifier les erreurs


journalctl -b -r -p err
 


toujours pour intel vérifier le log de X


cat /var/log/Xorg.0.log
 


si pas de bug voir aussi si il utilise "modeset" ou "xserver-xorg-video-intel"  (après 2007 de mémoire le gpu est mieux pris en charge par le noyau (modeset)
ensuite s' occuper de la carte nvidia (un petit doute sur la version du driver conseillé )
plutôt le driver 340 (a vérifier)
oui pour Switcheroo , si les deux cartes sont fonctionnelles

tu est sous buster ou bullseye  et quel bureau ?

ps: sous buster le legacy-340 est disponible (vérifier)

tu peu démarrer sous le gpu intel , et voir comment "nouveau" prend en charge ta carte nvidia en libre

Dernière modification par robert2a (30-01-2022 18:39:52)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 30-01-2022 19:16:43

Akephalos
Membre
Inscription : 30-01-2022

Re : Problème de carte graphique

Merci pour ta réponse robert2a.

Le chipset intégré Intel (HD Graphics 3000) fonctionne normalement correctement, je l'utilise déjà pour jouer aux jeux qu'il permet de faire tourner. Pas d'erreur le concernant dans journalctl ni dans le log de X. Quand je lance un programme en le sélectionnant avec switcheroo, c'est bien lui qui est utilisé. Quant à savoir s'il utilise "modeset" ou "xserver-xorg-video-intel", à priori c'est le premier parce que je n'ai pas xserver-xorg-video-intel installé. Et j'ai firmware-misc-nonfree installé.

Pour le driver nvidia, en vérifiant sur le site de nvidia (je ne l'ai pas installé en le téléchargeant sur le site, mais bien via le gestionnaire de paquets), c'est bien la version 390.xxx qui est donnée pour la carte Geforce 540M. La version 340.xxx, elle, n'a pas l'air de gérer les cartes graphiques pour PC portables.

Je suis sous Debian Bookworm, mais j'avais les mêmes problèmes sous Bullseye. Et j'utilise Sway, mais j'ai essayé sous XFCE avec les mêmes résultats.

Nouveau me permet en effet de basculer entre les deux cartes, a priori (en tout cas switcheroo ne m'insulte pas).

Hors ligne

#4 30-01-2022 20:31:35

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème de carte graphique

tout va bien alors smile
pour bookworm sur ce genre de machine  roll   ..............  tongue

je regarde pour le driver de ta carte nvidia , et je te répond pour la version du driver
ps: nvidia ne prend plus en charge avant "les chipsets pascal" pour les derniers drivers (si je me trompe pas "kepler n'est plus pris en charge )
et debian supprime doucement sur ses versions récentes les anciens drivers , il ne reste que nouveau . (je parle de nvidia (pour intel et amd normalement pas de problème ) ).

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#5 30-01-2022 20:37:50

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème de carte graphique

=> https://www.nvidia.fr/download/driverRe … x/70289/fr
=> https://www.techpowerup.com/gpu-specs/nvidia-gf108.g82

installe le driver legacy-340 que tu ne trouvera pas sur bookworm (sinon reste sur nouveau wink   )

ps : chipset "fermi"

Dernière modification par robert2a (30-01-2022 20:40:24)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#6 31-01-2022 11:22:14

Akephalos
Membre
Inscription : 30-01-2022

Re : Problème de carte graphique

Comment se fait-il alors que ma carte graphique fasse partie des cartes supportées sur la page de la version 390 ? (après les versions sur le site de nvidia et les versions legacy-xxx ne coïncident peut-être pas ?)

En fait je me suis aperçu, via le debug d'un jeu en développement, qu'avec le driver Nouveau j'avais un avertissement concernant une instruction de shader qui n'était pas supportée. Est-ce que tu sais s'il y a des chances que Nouveau ne supporte pas des fonctionnalités supportées par le driver propriétaire ?

Et puis ben sinon tant pis, je devrai rester sur Nouveau.

Hors ligne

#7 31-01-2022 11:44:48

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème de carte graphique

Bonjour

oui le gf108m => https://debian.pkgs.org/11/debian-nonfr … 4.deb.html
ps: carte 540m
je me suis trompé , ce driver supporte bien la génération "fermi"

tu fais comment l'installation du driver ?  ( et ta debian est propre ? , pas de résidu d ancien drivers nvidia ? , les headers sont installés ? )

par contre de ton #1


j'ai eu un message d'erreur dans la console m'indiquant que le pilote était incompatible avec ma carte
 


ça confirme que un souci avec cette version du driver .

Dernière modification par robert2a (31-01-2022 12:07:59)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#8 31-01-2022 16:16:36

Akephalos
Membre
Inscription : 30-01-2022

Re : Problème de carte graphique

Le message d'erreur (qui semble concerner le paquet nvidia-driver) que j'obtiens ici : https://paste.ee/p/4K3Ve

Oui ma debian est propre normalement. Pas de résidus d'anciens drivers nvidia, si ce n'est que j'ai refait plusieurs fois l'installation de la version 390.

Les linux headers que j'ai :
linux-headers-5.15.0-2-amd64 linux-headers-5.15.0-2-common linux-headers-5.15.0-3-amd64 linux-headers-5.15.0-3-common linux-headers-5.4.0-4-amd64 linux-headers-5.4.0-4-common linux-headers-amd64

Pour l'installation : apt-get install nvidia-legacy-390xx-driver

Hors ligne

Pied de page des forums