Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-01-2022 22:20:05

Simon44
Membre
Inscription : 18-02-2021

[Résolu] MAJ du paquet linux-image-5.10.0-8-amd64_5.10.46-5_amd64 KO

Bonjour,

Sur un ordi tournant sur Emmabuntus DE 4, c'est un ordi que je reconditionne pour le donner.
J'ai des erreurs logs de la MAJ des paquets :

Depuis l'interface :

Linux 5.10 for 64 bits PCs (signed)
linux-image-5.10.0-8-amd64_5.10.46-5



Error while installing package: impossible de copier les données extraites pour « ./lib/modules/5.10.0-8-amd64/kernel/drivers/iio/light/cm36651.ko » vers « /lib/modules/5.10.0-8-amd64/kernel/drivers/iio/light/cm36651.ko.dpkg-new » 



Sinon depuis la CLI :

emmabuntus@EmmaDE4:~$ sudo apt-get upgrade
[sudo] Mot de passe de emmabuntus :      
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  linux-image-5.10.0-8-amd64
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/53,6 Mo dans les archives.
Après cette opération, 2048 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
dpkg-deb (sous-processus) : decompressing archive '/var/cache/apt/archives/linux-image-5.10.0-8-amd64_5.10.46-5_amd64.deb' (size=53564732) member 'data.tar' : erreur LZMA : les données compressées sont corrompues
dpkg-deb (sous-processus) : impossible de copier le membre de l'archive depuis « /var/cache/apt/archives/linux-image-5.10.0-8-amd64_5.10.46-5_amd64.deb » dans le tuyau
du décompresseur : échec d'écriture (Relais brisé (pipe))
dpkg-deb: erreur: <decompress> subprocess returned error exit status 2
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 357217 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-image-5.10.0-8-amd64_5.10.46-5_amd64.deb ...
Dépaquetage de linux-image-5.10.0-8-amd64 (5.10.46-5) sur (5.10.46-4) ...
dpkg-deb (sous-processus) : decompressing archive '/var/cache/apt/archives/linux-image-5.10.0-8-amd64_5.10.46-5_amd64.deb' (size=53564732) member 'data.tar' : erreur LZMA : les données compressées sont corrompues
dpkg-deb: erreur: <decompress> subprocess returned error exit status 2
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-image-5.10.0-8-amd64_5.10.46-5_amd64.deb (--unpack) :
 impossible de copier les données extraites pour « ./lib/modules/5.10.0-8-amd64/kernel/drivers/iio/light/cm36651.ko » vers « /lib/modules/5.10.0-8-amd64/kernel/drivers/iio/light/cm36651.ko.dpkg-new » : fin de fichier ou de flux inattendue
I: /vmlinuz.old is now a symlink to boot/vmlinuz-5.10.0-11-amd64
I: /initrd.img.old is now a symlink to boot/initrd.img-5.10.0-11-amd64
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/linux-image-5.10.0-8-amd64_5.10.46-5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



J'ai cherché sur Internet et tester diverses choses mais cela ne change rien.

Merci de votre aide.

Dernière modification par Simon44 (31-01-2022 22:37:07)

Hors ligne

#2 31-01-2022 22:36:15

Simon44
Membre
Inscription : 18-02-2021

Re : [Résolu] MAJ du paquet linux-image-5.10.0-8-amd64_5.10.46-5_amd64 KO

Bon je m'en suis sorti en suivant cette page :
https://www.cyberithub.com/how-to-fix-b … y-methods/

Hors ligne

Pied de page des forums