Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-02-2022 14:03:06

Elzen
Modérateur
Distrib. : Debian Sid GNU/Linux
Noyau : amd64 (à jour le vendredi)
(G)UI : Touhy
Inscription : 01-07-2014

Récupérer/bloquer certaines vieilles versions de paquets ?

Bon, d'abord, une petite remarque : ce que je dis ici concerne mon usage très particulier. Si vous êtes des utilisateurs «normaux» pas spécialement bidouilleurs (typiquement, si utiliser sysvinit à la place de systemd est quelque chose dont vous ne voyez ni ce que ça change, ni comment on fait ça), ne faites pas comme moi, ça évitera de vous poser des soucis parfaitement inutiles. Voilà, ça, c'est dit.


Maintenant, ma situation.

Comme j'suis un vieux ronchon allergique au changement, mais pas trop, j'avais sur mon ancien ordinateur une Debian Sid avec sysVinit plutôt que systemd, quelques logiciels du style X-Chat qui arrivent et repartent dans les dépôts régulièrement, et surtout deux logiciels en version bloquée: The GIMP, parce qu'une de ses mises à jour faisait disparaître le plug-in resynthesizer (celui qui permet de refaire automatiquement des morceaux d'images, seul plugin utile selon moi, mais qui visiblement n'était pas compatible avec une MàJ de Python) et Firefox(-ESR), parce que j'utilise un userChrome.css personnalisé pour avoir une apparence un minimum regardable, et qu'évidemment, comme ils changent tout à chaque mise à jour et qu'on a environ aucune info sur comment leur bouzin est organisé, ça n'aide pas à réparer.

À la base, j'avais bloqué ces deux paquets (et p't'être quelques autres, je n'sais plus) en me disant que, de toute façon, mon ordi était en fin de vie, je pouvais bien rester comme ça quelques temps histoire d'être tranquille et que je me remettrai à jour une fois sur un nouvel ordi. La fin de vie a duré un brin plus longtemps que prévu (ordi de Schrödinger, tout ça), mais donc, ça y est, j'ai un nouvel ordinateur. Sauf que j'ai aussi tout à réinstaller proprement dessus, et que du coup, essayer de me battre avec le userChrome.css de Firefox, ça me saoule toujours autant, si ce n'est plus vu tout ce que j'ai à faire à côté. Et que de toute façon, je vais sans doute remettre en place quelques vieux trucs en python2 que j'avais codé moi-même et que je n'ai toujours pas eu le temps et l'énergie de migrer.

J'ai déjà eu besoin d'activer les dépôts stretch pour réinstaller X-Chat, qui visiblement n'est présentement pas dans les dépôts Sid en ce moment. Et je remarque, en utilisant un peu le nouveau Firefox, que la seule chose qui me saute aux yeux en termes de différence de fonctionnalités, c'est qu'il y a des trucs qui ont disparu (typiquement, l'option de menu contextuel «afficher l'image» a disparu au profit d'un «ouvrir l'image dans un nouvel onglet». Sachant que l'ancienne version permettait déjà de l'ouvrir dans un nouvel onglet en pressant juste la touche ctrl, mais évitait de multiplier les onglets si on voulait juste voir l'image, c'est quoi l'intérêt?)

Bref, comme je suis un vieux ronchon allergique au changement, je me demande si je ne vais pas essayer de retrouver dans les multiples versions des dépôts les versions de ces paquets que j'utilisais sur mon ancien ordi, et maintenir tout dans cet état jusqu'à nouvel ordre. Mais, comme je ne suis pas non plus complètement fermé, si vous avez de bonnes raisons pour lesquelles je devrais ne pas faire ça, par exemple une nouvelle fonctionnalité trop géniale que je n'aurais pas remarqué ou un souci majeur à utiliser les vieilles versions je vous lis avec attention :-)

(P.S.: Je ne suis qu'au tout début du processus de réinstallation complète de mon système, le nouvel ordi étant arrivé hier. Je risque donc d'avoir d'autres raisons de râler, typiquement autour de ces histoires de Python 2/3, donc ce post n'est possiblement pas le dernier ici pour râler. Ceci dit, j'ai quand même profité du changement pour mettre des trucs à jour. Typiquement, quand elle était sortie, la version Python 3 d'offlineimap buguait sur certaines histoires d'encodage, donc j'avais bloqué la version Python 2 sur mon ancien ordi. Je viens de tester, la dernière version a visiblement réussi à synchroniser mes mails sans aucun souci, donc c'est bon, pour ça je reprends le cours normal des mises à jour. Par contre j'ai quand même viré systemd au profit de sysVinit à l'installation de l'ordi, 'faut pas déconner.)

Hors ligne

#2 22-02-2022 14:39:59

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Récupérer/bloquer certaines vieilles versions de paquets ?

Hello
J'ai pas tout compris de pourquoi tu rales , mais il semble que maintenant la version ESR de firefox se mette a jour en arriére plan , c'est ce que j'ai constaté quand il est passé de 91.4 a 91.6.0

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 22-02-2022 16:36:51

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : Récupérer/bloquer certaines vieilles versions de paquets ?

je n'ai pas de mise a jour en arrière plan de firefox-esr sur bookworm (et j'en veut pas)
je suis sur la version 91.5.0esr(64bits) des dépôts de debian


apt policy firefox-esr
firefox-esr:
  Installé : 91.5.0esr-1
  Candidat : 91.5.0esr-1
 Table de version :
 *** 91.5.0esr-1 500
        500 https://deb.debian.org/debian bookworm/main amd64 Packages
        100 /var/lib/dpkg/status
 


ps: pour systemd je vois pas ou est le souci  roll


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD 5700X ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#4 23-02-2022 09:50:47

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Récupérer/bloquer certaines vieilles versions de paquets ?

j'ai pas vérifié la version du paquet robert2a , mais regarde par curiosité le a propos de quand tu es sur Firefox

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 23-02-2022 16:12:17

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : Récupérer/bloquer certaines vieilles versions de paquets ?

Bonjour
Ce que j'ai regardé en premier c'est : Aide =>  "A propos de Firefox"
Notes de version : => https://www.mozilla.org/en-US/firefox/9 … out-dialog

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD 5700X ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

Pied de page des forums