Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-03-2022 01:04:28

Jroom31
Membre
Inscription : 02-03-2022

Ecran secondaire inactif

Bonjour à tous,

Premier blocage sur un Debian 11 fraîchement installé et premier message pour moi ici. Promis, je me présente bientôt smile

Sur KDE je n'ai pas d'écran secondaire, il est comme débranché, hors sur SDDM et Gnome il marche correctement. Ça fait plusieurs jours que je cherche mais impossible de trouver la solution.


Voilà la config :

WARNING: you should run this program as super-user.
  *-display                
       description: Display controller
       product: Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:03:00.0
       version: c2
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: iomemory:60-5f iomemory:50-4f irq:86 memory:600000000-7ffffffff memory:500000000-5001fffff memory:d0800000-d087ffff memory:d08a0000-d08bffff
  *-display
       description: VGA compatible controller
       product: Renoir
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:07:00.0
       version: c6
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list
       configuration: driver=amdgpu latency=0
       resources: iomemory:fc0-fbf iomemory:fc0-fbf irq:76 memory:fcc0000000-fccfffffff memory:fcd0000000-fcd01fffff ioport:1000(size=256) memory:d0400000-d047ffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System: linux Debian
Current Operating System: Linux JROOMIAN 5.10.0-11-amd64 #1 SMP Debian 5.10.92-1 (2022-01-18) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.10.0-11-amd64 root=UUID=e0224e9c-8e99-4ed6-b2c4-c8d846210d77 ro quiet
Build Date: 16 December 2021  05:08:23PM
xorg-server 2:1.20.11-1+deb11u1 (https://www.debian.org/support)
Current version of pixman: 0.40.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.





Xrandr sur KDE :

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080    144.00*+
   1680x1050    144.00  
   1280x1024    144.00  
   1440x900     144.00  
   1280x800     144.00  
   1280x720     144.00  
   1024x768     144.00  
   800x600      144.00  
   640x480      144.00  
DisplayPort-1 disconnected (normal left inverted right x axis y axis)





Xrandr sur Gnome :

Screen 0: minimum 16 x 16, current 4480 x 1080, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080    143.88*+
XWAYLAND1 connected 2560x1080+1920+0 (normal left inverted right x axis y axis) 690mm x 290mm
   2560x1080     59.98*+




J'ai essayé de créer un nouvel utilisateur et de branché l'écran en displayport, idem écran noir.
J'ai aussi tenter  sudo dpkg-reconfigure -phigh xserver-xorg

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr:en_US",
        LC_ALL = (unset),
        LANG = "en_150.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory




Auriez-vous une piste pour m'aider à résoudre ce problème ?

Merci, Jérôme.

Hors ligne

#2 03-03-2022 06:10:46

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran secondaire inactif

Bonjour
tu a la réponse sur tes retours smile

KDE => serveur X
Gnome => xwayland ( Wayland)

j'ai appris que xrandr fonctionne sous wayland  wink (grace au paquet xwayland je suppose)
je suppose aussi que le paquet "firmware-amd-graphics" est installé (deux gpu AMD)

ps: je suppose qu'il est possible de passer le bureau sous Wayland sous KDE ? (serait peut être la solution ).

nota : comme je connais pas tout , SDDM est le gestionnaire de connexion de KDE (gdm3 pour gnome ).


Simple Desktop Display Manager (SDDM) est un gestionnaire d'affichage
 (un programme de connexion graphique et un gestionnaire de session)
 pour les systèmes de fenêtrage X11 et Wayland.
 SDDM a été écrit à partir de zéro en C++11 et prend en charge les thèmes via QML
 

Dernière modification par robert2a (03-03-2022 06:20:33)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 08-03-2022 09:36:42

Jroom31
Membre
Inscription : 02-03-2022

Re : Ecran secondaire inactif

Bonjour Robert,

En effet c'est le serveur d'affichage qui pose problème. Firmware-amd-graphics est bien installé.

Concernant le gestionnaire de connexion, après vérification, c'est bien GDM3 et non SDDM, donc wayland également.

Idéalement il faudrait que je debbug le serveur x et que j'essaye également wayland histoire d'avoir une alternative en cas de plantage d'un des deux.

Je n'ai pas réussi à trouver le problème jusqu'à présent donc j'utilise Gnome pour dépanner.

Comme dit précédemment, la commande 'sudo dpkg-reconfigure -phigh xserver-xorg' ne donne rien.
Je n'ai pas de fichier '/etc/X11/xorg.conf'

Si quelqu'un à un peu d'aide à m'apporter pour debbuger x et/ou passer à wayland sous kde, je suis preneur.

Hors ligne

#4 08-03-2022 09:53:37

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran secondaire inactif

Bonjour
activer wayland sur KDE , faut faire une recherche (a priori a partir de l'invite de connexion en général ).
pour le log de X , c'est dans ton /home/$USER/.local/share/xorg/Xorg.0.log

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#5 08-03-2022 10:01:22

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran secondaire inactif

regarde ici , et suis les liens => https://wiki.debian.org/Wayland#KDE
normalement avec un gpu AMD ça ne pose pas de problèmes
et aucune idée si les paquets de wayland sont installés
=> https://www.debian-fr.org/t/debian-10-k … nd/82856/8

=> https://wiki.debian.org/fr/Wayland

pour tester si le  bureau est wayland


echo $WAYLAND_DISPLAY
 


si aucun retour tu est sous X

Dernière modification par robert2a (08-03-2022 10:09:57)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#6 09-03-2022 01:44:11

Jroom31
Membre
Inscription : 02-03-2022

Re : Ecran secondaire inactif

Encore merci, j'ai un peu avancer. J'ai installer les paquets suivants :

plasma-wayland-protocols
plasma-workspace-wayland

Sur le gestionnaire de connexion, j'ai bien le choix 'Plasma Wayland'. Mais toujours pas d'écran secondaire, ça serait trop facile sinon :lol:

J'ai testé, je suis bien sur wayland

$WAYLAND_DISPLAY


wayland-0



Mais contrairement à Gnome, qu'une seul écran détecté.

xrandr


Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080    143.88*+
 



Du côté du serveur X, j'ai installé les paquets suivants :
xserver-xorg-video-nvidia
nvidia-xconfig

J'ai pu généré un fichier xorg.conf avec ce dernier paquet mais ça ne change rien puisque xrandr ne détecte toujours pas mon second écran, je ne peux donc pas l'ajouter à la conf.

J'ai plusieurs paquets xorg d'installer, je me demande si c'est pas qui fou la merde. Je vais essayer de désinstaller ceux qui n'ont pas l'air de me concerner pour voir :
xserver-xorg-video-ati (Je n'ai pas de carte ati)
xserver-xorg-video-intel (je n'ai pas d'APU ni de GPU intel)
xserver-xorg-video-nouveau (j'utilise le pilote amdgpu)
xserver-xorg-video-all
xserver-xorg-video-amdgpu
xserver-xorg-video-radeon

Il y a juste celui ci qui pourrait me concerner et qui n'est pas installé:
xserver-xorg-video-amdgpu-video-amdgpu

Hors ligne

#7 09-03-2022 07:19:53

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Ecran secondaire inactif

de ton #1
ps: la commande est a faire en root plutôt


*-display                
       description: Display controller
       product: Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:03:00.0
       version: c2
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: iomemory:60-5f iomemory:50-4f irq:86 memory:600000000-7ffffffff memory:500000000-5001fffff memory:d0800000-d087ffff memory:d08a0000-d08bffff
  *-display
       description: VGA compatible controller
       product: Renoir
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:07:00.0
       version: c6
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list
       configuration: driver=amdgpu latency=0
 


tu a deux gpu AMD

la seule chose a faire est de virer ceci


Du côté du serveur X, j'ai installé les paquets suivants :
xserver-xorg-video-nvidia
nvidia-xconfig
 


pourquoi installer le driver "nvidia" ? ( non free propriétaire )  sur KDE


apt remove --purge xserver-xorg-video-nvidia nvidia-xconfig nvidia*
 


et puis pourquoi installer un driver de X , alors que tu veut utiliser wayland ?
regarde si ceci est présent


apt policy firmware-amd-graphics
 



tu peu regarder les drm sous KDE


dmesg | grep -i drm
 


regarder les erreurs


journalctl -b -r -p err
 


les firmwares


dmesg | grep -i firmware
 



je connais pas wayland , mais en théorie il utilise le noyau pour configurer les gpu ( et des modules du noyau pour le driver ) .
avec 2 gpu pris en charge en driver libre rien a faire (pour toi c'est "amdgpu" qui est utilisé )
de plus vouloir supprimer des drivers de X sous KDE pas une bonne idée (de toute manière il ne devrait pas être utilisé) et tu risque de casser ton bureau .
il me semble que tu comprends pas trop ce que tu fais et les conséquences. roll
il y a peut être simplement un bug sous KDE pour deux écrans (puisque gnome fonctionne bien )

Dernière modification par robert2a (09-03-2022 07:20:51)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#8 11-03-2022 00:21:13

Jroom31
Membre
Inscription : 02-03-2022

Re : Ecran secondaire inactif

Bonjour Robert,

Je retenté, sans succès, après deux semaines de perte de temps je t'avoue que je me suis découragé.
J'ai installé Fedora et KDE pour découvrir l'univers Red hat, tout fonctionne parfaitement sur le serveur x et sur wayland.

Merci beaucoup pour le temps que tu as pris pour m'aider et bonne continuation smile

Hors ligne

Pied de page des forums