Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-03-2022 19:00:10

poimlk
Membre
Inscription : 13-03-2022

commande checkrestart

Debian 11

J'ai installé le paquet debian-goodies, par contre quand je lance la commande
checkrestart

j'ai

 checkrestart
bash: checkrestart : commande introuvable
 



Je suis perplexe

L'installation de debian-goodies n'a rien signalé

sudo apt install debian-goodies
[sudo] Mot de passe de gg :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcapi20-3 libcapi20-3:i386 libfaudio0 libfaudio0:i386 libmpg123-0:i386 libstb0 libstb0:i386 libxslt1.1:i386 linux-image-5.10.0-10-amd64
  linux-image-5.10.0-8-amd64
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  autoconf automake autopoint autotools-dev dctrl-tools debhelper dh-autoreconf dh-strip-nondeterminism dwz elfutils equivs gettext intltool-debian
  libarchive-cpio-perl libarchive-zip-perl libasm1 libdebhelper-perl libfile-slurper-perl libfile-stripnondeterminism-perl libfile-which-perl
  libltdl-dev libmail-sendmail-perl libperlio-utf8-strict-perl libsigsegv2 libsub-override-perl libsys-hostname-long-perl libtool m4 po-debconf
  popularity-contest
Paquets suggérés :
  autoconf-archive gnu-standards autoconf-doc debtags dh-make apt-file konqueror gettext-doc libasprintf-dev libgettextpo-dev libtool-doc gfortran
  | fortran95-compiler gcj-jdk m4-doc libmail-box-perl tor torsocks
Les NOUVEAUX paquets suivants seront installés :
  autoconf automake autopoint autotools-dev dctrl-tools debhelper debian-goodies dh-autoreconf dh-strip-nondeterminism dwz elfutils equivs gettext
  intltool-debian libarchive-cpio-perl libarchive-zip-perl libasm1 libdebhelper-perl libfile-slurper-perl libfile-stripnondeterminism-perl
  libfile-which-perl libltdl-dev libmail-sendmail-perl libperlio-utf8-strict-perl libsigsegv2 libsub-override-perl libsys-hostname-long-perl libtool
  m4 po-debconf popularity-contest
0 mis à jour, 31 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 6652 ko dans les archives.
Après cette opération, 20,7 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Réception de :1 http://deb.debian.org/debian bullseye/main amd64 popularity-contest all 1.71 [68,7 kB]
Réception de :2 http://deb.debian.org/debian bullseye/main amd64 libsigsegv2 amd64 2.13-1 [34,8 kB]
Réception de :3 http://deb.debian.org/debian bullseye/main amd64 m4 amd64 1.4.18-5 [204 kB]
Réception de :4 http://deb.debian.org/debian bullseye/main amd64 autoconf all 2.69-14 [313 kB]
Réception de :5 http://deb.debian.org/debian bullseye/main amd64 autotools-dev all 20180224.1+nmu1 [77,1 kB]
Réception de :6 http://deb.debian.org/debian bullseye/main amd64 automake all 1:1.16.3-2 [814 kB]
Réception de :7 http://deb.debian.org/debian bullseye/main amd64 autopoint all 0.21-4 [510 kB]
Réception de :8 http://deb.debian.org/debian bullseye/main amd64 dctrl-tools amd64 2.24-3+b1 [104 kB]
Réception de :9 http://deb.debian.org/debian bullseye/main amd64 libdebhelper-perl all 13.3.4 [189 kB]
Réception de :10 http://deb.debian.org/debian bullseye/main amd64 libtool all 2.4.6-15 [513 kB]
Réception de :11 http://deb.debian.org/debian bullseye/main amd64 dh-autoreconf all 20 [17,1 kB]
Réception de :12 http://deb.debian.org/debian bullseye/main amd64 libarchive-zip-perl all 1.68-1 [104 kB]
Réception de :13 http://deb.debian.org/debian bullseye/main amd64 libsub-override-perl all 0.09-2 [10,2 kB]
Réception de :14 http://deb.debian.org/debian bullseye/main amd64 libfile-stripnondeterminism-perl all 1.12.0-1 [26,3 kB]
Réception de :15 http://deb.debian.org/debian bullseye/main amd64 dh-strip-nondeterminism all 1.12.0-1 [15,4 kB]
Réception de :16 http://deb.debian.org/debian bullseye/main amd64 dwz amd64 0.13+20210201-1 [175 kB]
Réception de :17 http://deb.debian.org/debian bullseye/main amd64 gettext amd64 0.21-4 [1311 kB]
Réception de :18 http://deb.debian.org/debian bullseye/main amd64 intltool-debian all 0.35.0+20060710.5 [26,8 kB]
Réception de :19 http://deb.debian.org/debian bullseye/main amd64 po-debconf all 1.0.21+nmu1 [248 kB]
Réception de :20 http://deb.debian.org/debian bullseye/main amd64 debhelper all 13.3.4 [1049 kB]
Réception de :21 http://deb.debian.org/debian bullseye/main amd64 debian-goodies all 0.87 [87,0 kB]
Réception de :22 http://deb.debian.org/debian bullseye/main amd64 libasm1 amd64 0.183-1 [31,2 kB]
Réception de :23 http://deb.debian.org/debian bullseye/main amd64 elfutils amd64 0.183-1 [456 kB]
Réception de :24 http://deb.debian.org/debian bullseye/main amd64 equivs all 2.3.1 [22,7 kB]
Réception de :25 http://deb.debian.org/debian bullseye/main amd64 libarchive-cpio-perl all 0.10-1.1 [10,6 kB]
Réception de :26 http://deb.debian.org/debian bullseye/main amd64 libfile-slurper-perl all 0.012-1 [8344 B]
Réception de :27 http://deb.debian.org/debian bullseye/main amd64 libfile-which-perl all 1.23-1 [16,6 kB]
Réception de :28 http://deb.debian.org/debian bullseye/main amd64 libltdl-dev amd64 2.4.6-15 [162 kB]
Réception de :29 http://deb.debian.org/debian bullseye/main amd64 libsys-hostname-long-perl all 1.5-2 [11,8 kB]
Réception de :30 http://deb.debian.org/debian bullseye/main amd64 libmail-sendmail-perl all 0.80-1.1 [25,5 kB]
Réception de :31 http://deb.debian.org/debian bullseye/main amd64 libperlio-utf8-strict-perl amd64 0.008-1+b1 [12,0 kB]
6652 ko réceptionnés en 3s (2558 ko/s)                
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
Sélection du paquet popularity-contest précédemment désélectionné.
(Lecture de la base de données... 182223 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-popularity-contest_1.71_all.deb ...
Dépaquetage de popularity-contest (1.71) ...
Sélection du paquet libsigsegv2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../01-libsigsegv2_2.13-1_amd64.deb ...
Dépaquetage de libsigsegv2:amd64 (2.13-1) ...
Sélection du paquet m4 précédemment désélectionné.
Préparation du dépaquetage de .../02-m4_1.4.18-5_amd64.deb ...
Dépaquetage de m4 (1.4.18-5) ...
Sélection du paquet autoconf précédemment désélectionné.
Préparation du dépaquetage de .../03-autoconf_2.69-14_all.deb ...
Dépaquetage de autoconf (2.69-14) ...
Sélection du paquet autotools-dev précédemment désélectionné.
Préparation du dépaquetage de .../04-autotools-dev_20180224.1+nmu1_all.deb ...
Dépaquetage de autotools-dev (20180224.1+nmu1) ...
Sélection du paquet automake précédemment désélectionné.
Préparation du dépaquetage de .../05-automake_1%3a1.16.3-2_all.deb ...
Dépaquetage de automake (1:1.16.3-2) ...
Sélection du paquet autopoint précédemment désélectionné.
Préparation du dépaquetage de .../06-autopoint_0.21-4_all.deb ...
Dépaquetage de autopoint (0.21-4) ...
Sélection du paquet dctrl-tools précédemment désélectionné.
Préparation du dépaquetage de .../07-dctrl-tools_2.24-3+b1_amd64.deb ...
Dépaquetage de dctrl-tools (2.24-3+b1) ...
Sélection du paquet libdebhelper-perl précédemment désélectionné.
Préparation du dépaquetage de .../08-libdebhelper-perl_13.3.4_all.deb ...
Dépaquetage de libdebhelper-perl (13.3.4) ...
Sélection du paquet libtool précédemment désélectionné.
Préparation du dépaquetage de .../09-libtool_2.4.6-15_all.deb ...
Dépaquetage de libtool (2.4.6-15) ...
Sélection du paquet dh-autoreconf précédemment désélectionné.
Préparation du dépaquetage de .../10-dh-autoreconf_20_all.deb ...
Dépaquetage de dh-autoreconf (20) ...
Sélection du paquet libarchive-zip-perl précédemment désélectionné.
Préparation du dépaquetage de .../11-libarchive-zip-perl_1.68-1_all.deb ...
Dépaquetage de libarchive-zip-perl (1.68-1) ...
Sélection du paquet libsub-override-perl précédemment désélectionné.
Préparation du dépaquetage de .../12-libsub-override-perl_0.09-2_all.deb ...
Dépaquetage de libsub-override-perl (0.09-2) ...
Sélection du paquet libfile-stripnondeterminism-perl précédemment désélectionné.
Préparation du dépaquetage de .../13-libfile-stripnondeterminism-perl_1.12.0-1_all.deb ...
Dépaquetage de libfile-stripnondeterminism-perl (1.12.0-1) ...
Sélection du paquet dh-strip-nondeterminism précédemment désélectionné.
Préparation du dépaquetage de .../14-dh-strip-nondeterminism_1.12.0-1_all.deb ...
Dépaquetage de dh-strip-nondeterminism (1.12.0-1) ...
Sélection du paquet dwz précédemment désélectionné.
Préparation du dépaquetage de .../15-dwz_0.13+20210201-1_amd64.deb ...
Dépaquetage de dwz (0.13+20210201-1) ...
Sélection du paquet gettext précédemment désélectionné.
Préparation du dépaquetage de .../16-gettext_0.21-4_amd64.deb ...
Dépaquetage de gettext (0.21-4) ...
Sélection du paquet intltool-debian précédemment désélectionné.
Préparation du dépaquetage de .../17-intltool-debian_0.35.0+20060710.5_all.deb ...
Dépaquetage de intltool-debian (0.35.0+20060710.5) ...
Sélection du paquet po-debconf précédemment désélectionné.
Préparation du dépaquetage de .../18-po-debconf_1.0.21+nmu1_all.deb ...
Dépaquetage de po-debconf (1.0.21+nmu1) ...
Sélection du paquet debhelper précédemment désélectionné.
Préparation du dépaquetage de .../19-debhelper_13.3.4_all.deb ...
Dépaquetage de debhelper (13.3.4) ...
Sélection du paquet debian-goodies précédemment désélectionné.
Préparation du dépaquetage de .../20-debian-goodies_0.87_all.deb ...
Dépaquetage de debian-goodies (0.87) ...
Sélection du paquet libasm1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../21-libasm1_0.183-1_amd64.deb ...
Dépaquetage de libasm1:amd64 (0.183-1) ...
Sélection du paquet elfutils précédemment désélectionné.
Préparation du dépaquetage de .../22-elfutils_0.183-1_amd64.deb ...
Dépaquetage de elfutils (0.183-1) ...
Sélection du paquet equivs précédemment désélectionné.
Préparation du dépaquetage de .../23-equivs_2.3.1_all.deb ...
Dépaquetage de equivs (2.3.1) ...
Sélection du paquet libarchive-cpio-perl précédemment désélectionné.
Préparation du dépaquetage de .../24-libarchive-cpio-perl_0.10-1.1_all.deb ...
Dépaquetage de libarchive-cpio-perl (0.10-1.1) ...
Sélection du paquet libfile-slurper-perl précédemment désélectionné.
Préparation du dépaquetage de .../25-libfile-slurper-perl_0.012-1_all.deb ...
Dépaquetage de libfile-slurper-perl (0.012-1) ...
Sélection du paquet libfile-which-perl précédemment désélectionné.
Préparation du dépaquetage de .../26-libfile-which-perl_1.23-1_all.deb ...
Dépaquetage de libfile-which-perl (1.23-1) ...
Sélection du paquet libltdl-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../27-libltdl-dev_2.4.6-15_amd64.deb ...
Dépaquetage de libltdl-dev:amd64 (2.4.6-15) ...
Sélection du paquet libsys-hostname-long-perl précédemment désélectionné.
Préparation du dépaquetage de .../28-libsys-hostname-long-perl_1.5-2_all.deb ...
Dépaquetage de libsys-hostname-long-perl (1.5-2) ...
Sélection du paquet libmail-sendmail-perl précédemment désélectionné.
Préparation du dépaquetage de .../29-libmail-sendmail-perl_0.80-1.1_all.deb ...
Dépaquetage de libmail-sendmail-perl (0.80-1.1) ...
Sélection du paquet libperlio-utf8-strict-perl précédemment désélectionné.
Préparation du dépaquetage de .../30-libperlio-utf8-strict-perl_0.008-1+b1_amd64.deb ...
Dépaquetage de libperlio-utf8-strict-perl (0.008-1+b1) ...
Paramétrage de libfile-slurper-perl (0.012-1) ...
Paramétrage de libfile-which-perl (1.23-1) ...
Paramétrage de gettext (0.21-4) ...
Paramétrage de libarchive-zip-perl (1.68-1) ...
Paramétrage de popularity-contest (1.71) ...
Paramétrage de libdebhelper-perl (13.3.4) ...
Paramétrage de intltool-debian (0.35.0+20060710.5) ...
Paramétrage de autotools-dev (20180224.1+nmu1) ...
Paramétrage de libperlio-utf8-strict-perl (0.008-1+b1) ...
Paramétrage de libsigsegv2:amd64 (2.13-1) ...
Paramétrage de autopoint (0.21-4) ...
Paramétrage de dwz (0.13+20210201-1) ...
Paramétrage de libarchive-cpio-perl (0.10-1.1) ...
Paramétrage de libsub-override-perl (0.09-2) ...
Paramétrage de libasm1:amd64 (0.183-1) ...
Paramétrage de libsys-hostname-long-perl (1.5-2) ...
Paramétrage de dctrl-tools (2.24-3+b1) ...
Paramétrage de debian-goodies (0.87) ...
Paramétrage de libfile-stripnondeterminism-perl (1.12.0-1) ...
Paramétrage de elfutils (0.183-1) ...
Paramétrage de libtool (2.4.6-15) ...
Paramétrage de po-debconf (1.0.21+nmu1) ...
Paramétrage de m4 (1.4.18-5) ...
Paramétrage de libmail-sendmail-perl (0.80-1.1) ...
Paramétrage de autoconf (2.69-14) ...
Paramétrage de dh-strip-nondeterminism (1.12.0-1) ...
Paramétrage de automake (1:1.16.3-2) ...
update-alternatives: utilisation de « /usr/bin/automake-1.16 » pour fournir « /usr/bin/automake » (automake) en mode automatique
Paramétrage de dh-autoreconf (20) ...
Paramétrage de libltdl-dev:amd64 (2.4.6-15) ...
Paramétrage de debhelper (13.3.4) ...
Paramétrage de equivs (2.3.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-13+deb11u2) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.4-2) ...
Traitement des actions différées (« triggers ») pour install-info (6.7.0.dfsg.2-6) ...
$

Hors ligne

#2 13-03-2022 19:37:03

saitama-san
Membre
Inscription : 28-07-2019

Re : commande checkrestart

y a des chances que la commande soit à exécuter en tant que root

file /usr/sbin/checkrestart


bloc à supprimer si la commande n’affiche rien

Hors ligne

#3 13-03-2022 19:43:46

phreg
Membre
Distrib. : MX Manjaro Ubuntu
Noyau : 4.9 à 5.10
(G)UI : Xfce
Inscription : 02-04-2011

Re : commande checkrestart

Bonjour,
chez moi, les messages d'erreur en anglais sont plus clairs

checkrestart

retourne :

Command 'checkrestart' is available in the following places
 * /sbin/checkrestart
 * /usr/sbin/checkrestart
The command could not be located because '/sbin:/usr/sbin' is not included in the PATH environment variable.
This is most likely caused by the lack of administrative privileges associated with your user account.
checkrestart: command not found


Le message est clair : en simple user le path est mauvais donc la commande n'est pas trouvée.
En indiquant le chemin,

/sbin/checkrestart

on voit bien que la commande doit être lancée avec droit root :

ERROR: This program must be run as root in order to obtain information
about all open file descriptors in the system.

Hors ligne

#4 13-03-2022 19:44:17

poimlk
Membre
Inscription : 13-03-2022

Re : commande checkrestart

effectivement, ça marche, merci

Hors ligne

#5 13-03-2022 19:49:30

raleur
Membre
Inscription : 03-10-2014

Re : commande checkrestart

phreg a écrit :

la commande doit être lancée avec droit root


Ce n'est pas pour rien qu'elle est dans /usr/sbin (même s'il y a des exceptions qui confirment la règle).

Dernière modification par raleur (13-03-2022 19:52:19)


Il vaut mieux montrer que raconter.

Hors ligne

#6 13-03-2022 19:53:59

phreg
Membre
Distrib. : MX Manjaro Ubuntu
Noyau : 4.9 à 5.10
(G)UI : Xfce
Inscription : 02-04-2011

Re : commande checkrestart

@raleur,
ben oui, le message est clair.
Je suis surpris que pour poimlk ce soit aussi laconique que commande introuvable.

Hors ligne

#7 13-03-2022 20:18:36

raleur
Membre
Inscription : 03-10-2014

Re : commande checkrestart

C'est le message normal du shell, et j'ai la même chose. Tu dois avoir une extension comme command-not-found.

Il vaut mieux montrer que raconter.

Hors ligne

#8 13-03-2022 21:08:24

poimlk
Membre
Inscription : 13-03-2022

Re : commande checkrestart

je devrais plus souvent utiliser

alias fuck='sudo $(history -p \!\!)'



:-)

Dernière modification par poimlk (13-03-2022 21:08:48)

Hors ligne

#9 13-03-2022 22:38:47

phreg
Membre
Distrib. : MX Manjaro Ubuntu
Noyau : 4.9 à 5.10
(G)UI : Xfce
Inscription : 02-04-2011

Re : commande checkrestart

Je découvre en effet que "command-not-found" est installé par défaut sur Debian Facile. Bonne idée !

Hors ligne

Pied de page des forums