Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-03-2022 23:19:49

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

[Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Bonsoir à tous,

Non ce n'est pas une blague. Je pose une question équivalente à celle que j'ai posée il y a quelques mois pour mon portable ASUS.
J'ai fait des émules et mes filles ont préféré troquer leurs iPads avec lesquels on ne peut pas faire grand chose contre des portables ASUS comme le mien... ou presque.
Les bêtes sont des Asus E210MA-GJ969TS 11,6" Intel Celeron 4 Go RAM 64 Go eMMC sur lesquels j'ai installé Debian Bullseye avec un environnement KDE Plasma. La bonne surprise, c'est que la connexion bluetooth fonctionne du premier coup, par contre, je n'ai pas de connexion WiFi.

J'ai déroulé les étapes du tuto "https://debian-facile.org/doc:materiel:wifi:detecter" mais mes progrès en Linux sont insuffisants pour que je me débrouille tout seul.

Je vous livre donc le déroulé de la procédure avec les différents retours :

1 : Identifier la carte réseau

lspci -nnd ::0280


02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
 



lsusb


Bus 002 Device 002: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 13d3:3529 IMC Networks Bluetooth Radio
Bus 001 Device 003: ID 13d3:5a11 IMC Networks USB2.0 VGA UVC WebCam
Bus 001 Device 005: ID 0781:5591 SanDisk Corp. Ultra Flair
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 



2 : Vérifier la présence du module noyau

lspci -nnkd ::0280


02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
        DeviceName: WLAN
        Subsystem: AzureWave RTL8821CE 802.11ac PCIe Wireless Network Adapter [1a3b:3040]
        Kernel modules: rtw88_8821ce
 



3 : Vérifier la présence du firmware

ip a


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enx00e04c68071f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:e0:4c:68:07:1f brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.23/24 brd 192.168.1.255 scope global dynamic noprefixroute enx00e04c68071f
       valid_lft 84318sec preferred_lft 84318sec
    inet6 2a01:cb19:2f9:3700:a1d8:d733:e846:f2a7/64 scope global temporary dynamic
       valid_lft 1788sec preferred_lft 588sec
    inet6 2a01:cb19:2f9:3700:2e0:4cff:fe68:71f/64 scope global dynamic mngtmpaddr noprefixroute
       valid_lft 1788sec preferred_lft 588sec
    inet6 fe80::2e0:4cff:fe68:71f/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
 



dmesg | grep firmware


[    1.642448] i915 0000:00:02.0: firmware: failed to load i915/glk_dmc_ver1_04.bin (-2)
[    1.642454] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[    1.642458] i915 0000:00:02.0: Direct firmware load for i915/glk_dmc_ver1_04.bin failed with error -2
[    1.642461] i915 0000:00:02.0: [drm] Failed to load DMC firmware i915/glk_dmc_ver1_04.bin. Disabling runtime power management.
[    1.642462] i915 0000:00:02.0: [drm] DMC firmware homepage: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915
[    3.918590] platform regulatory.0: firmware: direct-loading firmware regulatory.db
[    3.946401] platform regulatory.0: firmware: direct-loading firmware regulatory.db.p7s
[    4.249523] rtw_8821ce 0000:02:00.0: firmware: failed to load rtw88/rtw8821c_fw.bin (-2)
[    4.249569] rtw_8821ce 0000:02:00.0: Direct firmware load for rtw88/rtw8821c_fw.bin failed with error -2
[    4.249573] rtw_8821ce 0000:02:00.0: failed to request firmware
[    4.270713] rtw_8821ce 0000:02:00.0: failed to load firmware
[    4.588690] r8152 2-1:1.0: firmware: failed to load rtl_nic/rtl8153a-4.fw (-2)
[    4.588735] r8152 2-1:1.0: Direct firmware load for rtl_nic/rtl8153a-4.fw failed with error -2
[    4.588738] r8152 2-1:1.0: unable to load firmware patch rtl_nic/rtl8153a-4.fw (-2)
 



4 : Activer l'interface réseau

/sbin/ifconfig -a


-bash: /sbin/ifconfig: Aucun fichier ou dossier de ce type
 



Voilà, j'ai essayé de lister toutes les commandes du tuto en espérant que l'un ou l'une d'entre vous trouvera des éléments pour que j'arrive à activer le WiFi sur cette machine.
Merci d'avance pour votre aide !

Dernière modification par orelyane (19-03-2022 09:07:59)


ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#2 15-03-2022 00:07:05

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Le paquet firmware-realtek contient les deux firmwares manquants.

Il vaut mieux montrer que raconter.

Hors ligne

#3 15-03-2022 07:35:43

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Ok, merci raleur.

J'ai trouvé ça https://debian.pkgs.org/11/debian-nonfr … l.deb.html, ça va ?
Par contre j'aime bien faire les installations avec apt, j'ai plus confiance. Comment je trouve le nom du paquet qui va bien ?

ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#4 15-03-2022 08:06:22

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Bonjour


apt install firmware-realtek
 



tu peu regarder ceci aussi si installé


apt policy firmware-misc-nonfree
 


il semble ne pas être installé


[    1.642448] i915 0000:00:02.0: firmware: failed to load i915/glk_dmc_ver1_04.bin (-2)
 


c'est pour ton gpu intel

remarque : il faut activer le nonfree dans ton sources.list
tu peu vérifier


cat /etc/apt/sources.list
 



la fin des lignes doivent contenir "main contrib non-free"

c'est une debian buster ?

Dernière modification par robert2a (15-03-2022 08:11:57)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#5 15-03-2022 08:25:35

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Ah ! Bonjour robert2a, content de te revoir.

cat /etc/apt/sources.list



Renvoit :

# deb cdrom:[Debian GNU/Linux 11.2.0 _Bullseye_ - Official amd64 NETINST 20211218-11:12]/ bullseye main

#deb cdrom:[Debian GNU/Linux 11.2.0 _Bullseye_ - Official amd64 NETINST 20211218-11:12]/ bullseye main

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb http://security.debian.org/debian-security bullseye-security main
deb-src http://security.debian.org/debian-security bullseye-security main

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports
deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 



Les non-free ne sont pas activées c'est ça ? Je l'avait fait sur mon ordi à moi, il faut que je retrouve comment j'avais identifiré et modifié le fichier concerné.


ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#6 15-03-2022 09:35:55

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

voila un exemple du sources.list pour bullseye


deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
 



tout le reste peut être commenté avec un "#" en début de ligne (les lignes "src" télécharge les sources des paquets , tu n'en a pas besoin )
ton sources.list modifié


# deb cdrom:[Debian GNU/Linux 11.2.0 _Bullseye_ - Official amd64 NETINST 20211218-11:12]/ bullseye main

#deb cdrom:[Debian GNU/Linux 11.2.0 _Bullseye_ - Official amd64 NETINST 20211218-11:12]/ bullseye main

deb http://deb.debian.org/debian/ bullseye main contrib non-free
#deb-src http://deb.debian.org/debian/ bullseye main

deb http://security.debian.org/debian-security bullseye-security main contrib non-free
#deb-src http://security.debian.org/debian-security bullseye-security main

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ bullseye-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 


tu fais ensuite


apt update
 


puis tu installes les paquets


apt install firmware-realtek firmware-misc-nonfree
 


et un reboot de la machine


reboot
 

Dernière modification par robert2a (15-03-2022 09:43:58)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#7 15-03-2022 09:41:12

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

pour modifié le sources.list avec nano par exemple


nano /etc/apt/sources.list
 



pour enregistrer "ctrl+o" et pour fermer nano "ctrl+x"


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#8 15-03-2022 11:07:17

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Merci, j'ai appliqué les modifications mais lorsque je déconnecte l'ethernet, je n'ai pas de réseau WiFi. Pourtant chez moi en ce moment tout le monde est bien connecté en WiFi et cela fonctionne.

ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#9 15-03-2022 11:09:08

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Par acquis de conscience, j'ai fait :

 apt install firmware-realtek



Mais tout est bien à jour.


ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#10 15-03-2022 11:42:11

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Après le reboot toujours pas de wifi ?
tu peu vérifier si encore des erreurs


journalctl -b -r -p err
 


et donne le retour

ps: tu quel bureau sur cette machine ?

Dernière modification par robert2a (15-03-2022 11:45:38)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#11 15-03-2022 11:50:38

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Je suis sous KDE Plasma.

Le retour de :

journalctl -b -r -p err



c'est :

-- Journal begins at Mon 2022-03-14 07:36:01 CET, ends at Tue 2022-03-15 10:48:44 CET. --
mars 15 10:00:23 petro pipewire[705]: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner: Could not >
mars 15 10:00:18 petro pipewire[655]: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner: Could not >
mars 15 10:00:16 petro bluetoothd[488]: sap-server: Operation not permitted (1)
mars 15 10:00:16 petro bluetoothd[488]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
mars 15 10:00:15 petro smartd[498]: In the system's table of devices NO devices found to scan
mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: failed to setup chip information
mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: failed to setup chip efuse info
mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: rfe 4 isn't supported
lines 1-9/9 (END)
 


ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#12 15-03-2022 11:54:19

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

tu utilise NetworkManager ou un fichier "interfaces"
que renvoie ceci


systemctl status NetworkManager
 


tu a aussi nmcli
par exemple


nmcli connection show
 


ou simplement


nmcli
 


sans informations dur de te dire ce qui ne va pas
la priorité est de vérifier si le noyau et le firmware-realtek sont correct pour ton matériel (retour des erreurs en #10 )


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#13 15-03-2022 11:56:45

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

le souci a priori ici


mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: failed to setup chip information
mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: failed to setup chip efuse info
mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: rfe 4 isn't supported
 


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#14 15-03-2022 12:00:40

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

trouvé un problème identique ici => https://debian-facile.org/viewtopic.php?id=30726

tu suis le fil , désactive le secure-boot , installe le firmware (tu la déjà fait ) et cela doit être correct

Dernière modification par robert2a (15-03-2022 12:02:39)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#15 15-03-2022 12:02:55

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

La commande

 systemctl status NetworkManager


renvoit :

root@petro:~#  systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-03-15 10:00:15 CET; 58min ago
       Docs: man:NetworkManager(8)
   Main PID: 493 (NetworkManager)
      Tasks: 3 (limit: 4446)
     Memory: 9.8M
        CPU: 1.122s
     CGroup: /system.slice/NetworkManager.service
             └─493 /usr/sbin/NetworkManager --no-daemon

mars 15 10:52:51 petro NetworkManager[493]: <info>  [1647337971.7851] device (enx00e04c68071f): state change: ip-check -> secondaries (reason 'none', sys-iface-state:>
mars 15 10:52:51 petro NetworkManager[493]: <info>  [1647337971.7854] device (enx00e04c68071f): state change: secondaries -> activated (reason 'none', sys-iface-state>
mars 15 10:52:51 petro NetworkManager[493]: <info>  [1647337971.7860] manager: NetworkManager state is now CONNECTED_LOCAL
mars 15 10:52:51 petro NetworkManager[493]: <info>  [1647337971.7871] manager: NetworkManager state is now CONNECTED_SITE
mars 15 10:52:51 petro NetworkManager[493]: <info>  [1647337971.7872] policy: set 'Wired connection 1' (enx00e04c68071f) as default for IPv4 routing and DNS
mars 15 10:52:51 petro NetworkManager[493]: <info>  [1647337971.8047] device (enx00e04c68071f): Activation: successful, device activated.
mars 15 10:52:51 petro NetworkManager[493]: <info>  [1647337971.8054] manager: NetworkManager state is now CONNECTED_GLOBAL
mars 15 10:52:53 petro NetworkManager[493]: <info>  [1647337973.3142] dhcp6 (enx00e04c68071f): activation: beginning transaction (timeout in 45 seconds)
mars 15 10:52:53 petro NetworkManager[493]: <info>  [1647337973.3153] policy: set 'Wired connection 1' (enx00e04c68071f) as default for IPv6 routing and DNS
mars 15 10:52:53 petro NetworkManager[493]: <info>  [1647337973.3678] dhcp6 (enx00e04c68071f): state changed unknown -> bound
lines



 nmcli connection show


donne :

NAME                UUID                                  TYPE      DEVICE          
Wired connection 1  0053dca5-281b-4859-a886-fe332098a91d  ethernet  enx00e04c68071f
 



et

nmcli


enx00e04c68071f: connecté à Wired connection 1
        "Realtek RTL8153"
        ethernet (r8152), 00:E0:4C:68:07:1F, hw, mtu 1500
        ip4 par défaut, ip6 par défaut
        inet4 192.168.1.23/24
        route4 0.0.0.0/0
        route4 192.168.1.0/24
        route4 169.254.0.0/16
        inet6 2a01:cb19:2f9:3700:9cc1:b44b:e61a:d7df/64
        inet6 2a01:cb19:2f9:3700:2e0:4cff:fe68:71f/64
        inet6 fe80::2e0:4cff:fe68:71f/64
        route6 2a01:cb19:2f9:3700::/64
        route6 ::/0
        route6 fe80::/64

lo: non-géré
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 192.168.1.1
        domains: home
        interface: enx00e04c68071f
 


ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#16 15-03-2022 12:03:28

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

De quelles informations complémentaires as-tu besoin ?

ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#17 15-03-2022 12:13:28

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

J'ai déconnecté le Secure Boot de l'UEFI mais je n'ai toujours pas de WiFi dans la liste de mes réseaux.

ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#18 15-03-2022 12:15:59

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

plus besoin , ton "secure-boot" est actif dans l'EFI (bios)
tu le désactive et ça doit fonctionner

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#19 15-03-2022 12:18:35

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

tu a toujours cette erreur ?


mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: failed to setup chip information
mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: failed to setup chip efuse info
mars 15 10:00:15 petro kernel: rtw_8821ce 0000:02:00.0: rfe 4 isn't supported
 


cette commande renvoie quoi ?


mokutil --sb-state
 

Dernière modification par robert2a (15-03-2022 12:18:53)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#20 15-03-2022 12:27:52

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

je vois pas de cartes wifi sur tes retours
ceci renvoie quoi ?


lspci -nnkd ::0280
 


ps: a moins que ce wifi demande un noyau plus récent , mais sur le lien raleur semble penser que il le prend en charge.


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#21 15-03-2022 12:38:50

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

robert2a a écrit :

trouvé un problème identique ici => https://debian-facile.org/viewtopic.php?id=30726

tu suis le fil , désactive le secure-boot , installe le firmware (tu la déjà fait ) et cela doit être correct


Tu as oublié de mentionner l'étape cruciale qui est l'installation du pilote externe 8821ce. C'est pour cela que le secure boot doit être désactivé.
Et le firmware ne sert à rien, il n'est utilisé que par le module interne (qui ne fonctionne pas avec ce contrôleur).

robert2a a écrit :

ton "secure-boot" est actif dans l'EFI


Qu'est-ce qui te fait dire cela ?

robert2a a écrit :

sur le lien raleur semble penser que il le prend en charge


Ce n'est pas moi qui le pense mais lspci qui l'affiche (en se basant sur les informations de modprobe donc du module lui-même). Mais ce n'est pas le cas (Realtek est coutumier des variantes de composants impossibles à différencier par les seuls identifiants PCI), et le problème a été résolu en installant et compilant le pilote externe (nécessitant la désactivation du secure boot). Une version supérieure du noyau (backports) pourrait peut-être résoudre le problème sans installer de pilote externe ni désactiver le secure boot.

Dernière modification par raleur (15-03-2022 12:41:26)


Il vaut mieux montrer que raconter.

Hors ligne

#22 15-03-2022 12:58:31

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

Bonjour raleur et content de te voir aussi sur ma discussion.

Bon, j'avoue que je ne comprends pas tout ce que vous dites. Mais du coup, je fait quoi maintenant ?

ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#23 15-03-2022 12:59:45

orelyane
Membre
Distrib. : Debian GNU/Linux 10 \n \l
Noyau : Linux 4.19.0-17-amd64
(G)UI : KDE
Inscription : 29-07-2021

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

J'installe le fameux pilote externe, maintenant que j'ai désactivé le Secure Boot ?

ASUS VivoBook 12" - Debian 11.1 - Linux 4.19.0-18-amd64 x86_64

Hors ligne

#24 15-03-2022 13:06:08

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

tu peut tester soit un noyau des backports , soit le pilote externe.
j'ai pas réagit , c'est vrais que le noyau debian est signé , ce qui n'oblige pas a désactiver le secure-boot.
pour le noyau il faut ajouter une ligne au sources.list pour les backports de bullseye

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#25 15-03-2022 13:11:54

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Pas de connexion WiFI sur Portable Asus E210MA-GJ969TS...

tu dois ajouter cette ligne a la fin de ton sources.list


deb http://deb.debian.org/debian bullseye-backports main contrib non-free
 



faire un update


apt update
 



puis installer ceci


apt install -t bullseye-backports linux-image-amd64
 


puis redémarrer la machine pour être sur le nouveau noyau


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

Pied de page des forums