Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-03-2022 19:33:57

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Problémes matériels (?) non identifiés.(Enfin résolu)

Bonsoir,
depuis hier, j'ai quelques soucis avec un portable Lenovo G50-45. 4 distributions en UEFI  (Lm, Manjaro, Kali, W10) y sont installés et présentent des bugs que je n'arrive pas à cerner. Que ce soit LM ou Manjaro, ceci- [[C^[[C|...- s'affiche des dizaines de fois au démarrage. au bout d'un temps assez long, j'arrive à me loger et accéder au bureau. Là, je n'est accès qu'aux applications graphiques.  Le terminal s'orne de : [OR^[OR^ ...-dont j'ignore la signification ( je n'ai rien trouvé sur le net).  Si je veux taper mon MP , il est systématiquement refusé ; Plus de droits administratifs.  Kali présente des problèmes graphiques qui m'ont fait renoncer à y accéder. W10 semble moins touché mais comme sur ses voisins, je n'arrive pas à naviguer correctement sur Firefox, ne pouvant taper correctement la moindre requêtes. Le disque de ce pc est très fatigué. Mais je retrouve la même situation si je branche Debian 11 sur disque externe (en legacy). J'ai pensé à un soucis au clavier (nappe?) mais, avant d'entreprendre quoique ce soit, j'aimerais avoir des avis éclairés.

Dernière modification par potemkine17 (12-04-2022 20:42:40)

Hors ligne

#2 20-03-2022 21:49:06

raleur
Membre
Inscription : 03-10-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Oui, ça ressemble à un défaut du clavier, j'ai déjà vu ça. Peut-être une ou plusieurs touches "collées".
Si GRUB n'est pas trop affecté, tu peux commencer par désactiver le clavier PS/2 intégré en ajoutant le paramètre i8042.nokbd à la ligne de commande du noyau et utiliser un clavier USB à la place. Si le problème disparaît, débrancher la nappe du clavier intégré et redémarrer sans le paramètre. Si le problème disparaît, ça vient du clavier ou de la nappe. Si le problème persiste, ça vient d'autre chose, peut-être le contrôleur clavier.

Il vaut mieux montrer que raconter.

Hors ligne

#3 20-03-2022 23:11:11

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Bonsoir Raleur.

désactiver le clavier PS/2 intégré en ajoutant le paramètre i8042.nokbd à la ligne de commande du noyau


Je vais suivre tes indications mais pas ce soir, n'ayant pas de clavier usb sous la main. Merci, j'en dirai plus demain. Bonsoir.

Hors ligne

#4 21-03-2022 14:00:10

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

J'ai tenté de suivre les conseils comme convenu. Mais en raison d'"erreurs de syntaxe", j'ai du procéder autrement avec "xinput" au terminal depuis le bureau de Linux-mint  (La commande est en user, heureusement pour moi). Ca a bien marché.  Pour ce qui est de débrancher la nappe, donc démonter le clavier, je ne peux pas le faire aujourd'hui (taf). Enfin, je sais déjà vers où chercher.

Hors ligne

#5 25-03-2022 18:57:23

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Raleur a écrit :

Peut-être une ou plusieurs touches "collées".


Bien vu, Raleur et merci. C'est la touche Ctrl gauche qui me joue des tours. Un simple nettoyage suffira peut-être.

Hors ligne

#6 25-03-2022 19:40:29

raleur
Membre
Inscription : 03-10-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Comment as-tu vu que c'était la touche Ctrl gauche ? C'est curieux, Ctrl est une touche morte qui ne devrait pas provoquer d'émission spontanée mais seulement affecter la frappe.

Il vaut mieux montrer que raconter.

Hors ligne

#7 26-03-2022 21:29:58

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Bonsoir Raleur,
j'avoue que l'idée n'est pas de moi mais d'un pote "windowsien". Sur M.S., le problème est visible surtout sur Edge et F.F. sur lesquels il est difficile de lancer une recherche cohérente : La frappe semble être interprété autrement par les navigateurs. De plus une petite fenêtre apparait prés de la barre de recherche   ,fenêtre "qui serait ouverte" par Ctrl-gauche (?). C'est en essayant de la refermer que cet ami - plutôt à l'aise dans l'usage du clavier- a constaté que la touche ne fonctionnait plus. Je n'ai pas les compétences nécessaire pour mettre en doute ses déductions. Mais si tu pense que c'est une impossibilité, j'essaierai, la semaine prochaine, de voir si il a une autre une solution. Quelle touche "grippée" peut provoqué ces problèmes ?

Hors ligne

#8 27-03-2022 11:43:24

raleur
Membre
Inscription : 03-10-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Je dis seulement que la touche Ctrl n'envoie pas de caractères toute seule, elle ne fait que modifier les caractères envoyés par les autres touches. Donc si des caractères sont envoyés sans que tu appuies sur aucune touche, il y a autre chose.

Il vaut mieux montrer que raconter.

Hors ligne

#9 27-03-2022 20:27:02

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Je comprend. En cherchant à me documenter, je vois que l'interprétation des frappes se fait par l'intermédiaire d'un micro-contrôleur. Même si je continue à chercher une réponse du côté du clavier, est-il possible que cela vienne de là ? Ce m.c. peut-il être défectueux partiellement ? Ou NON, soit il fonctionne, soit il n'est plus possible de taper quoique ce soit ?

Hors ligne

#10 28-03-2022 03:57:55

daniel b
Membre
Inscription : 28-03-2022

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

apres avoir installé debian facile sur mon surfacepro 6 j`ai un probleme de fluidité en naviguant sur internet, il se forme une ligne visible dans le haut . je n`avais pas ce problême sous windows. Malgré tout j`adore debian facile.

Hors ligne

#11 12-04-2022 20:42:10

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problémes matériels (?) non identifiés.(Enfin résolu)

Investigations enfin terminées. C'était bien la touche Ctrl gauche qui était collée. Merci de ton aide Raleur.

Hors ligne

Pied de page des forums