Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-03-2022 00:59:41

Muselaar
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64 (x86_64)
(G)UI : Xfce
Inscription : 20-05-2013

[RÉSOLU] apt-key is deprecated

Bonsoir,

Je veux enfin installer JOSM sur ma debian pour ne plus dépendre de mon Mac du bureau pour cartographier.

Dans les instructions, il y a ça :

wget -q https://josm.openstreetmap.de/josm-apt.key -O- | sudo apt-key add -


Et j'ai comme réponse : 

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
OK
 



J'ai cherché comment je pouvais utiliser gpg, je n'ai pas compris comment enregistrer cette clé pour passer à la suite de l'installation.

Dernière modification par Muselaar (31-03-2022 17:28:22)


ThinkPad T450 i5 HD+ (1600 x 900) sous Debian Stretch Xfce avec Clavier TypeMatrix 2030 USB en bépo. Pour le boulot, j'ai un Macmini (logiciels professionnels incontournables). Utilisateur Debian depuis 2013, et Mac depuis 1999.

Hors ligne

#2 31-03-2022 11:18:29

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.19 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [RÉSOLU] apt-key is deprecated

L’instruction "see apt-key(8)" t’invite à lancer cette commande :

man 8 apt-key



Dans la page de manuel en question, regarde en particulier la section "DEPRECATION" :

Except for using apt-key del in maintainer scripts, the use of apt-key is deprecated. This section shows how to replace existing use of apt-key.

If your existing use of apt-key add looks like this:

wget -qO- https://myrepo.example/myrepo.asc | sudo apt-key add -

Then you can directly replace this with (though note the recommendation below):

wget -qO- https://myrepo.example/myrepo.asc | sudo tee /etc/apt/trusted.gpg.d/myrepo.asc

Make sure to use the "asc" extension for ASCII armored keys and the "gpg" extension for the binary OpenPGP format (also known as "GPG key public ring"). The binary OpenPGP format works for all apt versions, while the ASCII armored format works for apt version >= 1.4.

Recommended: Instead of placing keys into the /etc/apt/trusted.gpg.d directory, you can place them anywhere on your filesystem by using the Signed-By option in your sources.list and pointing to the filename of the key. See sources.list(5) for details. Since APT 2.4, /etc/apt/keyrings is provided as the recommended location for keys not managed by packages. When using a deb822-style sources.list, and with apt version >= 2.4, the Signed-By option can also be used to include the full ASCII armored keyring directly in the sources.list without an additional file.


Jouer sous Debian ? Facile !

Hors ligne

#3 31-03-2022 16:45:27

Muselaar
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64 (x86_64)
(G)UI : Xfce
Inscription : 20-05-2013

Re : [RÉSOLU] apt-key is deprecated

Merci pour cette réponse,
Cependant, je n'ai pas de section DEPRECATION dans ma page. Ma version de apt est la 2.2.4
Par ailleurs, je ne comprends pas complètement ce que je dois remplacer par quoi, dans l'exemple qui est donné. Et comme en plus, je ne sais pas de quel type est la clé qui est proposée, ça devient compliqué pour moi. Je me basais sur cette page : https://josm.openstreetmap.de/wiki/Fr%3ADownload#Ubuntu

Par ailleurs, j'ai découvert que lors de ma dernière mise à jour générale, la dernière version de JOSM a été installée (sûrement parce que j'ai ajouté son dépôt dans la liste, parce qu'avant, dans les dépôts debian, il n'y avait que des versions obsolètes, ce logiciel évoluant tellement vite), et j'ai maintenant accès à cette version sur mon ordinateur, qui est fonctionnelle. La question de la clé est-elle indispensable ? J'ignore totalement le niveau de risque.

ThinkPad T450 i5 HD+ (1600 x 900) sous Debian Stretch Xfce avec Clavier TypeMatrix 2030 USB en bépo. Pour le boulot, j'ai un Macmini (logiciels professionnels incontournables). Utilisateur Debian depuis 2013, et Mac depuis 1999.

Hors ligne

#4 31-03-2022 17:06:17

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.19 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [RÉSOLU] apt-key is deprecated

Ah, je pense que tu as mal compris le message que apt-key a affiché. Malgré l’avertissement, la clé que tu as requise a bien été ajoutée, c’est la signification du « OK » final.

Si tu es sur Debian 11 Bullseye, tu peux à mon avis ignorer tout ça. Il faudra juste que tu fasses bien attention aux instructions de mise-à-jour lorsque tu passeras à Debian 12, il y aura peut-être des instructions pour migrer de l’ancien système de gestions des clés au nouveau.

Jouer sous Debian ? Facile !

Hors ligne

#5 31-03-2022 17:27:43

Muselaar
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64 (x86_64)
(G)UI : Xfce
Inscription : 20-05-2013

Re : [RÉSOLU] apt-key is deprecated

Ah, d'accord, merci pour ces éclaircissements.

ThinkPad T450 i5 HD+ (1600 x 900) sous Debian Stretch Xfce avec Clavier TypeMatrix 2030 USB en bépo. Pour le boulot, j'ai un Macmini (logiciels professionnels incontournables). Utilisateur Debian depuis 2013, et Mac depuis 1999.

Hors ligne

Pied de page des forums