Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-03-2022 18:04:07

Maufab
Membre
Lieu : Ariège
Distrib. : Bullseye
Noyau : 5.10.0-13-amd64
(G)UI : KDE
Inscription : 12-03-2010

Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

Bonjour,
Le portable : Asus X73SV avec deux cartes graphiques, Intel et Nvidia GT540M.

suite à une màj de Buster vers Bullseye, et après avoir voulu réinstaller Bumblebee, je me retrouve avec un écran noir avec le curseur clignotant en haut à gauche et disparition  des tous les tty. Donc plus d'accès au système par Ctrl-Alt-F1-6.
Je précise qu'après la màj du système, j'ai eu un démarrage normal en session graphique.

Sous Buster, j'avais fait fonctionner bumblebee avec le pilote propriétaire nvidia 390.148.run téléchargé chez nvidia, car le pilote legacy 390xx du dépot debian ne passait pas.
Lorsque j'ai voulu utiliser optirun sous bullseye, celui-ci était inopérant. J'ai donc refait une install de bumblebee depuis le début en commençant par purger les paquets nvidia et en réinstallant le pilote nvidia 390.148.run. Ce dernier a refusé de s'installer. Après un nvidia detect, j'ai donc installer celui du dépot debian nvidia-legacy-390xx malgré le fait qu'il me dise que ce pilote n'est pas compatible avec ma carte gt540m. Pendant l'installation, j'ai perdu la session graphique avec écran noir et suis obligé pour redémarrer de passer par l'extinction du portable en pressant le bouton power.
En passant par le mode rescue, j'ai tout purger à nouveau, installé le pilote nouveau, désinstallé le pilote nouveau et vga_switcheroo, etc.
J'ai cherché dans journactl, dans les firmwares, un peu partout, ... Rien qui m'indique quoi que ce soit. Un doute quand même concernant wayland et Xorg.
Voilà, je sollicite votre aide.

Dernière modification par Maufab (12-04-2022 11:23:19)

Hors ligne

#2 31-03-2022 18:31:41

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

Hello,

Essaie de passer nomodeset à la ligne de commande GRUB.
Pour de faire (méthode temproraire, valable que pour le boot en cours) :
   - À l'écran d'accueil de GRUB, choisir (sans taper ENTRÉE) le noyau que l'on veut démarrer puis taper sur e (éditer).
Ensuite, à la fin de la ligne commençant par linux, et avant RESUME=, ajouter nomodeset.
Puis taper sur F10, pour démarrer.
Si ça démarre en mode graphique (pourri), c'est le pilote de ta carte graphique qui est en cause.

Sinon, une autre voie d'investigation serait de démarrer en mode "recovery" et de visionner les logs pour voir ce qu'il se passe exactement.

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#3 31-03-2022 22:40:24

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

Bonsoir
Pourquoi ne pas avoir garder  Buster , il est encore maintenu par debian ?

pour reprendre la main sur ton bureau , il faut utiliser le gpu intel
a vérifier/réinstaller


apt --reinstall install firmware-misc-nonfree xserver-xorg-video-all linux-headers-amd64 linux-image-amd64 dkms
 


ps: avec la commande ci dessus tu dois avoir tout ce que tu a besoin ( le firmware fournit ce qu'il faut si besoin , pour intel et nvidia ).

il y a deux choses a vérifier :
que ton gpu intel fonctionne bien et que nouveau prend en charge ta carte nvidia GT540M

que KDE utilise bien "X" et pas "wayland"
pour vérifier le gpu utilisé , le paquet "mesa-utils" et la commande :


glxinfo -B
 


sinon regarder dans ton "home" le fichier "Xorg.0.log"


cat /home/$USER/.local/share/xorg/Xorg.0.log
 


ps: $USER et a remplacer par le nom utilisateur de ta session , le ".local" est un fichier caché .

pour nomodeset c'est pas la solution , tu désactive tous les drivers de KMS (noyau).
tu peu tester de ne désactiver que nouveau par exemple => nouveau.modeset=0 (donc que la carte nvidia ).

pour le gpu intel tu peu donner le retour de lspci (quand tu a le bureau )


lspci
 



tu va avoir une ligne qui commence par "VGA" , noter le nom du gpu "intel"
et une ligne qui commence par "3D" pour le gpu nvidia

le plus facile est de retrouver ton gpu intel , pour avoir le bureau fonctionnel .
ps: je sais pas si KDE sera fluide sur cette machine d'un certain âge .


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#4 02-04-2022 14:50:34

Maufab
Membre
Lieu : Ariège
Distrib. : Bullseye
Noyau : 5.10.0-13-amd64
(G)UI : KDE
Inscription : 12-03-2010

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

Merci de vos réponses.
Pour l'instant, j'ai récupéré ma session graphique en passant nomodeset au noyau.
J'ai fini par installer le dernier pilote depuis le site nvidia car le legacy des dépots debian ne passe pas. Mais je n'arrive pas à utiliser bumblebee, seul le gpu intégré Intel est actif (vu avec clinfo) et j'ai testé avec supertuxkart, ça rame dès que c'est un peu trop chargé.
J'ai aussi essayé d'installer la même version de ce pilote nvidia par rétroportage de la version de Sid. Aucune erreur lors de l'installation, sddm se lance correctement, KDE s'ouvre sur Firefox que j'avais laissé ouvert, mais plus de bureau .... kernal_panic.gif. C'est pourtant bien la même version que celui de Nvidia (390.147).

Je vérifierai pour xorg ou wayland. Mais je pense que je suis sous xorg. (Je ne suis pas sur mon ordi en ce moment)

D'après les posts sur Debian.fr et d'autres, Bullseye aurait dû amener plus de simplicité avec Optimus. Je constate juste que c'est pire qu'avec Buster.

@robert2a, j'ai déjà vérifié et réinstallé firmware-misc-nonfree, le noyau et les headers. Je vérifierai pour xserver-xorg-video-all. Le pilote intel i915 doit être déjà installé puisque c'est ce gpu qui tourne.
Je ne veux pas de nouveau comme pilote.
Enfin sous Buster, avec le pilote nvidia (390.138) pêché sur leur site et bumblebee, tout fonctionnait correctement : optirun avec glxgears, avec blender, etc.

Voilà, voilà ...
En tout cas, encore merci pour vos réponses.

Dernière modification par Maufab (02-04-2022 14:52:24)

Hors ligne

#5 03-04-2022 14:30:01

Maufab
Membre
Lieu : Ariège
Distrib. : Bullseye
Noyau : 5.10.0-13-amd64
(G)UI : KDE
Inscription : 12-03-2010

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

D'un autre coté, il est vrai qu'avec le pilote nvidia en provenance du site nvidia, j'aurais à vérifier systématiquement les versions du pilote lors des màj de bullseye.
J'aimerai donc trouver une solution avec les dépôts debian. Et surtout comprendre pourquoi le rétroportage de cette pourtant identique version 390.147 ne fonctionne qu'à moitié.

Hors ligne

#6 04-04-2022 21:42:31

Maufab
Membre
Lieu : Ariège
Distrib. : Bullseye
Noyau : 5.10.0-13-amd64
(G)UI : KDE
Inscription : 12-03-2010

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

glxinfo -B :

glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 3000 (SNB GT2) (0x116)
    Version: 20.3.5
    Accelerated: yes
    Video memory: 1536MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 3000 (SNB GT2)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.3.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 20.3.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 20.3.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
 

Hors ligne

#7 04-04-2022 21:52:49

Maufab
Membre
Lieu : Ariège
Distrib. : Bullseye
Noyau : 5.10.0-13-amd64
(G)UI : KDE
Inscription : 12-03-2010

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

primusrun glxinfo -B
primus: fatal: failed to connect to Bumblebee daemon: No such file or directory
 


Avec root :

systemctl restart bumblebeed


Pas d'erreur

primusrun glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: Mesa/X.org
OpenGL renderer string: llvmpipe (LLVM 11.0.1, 256 bits)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 20.3.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 20.3.5
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#8 04-04-2022 22:05:12

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

tu ne peut pas utiliser bumblebee avec le pilote du site nvidia
tu ne peu pas installer le pilote du site nvidia si tu n'a pas les prés-requis au niveau des versions de paquets et du noyau , et si ta carte n'est pas compatible avec ce driver .

si tu veut utiliser Bullseye , soit tu utilise uniquement le gpu intel , soit tu utilise bumblebee avec nouveau.
pour info c'est bumblebee-nvidia qui installe le driver (ça ne fonctionne pas si tu installe manuellement un driver nvidia propriétaire ) .

le driver nvidia nonfree des dépôt debian est configuré pour fonctionner avec la version de debian pour laquelle il est prévu .

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#9 05-04-2022 08:51:30

Maufab
Membre
Lieu : Ariège
Distrib. : Bullseye
Noyau : 5.10.0-13-amd64
(G)UI : KDE
Inscription : 12-03-2010

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

" tu ne peut pas utiliser bumblebee avec le pilote du site nvidia" : "Enfin sous Buster, avec le pilote nvidia (390.138) pêché sur leur site et bumblebee, tout fonctionnait correctement : optirun avec glxgears, avec blender, etc."
"tu ne peu pas installer le pilote du site nvidia si tu n'a pas les prés-requis au niveau des versions de paquets et du noyau , et si ta carte n'est pas compatible avec ce driver ." : pourtant si, avec ma réponse ci-dessus et bien sûr en choississant le driver correspondant à ma carte.
"le driver nvidia nonfree des dépôt debian est configuré pour fonctionner avec la version de debian pour laquelle il est prévu . " :  Il me semblait que le rétroportage revenait à une compilation du paquet source sur le système avec toutes ses dépendances.

Dernière modification par Maufab (05-04-2022 19:59:43)

Hors ligne

#10 12-04-2022 11:22:21

Maufab
Membre
Lieu : Ariège
Distrib. : Bullseye
Noyau : 5.10.0-13-amd64
(G)UI : KDE
Inscription : 12-03-2010

Re : Écran noir Bullseye portable Asus X73SV GPU Nvidia GT504M

Up !
Quelqu'un a t-il une idée ?
C'est quand même malheureux que depuis que cette technologie Optimus existe, elle soit aussimal gérée par Debian ...
Dois-je faire comme sur ce post https://debian-facile.org/viewtopic.php?id=31773 ? Passer sous Ubuntu ? Alors que je suis sous Debian depuis presque 15 ans ...

Dernière modification par Maufab (12-04-2022 11:29:19)

Hors ligne

Pied de page des forums