Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-04-2022 15:19:47

AZeKort
Membre
Inscription : 07-04-2022

Changer de version Gnome

Bonjour !

Depuis une tentative de changement de version de Gnome, je me retrouve avec quelques problèmes.
J'ai voulu faire la mise à jour de Gnome 3.38.6 (car j'ai la version Debian Stable) vers la version Gnome 41. Dans le but d'avoir des fonctionnalités de cette version.

J'ai trouvé une explication des étapes à réaliser pour avoir Gnome 41 sur Debian 11 Stable.]

J'ai maintenant la belle interface du nouveau Gnome 42. Il est sorti il y a 2 semaines donc au lieu d'avoir la version 41, je tombe sur la version 42. Seulement, une partie des fonctionnalités/Nouveau design d'interface est manquante. J'ai l'impression d'avoir un mélange de la version 3.38.6 et 42.
Par exemple : Je ne peux pas modifier l'apparence du Debian, "Ajustement" ou "Tweak-tool" ne fonctionne plus. La fonctionnalité "Apparence" dans les "paramètres" n'apparait pas


Après verification de la version de gnome avec différentes façons, voici les 3 informations que j'obtiens hmm
1 - Gnome 42     | Via la commande $gnome-shell --version
2 - Gnome 41.4  | Via la commande $screenfetch
3 - Gnome 3.38  | Via l'l'interface "Paramètre" > "A propos" > "Version de GNOME"

Voici le résultat de

apt policy gnome-core  gnome-shell


gnome-core:
  Installé : (aucun)
  Candidat : 1:3.38+3
 Table de version :
     1:42+3 100
        100 http://deb.debian.org/debian unstable/main amd64 Packages
     1:3.38+3 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
gnome-shell:
  Installé : 42.0-2
  Candidat : 42.0-2
 Table de version :
 *** 42.0-2 100
        100 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     3.38.6-1~deb11u1 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
 



J'aimerais ainsi soit rester à la version 42, mais que cette version fonctionne bien, soit descendre à la version 41 qui me sera largement satisfaisante.

Ci-dessous, les modifications que j'ai faites via ce tuto

#Unstable for lastest gnome version, manage in /etc/apt/preferences
deb http://deb.debian.org/debian unstable main contrib non-free
deb-src http://deb.debian.org/debian unstable main contrib non-free


# deb cdrom:[Debian GNU/Linux 11.2.0 _Bullseye_ - Official amd64 NETINST 20211218-11:12]/ bullseye main

deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye main contrib non-free

deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free



J'ai créé le fichier dans /etc/apt/preferences car il n'existait pas

Package: *
Pin: release a=bullseye
Pin-Priority: 500

Package: *
Pin: release a=unstable
Pin-Priority: 100

Package: gnome-session
Pin: release a=unstable
Pin-Priority: 1000

Package: gnome-backgrounds
Pin: release a=unstable
Pin-Priority: 1000

Package: gnome-applets
Pin: release a=unstable
Pin-Priority: 1000

Package: gnome-control-center
Pin: release a=unstable
Pin-Priority: 1000

Package: mutter
Pin: release a=unstable
Pin-Priority: 1000

Package: gjs
Pin: release a=unstable
Pin-Priority: 1000




Si quelqu'un a des idées, je suis preneur !
Merci. smile

Dernière modification par AZeKort (08-04-2022 08:38:17)

Hors ligne

#2 07-04-2022 15:55:50

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-13-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : Changer de version Gnome

Bonjour et bienvenue !   smile

Comme nous sommes sûrement très peu voire aucun ici à avoir effectué la démarche, le plus qualifié pour te répondre est celui qui a rédigé le tuto. Or, je remarque que son article ne laisse pas la place pour les commentaires des personnes qui auraient effectué la démarche !

Il n'y a donc aucun suivi et l'auteur du tuto se lave donc les mains de tout dysfonctionnement !

La bonne idée était justement de ne pas suivre ce tuto.




Le site lui-même avertit que les renseignements qu'il donne ne sont pas fiables :

https://www.linuxcapable.com/fr/Avertissement/

« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#3 07-04-2022 16:14:47

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Changer de version Gnome

Bonjour

Attention à la Frankendebian.

En gros, ce genre de manip peut fonctionner plus ou moins bien au début, et finir par casser complètement plus tard au fur et à mesure du développement de unstable.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#4 07-04-2022 16:50:11

AZeKort
Membre
Inscription : 07-04-2022

Re : Changer de version Gnome

--gilles-- a écrit :


La bonne idée était justement de ne pas suivre ce tuto.



Oui effectivement j'aurais dû en trouver un autre, je l'avais choisi car je le trouvais bien fait par rapport à certains autres ^^

bendia a écrit :


En gros, ce genre de manip peut fonctionner plus ou moins bien au début, et finir par casser complètement plus tard au fur et à mesure du développement de unstable.



Ajouter une partie "unstable" m'a toujours fait peur. Cependant, lorsque j'ai vu son explication de la rédaction du fichier /etc/apt/preferences, cela m'a vite mis en confiance.
C'est une partie de Debian que je ne connais pas trop, c'est l'occasion d'étudier cela

Si des personnes s'y connaisse mieux que moi pour des explications où pour essayer de régler les soucis, je suis tout de même preneur ^^

Merci de vos réponses rapide bendia et --gilles-- big_smile

Dernière modification par AZeKort (07-04-2022 16:50:24)

Hors ligne

Pied de page des forums