Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 22-04-2022 18:41:26

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] HDMI n'est plus détecté

cette commande renvoie quelque chose de correct ?


lspci | grep VGA
 


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#27 22-04-2022 18:54:04

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [Résolu] HDMI n'est plus détecté

Oui, l'écran disparaît après Grub.

dmesg | grep -i drm


[    0.947218] i915 0000:00:02.0: drm_WARN_ON(!IS_PLATFORM(dev_priv, INTEL_TIGERLAKE) && !IS_PLATFORM(dev_priv, INTEL_ROCKETLAKE))
[    0.947256] WARNING: CPU: 2 PID: 117 at drivers/gpu/drm/i915/intel_pch.c:124 intel_pch_type+0x897/0x950 [i915]
[    0.947256] Modules linked in: i915(+) crct10dif_pclmul crct10dif_common crc32_pclmul crc32c_intel i2c_algo_bit xhci_pci e1000e(+) xhci_hcd drm_kms_helper ahci libahci libata cec usbcore ptp drm pps_core scsi_mod i2c_i801 i2c_smbus intel_lpss_pci usb_common intel_lpss idma64 fan wmi video button
[    0.947813] i915 0000:00:02.0: [drm] VT-d active for gfx access
[    0.947816] fb0: switching to inteldrmfb from EFI VGA
[    0.949185] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    0.949877] i915 0000:00:02.0: [drm] *ERROR* crtc 51: Can't calculate constants, dotclock = 0!
[    0.949882] i915 0000:00:02.0: drm_WARN_ON_ONCE(drm_drv_uses_atomic_modeset(dev))
[    0.949907] WARNING: CPU: 1 PID: 117 at drivers/gpu/drm/drm_vblank.c:722 drm_crtc_vblank_helper_get_vblank_timestamp_internal+0x316/0x330 [drm]
[    0.949908] Modules linked in: i915(+) crct10dif_pclmul crct10dif_common crc32_pclmul crc32c_intel i2c_algo_bit xhci_pci e1000e(+) xhci_hcd drm_kms_helper ahci libahci libata cec usbcore ptp drm pps_core scsi_mod i2c_i801 i2c_smbus intel_lpss_pci usb_common intel_lpss idma64 fan wmi video button
[    0.949926] RIP: 0010:drm_crtc_vblank_helper_get_vblank_timestamp_internal+0x316/0x330 [drm]
[    0.949944]  drm_get_last_vbltimestamp+0xaa/0xc0 [drm]
[    0.949951]  drm_reset_vblank_timestamp+0x5b/0xd0 [drm]
[    0.949958]  drm_crtc_vblank_on+0x7b/0x130 [drm]
[    0.951826] i915 0000:00:02.0: drm_WARN_ON(!pll->info->funcs->get_hw_state(dev_priv, pll, &pipe_config->dpll_hw_state))
[    0.951864] WARNING: CPU: 1 PID: 117 at drivers/gpu/drm/i915/display/intel_display.c:11160 hsw_get_pipe_config+0xf7d/0x12c0 [i915]
[    0.951864] Modules linked in: i915(+) crct10dif_pclmul crct10dif_common crc32_pclmul crc32c_intel i2c_algo_bit xhci_pci e1000e(+) xhci_hcd drm_kms_helper ahci libahci libata cec usbcore ptp drm pps_core scsi_mod i2c_i801 i2c_smbus intel_lpss_pci usb_common intel_lpss idma64 fan wmi video button
[    0.952183] WARNING: CPU: 1 PID: 117 at drivers/gpu/drm/i915/display/intel_display.c:14330 intel_atomic_commit_tail+0x126d/0x12c0 [i915]
[    0.952183] Modules linked in: i915(+) crct10dif_pclmul crct10dif_common crc32_pclmul crc32c_intel i2c_algo_bit xhci_pci e1000e(+) xhci_hcd drm_kms_helper ahci libahci libata cec usbcore ptp drm pps_core scsi_mod i2c_i801 i2c_smbus intel_lpss_pci usb_common intel_lpss idma64 fan wmi video button
[    0.952648] [drm] Initialized i915 1.6.0 20200917 for 0000:00:02.0 on minor 0
[    0.953826] i915 0000:00:02.0: [drm] Cannot find any crtc or sizes
[    2.721675] systemd[1]: Starting Load Kernel Module drm...
[    2.729725] systemd[1]: modprobe@drm.service: Succeeded.
[    2.729850] systemd[1]: Finished Load Kernel Module drm.



lspci | grep VGA


00:02.0 VGA compatible controller: Intel Corporation Device 9ba8 (rev 03)


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#28 22-04-2022 19:08:31

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] HDMI n'est plus détecté

une commande pour les erreurs du système


journalctl -b -r -p err
 



un problème avec le firmware ou le noyau de bullseye , si raleur repasse par la pour dire ce qu'il en pense .
pour le noyau il y a les backports de bullseye , pour le firmware faut que je cherche
tu a bien retiré toutes les options de grub ? (comme nomodeset )

donc tester le noyau des backports de bullseye , il faut ajouter une ligne au sources.list


#debian11
deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye-backports main contrib non-free
 


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#29 22-04-2022 19:26:48

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [Résolu] HDMI n'est plus détecté

oui, nomodeset est retiré (il reste quiet et splash mais je ne pense pas que ça pose problème)
Je regarde pour mettre les backports.


root@zenon:~# journalctl -b -r -p err


-- Journal begins at Fri 2022-04-22 09:05:02 CEST, ends at Fri 2022-04-22 19:24:41 CEST. --
Apr 22 19:24:31 zenon pipewire[777]: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner: >
Apr 22 18:51:44 zenon pulseaudio[579]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not>
Apr 22 18:51:18 zenon pipewire[578]: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner: >
Apr 22 18:50:25 zenon sddm[494]: Could not start Display server on vt 7
Apr 22 18:50:25 zenon sddm[494]: Failed to read display number from pipe
Apr 22 18:50:24 zenon kernel: i915 0000:00:02.0: [drm] *ERROR* crtc 51: Can't calculate constants, dotclock = >
Apr 22 18:50:24 zenon kernel: x86/cpu: VMX (outside TXT) disabled by BIOS
 


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#30 22-04-2022 19:33:37

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.0.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] HDMI n'est plus détecté

bonsoir lancelot   smile  smile  smile

tu as quoi comme carte mère ?

dmesg | grep DMI:


quoi comme noyau ?

uname -a


apt search linux-image-5.10.


apt search linux-image-5.16


https://tracker.debian.org/pkg/linux

Dernière modification par Debian Alain (22-04-2022 19:37:58)

Hors ligne

#31 22-04-2022 20:27:02

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [Résolu] HDMI n'est plus détecté

Ma carte-mère est une Asus Prime H510M-E

Pour le noyau :

uname -a
Linux zenon 5.10.0-13-amd64 #1 SMP Debian 5.10.106-1 (2022-03-17) x86_64 GNU/Linux



Je vais essayer de changer de version du noyau.


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#32 22-04-2022 20:41:34

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.0.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] HDMI n'est plus détecté

j'ai un peu suivi ton fil , lancelot .   smile  smile  smile

je crois que l'on te parle (je sais plus où) , peut être ? de tester un noyau plus récent ...

je te propose d'installer un noyau des backports .

https://debian-facile.org/doc:systeme:a … -backports

tu trouvera dans ce lien ci - dessus le dépot backports à rajouter à ta stable .

n'oublie pas de faire un update et un upgrade après modification de tes sources .

et avant d'installer le noyau .

pour l'activer , redémarrage  préalable .

amicalement ,

alain .

coyotus.png

bonne chance .

Hors ligne

#33 22-04-2022 21:30:37

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [Résolu] HDMI n'est plus détecté

Çaaaaaa y est ! Le changement de version du noyau (de 10 à 16) a permis de résoudre le problème. Je fais quelques tests demain et je passe en résolu ! Merci pour votre aide, en espérant que ça servira à d'autres que moi !

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#34 22-04-2022 22:10:20

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.0.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] HDMI n'est plus détecté

bonsoir lancelot   smile  smile  smile

ta carte mère est relativement jeune .

je ne suis pas surpris que tes problèmes  soient résolus  avec un noyau plus récent .

pour être hétérogène , ce serai plus censé d'installer une testing (bookworm) sur ce genre de matériel .

tu auras alors des paquets relativement frais .

le seul ennui , c'est que testing est longue à faire rentrer les  correctifs .

en cas de panne , çà peut être long , voire très long d' obtenir les solutions .

il faudra que tu surveilles les noyaux des backports ,histoire de rester à jour .

normalement , pour bien faire , tu devrai installer les 2 mêta  paquets suivants :

linux-image-amd64  et linux-headers-amd64

depuis les backports , cela doit être bon et assurer la m.a.j. automatique des noyaux .

amicalement ,

alain .

coyotus.png



.

Dernière modification par Debian Alain (22-04-2022 22:19:15)

Hors ligne

#35 23-04-2022 18:34:53

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [Résolu] HDMI n'est plus détecté

Merci Alain pour la suggestion. C'est ce que je vais faire. Merci pour l'aide de tous, vous m'avez encore tiré du pétrin, comme il y a six ans, la première fois que j'ai installé Debian. Je passe le post en résolu.

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#36 23-04-2022 18:53:20

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.0.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] HDMI n'est plus détecté

tu peux peut être aussi installer les  noyaux à la main .

pour les mêta paquets :

sudo apt -t bullseye-backports install --reinstall linux-image-amd64 linux-headers-amd64


pour le noyau à la main :
(je ne sais plus si les mêta paquets suffisent)

sudo apt -t bullseye-backports install --reinstall linux-image-5.16.12-1~bpo11+1-amd64 linux-headers-5.16.12-1~bpo11+1-amd64


vérifie d'abord le bon nom des paquets du kernel :

apt search linux-image-5.16.



https://debian-facile.org/doc:systeme:a … troduction
pour testing , si tu n'es pas prêt , n'essaie pas .
tu peux commencer avec stable + les  backports .

Dernière modification par Debian Alain (23-04-2022 18:59:30)

Hors ligne

#37 23-04-2022 19:43:20

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] HDMI n'est plus détecté

Les headers ne servent à rien si on ne compile pas de module externe.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums