Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-05-2022 09:38:29

EJIND
Membre
Inscription : 05-05-2022

[RESOLU]Dependances non trouvées

Bonjour,

Je doit mettre à jour Mysql sur un serveur avec Debian Lenny (32 bits).
Mysql-client nécessite des dépendances que je ne trouve pas :

dpkg : des problèmes de dépendances empêchent la configuration de mysql-client-5.1 :
mysql-client-5.1 dépend de libncurses5 (>= 5.7+20100313) ; cependant :
  La version de libncurses5 sur le système est 5.7+20081213-1.
mysql-client-5.1 dépend de libreadline6 (>= 6.0) ; cependant :
  Le paquet libreadline6 n'est pas installé.

Pouvez-vous me dire où je pourrais trouver les .deb pour installer ces dépendances ?

Merci

Dernière modification par EJIND (09-05-2022 17:16:24)

Hors ligne

#2 05-05-2022 10:22:21

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [RESOLU]Dependances non trouvées

Bjr,

Le sources.list est-il à jour ? Disons avec l'adresse des archives ? J'avais ça pour wheezy regarde si ça fonctionne pour Lenny

deb http://archive.debian.org/debian/ lenny main

deb http://archive.debian.org/debian-archive/debian-security/ lenny updates/main


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#3 05-05-2022 10:33:53

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Bonjour,

J'ai mis tout ce que j'ai pu trouver en archive :


deb http://security.debian.org/ lenny/updates main
deb-src http://security.debian.org/ lenny/updates main

#deb http://volatile.debian.org/debian-volatile lenny/volatile main
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main

deb http://archive.debian.org/debian-security lenny/updates main contrib non-free
deb-src http://archive.debian.org/debian-security/ lenny/updates main contrib non-free
deb http://archive.debian.org/debian-volatile/ lenny/volatile main contrib
deb http://archive.debian.org/debian-archive/debian/ lenny main contrib non-free
deb-src http://archive.debian.org/debian-archive/debian/ lenny main contrib non-free

deb http://debian.proxad.net/debian lenny-backports main

deb http://archive.debian.org/debian/ hamm contrib main non-free

deb http://archive.debian.org/debian/ bo bo-unstable contrib main non-free
 



J'ai fait un apt-get update mais le paquet libreadline6 n'est pas trouvé par ex.

Hors ligne

#4 05-05-2022 10:39:57

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

J'obtiens ceci en ne laissant que les 2 sources que tu m'as donné :

Atteint http://archive.debian.org lenny/main Sources
Atteint http://archive.debian.org lenny/contrib Sources
Atteint http://archive.debian.org lenny/non-free Sources
582ko réceptionnés en 0s (763ko/s)
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: GPG error: http://archive.debian.org lenny/volatile Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1358963195
W: GPG error: http://archive.debian.org lenny Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: Impossible de récupérer http://debian.proxad.net/debian/dists/lenny-backports/main/binary-i386/Packages  404 Not Found [IP : 212.27.32.66 80]

W: Impossible de récupérer http://security.debian.org/dists/lenny/updates/main/binary-i386/Packages  404 Not Found [IP : 151.101.66.132 80]

W: Impossible de récupérer http://security.debian.org/dists/lenny/updates/main/source/Sources  404 Not Found [IP : 151.101.66.132 80]

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
 

Hors ligne

#5 05-05-2022 10:45:03

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [RESOLU]Dependances non trouvées

Hello,

C'est quand même un peu dangereux une Lenny :

https://www.debian.org/releases/lenny/ a écrit :

Les mises à jour de sécurité sont arrêtées depuis le 6 février 2012.


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#6 05-05-2022 13:37:58

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Oui, tu as tout à fait raison.
C'est un serveur qui va bientôt être arrêté mais il faut qu'on puisse se connecter sur Mysql avec un connecteur qui demande une version de 5.1 minimum d'où ma recherche pour mettre à jour Mysql.
Je suis arrivé à installer mysql-server en version supérieur mais je n'y arrive pas pour mysql-client.

Hors ligne

#7 05-05-2022 13:59:44

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

Hello
pour le sources.list se serait

deb http://archive.debian.org/debian-archive/debian/ lenny main contrib non-free
deb http://archive.debian.org/debian-security/ lenny/updates main contrib non-free



https://wiki.debian.org/fr/DebianLenny# … 6_versions


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 05-05-2022 14:25:16

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Je viens d'ajouter les 2 dépôts et fais un apt-get update :


root@bafinddtest:/home/temp/Eric# apt-get update
Réception de : 1 http://archive.debian.org lenny Release.gpg [1034B]
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Réception de : 2 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Ign http://archive.debian.org lenny/updates/contrib Translation-fr
Ign http://archive.debian.org lenny/updates/non-free Translation-fr
Atteint http://archive.debian.org lenny Release
Atteint http://archive.debian.org lenny/updates Release
Err http://archive.debian.org lenny Release

Réception de : 3 http://archive.debian.org lenny Release [99,6kB]
Ign http://archive.debian.org lenny Release
Réception de : 4 http://archive.debian.org lenny/updates Release [92,4kB]
Ign http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Ign http://archive.debian.org lenny/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/main Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/contrib Packages
Atteint http://archive.debian.org lenny/non-free Packages
Atteint http://archive.debian.org lenny/updates/main Packages
Atteint http://archive.debian.org lenny/updates/contrib Packages
Atteint http://archive.debian.org lenny/updates/non-free Packages
194ko réceptionnés en 0s (507ko/s)
Lecture des listes de paquets... Fait
W: GPG error: http://archive.debian.org lenny Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
 



Si j'essaie de mettre à jour libncurses5 :

 apt-get upgrade libncurses5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été conservés :
  bind9-host dnsutils libbind9-50 libisccc50 libisccfg50 liblwres50
0 mis à jour, 0 nouvellement installés, 0 à enlever et 6 non mis à jour.
 



Si je recherche libreadline, la version 6 n'apparaît pas :

apt-cache search  libreadline
libreadline-java-doc - API docs for readline/editline wrappers for Java
libreadline-java - GNU readline and BSD editline wrappers for Java
libreadline5-dbg - GNU readline and history libraries, debugging libraries
libreadline5-dev - GNU readline and history libraries, development files
libreadline-ruby - Readline interface for Ruby
libreadline-ruby1.8 - Readline interface for Ruby 1.8
ruby1.8 - Interpreter of object-oriented scripting language Ruby 1.8
libreadline-ruby1.9 - Readline interface for Ruby 1.9
libreadline5 - bibliothèques GNU readline et GNU history (exécutables)
 



Je me sens un peu dans l'impasse.

Hors ligne

#9 05-05-2022 14:31:24

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [RESOLU]Dependances non trouvées

Il y a des chances que l’absence de libreadline6 soit liée à tes erreurs de clés expirées, qui excluent certains dépôts que tu as renseignés des sources de paquets utilisables.

Jouer sous Debian ? Facile !

Hors ligne

#10 05-05-2022 18:58:40

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

je ne sais pas si on peu résoudre se sous de clé mais on peu forcé la mise à jour
voir

man apt-secure


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 06-05-2022 08:35:30

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Bonjour,

La commande apt-secure n'est pas connue (commande not found) et je ne vois pas comment l'installer.

Hors ligne

#12 06-05-2022 09:24:59

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

ah oui pas faux il me semble que apt solo c'est seulement depuis jessie
dans le man apt-get
essai voir avec l'option  --force-yes ou --allow-unauthenticated

man apt-get a écrit :

--allow-unauthenticated
Ignorer le fait que les paquets ne peuvent pas être authentifiés ; ne le signale pas à l'utilisateur. Cette option peut être utile si on travaille avec des dépôts locaux, mais cela représente un risque considérable si    l'authenticité des données n'est pas assurée d'une autre manière par l'utilisateur lui-même. L'utilisation de l'option Trusted pour les entrées de sources.list(5) devrait être habituellement préférée à ce remplacement
           global. Élément de configuration : APT::Get::AllowUnauthenticated.


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#13 06-05-2022 09:55:05

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Je viens d'essayer mais je retrouve les mêmes erreurs :

 apt-get update --allow-unauthenticated
Réception de : 1 http://archive.debian.org lenny Release.gpg [1034B]
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Réception de : 2 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Ign http://archive.debian.org lenny/updates/contrib Translation-fr
Ign http://archive.debian.org lenny/updates/non-free Translation-fr
Atteint http://archive.debian.org lenny Release
Atteint http://archive.debian.org lenny/updates Release
Err http://archive.debian.org lenny Release

Réception de : 3 http://archive.debian.org lenny Release [99,6kB]
Ign http://archive.debian.org lenny Release
Réception de : 4 http://archive.debian.org lenny/updates Release [92,4kB]
Ign http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Ign http://archive.debian.org lenny/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/main Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/contrib Packages
Atteint http://archive.debian.org lenny/non-free Packages
Atteint http://archive.debian.org lenny/updates/main Packages
Atteint http://archive.debian.org lenny/updates/contrib Packages
Atteint http://archive.debian.org lenny/updates/non-free Packages
194ko réceptionnés en 0s (471ko/s)
Lecture des listes de paquets... Fait
W: GPG error: http://archive.debian.org lenny Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
 

Hors ligne

#14 06-05-2022 10:07:03

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

vois le man apt-get possible que cette option soit apparu apres lenny , moi je regarde depuis Bullseye
edit : d'apres ce que je lis du man apt-get il y a des chances que sous lenny il y ait juste --force-yes de disponible

Dernière modification par Croutons (06-05-2022 10:14:15)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#15 06-05-2022 10:19:19

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Avec --force-yes, j'obtiens le même résultat :

apt-get update --force-yes
Réception de : 1 http://archive.debian.org lenny Release.gpg [1034B]
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Réception de : 2 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Ign http://archive.debian.org lenny/updates/contrib Translation-fr
Ign http://archive.debian.org lenny/updates/non-free Translation-fr
Atteint http://archive.debian.org lenny Release
Atteint http://archive.debian.org lenny/updates Release
Err http://archive.debian.org lenny Release

Réception de : 3 http://archive.debian.org lenny Release [99,6kB]
Ign http://archive.debian.org lenny Release
Réception de : 4 http://archive.debian.org lenny/updates Release [92,4kB]
Ign http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Ign http://archive.debian.org lenny/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/main Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/contrib Packages
Atteint http://archive.debian.org lenny/non-free Packages
Atteint http://archive.debian.org lenny/updates/main Packages
Atteint http://archive.debian.org lenny/updates/contrib Packages
Atteint http://archive.debian.org lenny/updates/non-free Packages
194ko réceptionnés en 0s (407ko/s)
Lecture des listes de paquets... Fait
W: GPG error: http://archive.debian.org lenny Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
 

Hors ligne

#16 06-05-2022 10:26:42

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

ah mince il faudrait peut être changer dans les fichiers de configuration
qu'est ce que cela donne si tu recherches avec grep

grep -i apt /etc/apt/apt.conf.d/*


il me semblait pourtant que on pouvait passer outre les réglages en passant une option a apt-get

Dernière modification par Croutons (06-05-2022 10:26:56)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#17 06-05-2022 10:32:00

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

DÉPÔTS NON SIGNÉS
Si une archive possède un fichier Release non signé ou pas de fichier Release du tout, les versions actuelles d'APT refuseront par défaut d'en télécharger des données dans les opérations update. Même si un frontal tel que apt-get(8) est forcé de télécharger, il demandera une confirmation explicite si une installation inclut un paquet d'une archive non authentifiée.
Vous pouvez contraindre les clients APT à n'émettre que des avertissements en configurant l'option Acquire::AllowInsecureRepositories à true. L'option allow-insecure=yes de sources.list(5) peut aussi permettre à des dépôts individuels d'être non sécurisés. Veuillez noter que les dépôts non sécurisés sont fortement déconseillés et toutes les options pour contraindre APT à continuer à les prendre en charge devront être éventuellement supprimées. Les utilisateurs disposent aussi de l'option Trusted pour désactiver même les avertissements, mais il faut être sûr de comprendre ses implications détaillées dans sources.list(5).
Un dépôt qui auparavant était authentifié, mais qui perdrait cet état lors d'une opération update envoie un message d'erreur à tous les clients d'APT quelle que soit l'option d'autoriser ou d'interdire l'utilisation de dépôts non sécurisés. L'erreur peut être contournée par le réglage supplémentaire de Acquire::AllowDowngradeToInsecureRepositories à true, ou, pour des dépôts individuels avec l'option allow-downgrade-to-insecure=yes de sources.list(5).



donc de se que j'en comprend soit on régle la sécurité dans un des fichiers apt.conf a Acquire::AllowDowngradeToInsecureRepositories à true
ou soit on défini l'option dans le sources.list pour les dépots concernés  allow-downgrade-to-insecure=yes

Dernière modification par Croutons (06-05-2022 10:38:18)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#18 06-05-2022 10:44:59

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Voici le résultat de la commande :

grep -i apt /etc/apt/apt.conf.d/*
/etc/apt/apt.conf.d/00trustcdrom:APT::Authentication::TrustCDROM "true";
/etc/apt/apt.conf.d/01autoremove:APT
/etc/apt/apt.conf.d/70debconf:DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};
 



J'ai essayé cette commande "apt-get update -o Acquire::AllowInsecureRepositories=true" mais même résultat :

  apt-get update -o Acquire::AllowInsecureRepositories=true
Réception de : 1 http://archive.debian.org lenny Release.gpg [1034B]
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Réception de : 2 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Ign http://archive.debian.org lenny/updates/contrib Translation-fr
Ign http://archive.debian.org lenny/updates/non-free Translation-fr
Atteint http://archive.debian.org lenny Release
Atteint http://archive.debian.org lenny/updates Release
Err http://archive.debian.org lenny Release

Réception de : 3 http://archive.debian.org lenny Release [99,6kB]
Ign http://archive.debian.org lenny Release
Réception de : 4 http://archive.debian.org lenny/updates Release [92,4kB]
Ign http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Ign http://archive.debian.org lenny/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/main Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/contrib Packages
Atteint http://archive.debian.org lenny/non-free Packages
Atteint http://archive.debian.org lenny/updates/main Packages
Atteint http://archive.debian.org lenny/updates/contrib Packages
Atteint http://archive.debian.org lenny/updates/non-free Packages
194ko réceptionnés en 0s (526ko/s)
Lecture des listes de paquets... Fait
W: GPG error: http://archive.debian.org lenny Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
 

Hors ligne

#19 06-05-2022 10:57:53

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

L'option "AllowDowngradeToInsecureRepositories" ne semble pas fonctionner, je ne sais pas comment la mettre dans un "val" :

apt-get update -o Acquire::AllowDowngradeToInsecureRepositories -o Acquire::AllowInsecureRepositories=true
E: Option Acquire::AllowDowngradeToInsecureRepositories : l'item configuration doit être spécifiée avec un =<val>.
 

Hors ligne

#20 06-05-2022 11:14:38

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

ah non ce sont pas des options de la ligne de commande mais des options de fichiers de configuration
en somme tu pourrais essayé dans ton fichier sources.list

deb http://archive.debian.org/debian-archive/debian/ lenny main contrib non-free allow-downgrade-to-insecure=yes
deb http://archive.debian.org/debian-security/ lenny/updates main contrib non-free allow-downgrade-to-insecure=yes


je sais pas trop si c'est en fin de ligne
essai déja de voir si cela fonctionne comme cela sinon , il faudra essayer avec Acquire::AllowDowngradeToInsecureRepositories à true
dans un fichier /etc/apt/apt.conf.d/
Juste en créant un fichier en root

nano /etc/apt/apt.conf.d/02InsecureRepositories


avec la ligne

Acquire::AllowDowngradeToInsecureRepositories "true" ;
 

Dernière modification par Croutons (06-05-2022 14:35:13)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#21 06-05-2022 11:30:35

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [RESOLU]Dependances non trouvées

Tu peux aussi tenter d'installer la clé

apt-get install --reinstall debian-archive-keyring


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#22 06-05-2022 11:32:52

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

En mettant l'option dans sources.list à la fin de la ligne, j'obtiens :

apt-get update
Réception de : 1 http://archive.debian.org lenny Release.gpg [1034B]
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Ign http://archive.debian.org lenny/allow-downgrade-to-insecure=yes Translation-fr
Réception de : 2 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Ign http://archive.debian.org lenny/updates/contrib Translation-fr
Ign http://archive.debian.org lenny/updates/non-free Translation-fr
Ign http://archive.debian.org lenny/updates/allow-downgrade-to-insecure=yes Translation-fr
Atteint http://archive.debian.org lenny Release
Atteint http://archive.debian.org lenny/updates Release
Err http://archive.debian.org lenny Release

Réception de : 3 http://archive.debian.org lenny Release [99,6kB]
Ign http://archive.debian.org lenny Release
Réception de : 4 http://archive.debian.org lenny/updates Release [92,4kB]
Ign http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Ign http://archive.debian.org lenny/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/allow-downgrade-to-insecure=yes Packages
Ign http://archive.debian.org lenny/updates/main Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/allow-downgrade-to-insecure=yes Packages
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/contrib Packages
Atteint http://archive.debian.org lenny/non-free Packages
Ign http://archive.debian.org lenny/allow-downgrade-to-insecure=yes Packages
Atteint http://archive.debian.org lenny/updates/main Packages
Atteint http://archive.debian.org lenny/updates/contrib Packages
Atteint http://archive.debian.org lenny/updates/non-free Packages
Ign http://archive.debian.org lenny/updates/allow-downgrade-to-insecure=yes Packages
Err http://archive.debian.org lenny/allow-downgrade-to-insecure=yes Packages
  404 Not Found [IP : 130.89.148.13 80]
Err http://archive.debian.org lenny/updates/allow-downgrade-to-insecure=yes Packages
  404 Not Found [IP : 130.89.148.13 80]
194ko réceptionnés en 0s (344ko/s)
W: GPG error: http://archive.debian.org lenny Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: Impossible de récupérer http://archive.debian.org/debian-archive/debian/dists/lenny/allow-downgrade-to-insecure=yes/binary-i386/Packages  404 Not Found [IP : 130.89.148.13 80]

W: Impossible de récupérer http://archive.debian.org/debian-security/dists/lenny/updates/allow-downgrade-to-insecure=yes/binary-i386/Packages  404 Not Found [IP : 130.89.148.13 80]

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
 



En créant un fichier "02InsecureRepositories" (mais je n'ai pas répété /apt/etc dans le path), j'obtiens la même erreur :

apt-get update
Réception de : 1 http://archive.debian.org lenny Release.gpg [1034B]
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Réception de : 2 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Ign http://archive.debian.org lenny/updates/contrib Translation-fr
Ign http://archive.debian.org lenny/updates/non-free Translation-fr
Atteint http://archive.debian.org lenny Release
Atteint http://archive.debian.org lenny/updates Release
Err http://archive.debian.org lenny Release

Réception de : 3 http://archive.debian.org lenny Release [99,6kB]
Ign http://archive.debian.org lenny Release
Réception de : 4 http://archive.debian.org lenny/updates Release [92,4kB]
Ign http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Ign http://archive.debian.org lenny/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/main Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/contrib Packages
Atteint http://archive.debian.org lenny/non-free Packages
Atteint http://archive.debian.org lenny/updates/main Packages
Atteint http://archive.debian.org lenny/updates/contrib Packages
Atteint http://archive.debian.org lenny/updates/non-free Packages
194ko réceptionnés en 0s (473ko/s)
Lecture des listes de paquets... Fait
W: GPG error: http://archive.debian.org lenny Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
 

Hors ligne

#23 06-05-2022 11:49:12

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

phlinux a écrit :

Tu peux aussi tenter d'installer la clé


oui avec un peu de chance, mais je sais meme pas si ce paquet existait sous lenny mais cela se tente

EJIND a écrit :

En créant un fichier "02InsecureRepositories" (mais je n'ai pas répété /apt/etc dans le path), j'obtiens la même erreur :


j'ai pas compris mais je n'ai pas répété /apt/etc dans le path, que veux tu dire ?


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#24 06-05-2022 14:00:56

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

que j'ai créé le dossier dans /etc/apt/apt.conf.d et non dans /etc/apt/etc/apt/apt.conf.d comme mentionné dans la commande "nano" (nano /etc/apt/etc/apt/apt.conf.d/02InsecureRepositories)

Hors ligne

#25 06-05-2022 14:34:24

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

ah oui my bad comme on dit entre gamer lol je correctionne mon message
la ligne existe peut être dans un des fichiers config de apt et si sa valeur est a false ?
il y a un apt.conf sous lenny? je pense que ce doit être lui qui est lu en premier puis viennent ensuite les fichiers dans /etc/apt/apt.conf.d/

edit : en cherchant sur le net j'ai vu quelqu'un qui avait trouvé une solution pour cette histoire de clé expiré
c'est un peu tiré par les cheveux mais si cela fonctionne le temps de tout mettre à jour
le truc consiste a ramené la machine 10 ans en arrière et faire les mise à jour vite fais avant que le système se remette a l'heure

date --set 2010-05-13


lu la
https://www.debian-fr.xyz/viewtopic.php?t=1927

Dernière modification par Croutons (06-05-2022 15:00:52)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums