Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-05-2022 18:48:39

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

[Résolu] Installer un paquet épinglé

Bonjour,
sur une sid, je voudrais réinstaller un paquet que j'avais épinglé et je tourne en rond,

Explanation: Pinned by apt-listbugs at 2021-11-21 09:38:31 +0100
Explanation:   #999912: libpython3.10-stdlib,python3-gdbm: both ship /usr/lib/python3.10/lib-dynload/_dbm.cpython-310-x86_64-linux-gnu.so
Package: libpython3.10-stdlib
Pin: version *
Pin-Priority: -30000


mais :

apt install libpython3.10-stdlib
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Aucune version du paquet libpython3.10-stdlib n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  libpython3.10-stdlib:i386


et là où ça devient embêtant:

Aucune version du paquet libpython3.10-stdlib:i386 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  libpython3.10-stdlib


merci pour vos avis et commentaires,

Dernière modification par ubub (08-05-2022 19:59:02)

Hors ligne

#2 08-05-2022 19:11:14

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] Installer un paquet épinglé

Hello
aucune trace du paquet que tu pourrais installé depuis le répertoire /var/cache/apt/archives/ ?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 08-05-2022 19:27:51

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Installer un paquet épinglé

Bonsoir
Que te retourne

dpkg --list | grep ^hi




Voir si le paquet est toujours épinglé ou non


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#4 08-05-2022 19:29:30

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Installer un paquet épinglé

Salut,
en user, ca me renvoie rien ..

Hors ligne

#5 08-05-2022 19:48:34

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Installer un paquet épinglé

C'est qu'il n'est plus épinglé....

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#6 08-05-2022 19:50:02

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Installer un paquet épinglé

Bizarre il devrait le trouver

apt-cache policy libpython3.10-stdlib
libpython3.10-stdlib:
  Installé : 3.10.4-3
  Candidat : 3.10.4-3
 Table de version :
 *** 3.10.4-3 500
        500 http://deb.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#7 08-05-2022 19:54:47

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Installer un paquet épinglé

Semble être toujours d'actualité
https://packages--debian--org---zcfe4ww … b/download

J'avais pas fait gaffe que c'était un i386

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#8 08-05-2022 20:06:46

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Installer un paquet épinglé

Bon, j'ai résolu mon problème, je pense,
J'ai effacé mon fichier apt-listbugs dans /etc/apt/preferences.d,
et lancé un upgrade, et un fatras de paquets dont pas mal de python se sont installés, et j'ai pu réinstaller Gvim qui nécessitait ce fameux paquet, et là pas de couic
désolé croutons, j'avais pas vu ton post ..

cyrille a écrit :

C'est qu'il n'est plus épinglé...


je voulais savoir, c'est quoi hi ?
merci, wink

Hors ligne

#9 08-05-2022 20:11:19

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Installer un paquet épinglé

je dirais h pour hold (épinglé) et i pour installé

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#10 08-05-2022 20:12:15

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Installer un paquet épinglé

Sinon le même via aptitude

aptitude search "~ahold"


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#11 08-05-2022 20:27:20

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Installer un paquet épinglé

Du coup, c'est censé renvoyer les paquets épinglés h ?
J'ai un paquet épinglé, en testant les deux commandes, j'ai aucun retour ...

Hors ligne

#12 08-05-2022 20:31:11

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Installer un paquet épinglé

Bizarre .... Sauf si l'épinglage lors de l'upgrade de la sid fonctionne différemment de l'épinglage manuel (mark hold) .
Honnetement, jamais réellement posé la question, je vais y réfléchir asap

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#13 08-05-2022 20:44:22

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Installer un paquet épinglé

Bah, j'aurais pas compris sinon si y'avait aucun paquet épinglé, le changement avec effacer à mano le fichier.
Mais, du coup, j'avais pas tout effacé, comme wpasupplicant que j'avais laissé épinglé,
mais le fichier (retouché) a été écrasé par un nouveau fichier listbugs..
Cependant, wpasupplicant n'a pas été upgradé et n'est pas épinglé ...

wpasupplicant:
  Installé : 2:2.9.0-23
  Candidat : 2:2.10-9


dpkg --list | grep wpasupplicant


bloc à supprimer si la commande n’affiche rien


ii  wpasupplicant                         2:2.9.0-23                         amd64        client support for WPA and WPA2 (IEEE 802.11i)

Hors ligne

Pied de page des forums