Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-07-2022 17:56:58

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

[RESOLU] Soucis de boot sur serveur HP Proliant

Bonjour j'ai un serveur Serveur HP ProLiant ML 310e Gen 8 v2, depuis qq années. Pas de soucis.

Il était sous debian 10 et je l'ai upgrader sous debian 11 sans soucis.

Par contre lors du reboot j'ai vu ce message d'erreur au boot :

[   37.204728] ata2: COMRESET failed (errno=-16)
[   47.236727] ata2: COMRESET failed (errno=-16)



ça allonge le temps de boot mais au final, il boote

Un dmesg me retourne

[   12.060723] ata2: COMRESET failed (errno=-16)
[   21.973036] ata2.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x8 0)
[   37.204728] ata2: COMRESET failed (errno=-16)
[   47.236727] ata2: COMRESET failed (errno=-16)
[   53.733012] ata2.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x8 0)
[   68.948692] ata2: COMRESET failed (errno=-16)
[   78.980724] ata2: COMRESET failed (errno=-16)
[   85.413034] ata2.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x8 0)
[  100.692724] ata2: COMRESET failed (errno=-16)
[  110.724702] ata2: COMRESET failed (errno=-16)



Et autre chose mais je ne les ai pas sous la main... parce qu'en cherchant via un moteur de recherche , j'ai vu que ça pouvait venir du lecteur CD.

Du coup je l'ai débranché mais depuis impossible de booter, même en le rebranchant... La séquence de boot s'initialise puis j'ai un message que l'écran passe en veille (avant d'arriver au grub, donc durant le boot de l'HP, ça plante à 20% de iLO environ) et impossible de reprendre la main


Par contre en ouvrant la machine j'ai entendu un claquement, je pense qu'il vient de l'alimentation (peut être l'électro aimant ? je ne sais pas trop)

Si vous aviez des idées, je suis preneur , d'avance merci wink

(PS le soucis ne vient pas de debian mais je ne savais pas trop où poster...)

Dernière modification par cyrille (04-07-2022 14:59:06)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#2 04-07-2022 10:07:43

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Soucis de boot sur serveur HP Proliant

Bonjour
pas assez d'infos


Format Tour (4U), Intel Xeon E3, 1220 V3, 4 Go, 350 Watts, 1 To / RAID 1
 


ps: il semble que les disques soit propriétaires (uniquement disque HP )

la machine boot sur clé usb , CD ou DVD , ou un disque (par exemple le second du raid 1)
pas un souci du noyau pour booter sur les disques ? (tenter un noyau de buster sur bullseye)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD 5700X ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 04-07-2022 11:03:13

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU] Soucis de boot sur serveur HP Proliant

Merci Robert pour avoir jeté un oeil à ce thread wink

Bon, je l'ai débranché vendredi en partant du travail, rebranché ce matin.
Et le serveur a booté et a démarré .

Il y a toujours cette histoire de ata2: COMRESET failed (errno=-16) qui ralentit le boot mais ça passe

Plus de bruit de claquement c'est toujours ça

Alors voici le dmesg
https://paste.debian.net/1246093/

Et le dmidecode pour le matériel
https://paste.debian.net/1246094/

J'avoue ne pas être très à l'aise avec cette machine HP

Merci d'avance wink

Dernière modification par cyrille (04-07-2022 11:05:04)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#4 04-07-2022 13:34:44

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-21-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : [RESOLU] Soucis de boot sur serveur HP Proliant

Bonjour cyrille ! smile

Je vois plusieurs fois ces deux lignes qui se suivent dans le dmesg :

[    7.332846] ata2: link is slow to respond, please be patient (ready=0)
[   12.012847] ata2: COMRESET failed (errno=-16)



Si on cherche :


https://duckduckgo.com/?q=ata2%3A+link+ … =h_&ia=web

On voit un lecteur CD en panne qui cause l'erreur et le ralentissement du démarrage : https://forums.gentoo.org/viewtopic-t-776558.html

Des câbles reliés à aucun appareil et qui enlevés suppriment la panne : https://bbs.archlinux.org/viewtopic.php … 57#p797457

La désactivation d'un lecteur d'empreinte qui supprime la panne : https://bbs.archlinux.org/viewtopic.php … 60#p781560


Qu'est-ce est censé être ata2 ?

Parce que ata1, je vois bien ce que ce c'est :

[    1.980199] ata1.00: ATA-8: MB0500GCEHE, HPG1, max UDMA/133
[    1.980202] ata1.00: 976773168 sectors, multi 0: LBA48 NCQ (depth 32), AA
[    1.980727] ata1.00: configured for UDMA/133


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#5 04-07-2022 14:13:06

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU] Soucis de boot sur serveur HP Proliant

Merci Gilles pour ta réponse

J'avais cherché sur le Net et étais resté sur le lecteur de CD (même lien que le 1er que tu proposes), j'aurais dû penser au 2e disque, pauvre âne que je suis !


A la base sur ce serveur , il y avait 2 disques identiques (le second était un backup du premier). C'était un serveur kwartz sur lequel j'avais mis une debian (j'avais pas la licence du kwartz...)

Mais je ne me suis jamais servi du 2nd disque

ls -al /dev/disk/by-path/!(*part*)
lrwxrwxrwx 1 root root 9  4 juil. 08:23 /dev/disk/by-path/pci-0000:00:1f.2-ata-1 -> ../../sda
lrwxrwxrwx 1 root root 9  4 juil. 08:23 /dev/disk/by-path/pci-0000:00:1f.2-ata-1.0 -> ../../sda
lrwxrwxrwx 1 root root 9  4 juil. 08:23 /dev/disk/by-path/pci-0000:00:1f.2-ata-5 -> ../../sr0
lrwxrwxrwx 1 root root 9  4 juil. 08:23 /dev/disk/by-path/pci-0000:00:1f.2-ata-5.0 -> ../../sr0



Ne montre pas de sdb donc je dirais que c'est le second disque qui devrait être en ata2 mais il a disparu.

D'ailleurs un fdisk ne le voit même plus

fdisk -l
[sudo] Mot de passe de serveur :
Disque /dev/sda : 465,76 GiB, 500107862016 octets, 976773168 secteurs
Modèle de disque : MB0500GCEHE
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'
étiquette de disque : dos
Identifiant de disque : 0x96996938

Périphérique Amorçage     Début       Fin  Secteurs Taille Id Type
/dev/sda1    *             2048  97656831  97654784  46,6G 83 Linux
/dev/sda2              97656832 390625279 292968448 139,7G 83 Linux
/dev/sda3             390625280 410157055  19531776   9,3G 82 partition d'échange Linux / Solaris
/dev/sda4             410159102 976771071 566611970 270,2G  5 Étendue
/dev/sda5             410159104 585938943 175779840  83,8G 83 Linux
/dev/sda6             585940992 781447167 195506176  93,2G 83 Linux
/dev/sda7             781449216 976771071 195321856  93,1G 83 Linux



Donc ça pourrait être bien cela.

Donc la solution dans ce cas serait de le débrancher, je présume ([à défaut  | en attendant ] de le remplacer ?

En tout cas merci

Dernière modification par cyrille (04-07-2022 14:36:37)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#6 04-07-2022 14:37:07

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-21-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : [RESOLU] Soucis de boot sur serveur HP Proliant

C'est la solution qui m'apparaît la plus probable à ce stade de la démarche. Mais le débrancher ce disque en enlevant aussi le câble puisque des messages incriminent aussi les câbles reliés à aucun appareil.

« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#7 04-07-2022 14:41:01

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU] Soucis de boot sur serveur HP Proliant

OK, merci bien, je m'en vais faire de suite le ménage !

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#8 04-07-2022 14:58:43

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RESOLU] Soucis de boot sur serveur HP Proliant

Débranché et effectivement plus d'erreur...
Bon je vais voir combien coûte un disque de ce type

Un grand merci en tout cas, je passe en résolu wink

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

Pied de page des forums