Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-07-2022 14:55:17

Pierre_Muller
Membre
Inscription : 21-07-2022

Accéder aux fichiers d'un serveur NAS

Bonjour la communauté Debian,

J'ai installé Debian sur un micro-ordinateur Banana Pi, et j'aurais besoin d'accéder à des fichiers présents sur un serveur NAS.
Au début, je ne réussissais pas à accéder aux fichiers du NAS via le gestionnaire de fichier par défaut, j'ai donc installé un autre gestionnaire de fichier "nautilus", dans lequel j'ai renseigné l'adresse IP de mon NAS. Désormais, je peux accéder à ces fichiers. Mon seul problème, est lors de leur lancement dans une application, c'est impossible. J'ai testé avec un simple copié collé des fichiers du NAS depuis le bureau, et là pas de problème.
Seulement, comme j'ai un projet qui nécessite une modification des fichiers à chacune de leurs utilisations par plusieurs postes possibles, j'aimerais pouvoir les lancer depuis le serveur NAS.
Est-ce que quelqu'un aurait une solution ou une idée?

Cordialement,

Hors ligne

#2 21-07-2022 15:35:30

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Accéder aux fichiers d'un serveur NAS

Hello
quel genre de fichier ? images ,vidéos ou autre

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 21-07-2022 15:43:49

Pierre_Muller
Membre
Inscription : 21-07-2022

Re : Accéder aux fichiers d'un serveur NAS

Des fichiers pyhtons, lorsque je les ouvre à partir de Geany, il reste vide et impossible à exécuter

Hors ligne

#4 21-07-2022 15:51:44

FrankiBoy
Membre
Lieu : chez la Bonne-Mère
Distrib. : Ubuntu 18.04 LTS
Noyau : 5.4.0-65-generic
(G)UI : XFCE 4.12
Inscription : 11-05-2014

Re : Accéder aux fichiers d'un serveur NAS

Il y aurait pas un pb de droits dessus?

Hors ligne

#5 21-07-2022 16:04:59

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Accéder aux fichiers d'un serveur NAS

assure toi que les fichiers aient les bons droits
Les droits sont défini dans les options de montage, voir avec la commande mount

Pierre_Muller a écrit :

Au début, je ne réussissais pas à accéder aux fichiers du NAS via le gestionnaire de fichier par défaut, j'ai donc installé un autre gestionnaire de fichier "nautilus"


Il faudra peut être spécifier le montage dans le fichier fstab, ainsi le raccourci du gestionnaire de fichier utilisera le fstab pour les options de montage

quel message d'erreur te renvoie le terminale quand tu éxécutes sous Geany?
en relisant je pense  que tu n'as même pas les droits en lecture , c'est du simple texte sa devrait déja s'afficher
edit: j'ai fais un test sur un script qui lance une application python depuis mon serveur, pas de soucis
commence déja par voir du coté de mount
tu devrais avoir une ligne avec l'adresse ip de ton serveur
du genre

//192.168.1.118/hdd1 on /home/stephane/Emtec type cifs (rw,nosuid,nodev,relatime,vers=1.0,sec=none,cache=strict,uid=1000,forceuid,gid=1000,forcegid,addr=192.168.1.118,soft,unix,posixpaths,serverino,mapposix,acl,rsize=61440,wsize=65536,echo_interval=60,actimeo=1,user=stephane,_netdev)



après du coté de ls les droits

ls -l /home/stephane/Emtec

Dernière modification par Croutons (21-07-2022 17:51:33)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 22-07-2022 11:03:44

Pierre_Muller
Membre
Inscription : 21-07-2022

Re : Accéder aux fichiers d'un serveur NAS

Quand j'essai d'ouvrir un fichier présent sur le NAS à partir de Geany, rien ne se passe. Je parviens à parcourir toute l'arborescence jusqu'à mon fichier, ensuite je clic dessus et l'arborescence se ferme, mais Geany reste vide comme si je n'avais rien ouvert. Pourtant lorsque je fait un copier-copier du même fichier sur le bureau, là il fonctionne parfaitement. De même sur Windows, j'arrive à ouvrir le fichier sur IDLE à partir du NAS.

Lorsque je regarde les permissions accordées sur le réseau NAS, je suis bien en lecture/écriture.

Hors ligne

#7 22-07-2022 11:24:24

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Accéder aux fichiers d'un serveur NAS

sa peut dépendre tu type de connexion au serveur quand tu as renseigné les champs , je vois sous Caja (le gestionnaire de fichier par défaut de mate) il y a plusieurs type possible et selon le type utilisé parfois il y a pas de point de montage
quel type de connexion a tu choisis?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 22-07-2022 11:36:52

Pierre_Muller
Membre
Inscription : 21-07-2022

Re : Accéder aux fichiers d'un serveur NAS

Le type de connexion au serveur est samba. J'ai renseigné smb:// suivi de l'adresse IP.

Hors ligne

#9 22-07-2022 14:28:19

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Accéder aux fichiers d'un serveur NAS

ok donc tu as un point de montage dans un sous répertoire de /run je pense c'est un peu particulier sa te donne un chemin à la con

ls /run/user/1000/gvfs



exemple: si j'utilise la même connexion pour mon serveur

ls /run/user/1000/gvfs/smb-share\:server\=192.168.1.118\,share\=hdd1/


101CANON  2021_photos  BT  buda_vfs.img  core  Fichiers_PC  Films  image  images  movie  music  Musiques  Musiques_Videos  Papillons  REC  Serie



findmnt |grep run


├─/run                                tmpfs                  tmpfs           rw,nosuid,noexec,relatime,size=404092k,mode=755
│ ├─/run/lock                         tmpfs                  tmpfs           rw,nosuid,nodev,noexec,relatime,size=5120k
│ └─/run/user/1000                    tmpfs                  tmpfs           rw,nosuid,nodev,relatime,size=404088k,mode=700,uid=1000,gid=1000
│   └─/run/user/1000/gvfs             gvfsd-fuse             fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000



j'arrive quand même a ouvrir mes fichiers, mais faut quand même admettre que c'est pas le top
c'est un peu pour cette raison que je passe plus par cette option du gestionnaire de fichier se connecter a un serveur

de plus pour arriver a se résultat tu as été obligé de changer de gestionnaire de fichier

oublie cette façon de faire et install le paquet

apt install cifs-utils


(voir apt show cifs-utils)

Tu pourras choisir de créer un répertoire sous ton /home qui te servira de point de montage
exemple avec mon serveur je retrouve mes fichiers avec un chemin beaucoup plus court

ls /home/stephane/Emtec


101CANON  2021_photos  BT  buda_vfs.img  core  Fichiers_PC  Films  image  images  movie  music  Musiques  Musiques_Videos  Papillons  REC  Series



la ligne que j'ai integré dans mon fichier /etc/fstab

//192.168.1.118/hdd1  /home/stephane/Emtec cifs guest,user,noauto,nofail,iocharset=utf8,uid=1000,file_mode=0777,dir_mode=0777,_netdev,nosetuids,vers=1.0   0 0


option noauto pour que le serveur ne soit pas monté en automatique, il est monté sur demande quand je clique sur le raccourci du panneau latéral du gestionnaire de fichier
nofail a ne pas oublier , Ne pas renvoyer d'erreur pour ce périphérique s'il n'existe pas
_netdev de mémoire c'est pour attendre que le réseau soit bien activé
guest je me connecte sans demande de mot de passe
vers=1.0 car mon serveur est trop vieux et supporte mal les nouvelles version du protocole
certaine options sont spécifique a cifs d'autre non

a lire

man mount.cifs


man mount


pour toi il te faudra en plus les options

 

man mount.cifs a écrit :

username=arg|user=arg
              specifies the username to connect as. If this is not given, then the environment variable USER is used.

              Earlier  versions  of  mount.cifs also allowed one to specify the username in a user%password or workgroup/user or workgroup/user%password to allow the password and
              workgroup to be specified as part of the username. Support for those alternate username formats is now deprecated and should no longer be used. Users should use the
              discrete  password=  and domain= to specify those values. While some versions of the cifs kernel module accept user= as an abbreviation for this option, its use can
              confuse the standard mount program into thinking that this is a non-superuser mount. It is therefore recommended to use the full username= option name.

       password=arg|pass=arg
              specifies the CIFS password. If this option is not given then the environment variable PASSWD is used. If the password is not specified directly or  indirectly  via
              an argument to mount, mount.cifs will prompt for a password, unless the guest option is specified.

              Note  that a password which contains the delimiter character (i.e. a comma ',') will fail to be parsed correctly on the command line. However, the same password de‐
              fined in the PASSWD environment variable or via a credentials file (see below) or entered at the password prompt will be read correctly.

       credentials=filename|cred=filename
                 specifies a file that contains a username and/or password and optionally the name of the workgroup. The format of the file is:

                     username=value
                     password=value
                     domain=value

              This is preferred over having passwords in plaintext in a shared file, such as /etc/fstab . Be sure to protect any credentials file properly.



edit: note que tu peut utiliser la commande mount avant d’intégrer la ligne dans le fichier fstab , cela évite les allées et venu dans l’éditeur de texte

mount -t cifs //adresse_ip du serveur/Disque\ dur  /home/user/point de montage -o guest,iocharset=utf8,file_mode=0777,dir_mode=0777,uid=1000


pour les uid et gid réfère toi à la comme id , normalement si c'est le premier utilisateur créé il devrait être 1000, mais c'est possible que sa soit pas le cas

id

Dernière modification par Croutons (22-07-2022 14:47:14)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 27-07-2022 11:36:28

Pierre_Muller
Membre
Inscription : 21-07-2022

Re : Accéder aux fichiers d'un serveur NAS

Merci la méthode suivante à fonctionnée:

sudo mount -t cifs -0 username=MON_ID,password=mon_mdp //adresseIPserveur/Disque\dur  /point de montage

Cependant deux nouveaux problèmes sont survenus:

1)Lors du redémarrage du Pi, le dossier point de montage est de nouveau vide sans accès au serveur et je suis obligé de retaper la commande précédente dans un terminal.
2)J'ai un problème de permission sur le dossier point de montage: Root(Lecture et Ecriture), Groupe(Lecture seule) et Autres(Lecture seule). J'ai essayé de modifier les dites-permissions avec la commande chmod en utilisant la méthode 777(toutes permissions) et ugo+rwx avec le chemin d'accès au point de montage. Le terminal ne renvoie pas d'erreur, mais quand je vérifie les permissions restent inchangées.

Hors ligne

#11 27-07-2022 14:30:19

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Accéder aux fichiers d'un serveur NAS

il ne sert a rien de vouloir modifier les permissions via chmod
les fichiers appartiennent a celui qui monte le système de fichiers (root)
pour s'en rendre compte

findmnt |grep cifs


 └─/home/stephane/Emtec              //192.168.1.118/hdd1   cifs            rw,relatime,vers=1.0,sec=none,cache=strict,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.118,soft,unix,posixpaths,serverino,mapposix,acl,rsize=61440,wsize=65536,echo_interval=60,actimeo=1



comme tu peux le voir uid=0 et gid=0 c'est à dire root
comme c'est toujours root qui a le droit de monter les systémes de fichier il faut préciser uid et le gid de ton utilisateur dans les options de montage comme expliqué dans mon message #9
Cependant ceci n'est pas nécessaire si tu spécifies l'option noauto et user dans les options de montage, ainsi le serveur ne sera monté qu'a la demande de l'utilisateur et il sera de ce faite propriétaire des dossiers et fichiers
Toujours en message #9 je t'ai mis en exemple le genre de ligne que tu doit ajouter dans ton fichier fstab pour que les info. de montage soit permanente

nano /etc/fstab


se déplacer avec les flèches du clavier
quitter avec Ctrl+x , a la réponse voulez vous enregistrer le fichier répondre oui
pour que le fichier modifié prenne effet

mount -a

Dernière modification par Croutons (27-07-2022 14:32:04)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums