Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-07-2022 15:58:00

babou29
Membre
Lieu : Morbihan
Inscription : 03-10-2019

Installation Steam

Bonjour,

Je viens vers vous car je souhaite installer Steam sur ma petite Debian 11 à jour.

J'ai téléchargé le paquet Steam sur le site officiel, j'ai lancé l'installation et j'ai ces message d'erreur :

En console :

steam
/home/nicolas/.local/share/Steam/steam.sh: ligne 124: VERSION_ID : variable sans liaison



Quand je lance l’icône Steam sur le bureau :

Steam needs to install these additional packages:
libc6:amd64 libc6:i386 libegl1:amd64 libegl1:i386 libgbm1:amd64 libgbm1:i386 libgl1-mesa-dri:amd64 libgl1-mesa-dri:i386 libgl1:amd64 libgl1:i386 steam-libs-amd64:amd64

Press return to proceed with the installation:


je fais Entrée puis je rentre mon code

et j'ai cela :

Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
libc6 est déjà la version la plus récente (2.33-8).
libegl1 est déjà la version la plus récente (1.4.0-1).
libegl1 passé en « installé manuellement ».
libgl1 est déjà la version la plus récente (1.4.0-1).
libgl1 passé en « installé manuellement ».
libgbm1 est déjà la version la plus récente (22.1.3-1).
libgbm1 passé en « installé manuellement ».
libgl1-mesa-dri est déjà la version la plus récente (22.1.3-1).
libc6:i386 est déjà la version la plus récente (2.33-8).
libc6:i386 passé en « installé manuellement ».
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1-mesa-dri:i386 : Dépend: libllvm14:i386 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Press return to continue:




Puis une fenêtre se lance avec comme titre : Erreur
et cela dedans :

You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
libdrm.so.2
libdrm.so.2
libdrm.so.2



Auriez vous des idées de ce que je peux faire s'il vous plaît?

Merci beaucoup à vous.
Cordialement,
Nicolas

Hors ligne

#2 22-07-2022 16:39:34

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Installation Steam

Steam est déjà présent dans les dépôts Debian, tu as une bonne raison d’éviter ce paquet au profit de la version que tu ne réussis pas à faire tourner ?

---

Au passage vu les erreurs que tu partages je doute que tu sois vraiment sur une Debian 11. Tu peux partager le retour de la commande suivante pour confirmer ?

apt policy libc6:{amd64,i386}


Jouer sous Debian ? Facile !

Hors ligne

#3 22-07-2022 16:50:33

babou29
Membre
Lieu : Morbihan
Inscription : 03-10-2019

Re : Installation Steam

Merci de ta réponse. !!

Non, j'ai essayer avec Apt et avec le .deb de Steam et c'est le même résultat. J'ai aucune préférence ! big_smile


ha bon, pourtant mes dépôts sont avec ... scratchhead.gif

Voici les résultats de la commande que tu m'as demandé de faire :


apt policy libc6:{amd64,i386}
libc6:
  Installé : 2.33-8
  Candidat : 2.33-8
 Table de version :
 *** 2.33-8 500
        500 http://httpredir.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u3 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
     2.28-10+deb10u1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
libc6:i386:
  Installé : 2.33-8
  Candidat : 2.33-8
 Table de version :
 *** 2.33-8 500
        500 http://httpredir.debian.org/debian sid/main i386 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u3 500
        500 http://deb.debian.org/debian bullseye/main i386 Packages
     2.28-10+deb10u1 500
        500 http://deb.debian.org/debian buster/main i386 Packages




C'est pas bizarre que j'ai "bullseye" et "buster" avec ta commande?

Merci encore.
Nicolas

Hors ligne

#4 22-07-2022 17:16:20

babou29
Membre
Lieu : Morbihan
Inscription : 03-10-2019

Re : Installation Steam

Sniffff, je viens de faire un

lsb_release -a



et cela m'a affiché :


No LSB modules are available.
Distributor ID: Debian
Description:  Debian GNU/Linux bookworm/sid
Release:  10.12
Codename: buster
 



Je suis bien en Buster !!

J’étais sur d’être en 11 !!

je vais du coup y remédier:D

Hors ligne

#5 22-07-2022 17:40:40

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Installation Steam

babou29 a écrit :

J’étais sur d’être en 11 !!



Ça c’était avant, maintenant tu es sur une Debian Sid big_smile


Jouer sous Debian ? Facile !

Hors ligne

#6 22-07-2022 18:22:23

babou29
Membre
Lieu : Morbihan
Inscription : 03-10-2019

Re : Installation Steam

Bon, je viens de faire les mises à jour.

Voici ce que me donnent les commandes maintenant :

apt policy libc6:{amd64,i386}



libc6:
  Installé : 2.33-8
  Candidat : 2.33-8
 Table de version :
 *** 2.33-8 100
        100 /var/lib/dpkg/status
     2.31-13+deb11u3 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
libc6:i386:
  Installé : 2.33-8
  Candidat : 2.33-8
 Table de version :
 *** 2.33-8 100
        100 /var/lib/dpkg/status
     2.31-13+deb11u3 500
        500 http://deb.debian.org/debian bullseye/main i386 Packages



Voici ce que j'ai fais ensuite :

apt install steam
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Aucune version du paquet steam n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'
il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  steam-launcher

E: Le paquet « steam » n'a pas de version susceptible d'être installée



Puis :

apt install steam-launcher
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
steam-launcher est déjà la version la plus récente (1:1.0.0.74).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



J'essaie de lancer Steam :

a
Steam needs to install these additional packages:
libc6:amd64 libc6:i386 libegl1:amd64 libegl1:i386 libgbm1:amd64 libgbm1:i386 libgl1-mesa-dri:amd64 libgl1-mesa-dri:i386 libgl1:amd64 libgl1:i386

Press return to proceed with the installation:



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
libc6 est déjà la version la plus récente (2.33-8).
libc6:i386 est déjà la version la plus récente (2.33-8).
libc6:i386 passé en « installé manuellement ».
libegl1 est déjà la version la plus récente (1.4.0-1).
libegl1 passé en « installé manuellement ».
libgbm1 est déjà la version la plus récente (22.1.3-1).
libgbm1 passé en « installé manuellement ».
libgl1 est déjà la version la plus récente (1.4.0-1).
libgl1 passé en « installé manuellement ».
libgl1-mesa-dri est déjà la version la plus récente (22.1.3-1).
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libdrm-intel1:i386 : Dépend: libdrm2:i386 (>= 2.4.38) mais il n'est pas installable
 libegl1 : Casse: libegl1:i386 (!= 1.4.0-1) mais 1.3.2-1 devra être installé
 libegl1:i386 : Dépend: libglvnd0:i386 (= 1.3.2-1) mais il n'
est pas installable
                Dépend: libegl-mesa0:i386 mais il n'est pas installable
                Casse: libegl1 (!= 1.3.2-1) mais 1.4.0-1 devra être installé
 libgbm1 : Casse: libgbm1:i386 (!= 22.1.3-1) mais 20.3.5-1 devra être installé
 libgbm1:i386 : Dépend: libdrm2:i386 (>= 2.4.75) mais il n'
est pas installable
                Dépend: libexpat1:i386 (>= 2.0.1) mais il n'est pas installable
                Dépend: libwayland-server0:i386 (>= 1.15.0) mais il n'
est pas installable
                Casse: libgbm1 (!= 20.3.5-1) mais 22.1.3-1 devra être installé
 libgl1 : Casse: libgl1:i386 (!= 1.4.0-1) mais 1.3.2-1 devra être installé
 libgl1:i386 : Dépend: libglvnd0:i386 (= 1.3.2-1) mais il n'est pas installable
               Dépend: libglx0:i386 (= 1.3.2-1) mais il n'
est pas installable
               Casse: libgl1 (!= 1.3.2-1) mais 1.4.0-1 devra être installé
 libgl1-mesa-dri : Casse: libgl1-mesa-dri:i386 (!= 22.1.3-1) mais 20.3.5-1 devra être installé
 libgl1-mesa-dri:i386 : Dépend: libdrm-amdgpu1:i386 (>= 2.4.100) mais il n'est pas installable
                        Dépend: libdrm-nouveau2:i386 (>= 2.4.66) mais il n'
est pas installable
                        Dépend: libdrm-radeon1:i386 (>= 2.4.31) mais il n'est pas installable
                        Dépend: libdrm2:i386 (>= 2.4.75) mais il n'
est pas installable
                        Dépend: libelf1:i386 (>= 0.142) mais il n'est pas installable
                        Dépend: libexpat1:i386 (>= 2.0.1) mais il n'
est pas installable
                        Dépend: libglapi-mesa:i386 (= 20.3.5-1) mais il n'est pas installable
                        Dépend: libstdc++6:i386 (>= 5.2) mais il n'
est pas installable
                        Dépend: libvulkan1:i386 (>= 1.2.131.2) mais il n'est pas installable
                        Dépend: libzstd1:i386 (>= 1.4.0) mais il n'
est pas installable
                        Dépend: zlib1g:i386 (>= 1:1.1.4) mais il n'est pas installable
                        Casse: libgl1-mesa-dri (!= 20.3.5-1) mais 22.1.3-1 devra être installé
 libllvm11:i386 : Dépend: libedit2:i386 (>= 2.11-20080614-0) mais il n'
est pas installable
                  Dépend: libstdc++6:i386 (>= 9) mais il n'est pas installable
                  Dépend: libtinfo6:i386 (>= 6) mais il n'
est pas installable
                  Dépend: libz3-4:i386 (>= 4.8.9) mais il n'est pas installable
                  Dépend: zlib1g:i386 (>= 1:1.2.0) mais il n'
est pas installable
 libpciaccess0:i386 : Dépend: zlib1g:i386 (>= 1:1.2.3.3) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'
état ».




Pareil que tout à l'heure.

Une autre bonne idée ?:D
Merci

Hors ligne

#7 23-07-2022 22:08:41

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Installation Steam

Le paquet libc6 en version 2.33 indique que tu es toujours sur une Debian Sid.
Malheureusement le retour en arrière est faisable mais assez complexe et demande une bonne expérience de apt et dpkg.

Arrivés là on a grosso-modo deux options :
- rester en Sid, et débloquer l’installation de steam
- revenir sur une stable, et installer steam ensuite

Quelle approche t’intéresse le plus ?

Jouer sous Debian ? Facile !

Hors ligne

#8 24-07-2022 09:44:47

babou29
Membre
Lieu : Morbihan
Inscription : 03-10-2019

Re : Installation Steam

Bonjour,

Merci encore pour tes réponses.

Je veux bien repasser en Stable si c'est possible?

Tu aurais la procédure ou un lien?

Merci.
Nicolas

Hors ligne

#9 25-07-2022 16:18:57

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Installation Steam

babou29 a écrit :

Je veux bien repasser en Stable si c'est possible?

Tu aurais la procédure ou un lien?



C’est possible, même si ça va demander un peu de boulot et de temps pour faire les choses correctement.
Je t’invite à ouvrir une nouvelle discussion à ce sujet, histoire que ça ne se mélange pas avec les soucis d’installation de Steam.


Jouer sous Debian ? Facile !

Hors ligne

#10 25-07-2022 19:09:44

babou29
Membre
Lieu : Morbihan
Inscription : 03-10-2019

Re : Installation Steam

Bonsoir.

Merci encore à toi.

Je viens de faire le nouveau Topic.

Je laisse celui-ci ouvert, je verrais si cela fonctionne ou pas apres.
merci.gif

Hors ligne

Pied de page des forums