Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-07-2022 18:16:44

Lek1
Adhérent(e)
Lieu : Quelque part sur Gaya
Distrib. : Debian 11 Bullseye
Noyau : 5.10.0-10-amd64
(G)UI : Plasma
Inscription : 30-08-2021

erreur de mise à jour

Bonjour,

Je fais mes mise à jour avec le terminal.
Jusque là, pas eu de soucis.
Aujourd'hui, j'ai une erreur et ne sachant pas quoi faire, je vous la soumets.
Il indique un "Possible missing firmware qu'il ne m'avait pas encore indiqué, d’où mon étonnement.
Merci pour votre aide.


sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-image-5.10.0-13-amd64 linux-image-5.10.0-14-amd64
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
3 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Paramétrage de initramfs-tools (0.140) ...
update-initramfs: deferring update (trigger activated)
Paramétrage de linux-image-5.10.0-16-amd64 (5.10.127-1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.10.0-16-amd64
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_gpu_info.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_ta.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_sos.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_ta.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_asd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_sos.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_me.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_pfp.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_ce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/sienna_cichlid_mes.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navi10_mes.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_vcn.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_vcn.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_dmcub.bin for module amdgpu

gzip: stdout: No space left on device
E: mkinitramfs failure gzip 1
update-initramfs: failed for /boot/initrd.img-5.10.0-16-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-5.10.0-16-amd64 (--configure) :
 installed linux-image-5.10.0-16-amd64 package post-installation script subprocess returned error exit status 1
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-amd64 :
 linux-image-amd64 dépend de linux-image-5.10.0-16-amd64 (= 5.10.127-1) ; cependant :
 Le paquet linux-image-5.10.0-16-amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-image-amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour initramfs-tools (0.140) ...
update-initramfs: Generating /boot/initrd.img-5.10.0-15-amd64
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_gpu_info.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_ta.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_sos.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_ta.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_asd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_sos.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_me.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_pfp.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_ce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/sienna_cichlid_mes.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navi10_mes.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_vcn.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_vcn.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_dmcub.bin for module amdgpu

gzip: stdout: No space left on device
E: mkinitramfs failure gzip 1
update-initramfs: failed for /boot/initrd.img-5.10.0-15-amd64 with 1.
dpkg: erreur de traitement du paquet initramfs-tools (--configure) :
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-5.10.0-16-amd64
 linux-image-amd64
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
 


J'écris aussi en Bépo.
Ceux qui ne bougent pas, ne sentent pas leurs chaînes. (Rosa Luxembourg.)
Config : Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Hors ligne

#2 23-07-2022 18:24:29

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : erreur de mise à jour

Lek1 a écrit :

No space left on device


pas assez d'espace pour décompresser les paquets a installer

df -h


Je crois que tu devrais régler le soucis avant d'éteindre ou de redémarrer ton ordi hmm

Dernière modification par Croutons (23-07-2022 18:26:09)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 23-07-2022 19:06:29

Lek1
Adhérent(e)
Lieu : Quelque part sur Gaya
Distrib. : Debian 11 Bullseye
Noyau : 5.10.0-10-amd64
(G)UI : Plasma
Inscription : 30-08-2021

Re : erreur de mise à jour

Voici le code. J'avais vérifié, j'ai assez de place.


df -h
df: /run/user/1000/doc: Opération non permise
Sys. de fichiers      Taille Utilisé Dispo Uti% Monté sur
udev                    7,8G       0  7,8G   0% /dev
tmpfs                   1,6G    2,9M  1,6G   1% /run
/dev/sda2                47G     14G   31G  32% /
tmpfs                   7,8G     32K  7,8G   1% /dev/shm
tmpfs                   5,0M    4,0K  5,0M   1% /run/lock
tmpfs                   4,1G       0  4,1G   0% /var/tmp
tmpfs                   4,1G     50M  4,1G   2% /tmp
/dev/sda4               405G    229G  157G  60% /home
tmpfs                   1,0G    124M  901M  13% /home/ordinosor/.cache
/dev/sda1               331M    287M   23M  93% /boot
tmpfs                   1,6G    140K  1,6G   1% /run/user/1000
 


J'écris aussi en Bépo.
Ceux qui ne bougent pas, ne sentent pas leurs chaînes. (Rosa Luxembourg.)
Config : Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Hors ligne

#4 23-07-2022 19:23:00

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : erreur de mise à jour

/dev/sda1               331M    287M   23M  93% /boot


je peux me tromper mais il me semble que sa se situe la le problème


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 23-07-2022 20:12:30

raleur
Membre
Inscription : 03-10-2014

Re : erreur de mise à jour

Lek1 a écrit :

Il indique un "Possible missing firmware qu'il ne m'avait pas encore indiqué, d’où mon étonnement.


Ce message n'est qu'un avertissement et non une erreur, et selon toute vraisemblance il a toujours été présent mais comme tout se passait bien tu n'y as jamais prêté attention.

Croutons a écrit :

pas assez d'espace pour décompresser les paquets a installer


Il s'agit bien d'un problème d'espace disque mais pour créer l'initramfs (qui est une archive compressée, d'où l'erreur de gzip) dans /boot, pas pour décompresser des paquets. Vu la taille actuelle par défaut de l'initramfs (de l'ordre de 50 Mo), 44 Mo est insuffisant.
Quelques options disponibles :
- désinstaller un ancien noyau inutile, par exemple linux-image-5.10.0-13-amd64
- générer un initramfs compact avec MODULES=dep au lieu de most dans /etc/initramfs-tools/initramfs.conf
- désinstaller plymouth (animation graphique au démarrage), ce qui réduit un peu la taille de l'initramfs
- réintégrer le contenu de /boot dans le système de fichiers racine

PS: Y avait-il une raison particulière de créer une partition /boot séparée ?

Dernière modification par raleur (23-07-2022 20:43:53)


Il vaut mieux montrer que raconter.

Hors ligne

#6 23-07-2022 21:19:05

Lek1
Adhérent(e)
Lieu : Quelque part sur Gaya
Distrib. : Debian 11 Bullseye
Noyau : 5.10.0-10-amd64
(G)UI : Plasma
Inscription : 30-08-2021

Re : erreur de mise à jour

Merci pour vos réponses.

Le /boot, je ne crois pas l'avoir fait, mais je ne suis pas certain.

J'ai supprimé l'ancien noyau, refait un update et un upgrade et cela a terminé sans erreur.

J'aimerais intégrer le /boot dans la racine, mais honnêtement, je ne sais pas comment faire.
Y a t-il un tuto pour le faire ?

Ton deuxième point et vraiment obscure pour moi.

Désinstaller plymouth, si j'ai à nouveau cette erreur, je le ferai aussi.

Merci encore pour tes réponses.

Dernière modification par Lek1 (23-07-2022 21:21:40)


J'écris aussi en Bépo.
Ceux qui ne bougent pas, ne sentent pas leurs chaînes. (Rosa Luxembourg.)
Config : Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Hors ligne

#7 23-07-2022 22:12:43

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : erreur de mise à jour

raleur a écrit :

Lek1 a écrit :

Il indique un "Possible missing firmware qu'il ne m'avait pas encore indiqué, d’où mon étonnement.


Ce message n'est qu'un avertissement et non une erreur, et selon toute vraisemblance il a toujours été présent mais comme tout se passait bien tu n'y as jamais prêté attention.



Je confirme qu’à partir du moment où les performances d’affichage sont correctes ces avertissements peuvent être ignorés sans soucis, ces firmwares n’étant pas forcément requis pour la carte graphique en cours d’utilisation.


Jouer sous Debian ? Facile !

Hors ligne

#8 23-07-2022 22:29:54

raleur
Membre
Inscription : 03-10-2014

Re : erreur de mise à jour

Lek1 a écrit :

Le /boot, je ne crois pas l'avoir fait, mais je ne suis pas certain.


Il ne s'est pas fait tout seul. L'installateur Debian ne crée une partition /boot automatiquement que si on choisit le partitionnement assisté avec LVM.
Il ne met pas /tmp ni /var/tmp en tmpfs non plus. Concernant ce dernier, c'est une erreur car d'après le FHS le contenu de /var/tmp est censé persister après un redémarrage.

Lek1 a écrit :

J'aimerais intégrer le /boot dans la racine, mais honnêtement, je ne sais pas comment faire.
Y a t-il un tuto pour le faire ?


Il n'y a pas un tutoriel pour tout.
- démonter /boot
- remonter la partition sur /mnt
- copier le contenu de /mnt dans /boot
- réinstaller grub (grub-install, update-grub)
- commenter /boot dans /etc/fstab

Lek1 a écrit :

Ton deuxième point et vraiment obscure pour moi


Cette option retire de l'initramfs tous les pilotes de stockage qui ne sont pas utiles pour démarrer sur cette machine (empêchant potentiellement le démarrage sur une autre machine)

man initramfs.conf



Lek1 a écrit :

Désinstaller plymouth, si j'ai à nouveau cette erreur, je le ferai aussi.


Cette option retire de l'initramfs plymouth, les pilotes graphiques et leurs firmwares. Le gain n'est pas forcément significatif. J'ai mentionné cette option par souci d'exhaustivité.

Dernière modification par raleur (24-07-2022 09:42:23)


Il vaut mieux montrer que raconter.

Hors ligne

#9 24-07-2022 07:43:46

Lek1
Adhérent(e)
Lieu : Quelque part sur Gaya
Distrib. : Debian 11 Bullseye
Noyau : 5.10.0-10-amd64
(G)UI : Plasma
Inscription : 30-08-2021

Re : erreur de mise à jour

D'accord, merci pour ces précisions.
Je vais m'y atteler.

J'écris aussi en Bépo.
Ceux qui ne bougent pas, ne sentent pas leurs chaînes. (Rosa Luxembourg.)
Config : Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Hors ligne

Pied de page des forums