Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 28-07-2022 18:04:26

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

root@debian:~# adduser clamav



Ajout de l'utilisateur « clamav » ...
Ajout du nouveau groupe « clamav » (1001) ...
Ajout du nouvel utilisateur « clamav » (1001) avec le groupe « clamav » ...
Création du répertoire personnel « /home/clamav »...
Copie des fichiers depuis « /etc/skel »...
Entrez le nouveau mot de passe UNIX :
 



C'est ça ? je ne veux pas créer de mot de passe pour ce nouvel utilisateur, ça risque pas de bugger à l'allumage ?

https://manpages.debian.org/stretch/add … .8.fr.html

Dernière modification par D777 (28-07-2022 18:09:26)

Hors ligne

#27 28-07-2022 18:11:55

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Pas tout à fait ....

Ajout du nouvel utilisateur « clamav »
Création du répertoire personnel « /home/clamav »..



..tu viens de créer un nouvel utilisateur qui s'apelle «clamav», donc le système est entrain de lui créer son "home" et tutti quanti ...

Hors ligne

#28 28-07-2022 18:14:32

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

ubub a écrit :

Pas tout à fait ....

Ajout du nouvel utilisateur « clamav »
Création du répertoire personnel « /home/clamav »..



..tu viens de créer un nouvel utilisateur qui s'apelle «clamav», donc le système est entrain de lui créer son "home" et tutti quanti ...



Merde !

les autres lignes de commandes ne fonctionnaient pas....j'ai essayé celle là big_smile

bon je ferme le terminal sans renseigné de mot de passe et je croise les doigts

Hors ligne

#29 28-07-2022 18:18:48

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

et si je créer un group clamav ? après je créer un utilisateur dans ce groupe ?

addgroup clamav

puis

adduser dom clamav

non ?

Hors ligne

#30 28-07-2022 18:18:50

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Après tu peux très bien lui mettre un mot de passe, genre 'X', ça ne genera pas ton système, et au moins tu pourras y accéder

Hors ligne

#31 28-07-2022 18:20:52

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

D777 a écrit :

et si je créer un group clamav ? après je créer un utilisateur dans ce groupe ?

addgroup clamav

puis

adduser dom clamav

non ?



ha non créer un groupe c'est comme créer un utilisateur je pense, un groupe qui s'appelle clamav.

rien à voir avec le logiciel clamav scratchhead.gif

Hors ligne

#32 28-07-2022 18:22:58

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

et si je créer un group clamav ? après je créer un utilisateur dans ce groupe ?


c'est pas pour ça que ça te débloquera ce qui est (déja créé) dans ton fichier /dpkg/statover..
En vrai, je trouve pas de page de manuel clamav, je sais même pas si un groupe "clamav" existe ...
La doc est très dense ...

Hors ligne

#33 28-07-2022 18:30:00

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

ubub a écrit :

la commande groups te dira à quels groupes appartient ton "user"

groups d777



Je viens de voir cette réponse, la commande "groups dom" ou "groups root" ne donne rien !

Si je cherche la liste des "users" j'ai ça ????????

root@debian:~# ls -u



statoverride.save  nano.save  esets_install.txt
 

Hors ligne

#34 28-07-2022 18:37:55

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

en regardant dans /etc/group tu devrai pouvoir voir les groupes existants dans ton système, et voir si y'a un groupe clamav qui existe

cat /etc/groups

Dernière modification par ubub (28-07-2022 18:55:53)

Hors ligne

#35 28-07-2022 18:46:49

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

en tapant /etc/group même en root , il me dit "Permission non accordée" !

donc j'ai essayé cette ligne de commande

root@debian:~# ls -group



total 12
-rw------- 1    1 juil. 28 15:38 statoverride.save
-rw------- 1    0 juil. 28 15:10 nano.save
-rw------- 1 4942 mars  10 20:39 esets_install.txt
 



et si je supprimais le groupe esets ? il me sert plus à rien depuis longtemps, entre anti-virus ils se tirent la bourre possible l'insta de l'un bloque l'autre etc

en root : deletegroup esets?

Hors ligne

#36 28-07-2022 18:56:50

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

en root : deletegroup esets?



non

Hors ligne

#37 28-07-2022 19:05:04

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

root@optibub:~# /etc/group
-bash: /etc/group: Permission non accordée
root@optibub:~# cat /etc/group
root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:

Hors ligne

#38 28-07-2022 19:12:11

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

C'est quoi tous ces groupes ??????

root@debian:~# cat /etc/group



root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:
fax:x:21:
voice:x:22:
cdrom:x:24:dom
floppy:x:25:dom
tape:x:26:
sudo:x:27:dom
audio:x:29:pulse,dom
dip:x:30:dom
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:dom
sasl:x:45:
plugdev:x:46:dom
staff:x:50:
games:x:60:
users:x:100:
nogroup:x:65534:
input:x:101:
systemd-journal:x:102:
systemd-timesync:x:103:
systemd-network:x:104:
systemd-resolve:x:105:
systemd-bus-proxy:x:106:
crontab:x:107:
netdev:x:108:dom
ssl-cert:x:109:
lpadmin:x:110:dom
messagebus:x:111:
avahi:x:112:
scanner:x:113:saned,dom
Debian-exim:x:114:
mlocate:x:115:
ssh:x:116:
bluetooth:x:117:dom
colord:x:118:
geoclue:x:119:
utempter:x:120:
pulse:x:121:
pulse-access:x:122:
rtkit:x:123:
saned:x:124:
Debian-gdm:x:125:
dom:x:1000:dom
dirmngr:x:127:
sddm:x:128:
clamsmtp:x:129:
p3scan:x:130:
 

Hors ligne

#39 28-07-2022 19:16:26

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

par exemple, cdrom  dom ; c'est le groupe auquel tu appartient qui te permet d'utiliser le cdrom lecteur ...
fax pour se servir du fax etc
y'en a pas un qui s'apelle clamav ?

Hors ligne

#40 28-07-2022 19:19:07

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Ok j'ai compris !

Le seul qui ressemble c'est "clamsmtp:x:129:"

Je supprime ce groupe ?

en root : "deletegroup clamsmtp" ?

Hors ligne

#41 28-07-2022 19:30:10

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

D'où tu sors cette commande deletegroup ?

Si tu veux supprimer un groupe :

delgroup nom_du_groupe_à_supprimer

Attention aux conséquences !


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#42 28-07-2022 19:39:19

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

ClamSMTP est un démon mandataire SMTP qui vérifie la présence de virus en utilisant le logiciel anti-virus ClamAV.

Hors ligne

#43 28-07-2022 20:15:43

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Tawal a écrit :

D'où tu sors cette commande deletegroup ?

Si tu veux supprimer un groupe :

delgroup nom_du_groupe_à_supprimer

Attention aux conséquences !



Salut Tawal ! de mon imagination lol

Tu penses que le groupe "clamsmtp" sert encore à qqchose alors que j'ai désintallé clamvav (plus rien de visible sur synaptic) ?

Il y a ausi le fichier "esets" qui ne sert  normalement plus à rien vu qu'il est désinstallé...

Une ligne de commande pour "supprimer" tous les fichiers résiduels des applications désinstallées n'existe pas ?

exemple : delall old folder ?

Hors ligne

#44 28-07-2022 20:25:19

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Oui, je pense que tu peux supprimer ce groupe.
Mais je doute que ça résolve ton problème.

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#45 28-07-2022 20:29:24

raleur
Membre
Inscription : 03-10-2014

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

D777 a écrit :

Peut-être ouvrir le fichier "statoverride" et le lobotomiser ?


Il y a une méthode plus civilisée : la commande dpkg-statoverride. Consulter sa page de manuel pour les détails.

D777 a écrit :

adduser clamav


clamav devrait être créé comme un utilisateur système avec création du groupe système correspondant, et non comme un utilisateur normal. Consulter la page de manuel d'adduser pour les détails.


Il vaut mieux montrer que raconter.

Hors ligne

#46 29-07-2022 08:54:22

mister_g
Membre
Distrib. : debian sid
Noyau : Linux 5.18.0-2-amd64
(G)UI : fluxbox
Inscription : 20-07-2022

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Sur le site de clamav,
après le remove  de clamav

il est noté :

Make sure that you haven’t got old libraries (libclamav.so) lying around your filesystem. You can verify it using:

ldd `which freshclam`

Also make sure there is really only one version of ClamAV installed on your system:

whereis freshclam

whereis clamscan



cf https://docs.clamav.net/faq/faq-uninstall.html

Hors ligne

#47 29-07-2022 08:54:48

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

peut etre

dpkg-statoverride --update


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#48 29-07-2022 10:15:05

raleur
Membre
Inscription : 03-10-2014

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Non, il manque une commande. --update n'est qu'une option.

Il vaut mieux montrer que raconter.

Hors ligne

#49 29-07-2022 13:39:46

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

Croutons a écrit :

peut etre

dpkg-statoverride --update




Salut Croutons, je te réponds en premier :

dom@debian:~$ dpkg-statoverride --update



dpkg-statoverride: erreur: requiert une option d'action

Utiliser --help pour de l'aide sur la façon de ne pas tenir compte des informations relatives au fichier (« file stat information »).



dom@debian:~$ su -



Mot de passe :
root@debian:~# dpkg-statoverride --update
dpkg-statoverride: erreur: requiert une option d'action

Utiliser --help pour de l'aide sur la façon de ne pas tenir compte des informations relatives au fichier (« file stat information »).

Hors ligne

#50 29-07-2022 13:46:36

D777
Membre
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 5.10.0-16-686-pae
(G)UI : LXDE
Inscription : 02-09-2017

Re : Mise à jour (apt-get update) impossible ! [RéSOLU]

mister_g a écrit :

Sur le site de clamav,
après le remove  de clamav

il est noté :

Make sure that you haven’t got old libraries (libclamav.so) lying around your filesystem. You can verify it using:

ldd `which freshclam`

Also make sure there is really only one version of ClamAV installed on your system:

whereis freshclam

whereis clamscan



cf https://docs.clamav.net/faq/faq-uninstall.html



Salut Mister_g

J'ai consulté la doc avant de faire la manip.

root@debian:~# ldd `which freshclam`



ldd: arguments de fichier manquants
Pour en savoir davantage, faites : `ldd --help'.
 



root@debian:~# whereis freshclam


freshclam:
root@debian:~#
 




root@debian:~# whereis clamscan


clamscan:
root@debian:~#
 



root@debian:~# whereis brian



brian: brian is in the kitchen
root@debian:~#

Hors ligne

Pied de page des forums