Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-08-2022 22:17:26

mladen
Membre
Inscription : 30-10-2012

Bug au démarrage après installation de lmde 5

Bonjour,

J'ai cru comprendre qu'on peux poser des questions pour lmde aussi.

Donc voila je viens d'installer lmde 5 et ça bug au démarrage, ça dit :

modprobe: module dm-raid45 not found in modules.dep
You are in emergency mode. After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or "exit"
to boot into default mode.

Cannot access to console, the root account is locked.
See sulogin(8) manpage for more details.

Press enter to continue

Reloading system manager configuration
Starting default target
_


Et ensuite ça remet le même message.

Je crois que le problème viens de la première ligne
Merci aux âmes charitables qui pourront tenter de m'aider à débloquer ma situation.

Dernière modification par mladen (03-08-2022 22:36:53)

Hors ligne

#2 04-08-2022 10:38:22

raleur
Membre
Inscription : 03-10-2014

Re : Bug au démarrage après installation de lmde 5

Je ne connais pas LMDE mais j'ai cru comprendre que c'était assez étroitement basé sur Debian (plus qu'Ubuntu ou Mint).
Mes observations :
- Les noyaux actuels de Debian n'ont pas de module dm-raid45 ni d'alias de module de ce nom.
- Je suis assez surpris que l'échec de chargement d'un module du noyau provoque le passage en emergency mode. Cela ne se produit pas si j'ajoute un nom de module inexistant dans /etc/modules sous Debian, il y a juste un message d'erreur (différent) dans les logs.
- A priori ce message d'erreur ne provient pas de la commande modprobe habituelle du paquet kmod (le message est différent) mais de celle intégrée à busybox. Or sous Debian les commandes de busybox ne sont utilisées que dans l'initramfs (avant le montage de la racine et le lancement d'init/systemd, donc ne peut être la cause du passage en emergency mode) et ce n'est même pas le cas de modprobe qui est la version de kmod comme dans le système normal.
- Cela illustre encore une fois la stupidité de ne pas définir de mot de passe root et de vouloir tout faire avec sudo. On ne peut pas utiliser sudo dans toutes les circonstances, comme celle-ci mais pas seulement.

Suggestion :
- Examiner les paramètre de la ligne de commande du noyau linux dans le menu de GRUB (touche "e") pour vérifier si "single" n'y figurerait pas pour forcer le démarrage en mode dépannage.
- Démarrer en ajoutant le paramètre "break" pour interrompre le démarrage dans l'initramfs. Si le message de modprobe s'affiche, cela signifie qu'il est émis par l'initramfs. Sinon, il est émis par un script d'init ou une unité systemd.
- Démarrer en remplaçant le paramètre "ro" par "rw init=/bin/bash" pour lancer un shell root au lieu d'init/systemd. Exécuter la commande "passwd" pour définir un mot de passe root. Exécuter "exec /sbin/init" pour reprendre le démarrage normal. Attention, le clavier est géré en QWERTY US donc ne pas utiliser de caractère dont la disposition est différente sur le clavier réel (avec un clavier AZERTY éviter les chiffres du clavier principal, les caractères de ponctuation et symboles, les lettres a, q, w, z et m). Le mot de passe pourra être changé plus tard pour un plus robuste.

Il vaut mieux montrer que raconter.

Hors ligne

#3 09-08-2022 00:21:32

mladen
Membre
Inscription : 30-10-2012

Re : Bug au démarrage après installation de lmde 5

Merci,
Après réflexion j'ai finalement installé debian, les problèmes avec les firmwares graphique et wifi étaient simples finalement.
Je laisse la discussion.

Hors ligne

Pied de page des forums