Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-08-2022 13:13:05

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Mobac

Bonjour
Je n'arrive pas à installer Mobac; (Mobile Atlas Creator).
Dans les dépots via synaptic il me dit dépendances cassés.
En terminal:

marc @ marc  ~
└─ $ ▶ sudo apt install mobile-atlas-creator
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 ant : Dépend: default-jre-headless (>= 2:1.8) mais il n'est pas installable ou
                java8-runtime-headless
 mobile-atlas-creator : Dépend: default-jre mais il n'
est pas installable ou
                                 java2-runtime ou
                                 java-runtime
 osmosis : Dépend: default-jre-headless mais il n'est pas installable ou
                    java8-runtime-headless
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'
état ».
marc @ marc  ~
└─ $ ▶

 



Je ne sais pas comment faire , je n'arrive pas à installer jre, j'ai installer java mais ça ne marche pas.
Pouvez vous m'aider?
Merci d'avance

bloc à supprimer si la commande n’affiche rien

Dernière modification par Marc29 (17-08-2022 13:15:37)


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#2 17-08-2022 13:23:21

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-19-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : Mobac

As-tu au moins effectué une mise à jour avant de vouloir installer mobile-atlas-creator ?



Sinon :

apt update && apt upgrade


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#3 17-08-2022 13:27:31

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

oui, mais je n'arrive pas à installer JRE

marc @ marc  ~
└─ $ ▶ sudo apt-get install default-jre
[sudo] Mot de passe de marc :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 openjdk-11-jre-headless : Dépend: ca-certificates-java (>= 20190405~) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'
état ».
marc @ marc  ~
└─ $ ▶

 


bloc à supprimer si la commande n’affiche rien

Dernière modification par Marc29 (17-08-2022 13:36:21)


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#4 17-08-2022 13:53:58

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-19-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : Mobac

Oui JRE absolument d'accord, mais quel paquets exactement ?


Parce que j'ai ces paquets installés :

aptitude search '~i default-jre'

i A default-jre                                        - environnement d'exécution Java standard ou compatible      
i   default-jre-headless                               - environnement d'exécution standard Java ou compatible — non




Bon, édition du message puisque tu as complété, merci ! smile

Euh ! Bin, le problème se reporte donc maintenant sur le paquet ca-certificates-java !


Quellle version du  paquet ca-certificates-java disposes-tu ?  :

apt policy ca-certificates-java


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#5 17-08-2022 14:00:37

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

marc @ marc  ~
└─ $ ▶ apt policy ca-certificates-java
ca-certificates-java:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
     20190909 -30000
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
marc @ marc  ~
└─ $ ▶

 


bloc à supprimer si la commande n’affiche rien


Par synaptic il ne veut pas installer ca-certificates-java
Mais je l'ai installé déjà, peut être un redémarrage...

Dernière modification par Marc29 (17-08-2022 14:03:18)


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#6 17-08-2022 14:06:28

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

J'ai re démarrer mais tour pas de ca-certificates_.
Pourtant j'ai installer : ca-certificates_20200601~deb10u2_all.deb
Impossible d'installer: ca-certificates-java_20220719_all.deb

Dernière modification par Marc29 (17-08-2022 14:09:08)


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#7 17-08-2022 14:16:32

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-19-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : Mobac

C'est normal que l'installation du paquet ca-certificates-java ne se fasse pas puisque ce paquet est épinglé à une priorité négative de -30000 !


Marc29 a écrit :

marc @ marc  ~
└─ $ ▶ apt policy ca-certificates-java
ca-certificates-java:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
     20190909 -30000
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
marc @ marc  ~
└─ $ ▶

 



Table de version :
     20190909 -30000 !



Chez moi :

apt policy ca-certificates-java

ca-certificates-java:
  Installé : 20190909
  Candidat : 20190909
 Table de version :
 *** 20190909 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status



Table de version :
*** 20190909 500 priorité ordinaire de 500 ( puisque je n'ai épinglé aucun paquet du système ).


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#8 17-08-2022 14:17:58

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

Ah? Mais je fais comment du coup?
C'est une histoire de priorité dans mes dépôts?

Dernière modification par Marc29 (17-08-2022 14:27:15)


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#9 17-08-2022 14:37:29

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

Avec synaptic, ca-certificates ne veut pas non plus s'installer.

Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#10 17-08-2022 14:56:46

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-19-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : Mobac

Ici et maintenant, pour ce que tu devrais faire pour corriger cette situation, je ne sais pas, je n'ai jamais épinglé ou désépinglé de paquets. Juste quelques maintien en l'état d'un paquet quelquefois.


Il me semble que cette priorité ou cet épinglage peut se régler paquet par paquet ou globalement par dépôts. Dans le cas où rien n'aurait été changé dans ta machine concernant les priorités ou les paquets épinglés, tu devrais obtenir ceci :


apt policy

Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 https://deb.debian.org/debian bullseye-updates/main amd64 Packages
     release v=11-updates,o=Debian,a=stable-updates,n=bullseye-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org bullseye-security/non-free amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org bullseye-security/main amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 https://security.debian.org/debian-security bullseye-security/main amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 https://deb.debian.org/debian bullseye/non-free amd64 Packages
     release v=11.4,o=Debian,a=stable,n=bullseye,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 https://deb.debian.org/debian bullseye/contrib amd64 Packages
     release v=11.4,o=Debian,a=stable,n=bullseye,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 https://deb.debian.org/debian bullseye/main amd64 Packages
     release v=11.4,o=Debian,a=stable,n=bullseye,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
 




marc29 a écrit :

Avec synaptic, ca-certificates ne veut pas non plus s'installer.

C'est normal, ces priorités ou ces épinglages sont globaux, c'est à dire qu'ils sont lus et pris en compte par tous les moyens de mises à jour. Imagine le bordel si un moyen de mise à jour n'était pas harmonisé avec les autres !

Je me pose la question de savoir comment et pourquoi une priorité de dépôts ou un épinglage de paquet a atterri sur ta machine sans que tu t'en aperçoives ?
Il y avait peut-être une raison à un moment donné de prioriser des dépôts ou d'épingler des paquets. Qui l'a fait et pourquoi ?

Tu devrais lancer un autre sujet du genre : « Épinglage de paquet ou priorité de dépôt plus valable ou non-valable » pour déjà tirer cela au clair !

Avec la commande apt policy et son résultat pour commencer !

Avant de revenir sur ce sujet ici.

Bon courage pour la suite des opérations. smile


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#11 17-08-2022 14:59:47

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

Oulala!

└─ $ ▶ apt policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://dl.google.com/linux/earth/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 http://security.debian.org/debian-security bullseye-security/non-free amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security bullseye-security/main amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian bullseye-updates/main amd64 Packages
     release v=11-updates,o=Debian,a=stable-updates,n=bullseye-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/non-free amd64 Packages
     release v=11.4,o=Debian,a=stable,n=bullseye,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/contrib amd64 Packages
     release v=11.4,o=Debian,a=stable,n=bullseye,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/main amd64 Packages
     release v=11.4,o=Debian,a=stable,n=bullseye,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
     ca-certificates-java -> 20190909 avec la priorité -30000
marc @ marc  ~
└─ $ ▶

 


il n'y a que celui là qui est épinglé!

bloc à supprimer si la commande n’affiche rien


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#12 17-08-2022 15:06:32

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

Merci quand même , j'ai lané le fil.
https://debian-facile.org/viewtopic.php … 25#p384525

Dernière modification par Marc29 (17-08-2022 15:09:58)


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#13 17-08-2022 15:14:25

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-19-amd64
(G)UI : mutter 3.38.6-2~deb11u2
Inscription : 15-02-2016

Re : Mobac

Tant mieux ! smile


Que donne : 

ls /etc/apt/preferences.d/

?

D'après cette documentation : https://debian-facile.org/doc:systeme:apt:pinning


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#14 17-08-2022 15:31:55

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

En effet ça vient de là:

marc @ marc  ~
└─ $ ▶ ls /etc/apt/preferences.d/
apt-listbugs
 


bloc à supprimer si la commande n’affiche rien


Mais du coup je suis sur l'autre sujet pour ça:
https://debian-facile.org/viewtopic.php … 25#p384525

Dernière modification par Marc29 (17-08-2022 15:33:07)


Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

#15 17-08-2022 15:49:01

Marc29
Membre
Lieu : Quimper
Distrib. : debian 11
Noyau : 5.10 -amd64
(G)UI : Xfce4
Inscription : 10-12-2012

Re : Mobac

C'est bon, grand merci et bravo, j'installe mobac

Debian Buster xfce
SSD 120 giga/ pci: NVIDIA corporation GT218; gpu: getforce210/ RAM: -8 go

Hors ligne

Pied de page des forums