Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-09-2022 11:29:03

sofiane60800
Membre
Inscription : 01-09-2022

Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Bonjour,

Pour mon travail, je devais mettre à jour FusionInventory, ce que j'ai fais, voila à quoi cela ressemble désormais

9a3k.png

Je dois donc mettre à jour GLPI, j'ai retourner tous les forum possible et imaginable, et j'ai bien compris que pour update GLPI, je devais mettre le nouveau dossier GLPI à la place de l'ancien, malheureusement, ca ne fonctionne pas, et j'ai eu un message me disant "Php 7.2 >= is needed" donc j'ai voulu mettre à jour PHP
Mais lorsque j'essaye, meme chose, voila le soucis que je rencontre :

7hn3.png

Impossible de trouver le paquet, je ne sais pas pourquoi.
Meme chose, j'ai retourner tout les forum d'aide possible, j'ai déjà fais plusieurs apt update/upgrade, j'ai essayé d'installer des package en plus ect ... rien ne marche, j'en revient toujours au même point

Résultat, la maj php m'empeche d'update glpi qui m'empeche lui d'update fusion, auriez-vous des idées ?

S'il vous faut des informations particulière, n'hésitez pas je vous donnerais tout ce qu'il vous faut.

Merci d'avance

Dernière modification par sofiane60800 (01-09-2022 11:32:48)

Hors ligne

#2 01-09-2022 11:30:21

sofiane60800
Membre
Inscription : 01-09-2022

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

update : la version de php installé est la suivante :

après un php -v

PHP 7.0.33-0+deb9u12 (cli) (built: Oct 26 2021 17:51:39) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.33-0+deb9u12, Copyright (c) 1999-2017, by Zend Technologies

Hors ligne

#3 01-09-2022 14:03:55

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Il existe bien un dépôt permettant d’accéder aux versions récentes de PHP sur Debian stable (https://deb.sury.org/) mais à ma connaissance il ne remonte que jusqu’à Debian 10 (Buster).

Debian 9 (Stretch) ne bénéficie plus d’une prise en charge totale, pas même pour les mises-à-jour de sécurité, donc c’est un système à envisage de mettre à jour vers une version actuelle de Debian, idéalement Debian 11 (Bullseye).

Jouer sous Debian ? Facile !

Hors ligne

#4 01-09-2022 16:33:11

sofiane60800
Membre
Inscription : 01-09-2022

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Hello, merci de ton retour,
J'ai vu sur plusieurs forum et autres, des gens installé php 7.2 sur du debian 9 (ce que j'ai) et cela ne posait pas de soucis, je ne pense pas que le problèmes viennent de la malheureusement...
De plus, c'étais prévu plus tard le changement vers debian 11, mais dans l'instant, je dois au plus vite terminer les MAJ GLPI/FUSION/PHP
D'autre pistes ?

Dernière modification par sofiane60800 (01-09-2022 16:36:15)

Hors ligne

#5 01-09-2022 16:39:26

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Hello!
Moi je pense que le problème vient bien de la, car ce que tu as vu sur les forums, date peut-être de Mathusalem ! big_smile

Dernière modification par Jean-Pierre Pinson (01-09-2022 16:39:58)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#6 01-09-2022 16:59:33

sofiane60800
Membre
Inscription : 01-09-2022

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Jean-Pierre Pinson a écrit :

Hello!
Moi je pense que le problème vient bien de la, car ce que tu as vu sur les forums, date peut-être de Mathusalem ! big_smile



Merci de ton retour également smile
Ma logique voudrait que même si j'ai regarder des forum de 2015, et que les gens ont réussit sur du debian 9, à installer php 7.2, pourquoi 5 ans après ce ne serait plus possible.
Je ne comprend pas...
Ca voudrait dire que PHP à retirer la possibilité de déployer php 7.2 sur debian 9 ?

Merci encore pour vos retours plus que rapides smile

Hors ligne

#7 01-09-2022 17:06:03

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Ça veut dire que, Debian 9 (Stretch) ne bénéficie plus d’une prise en charge totale, pas même pour les mises-à-jour de sécurité et donc de php ! smile
donc php n'existe plus sur Debian 9 (Stretch)

Et de toutes façons Debian 9 (Stretch) ça commence à être vieux !

Dernière modification par Jean-Pierre Pinson (01-09-2022 17:42:02)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#8 02-09-2022 10:28:36

TyZef
Membre
Distrib. : dn sid
(G)UI : OpenBox
Inscription : 09-05-2013

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY


......###     #       #    #        #
..#            # #    #    #        #
.#   ###   #    # #    #        #
....###    #       #       ###   Linux

Hors ligne

#9 02-09-2022 11:07:46

sofiane60800
Membre
Inscription : 01-09-2022

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Jean-Pierre Pinson a écrit :

Ça veut dire que, Debian 9 (Stretch) ne bénéficie plus d’une prise en charge totale, pas même pour les mises-à-jour de sécurité et donc de php ! smile
donc php n'existe plus sur Debian 9 (Stretch)

Et de toutes façons Debian 9 (Stretch) ça commence à être vieux !



Bonjour,

J'ai exposé tout cela à mon chef, nous mettrons Debian à jour lorsque nous changerons le serveur GLPI dans quelques mois, pour le moment cela restera donc comme tel.

En revanche, j'aimerais un peu plus poussé la chose à titre personnel pour ma culture, j'ai regarder de nouveau forum datant de fin 2021 par exemple, sur lesquels ils expliquait comment installé php sur debian.
Bon ducoup ma question est la suivante, admettons que je supprime php de mon serveur :

- Est-ce que je ne pourais plus du tout installé PhP ?
- Ou alors est-ce que je pourais réinstallé php mais avec une version (par exemple) 7.1 maximum ?
- Ou alors, est-ce que cela vaudrait le coup sur une VM cloner de tester de viré l'ancienne version et essayer d'installer une autre version de php, et qu'avec un peu de chance, la dernière version de php, au alors au moins la version 7.2 poura s'installer ?

Désolé d'insister autant, c'est que j'aime bien comprendre completement les choses ! smile
Et encore merci pour vos retours c'est super cool et réactif !

Hors ligne

#10 02-09-2022 12:51:51

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

En installant PHP depuis les dépôts Debian (ce que tu pourras toujours faire, même si tu as désinstallé PHP entre temps), tu seras limité à PHP 7.0.

En utilisant le dépôt tiers proposé dans le guide que TyZef propose tu devrais bien avoir accès à PHP 7.2, mais ça me surprend parce qu’il s’agit justement du dépôt tiers que j’étais allé vérifier et qui ne semble plus prendre en charge Debian 9. C’est possible que ce guide ne soit plus valable aujourd’hui.

Le dépôt tiers en question, au mainteneur duquel on peut faire confiance vu que c’est aussi lui qui maintient les paquets pour PHP des dépôts Debian officiels, propose les versions suivantes de PHP :
- 5.6
- 7.0
- 7.1
- 7.2
- 7.3
- 7.4
- 8.0
- 8.1
- 8.2

Jouer sous Debian ? Facile !

Hors ligne

#11 02-09-2022 14:15:25

sofiane60800
Membre
Inscription : 01-09-2022

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

vv222 a écrit :

En installant PHP depuis les dépôts Debian (ce que tu pourras toujours faire, même si tu as désinstallé PHP entre temps), tu seras limité à PHP 7.0.

En utilisant le dépôt tiers proposé dans le guide que TyZef propose tu devrais bien avoir accès à PHP 7.2, mais ça me surprend parce qu’il s’agit justement du dépôt tiers que j’étais allé vérifier et qui ne semble plus prendre en charge Debian 9. C’est possible que ce guide ne soit plus valable aujourd’hui.

Le dépôt tiers en question, au mainteneur duquel on peut faire confiance vu que c’est aussi lui qui maintient les paquets pour PHP des dépôts Debian officiels, propose les versions suivantes de PHP :
- 5.6
- 7.0
- 7.1
- 7.2
- 7.3
- 7.4
- 8.0
- 8.1
- 8.2




Je te confirme qu'après avoir suivie ce tutoriel, cela ne fonctionne toujours pas, après avoir installé les paquets (wget ...) au moment d'apt update j'ai exactement la même erreur que la personne dans le tuto, puis, j'installe le certificat, jusque la aucun soucis, mais au moment d'apt update j'ai ceci : (voir screen)

p3us.png


Puis, lorsque j'essai quand même d'installé php 7.2, meme chose, voici ce que j'ai : (voir screen)

ohsh.png

Cordialement

Hors ligne

#12 02-09-2022 14:32:29

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Probleme MAJ PHP/GLPI/FUSIONINVENTORY

Bonjour,
en allant voir le site, on voit que ne sont proposé des paquets au téléchargement que pour buster et bullseye... Soit debian 10 et 11...
https://packages.sury.org/php/dists/
Pour plus vieux, je pense qu'il faut passer par freexian qui prend en charge le long terme (pour debian 8 et 9 en tout cas) mais je pense qu'il faut peut être sortir le porte-monnaie pour en bénéficier....
https://php.freexian.com/
./.
https://deb.sury.org/

Dernière modification par ubub (02-09-2022 14:34:17)

En ligne

Pied de page des forums