Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-10-2022 17:00:50

Jean-c
Membre
Lieu : Lyon
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-21-amd64
(G)UI : Gnome
Inscription : 17-09-2022

Pas de son sur nouvelle installation de Debian

Bonjour,

Je viens d'installer une debian 11, ça marche, mais je n'ai pas de son.
Que faire ?

Merci.

Hors ligne

#2 01-10-2022 17:44:22

vincen
Adhérent(e)
Lieu : Lausanne, Suisse
Distrib. : Debian 11
Noyau : Linux 5.10.0-16-amd64
(G)UI : KDE
Inscription : 19-08-2021
Site Web

Re : Pas de son sur nouvelle installation de Debian

Alors comme il n'y a pas de devin parmi les membres du forum il va falloir en dire plus smile Quel est le modèle de carte son dans la machine ? Debian voit la carte son ou pas du tout ? Aucun volume ou carte son visible ?

J'écris en Bépo
Je stocke mes fichiers dans NextCloud
Tous mes ordinateurs tournent sous Linux et mes serveurs d'hébergement sous Linux/Webmin/Virtualmin wink
Vive l'informatique libre !

Hors ligne

#3 01-10-2022 20:55:07

Jean-c
Membre
Lieu : Lyon
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-21-amd64
(G)UI : Gnome
Inscription : 17-09-2022

Re : Pas de son sur nouvelle installation de Debian

Bonsoir,

Comment ça ? On ne lit pas la config des gens dans les entrailles d'une truite fraîche ?

root@debianAnneSo:/# discover -v


Loading XML data... ata pci pcmcia scsi usb Done
Scanning buses... ata pci pcmcia scsi usb Done
Intel Corporation ValleyView Power Control Unit
Intel Corporation ValleyView USB xHCI Host Controller
Intel Corporation ValleyView Gen7
Intel Corporation ValleyView SEC
Intel Corporation ValleyView SSA-CUnit
Linux Foundation 3.0 root hub
unknown unknown
unknown unknown
Genesys Logic, Inc. USB-2.0 4-Port HUB
Linux Foundation 2.0 root hub



Ou encore...


lspci


root@debianAnneSo:/# lspci -v
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0f)
    Subsystem: Device 1027:2014
    Flags: bus master, fast devsel, latency 0
    Kernel driver in use: iosf_mbi_pci

00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0f) (prog-if 00 [VGA controller])
    DeviceName:  Onboard IGD
    Subsystem: Device 1027:2014
    Flags: bus master, fast devsel, latency 0, IRQ 74
    Memory at 90000000 (32-bit, non-prefetchable) [size=4M]
    Memory at 80000000 (32-bit, prefetchable) [size=256M]
    I/O ports at 1000 [size=8]
    Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
    Capabilities: [d0] Power Management version 2
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [b0] Vendor Specific Information: Len=07 <?>
    Kernel driver in use: i915
    Kernel modules: i915

00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0f) (prog-if 30 [XHCI])
    Subsystem: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI
    Flags: bus master, medium devsel, latency 0, IRQ 72
    Memory at 90800000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [70] Power Management version 2
    Capabilities: [80] MSI: Enable+ Count=1/8 Maskable- 64bit+
    Kernel driver in use: xhci_hcd
    Kernel modules: xhci_pci

00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0f)
    Subsystem: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine
    Flags: bus master, fast devsel, latency 0, IRQ 82
    Memory at 90700000 (32-bit, non-prefetchable) [size=1M]
    Memory at 90600000 (32-bit, non-prefetchable) [size=1M]
    Capabilities: [80] Power Management version 3
    Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Kernel driver in use: mei_txe
    Kernel modules: mei_txe

00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0f)
    Subsystem: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit
    Flags: bus master, medium devsel, latency 0
    Capabilities: [e0] Vendor Specific Information: Len=0c <?>
    Kernel driver in use: lpc_ich
    Kernel modules: lpc_ich



Et pour faire bonne mesure :

lsusb


root@debianAnneSo:/# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 058f:5608 Alcor Micro Corp. USB 2.0 Camera
Bus 001 Device 004: ID 0911:2188 Philips Speech Processing USB Keyboard
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



Dans tout ça, j'avoue avoir un peu de mal à localiser la carte son.
Mais ça relève un poil moins de la divination.

Merci de votre aide.

Dernière modification par Jean-c (02-10-2022 12:33:19)

Hors ligne

#4 01-10-2022 20:56:27

Jean-c
Membre
Lieu : Lyon
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-21-amd64
(G)UI : Gnome
Inscription : 17-09-2022

Re : Pas de son sur nouvelle installation de Debian

LE BB Code n'a pas marché semble-t-il... si après correction. Merci au message suivant pour le flash forward.

Dernière modification par Jean-c (02-10-2022 12:34:05)

Hors ligne

#5 02-10-2022 10:33:58

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Pas de son sur nouvelle installation de Debian

Jean-c a écrit :

LE BB Code n'a pas marché semble-t-il...


oui tu n'as pas fermé ta première balise code , le / n'est pas au bon endroit , ce qui fou en l'air le reste du texte

sinon y'a t'il déjà eu Debian ou autre distribution Linux d'installer sur cet ordi ou le son fonctionnait?

Dernière modification par Croutons (02-10-2022 10:34:20)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 02-10-2022 12:35:54

Jean-c
Membre
Lieu : Lyon
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-21-amd64
(G)UI : Gnome
Inscription : 17-09-2022

Re : Pas de son sur nouvelle installation de Debian

Bonjour,

Auparavant ce PC était sous Windows, c'est sa première Debian.
Ca m'émeut...
J'ai corrigé le BBCode ça devrait aider.
Pour autant que je sache oui, avant le son fonctionnait.

Hors ligne

#7 02-10-2022 13:44:59

vincen
Adhérent(e)
Lieu : Lausanne, Suisse
Distrib. : Debian 11
Noyau : Linux 5.10.0-16-amd64
(G)UI : KDE
Inscription : 19-08-2021
Site Web

Re : Pas de son sur nouvelle installation de Debian

Jean-c a écrit :

Pour autant que je sache oui, avant le son fonctionnait.


Les deux trucs unknown sont probablement les interfaces son manquantes ! C'est une machine d'assemblage ? si oui quelle est la carte son ou la carte-mère ? Si c'est un modèle tout fait la référence du modèle et le fabricant ?


J'écris en Bépo
Je stocke mes fichiers dans NextCloud
Tous mes ordinateurs tournent sous Linux et mes serveurs d'hébergement sous Linux/Webmin/Virtualmin wink
Vive l'informatique libre !

Hors ligne

#8 02-10-2022 14:41:23

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Pas de son sur nouvelle installation de Debian

Bonjour,
possible d'avoir des renseignements sur l'audio avec inxi -A

apt install inxi



inxi -A



... tant qu'aux trucs unknown, j'en ai sur mon retour de commande et même dans les exemples de la page de manuel, y'en a ... Peut-être quasi-normal chez discover..?...

En ligne

#9 02-10-2022 14:49:03

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Pas de son sur nouvelle installation de Debian

je crois pas que on apprenne + avec inxi
il faudrait voir les erreurs

journalctl -r -p err


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 02-10-2022 20:51:04

Jean-c
Membre
Lieu : Lyon
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-21-amd64
(G)UI : Gnome
Inscription : 17-09-2022

Re : Pas de son sur nouvelle installation de Debian

Bonsoir,

Voici ce que me retourne la commande :


journalctl -r -p err
 



Journal begins at Sat 2022-10-01 15:13:00 CEST, ends at Sun 2022-10-02 20:36>
oct. 02 20:35:39 debianAnneSo systemd[1045]: Failed to start Application launch>
oct. 02 20:35:34 debianAnneSo bluetoothd[473]: src/profile.c:ext_start_servers(>
oct. 02 20:35:34 debianAnneSo bluetoothd[473]: src/profile.c:ext_start_servers(>
oct. 02 20:35:34 debianAnneSo pulseaudio[1061]: Failed to load module "module-a>
oct. 02 20:35:34 debianAnneSo pulseaudio[1061]: Failed to find a working profil>
oct. 02 20:35:34 debianAnneSo kernel:  Baytrail Audio Port: ASoC: failed to sta>
oct. 02 20:35:34 debianAnneSo kernel:  SSP2-Codec: ASoC: BE open failed -16
oct. 02 20:35:34 debianAnneSo kernel: sst-mfld-platform sst-mfld-platform: ASoC>
oct. 02 20:35:34 debianAnneSo kernel: intel_sst_acpi 80860F28:00: fw returned e>
oct. 02 20:35:34 debianAnneSo kernel: intel_sst_acpi 80860F28:00: Wait timed-ou>
oct. 02 20:35:32 debianAnneSo pulseaudio[1061]: Failed to load module "module-a>
oct. 02 20:35:32 debianAnneSo kernel:  Baytrail Audio Port: ASoC: failed to sta>
oct. 02 20:35:32 debianAnneSo kernel:  SSP2-Codec: ASoC: BE open failed -16
oct. 02 20:35:32 debianAnneSo kernel: sst-mfld-platform sst-mfld-platform: ASoC>
oct. 02 20:35:32 debianAnneSo kernel: intel_sst_acpi 80860F28:00: fw returned e>
oct. 02 20:35:32 debianAnneSo kernel: intel_sst_acpi 80860F28:00: Wait timed-ou>
oct. 02 20:35:32 debianAnneSo pulseaudio[1061]: Failed to find a working profil>
oct. 02 20:35:32 debianAnneSo systemd[1045]: Failed to start Application launch>
oct. 02 20:35:31 debianAnneSo pipewire[1060]: Failed to receive portal pid: org>
oct. 02 20:35:30 debianAnneSo gdm-password][1034]: gkr-pam: unable to locate da>
oct. 02 20:34:59 debianAnneSo wpa_supplicant[493]: bgscan simple: Failed to ena>
oct. 02 20:34:51 debianAnneSo pulseaudio[629]: Failed to load module "module-al>

 



Pour bien faire il aurait fallu exporter le journal dans un fichier.
J'espère qu ça aide.

Hors ligne

#11 02-10-2022 22:30:51

Jean-c
Membre
Lieu : Lyon
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-21-amd64
(G)UI : Gnome
Inscription : 17-09-2022

Re : Pas de son sur nouvelle installation de Debian

J'ai trouvé pour le son : il me manquait encore un microcode en Fw pour la gestion du son.
On voyait l'erreur au démarrage mais je l'avais loupé ça défilé vite.
Merci !

Hors ligne

Pied de page des forums