Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-10-2022 14:51:11

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

[résolu]bluetooth 5 intel AX200 ne fonctionne pas

Bonjour
sur une machine avec une carte GC-WBAX200 Aorus en bookworm sur le bureau Mate , le bluetooth ne fonctionne pas.
quelques retours


lsusb
Bus 001 Device 003: ID 8087:0029 Intel Corp. AX200 Bluetooth
 




service bluetooth status
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; preset: enabled)
     Active: active (running) since Sat 2022-10-08 14:09:58 CEST; 22min ago
       Docs: man:bluetoothd(8)
   Main PID: 630 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 16648)
     Memory: 3.2M
        CPU: 28ms
     CGroup: /system.slice/bluetooth.service
             └─630 /usr/libexec/bluetooth/bluetoothd

oct. 08 14:09:58 raven2200g systemd[1]: Starting Bluetooth service...
oct. 08 14:09:58 raven2200g bluetoothd[630]: Bluetooth daemon 5.65
oct. 08 14:09:58 raven2200g bluetoothd[630]: Starting SDP server
oct. 08 14:09:58 raven2200g systemd[1]: Started Bluetooth service.
oct. 08 14:09:58 raven2200g bluetoothd[630]: Bluetooth management interface 1.22 initialized
 




dmesg | grep -i bluetooth
[    4.051194] Bluetooth: Core ver 2.22
[    4.051224] NET: Registered PF_BLUETOOTH protocol family
[    4.051225] Bluetooth: HCI device and connection manager initialized
[    4.051229] Bluetooth: HCI socket layer initialized
[    4.051231] Bluetooth: L2CAP socket layer initialized
[    4.051234] Bluetooth: SCO socket layer initialized
[    5.368993] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.368995] Bluetooth: BNEP filters: protocol multicast
[    5.368999] Bluetooth: BNEP socket layer initialized
[    6.148027] Bluetooth: hci0: command 0xfc05 tx timeout
[    6.148036] Bluetooth: hci0: Reading Intel version command failed (-110)
 



le gestionnaire blueman (icone du tableau de bord ne fonctionne pas)
mes enceintes "LOGI" ne fonctionne pas en bluetooth
ps: sur Mate , blueman (gtk2) ou gnome-bluetooth (gtk3)  ?
sur l'utilitaire  de pulseaudio je vois pas le bluetooth

Dernière modification par robert2a (12-10-2022 15:36:47)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#2 12-10-2022 14:04:26

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu]bluetooth 5 intel AX200 ne fonctionne pas

je n'ai pas de problème avec ce module bluetooth


Bus 009 Device 003: ID 8087:0025 Intel Corp. Wireless-AC 9260 Bluetooth Adapter
 


cela serait un souci de kernel et de module bluetooth (pilote) avec l AX200  ?
ci dessus le module (pilote)


Pilote : module-bluez5-device.c
 



les deux sont en bluetooth 5

Dernière modification par robert2a (12-10-2022 14:11:40)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 12-10-2022 15:45:04

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu]bluetooth 5 intel AX200 ne fonctionne pas

bon j'ai installé le firmware-misc-nonfree et cela fonctionne


service bluetooth status
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; preset: enabled)
     Active: active (running) since Wed 2022-10-12 15:31:57 CEST; 2min 24s ago
       Docs: man:bluetoothd(8)
   Main PID: 660 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 16647)
     Memory: 3.5M
        CPU: 74ms
     CGroup: /system.slice/bluetooth.service
             └─660 /usr/libexec/bluetooth/bluetoothd

oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint unregistered: sender=:1.24 path=/MediaEndpoint/A2DPSource/sbc_xq_552
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSink/sbc
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSource/sbc
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSink/sbc_xq_453
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSource/sbc_xq_453
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSink/sbc_xq_512
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSource/sbc_xq_512
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSink/sbc_xq_552
oct. 12 15:32:12 raven2200g bluetoothd[660]: Endpoint registered: sender=:1.37 path=/MediaEndpoint/A2DPSource/sbc_xq_552
oct. 12 15:33:10 raven2200g bluetoothd[660]: /org/bluez/hci0/dev_7C_96_D2_BA_F1_04/sep1/fd0: fd(40) ready
 


j'ai bien mes profils actif (AD2P)

pour les erreurs pas très joli mais ça fonctionne


journalctl -b -r -p err
oct. 12 15:32:12 raven2200g pulseaudio[829]: Error opening PCM device front:1: Aucun fichier ou dossier de ce type
oct. 12 15:32:11 raven2200g lightdm[1153]: gkr-pam: unable to locate daemon control file
oct. 12 15:31:57 raven2200g bluetoothd[660]: sap-server: Operation not permitted (1)
oct. 12 15:31:57 raven2200g bluetoothd[660]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
oct. 12 15:31:56 raven2200g kernel: bluetooth hci0: firmware: failed to load intel/ibt-20-0-0.sfi (-2)
oct. 12 15:31:56 raven2200g kernel: bluetooth hci0: firmware: failed to load intel/ibt-20-0-0.sfi (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-64.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-64.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-65.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-65.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-66.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-66.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-67.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-67.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-68.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-68.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-69.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-69.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-70.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-70.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-71.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-71.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-72.ucode (-2)
oct. 12 15:31:55 raven2200g kernel: firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
oct. 12 15:31:55 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-72.ucode (-2)
 



c'est une machine en AMD , pas penser a l'utilité de ce firmware   roll

j'ai utilisé ceci  =>  https://debian-facile.org/viewtopic.php?id=31836

Dernière modification par robert2a (12-10-2022 15:47:44)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#4 06-11-2022 16:27:02

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu]bluetooth 5 intel AX200 ne fonctionne pas

Bonjour
suite a la saga des kernels sur testing/sid j'ai retrouvé , puis perdu a nouveau le bluetooth sur ce matériel
a priori c'est correct maintenant


uname -a
Linux raven2200g 6.0.0-2-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.0.5-1 (2022-10-28) x86_64 GNU/Linux
 


les erreurs (plus propre que ci dessus #3 ).


journalctl -b -r -p err
nov. 06 12:16:54 raven2200g lightdm[1231]: gkr-pam: unable to locate daemon control file
nov. 06 12:16:34 raven2200g bluetoothd[682]: sap-server: Operation not permitted (1)
nov. 06 12:16:34 raven2200g bluetoothd[682]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
nov. 06 12:16:33 raven2200g kernel: bluetooth hci0: firmware: failed to load intel/ibt-20-0-0.sfi (-2)
nov. 06 12:16:33 raven2200g kernel: bluetooth hci0: firmware: failed to load intel/ibt-20-0-0.sfi (-2)
nov. 06 12:16:32 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
nov. 06 12:16:32 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
nov. 06 12:16:32 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-72.ucode (-2)
nov. 06 12:16:32 raven2200g kernel: firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
nov. 06 12:16:32 raven2200g kernel: iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-cc-a0-72.ucode (-2)
 


le bluetooth (avec enfin les profils )


service bluetooth status
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; preset: enabled)
     Active: active (running) since Sun 2022-11-06 12:16:34 CET; 2h 58min ago
       Docs: man:bluetoothd(8)
   Main PID: 682 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 16647)
     Memory: 3.4M
        CPU: 93ms
     CGroup: /system.slice/bluetooth.service
             └─682 /usr/libexec/bluetooth/bluetoothd

nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSource/faststream
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSource/faststream_duplex
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSink/opus_05
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSource/opus_05
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSource/opus_05_51
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSource/opus_05_71
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSink/opus_05_duplex
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSource/opus_05_duplex
nov. 06 12:16:55 raven2200g bluetoothd[682]: Endpoint registered: sender=:1.47 path=/MediaEndpoint/A2DPSource/opus_05_pro
nov. 06 14:53:24 raven2200g bluetoothd[682]: /org/bluez/hci0/dev_7C_96_D2_BA_F1_04/sep1/fd0: fd(40) ready
 


j'utilise pipewire , le paquet pulseaudio est absent remplacé par pipewire-pulse
on verra a l'utilisation , a priori le noyau va encore bouger .


LANG=C pactl info | grep '^Server Name'
Server Name: PulseAudio (on PipeWire 0.3.59)
 



ps: j'ai du ouvrir plusieurs fils pour ce souci de bluetooth désolé    roll


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

Pied de page des forums