Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-10-2022 18:53:39

capdefradeb
Membre
Distrib. : LMDE4 XFCE, LM20 Cinnamon, MX19.2
(G)UI : Cinnamon et XFCE
Inscription : 14-07-2016

Freezes Ecran très fréquents avec vieille carte NVIDIA

J'ai rencontré le pb de freezes de l'écran sur mon vieil ordi tour qui a une carte video Nvidia ancienne, une GeForce GT320,lors du passage de LMDE4 à LMDE5. Très fréquemment et notamment en utilisant un navigateur, Firefox ou Chrome, ou Thunderbird je me retrouvais avec le clavier inopérant et le curseur souris possible à déplacer (mais aucun clic possible) puis le curseur figé et il n'y avait pas d'autre solution qu'un redémarrage en appuyant sur le bouton d'extinction. J'avais cru initialement que c'était un bug de LMDE5 et j'avais installé à la place LM21 XFCE mais le pb était le même, juste un peu moins fréquent.
En furetant sur internet j'ai constaté que le pb était connu et généralisé chez tous ceux qui étaient passés à LM21, Ubuntu 22 ou LMDE5 (et sans doute Debian 11 aussi) si leur ordi avait une vieille carte NVIDIA gérée auparavant par le pilote Linux 340. Or ce pilote n'est plus disponible avec ces systèmes Linux récents et c'est donc le pilote générique Linux "nouveau" qui est utilisé; et c'est lui le coupable!
A force de chercher j'ai trouvé un gars qui a modifié le pilote 340 pour le patcher et le rendre compatible avec les systèmes Linux récents (Ubuntu, LM, Debian); il l'a mis à disposition sur un PPA et du coup, le pilote alternatif Nvidia 340 apparait à nouveau dans le gestionnaire de pilotes, pour les systèmes qui ont ce type de gestionnaire ou bien on peut l'installer en ligne de commande.
Je l'ai installé à la place de "nouveau" et, pour le moment, plus aucun plantage de l'écran!

Le lien pour le PPA est le suivant:
https://launchpad.net/~kelebek333/+arch … dia-legacy

et la discussion qui m'a permis de tester cette solution et qui donne toute la procédure d'installation est: https://forums.developer.nvidia.com/t/u … ers/222935
Voilà, j'espère que ça pourra être utile à d'autres, notamment ceux qui utilisent Debian 11 et qui avaient eux aussi constaté ce problème. Je sais que ça demande l'installation d'un PPA, peu prisée dans le monde Debian mais ça vaut mieux qu'un ordi planté en permanence...

Dernière modification par capdefradeb (20-10-2022 23:02:46)

Hors ligne

#2 20-10-2022 22:41:16

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-18-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Hello,
Les liens ne fonctionnent pas.

Dernière modification par Philou92 (20-10-2022 23:45:31)


Tousse antique Ovide !

Hors ligne

#3 20-10-2022 22:58:21

capdefradeb
Membre
Distrib. : LMDE4 XFCE, LM20 Cinnamon, MX19.2
(G)UI : Cinnamon et XFCE
Inscription : 14-07-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Philou92 a écrit :

Hello,
Les liens ne fonctionne pas.


Et bien oui, je viens de voir qu'ils n'ont pas été pris en totalité. Je vais essayer de les remettre.

Dernière modification par capdefradeb (20-10-2022 23:00:34)

Hors ligne

#4 20-10-2022 23:00:12

capdefradeb
Membre
Distrib. : LMDE4 XFCE, LM20 Cinnamon, MX19.2
(G)UI : Cinnamon et XFCE
Inscription : 14-07-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

capdefradeb a écrit :

Philou92 a écrit :

Hello,
Les liens ne fonctionne pas.


Et bien oui, je viens de voir qu'ils n'ont pas pris en totalité. Je vais essayer de les remettre.



Nouveaux liens:

https://launchpad.net/~kelebek333/+arch … dia-legacy

https://forums.developer.nvidia.com/t/u … ers/222935

Hors ligne

#5 21-10-2022 21:30:43

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-18-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Je lis :

The problem is that with this configuration GNOME desktop often freezes while working in GUI applications



Quel gestionnaire de fenêtre utilises-tu ?


Tousse antique Ovide !

Hors ligne

#6 23-10-2022 00:07:44

capdefradeb
Membre
Distrib. : LMDE4 XFCE, LM20 Cinnamon, MX19.2
(G)UI : Cinnamon et XFCE
Inscription : 14-07-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Philou92 a écrit :

Je lis :

The problem is that with this configuration GNOME desktop often freezes while working in GUI applications



Quel gestionnaire de fenêtre utilises-tu ?


J'avais installé XFCE à la place de Cinnamon dans LMDE4 et LMDE5 et j'ai choisi aussi XFCE pour LM21.
Après plusieurs jours d'utilisation je confirme qu'il s'agissait bien d'un problème de pilote vidéo avec la carte NVIDIA car, depuis l'installation du vieux pilote 340, je n'ai plus eu une seule fois ce problème d'écran en partie figé et de souris et clavier inopérants.
Je pourrais d'ailleurs repasser sur la version Debian de Linuxmint en réinstallant LMDE5 mais je pense que je vais avoir la flemme et me contenter durant un moment d'avoir retrouvé un ordinateur pleinement fonctionnel !

Dernière modification par capdefradeb (23-10-2022 00:08:15)

Hors ligne

#7 02-11-2022 18:18:40

Marmo
Membre
Inscription : 27-09-2021

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Salut,
Je pense que je loupe un petit truc là...
J'ai une carte Nvidia GT730 et je suis sur bullseye et j'ai exactement le même problème et même parfois, l'ordi s'éteint tout seul et se rallume en mode veille...
Voici ce  que j'ai fait:

sudo add-apt-repository ppa:kelebek333/nvidia-legacy
sudo apt update

Ce qui renvoie:

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
gpg: aucune donnée OpenPGP valable n'a été trouvée.
# apt update
Atteint :1 http://deb.debian.org/debian bullseye InRelease
Atteint :2 http://security.debian.org bullseye-security InRelease              
Ign :3 http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar InRelease
Atteint :4 http://deb.debian.org/debian-security bullseye-security InRelease  
Réception de :5 http://deb.debian.org/debian bullseye-updates InRelease [44,1 kB]
Err :6 http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar Release  
  404  Not Found [IP : 185.125.190.52 80]
Réception de :7 http://deb.debian.org/debian bullseye-backports InRelease [49,0 kB]
Réception de :8 http://deb.debian.org/debian bullseye-backports/main amd64 Packages.diff/Index [63,3 kB]
Réception de :9 http://deb.debian.org/debian bullseye-backports/main all Contents (deb).diff/Index [63,6 kB]
Réception de :10 http://deb.debian.org/debian bullseye-backports/main amd64 Packages T-2022-11-02-0803.40-F-2022-11-02-0803.40.pdiff [328 B]
Réception de :10 http://deb.debian.org/debian bullseye-backports/main amd64 Packages T-2022-11-02-0803.40-F-2022-11-02-0803.40.pdiff [328 B]
Réception de :11 http://deb.debian.org/debian bullseye-backports/main all Contents (deb) T-2022-11-02-0803.40-F-2022-11-02-0803.40.pdiff [190 B]
Réception de :11 http://deb.debian.org/debian bullseye-backports/main all Contents (deb) T-2022-11-02-0803.40-F-2022-11-02-0803.40.pdiff [190 B]
Atteint :12 http://repository.spotify.com stable InRelease        
Atteint :13 https://deb.leap.se/client release InRelease          
Lecture des listes de paquets... Fait        
E: Le dépôt http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar Release n'
a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'
apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.






Puis, dans sources.list, j'ai ajouté ceci:
deb https://ppa.launchpadcontent.net/kelebe … acy/ubuntu bullseye main contrib non-free

mais j'obtiens ceci:

# apt update
Atteint :1 http://security.debian.org bullseye-security InRelease
Atteint :2 http://repository.spotify.com stable InRelease                                                  
Ign :3 http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar InRelease                            
Atteint :4 http://deb.debian.org/debian bullseye InRelease                                                
Atteint :5 http://deb.debian.org/debian-security bullseye-security InRelease                              
Atteint :6 http://deb.debian.org/debian bullseye-updates InRelease                                        
Atteint :7 http://deb.debian.org/debian bullseye-backports InRelease                                      
Ign :8 https://ppa.launchpadcontent.net/kelebek333/nvidia-legacy/ubuntu bullseye InRelease                
Err :9 http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar Release                              
  404  Not Found [IP : 185.125.190.52 80]
Err :10 https://ppa.launchpadcontent.net/kelebek333/nvidia-legacy/ubuntu bullseye Release              
  404  Not Found [IP : 185.125.190.52 443]
Atteint :11 https://deb.leap.se/client release InRelease                                              
Lecture des listes de paquets... Fait        
E: Le dépôt http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'
effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt https://ppa.launchpadcontent.net/kelebek333/nvidia-legacy/ubuntu bullseye Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'
effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
 



Quelle est mon erreur?

Est-ce que je dois modifier des lignes dans le fichier se trouvant dans trusted.gpg.d ?

Dernière modification par Marmo (02-11-2022 19:48:44)

Hors ligne

#8 02-11-2022 21:51:13

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

hello
la cle est plus valide on dirait bien

apt install software-properties-common


add-apt-repository ppa:kelebek333/nvidia-legacy


 Nvidia-340 legacy driver for newer kernel series.

---------------------------------

Notes for kernel 5.11.x and newer versions:

Following lines may need to be added to a configuration file for Nvidia driver to be enabled with the 5.11 update of the kernel. These lines added to /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass-ubuntu.conf by default on nvidia-340 package.

---
Section "Files"
    ModulePath "/usr/lib/nvidia-340/xorg"
    ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Device"
    Identifier "Nvidia Card"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
EndSection
---

If you have created /etc/X11/xorg.conf config file, it will overwrite the default configuration file as it has priority. You can delete the xorg.conf file with the command below to get workaround.

sudo rm -f /etc/X11/xorg.conf

Or, you can find a solution by adding the following lines to xorg.conf file.

---
Section "Files"
    ModulePath "/usr/lib/nvidia-340/xorg"
    ModulePath "/usr/lib/xorg/modules"
EndSection
---

Or you can install the xorg-modulepath-fix package from PPA repository with the following command to do this for you. This package will automatically add the above lines to xorg.conf file. This package also allows the above lines to be automatically added to the xorg.conf file when you run nvidia-xconfig command.

sudo apt install xorg-modulepath-fix
 More info: https://launchpad.net/~kelebek333/+archive/ubuntu/nvidia-legacy
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: le trousseau local « /tmp/tmp6ciqjrrc/pubring.gpg » a été créé
gpg: /tmp/tmp6ciqjrrc/trustdb.gpg : base de confiance créée
gpg: clef 23E50C670722A6D9 : clef publique « Launchpad PPA for Butterfly » importée
gpg:       Quantité totale traitée : 1
gpg:                     importées : 1
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
gpg: aucune donnée OpenPGP valable n'a été trouvée.
 


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 02-11-2022 21:52:37

ylag
Membre
Inscription : 16-03-2020

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Bonsoir,

J'ai le même problème avec un carte NVIDIA GeForce 8600GT, qui demande le pilote NVIDIA de série 340.

Sous toute réserve, le PPA kelebek333/nvidia-legacy n'a pas de section concernant Debian, on le voit dans le second résultat de la commande apt update au #7 :

E: Le dépôt https://ppa.launchpadcontent.net/kelebek333/nvidia-legacy/ubuntu bullseye Release n'a pas de fichier Release.


...ça signifierait que le dépôt n'est pas compatible avec Debian Bullseye.

Perso, je n'ai jamais réussi à installer quoi que ce soit sur ma Bullseye en provenance de ce dépôt ; faudrait peut-être faire une requête au dev du site pour voir quelle serait la possibilité d'installation sur une Debian ?

Le site ne semble supporter que les versions D'Ubuntu à partir de la 18.04.

Si certain(e)s ont réussi à installer ce pilote sur Bullseye, je serais preneur de la procédure à suivre pour y arriver.  smile

Par chance, ma carte tourne relativement bien avec le pilote libre «nouveau», sauf pour les retours de mise en veille qui ne réactivent pas le serveur X. Il me faut passer le paramètre init_on_alloc=0 à la ligne de commande du démarrage pour que ça fonctionne.

A+

Dernière modification par ylag (02-11-2022 21:54:06)

Hors ligne

#10 03-11-2022 00:46:42

èfpé
Membre
Inscription : 10-07-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Bon{soir,ne nuit,jour},

Marmo a écrit :

Je pense que je loupe un petit truc là...


C'est la commande add-apt-repository qui se loupe en beauté, le sujet a été évoqué en juin dernier.
Donc, si tu y tiens il va te falloir éditer le fichier *.list créé, et importer la clé publique manuellement :

# cd /etc/apt/sources.list.d
# mv *-ubuntu-nvidia-legacy-lunar.list kelebek333-ubuntu-nvidia-legacy-impish.list
# sed -i s,lunar,impish, kelebek333-ubuntu-nvidia-legacy-impish.list
# apt-key adv --keyserver hkps://keyserver.ubuntu.com --recv-keys 23E50C670722A6D9
# apt update
# apt install nvidia-340 -s


Mais l'installation n'aboutit pas (une sombre histoire de procédé de compression inconnu), du coup :

# rm /etc/apt/sources.list.d/kelebek333-ubuntu-nvidia-legacy-impish.list
# rm /etc/apt/trusted.gpg.d/kelebek333_ubuntu_nvidia-legacy.gpg #0 octet


Pour faire le ménage (pour être bien, supprimer la clé publique importée dans /etc/apt/trusted.gpg).

Marmo a écrit :

Quelle est mon erreur ?


La modification de ton fichier sources.list était redondante et erronée... supprime cette ligne fautive.

Dernière modification par èfpé (03-11-2022 13:46:42)

Hors ligne

#11 03-11-2022 10:37:29

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

sinon il est dans le dépot sid le driver nvidia-lagacy-340 , en ajoutant le sid ça le ferait pas?
ou sinon celui des buster-backports

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#12 03-11-2022 11:00:22

Marmo
Membre
Inscription : 27-09-2021

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

èfpé a écrit :

si tu y tiens il va te falloir éditer le fichier *.list créé, et importer la clé publique manuellement !

La modification de ton fichier sources.list était redondante et erronée... supprime cette ligne fautive.

c'est commenté

J'avais déjà ajouté "deb http://ppa.launchpad.net/kelebek333/nvi … acy/ubuntu lunar main" dans kelebek333-ubuntu-nvidia-legacy-lunar.list

Dernière modification par Marmo (03-11-2022 11:00:45)

Hors ligne

#13 03-11-2022 11:04:49

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

c'est bizarre j'ai rien vu sur lunar en parcourant le serveur, sa s'arrete a jammy on dirait

Dernière modification par Croutons (03-11-2022 11:05:31)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#14 03-11-2022 11:12:17

Marmo
Membre
Inscription : 27-09-2021

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Croutons a écrit :

sinon il est dans le dépot sid le driver nvidia-lagacy-340 , en ajoutant le sid ça le ferait pas?
ou sinon celui des buster-backports


Tu proposes que j'ajoute     deb http://deb.debian.org/debian/ sid main non-free contrib ou deb http://deb.debian.org/debian/ buster-backports main contrib non-free

dans mon sources.list?

Hors ligne

#15 03-11-2022 11:19:16

ylag
Membre
Inscription : 16-03-2020

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Bonjour,

Croutons a écrit :

sinon il est dans le dépot sid le driver nvidia-lagacy-340 , en ajoutant le sid ça le ferait pas?
ou sinon celui des buster-backports


Merci pour ta réponse ...

Concernant le paquet nvidia-lagacy-340 dans Sid, ça cherche à créer une «Frankendebian» sur ma Bullseye avec l'installation d'une flopée de dépendances dont une montée de version pour libc6. Je n'ai pas insisté.
Faudrait carrément passer de Bullseye à Sid pour installer proprement ce pilote «legacy», qui n'est utile que pour d'anciens GPU qu'on risque peu de trouver sur du matériel récent.
Une version de ce pilote serait bien plus utile dans les dépôts de Bullseye, ou au moins dans ses «backports», AMHA ?

Me resterait à tenter avec buster-backports, à voir ...

A+

Dernière modification par ylag (03-11-2022 11:24:53)

Hors ligne

#16 03-11-2022 12:24:42

èfpé
Membre
Inscription : 10-07-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Re-,

en #11, Croutons a écrit :

il est dans le dépôt sid le [paquet nvidia-legacy-340xx-driver] ,


La migration vers testing est bloquée – et il avait été supprimé de bullseye pour raisons de sécurité.

en #13, Croutons a écrit :

rien vu sur lunar en parcourant le serveur, ça s'arrête à jammy


C'est un souci avec add-apt-repository, qui ajoute sans vérifier la dernière branche Ubuntu officielle.

Hors ligne

#17 03-11-2022 12:30:55

ylag
Membre
Inscription : 16-03-2020

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Bonjour,

Pour infos, je viens de tester avec le pilote nvidia-legacy-340xx-driver du dépôt «backports» de Buster, et ça semble fonctionner pour moi sur ma Bullseye, sauf pour
gnome-control-center (Paramètres) qui refuse de se lancer avec ces erreurs :

yvan@yvan-maison:~$ gnome-control-center
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Xlib: sequence lost (0x100b3 > 0xb5) in reply type 0x0!

(gnome-control-center:11515): Gdk-ERROR **: 06:29:47.528: The program 'gnome-control-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 192 error_code 2 request_code 154 (GLX) minor_code 24)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trappe pour point d'arrêt et de trace
yvan@yvan-maison:~$



A+

Hors ligne

#18 03-11-2022 13:03:02

Marmo
Membre
Inscription : 27-09-2021

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

En ce qui me concerne, voici ce que rend un

apt update


après avoir rajouté 'deb http://deb.debian.org/debian/ buster-backports main contrib non-free' dans mon sources.list


# apt update
Atteint :1 http://deb.debian.org/debian bullseye InRelease
Atteint :2 http://security.debian.org bullseye-security InRelease              
Ign :3 http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar InRelease
Atteint :4 http://deb.debian.org/debian-security bullseye-security InRelease  
Réception de :5 http://deb.debian.org/debian bullseye-updates InRelease [44,1 kB]
Err :6 http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar Release  
  404  Not Found [IP : 185.125.190.52 80]
Réception de :7 http://deb.debian.org/debian bullseye-backports InRelease [49,0 kB]
Réception de :8 http://deb.debian.org/debian buster-backports InRelease [51,4 kB]
Réception de :9 http://deb.debian.org/debian buster-backports/main amd64 Packages [487 kB]
Atteint :10 https://deb.leap.se/client release InRelease                      
Réception de :11 http://deb.debian.org/debian buster-backports/main Translation-en [411 kB]
Atteint :12 http://repository.spotify.com stable InRelease            
Réception de :13 http://deb.debian.org/debian buster-backports/main amd64 Contents (deb) [5804 kB]
Réception de :14 http://deb.debian.org/debian buster-backports/contrib amd64 Packages [9196 B]
Réception de :15 http://deb.debian.org/debian buster-backports/contrib Translation-en [8080 B]
Réception de :16 http://deb.debian.org/debian buster-backports/contrib amd64 Contents (deb) [27,7 kB]
Réception de :17 http://deb.debian.org/debian buster-backports/non-free amd64 Packages [37,2 kB]
Réception de :18 http://deb.debian.org/debian buster-backports/non-free Translation-en [39,5 kB]
Réception de :19 http://deb.debian.org/debian buster-backports/non-free amd64 Contents (deb) [115 kB]
Lecture des listes de paquets... Fait                                          
E: Le dépôt http://ppa.launchpad.net/kelebek333/nvidia-legacy/ubuntu lunar Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'
effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
 

Hors ligne

#19 03-11-2022 16:45:54

ylag
Membre
Inscription : 16-03-2020

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Bonjour,

Finalement revenu sur le pilote libre «nouveau», la machine redémarrait systématiquement sur ce dernier bien qu'un fichier de «blacklist nouveau» ait été créé à l'installation du pilote nvidia-legacy-340xx-driver ; retour à la case départ pour moi.

Ça fonctionne correctement avec «nouveau», sauf pour gnome-control-center qui gèle le système lorsque lancé après une sortie de veille.
Pour avoir accès à «Paramètres», il faut l'avoir lancé avant une mise en veille et le garder ouvert si on désire réutiliser la mise en veille de la machine.

@Marmo :

Retire le PPA kelebek333/nvidia-legacy de tes sources, il ne possède pas de section compatible avec Debian, AMHA ...

A+

Dernière modification par ylag (03-11-2022 16:51:46)

Hors ligne

#20 03-11-2022 17:21:55

capdefradeb
Membre
Distrib. : LMDE4 XFCE, LM20 Cinnamon, MX19.2
(G)UI : Cinnamon et XFCE
Inscription : 14-07-2016

Re : Freezes Ecran très fréquents avec vieille carte NVIDIA

Je vois donc que j'avais assez peu de chances d'y parvenir en conservant LMDE5 plutôt que LM21! C'est dommage car je préfère fonctionner avec une base Debian mais l'ordi plantait tellement que ma femme allait le jeter par la fenêtre ou moi à la place ou pire, me demander de revenir à Windows 10 ! hmm Du coup je fais avec LM21 XFCE et je confirme après de nombreuses heures d'utilisation de l'ordinateur, qu'il n'y a plus aucun problème de plantage de l'écran (avec souris et clavier associés).

Hors ligne

Pied de page des forums