Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-11-2022 11:52:47

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Installer debian sur un AMELIO M4438G

Bonjour je déterre cette vieille et récurrente question. A mon travail j'ai des ordinateurs qui tournent encore sous xp ( 2008 max) . Lorsque je veux les passer sous debian ben ça marche pas. L'installation se déroule correctement avec un cd en net install avec un petit gestionnaire de bureau comme xfce . Mais après l'affichage ne se fait plus ou le démarrage devient aléatoire . Problème de noyau ? et si oui quel version du noyau faut il récupérer ? Existe t il des version de debian pour des pc aillant peu de ram ?

Merci d'avance

nico

PS: j'ai changé le titre du sujet pour être plus précis:

Dernière modification par calixtus06 (17-11-2022 16:45:20)


Il n'y a pas de mauvaises questions...

Hors ligne

#2 17-11-2022 11:58:52

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

calixtus06 a écrit :

l'affichage ne se fait plus ou le démarrage devient aléatoire


Trop vague. Merci de décrire en détail ce qui se passe dans chaque cas.
Que donne le démarrage en mode recovery ?
Quelles sont les caractéristiques des machines (CPU, GPU, RAM, disque) ?

Dernière modification par raleur (17-11-2022 12:00:55)


Il vaut mieux montrer que raconter.

Hors ligne

#3 17-11-2022 16:43:19

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

Dans le cadre de mon boulot, j'ai un mini atelier informatique. Et avec les môme on tente de restaurer des vieux coucous.

J'ai donc:

Un amelio M4438G( pentium M750 ?   2 go de DDR2)  ?  qui parvenait à "tourner" avec un peu de lenteur sous debian 10 , l'installation de debian 11 se fait en net install mais au redémarrage j'ai un " starting hostname service" qui n'en finit plus ..

Il n'y a pas de mauvaises questions...

Hors ligne

#4 17-11-2022 17:30:39

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

Et en mode recovery ?

PS : Si GPU ATI/AMD, tu as bien installé firmware-amd-graphics ?

Dernière modification par raleur (17-11-2022 17:35:22)


Il vaut mieux montrer que raconter.

Hors ligne

#5 18-11-2022 12:53:50

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

raleur a écrit :

Et en mode recovery ?

PS : Si GPU ATI/AMD, tu as bien installé firmware-amd-graphics ?





On me demande à l'installation d'installer un firmware mais uniquement pour la wifi.

Là je refait l'install en "automated " et je vous tiens au jus, notamment pour le mode recovery


Il n'y a pas de mauvaises questions...

Hors ligne

#6 21-11-2022 15:47:43

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

Hello , bon   Il m'est proposé deux noyaux le 5 ..18 et le 5 ..19 , je démarre en recovery mode dans les deux cas. ça bugue sur "printk : suspending console ( use no console to debug) "

Il n'y a pas de mauvaises questions...

Hors ligne

#7 21-11-2022 20:15:04

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

Qu'entends-tu par "ça bugue" ? Que se passe-t-il exactement ?
As-tu essayé de démarrer avec le paramètre "nomodeset" pour désactiver le pilote graphique accéléré ?

calixtus06 a écrit :

On me demande à l'installation d'installer un firmware mais uniquement pour la wifi.


Aucun rapport. L'installateur ne demande pas de firmwares graphiques, il n'en a pas besoin car il utilise seulement les pilotes d'affichage génériques.
Quel est le type de GPU de cette machine ?


Il vaut mieux montrer que raconter.

Hors ligne

#8 22-11-2022 14:17:22

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

raleur a écrit :

Qu'entends-tu par "ça bugue" ? Que se passe-t-il exactement ?
As-tu essayé de démarrer avec le paramètre "nomodeset" pour désactiver le pilote graphique accéléré ?

calixtus06 a écrit :

On me demande à l'installation d'installer un firmware mais uniquement pour la wifi.


Aucun rapport. L'installateur ne demande pas de firmwares graphiques, il n'en a pas besoin car il utilise seulement les pilotes d'affichage génériques.
Quel est le type de GPU de cette machine ?



Il m'est demandé si je veux installer un pilote wifi lors de l'installation

j'ai essayé d'aller dans le menu de grub en tapant sur la touche e . Et à la ligne linux... j'ai ajouté nomodeset . Je suppose que je m'y suis mal pris. En tout cas je ne suis pas tombé sur la ligne GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Du coup j'ai rajouté cette ligne en la modifiant  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" mais je reste devant un écran noir et un tiret fixe

Quand tu parles de GPU je suppose que c'est de la carte graphique dont tu parles ? Comment puis je le savoir ? je crois comprendre que les carte NVDIA posent soucis..mais là je ne sais pas ce que j'ai dans cet ordi

Dernière modification par calixtus06 (22-11-2022 14:26:51)


Il n'y a pas de mauvaises questions...

Hors ligne

#9 22-11-2022 14:35:01

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

calixtus06 a écrit :

j'ai essayé d'aller dans le menu de grub en tapant sur la touche e . Et à la ligne linux... j'ai ajouté nomodeset


Bien. Ensuite tu as lancé le démarrage immédiatement avec F10 ou Ctrl+x ? Il ne faut pas revenir au menu sinon les modifications sont annulées.

calixtus06 a écrit :

je ne suis pas tombé sur la ligne GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"


Cette ligne est dans /etc/default/grub, pas dans les entrées de menu. On ne voit que son effet qui est d'ajouter les paramètres à la ligne "linux ...".

calixtus06 a écrit :

Du coup j'ai rajouté cette ligne en la modifiant  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"


Dans /etc/default/grub suivi de l'exécution de update-grub ? Si tu l'as fait dans l'éditeur d'entrée de menu de GRUB ça n'a aucun efficacité.

calixtus06 a écrit :

Quand tu parles de GPU je suppose que c'est de la carte graphique dont tu parles ? Comment puis je le savoir ?


Avec la commande lspci par exemple, ou bien en consultant les spécifications de la machine fournies par le fabricant.


Il vaut mieux montrer que raconter.

Hors ligne

#10 22-11-2022 14:35:44

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

je rallume le pc rajoute slash nomodeset à la ligne no quiet  et me retrouve avec un écran gris avec trois gros bloc verticaux ( ??) j'appuie sur  echap et au bout d'un moment le bureau arrive. Je suppose que je dois mettre grub à jour et installer  le pilote nouveau après avoir purgé l'éventuel pilote nvidia?

l'affichage est baveux désormais . Le taux de rafraîchissement est à 0 . Est ce que le noyau est adapté à cette vieille bécanne ?

Dernière modification par calixtus06 (22-11-2022 14:56:48)


Il n'y a pas de mauvaises questions...

Hors ligne

#11 22-11-2022 14:39:44

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

Ne mets pas "splash", enlève-le s'il y est. Enlève "quiet" aussi.
Est-ce que du texte s'affiche à un moment ou un autre après GRUB, ou bien rien ne s'affiche jamais ?

Dernière modification par raleur (22-11-2022 14:42:14)


Il vaut mieux montrer que raconter.

Hors ligne

#12 22-11-2022 14:57:43

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

raleur a écrit :

Ne mets pas "splash", enlève-le s'il y est. Enlève "quiet" aussi.
Est-ce que du texte s'affiche à un moment ou un autre après GRUB, ou bien rien ne s'affiche jamais ?



je redémarre l'ordi et refait la manip ?

J'ai refait la manip et sur la ligne après "ro" et j'ai bien peur que ce soit "no" mal affiché j'ai supprimé quiet et mis à la place nomodeset..

la séquence d'allumage s'arrête sur printk : suspending console(s) use no console to debug. Au moment de forcer l'extinction l'ordi se remet en route

Dernière modification par calixtus06 (22-11-2022 15:10:56)


Il n'y a pas de mauvaises questions...

Hors ligne

#13 22-11-2022 16:59:49

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

calixtus06 a écrit :

j'ai bien peur que ce soit "no" mal affiché


Comment ça ?

calixtus06 a écrit :

la séquence d'allumage s'arrête sur printk : suspending console(s) use no console to debug


Et qu'est-ce qui est affiché dans les lignes précédentes ?


Il vaut mieux montrer que raconter.

Hors ligne

#14 23-11-2022 12:51:40

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

raleur a écrit :

calixtus06 a écrit :

j'ai bien peur que ce soit "no" mal affiché


Comment ça ?

calixtus06 a écrit :

la séquence d'allumage s'arrête sur printk : suspending console(s) use no console to debug


Et qu'est-ce qui est affiché dans les lignes précédentes ?



Dans le menu de grub ( grub>e) à la fin de la ligne linux il y avait " ro quiet" et non " no quiet"

knwl.jpg


Il n'y a pas de mauvaises questions...

Hors ligne

#15 23-11-2022 15:00:10

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

calixtus06 a écrit :


Dans le menu de grub ( grub>e) à la fin de la ligne linux il y avait " ro quiet" et non " no quiet"


"ro" est le paramètre correct (pour "read only", montage de la racine en lecture seule).

Ces messages ressemblent à ceux produits lors de la mise en veille (suspend) et de la sortie de veille. Si cela arrive spontanément au démarrage, ce n'est pas normal.
Que s'est-il passé entre 47 s et 171 s (3mn), et entre 171 s et 13903 s (3h51mn)


Il vaut mieux montrer que raconter.

Hors ligne

#16 24-11-2022 16:45:46

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

j'ai appuyé sur on/off en voulant éteindre l'ordi qui a paradoxalement poursuivi sa course vers l'interface utilisateur/mot de passe.

Dernière modification par calixtus06 (24-11-2022 16:53:05)


Il n'y a pas de mauvaises questions...

Hors ligne

#17 25-11-2022 21:08:18

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

Ça ne m'étonne pas vraiment. L'appui sur le bouton marche/arrêt a sorti la machine de veille.
Maintenant la question est : pourquoi la machine se met-elle en veille spontanément au démarrage ? Je n'avais jamais vu ça.
Puisque tu as un système opérationnel, tu peux examiner les logs de démarrage complets.
Tous les exemplaires de ce modèle font pareil ou c'est le seul ? Si c'est le seul, cause matérielle possible (bouton de mise en veille appuyé en permanence ?).

Dernière modification par raleur (25-11-2022 21:10:11)


Il vaut mieux montrer que raconter.

Hors ligne

#18 29-11-2022 14:39:59

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

hello, j'ai fait /var/log/cat messages mais le site ne semble pas vouloir accepter un texte aussi long , du coup je le mets en ligne:

https://kdrive.infomaniak.com/app/share … cdd2fbd89f

Il n'y a pas de mauvaises questions...

Hors ligne

#19 30-11-2022 21:53:25

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

On constate à chaque fois que les messages s'interrompent après

PM: suspend entry (s2idle)


qui signale une mise en veille, comme je le soupçonnais. Mais je ne trouve rien sur ce qui déclenche cette mise en veille intempestive si tôt après le démarrage.
Je n'ai pas trouvé comment désactiver la mise en veille dans le noyau. Peut-être en désactivant l'ACPI mais c'est un peu extrême car ça désactive d'autres fonctionnalités.
Démarrer avec le paramètre du noyau "pm_debug_messages" affichera peut-être plus d'informations.


Il vaut mieux montrer que raconter.

Hors ligne

#20 01-12-2022 08:14:42

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

Je suis parvenu à faire démarrer l'ordi "correctement" en allant dans /etc/default/grub comme indiqué plus haut. Désolé j'avais lu le message trop vite.

Désormais c'est à l'extinction que je dois appuyer sur le bouton on off pour relancer la fin du processus.

Comment démarrer avec "pm_debug_messages" ?

Il n'y a pas de mauvaises questions...

Hors ligne

#21 01-12-2022 09:37:41

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G

calixtus06 a écrit :

Je suis parvenu à faire démarrer l'ordi "correctement" en allant dans /etc/default/grub comme indiqué plus haut.


C'est-à-dire ?

calixtus06 a écrit :

Comment démarrer avec "pm_debug_messages" ?


Comme avec n'importe quel autre paramètre de la ligne de commande du noyau (quiet, splash, nomodeset...). Tu sais faire.


Il vaut mieux montrer que raconter.

Hors ligne

#22 01-12-2022 17:01:41

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

raleur a écrit :

calixtus06 a écrit :

Je suis parvenu à faire démarrer l'ordi "correctement" en allant dans /etc/default/grub comme indiqué plus haut.


C'est-à-dire ?

J e suis d'abord allé dans grub au démarrage en tapant e et en remplaçant quiet par  nomodeset . Ensuite je suis allé dans la config de grub et j'ai remplacé à nouveau  quiet par nomedeset. J'ai fait un update-grub et depuis l'ordi s'ouvre sur la session utilisateur.

calixtus06 a écrit :

Comment démarrer avec "pm_debug_messages" ?


Comme avec n'importe quel autre paramètre de la ligne de commande du noyau (quiet, splash, nomodeset...). Tu sais faire.


Il n'y a pas de mauvaises questions...

Hors ligne

#23 01-12-2022 17:05:11

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Installer debian sur un AMELIO M4438G

[img]https://.casimages.com/img/2022/12/01/mini_Erreur 1[/img]

Dernière modification par calixtus06 (01-12-2022 17:07:45)


Il n'y a pas de mauvaises questions...

Hors ligne

#24 01-12-2022 17:58:45

rodrigue7973
Membre
Lieu : beloeil
Distrib. : windows 11 pro
(G)UI : gnome
Inscription : 19-11-2017
Site Web

Re : Installer debian sur un AMELIO M4438G

no requiet

Etant dyslexique, j'ai des problèmes quant à la rédaction de messages en français courant. Je vous prie dès lors d'accepter toutes mes excuses si mes interventions peuvent vous paraître étranges et je vous remercie d'avance pour votre compréhension.

Hors ligne

#25 01-12-2022 20:14:57

raleur
Membre
Inscription : 03-10-2014

Re : Installer debian sur un AMELIO M4438G


L'URL du lien est différent du texte du lien et aucun des deux n'affiche une image.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums