Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-12-2022 12:09:50

manet42
Membre
Lieu : Lorraine
Distrib. : Bullseye
Noyau : amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

RESOLU Bullseye et microcode

Bonjour
Je viens donc de faire une installation complète de Bullseye sur le Pc bureau à la place de Stretch et sur un nouveau DD.
J'avis déjà migré de Buster à Bullseye sur mon vieux portable. Surprise leur aspect est un peu différent.
Mais à l'ouverture du PC bureau j'ai un message:
"Tsc Deadline disabled update microcode...." Tout fonctionne cependant.
Après des recherches, j'ai fait:

root@Linux:~# dmesg | grep microcode
[    0.027720] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)
[    0.092533] MDS: Vulnerable: Clear CPU buffers attempted, no microcode
[    0.092534] SRBDS: Vulnerable: No microcode
[    0.952964] microcode: sig=0x306c3, pf=0x2, revision=0x9
[    0.952968] microcode: Microcode Update Driver: v2.2.



Puis:

root@Linux:~# apt-get install intel-microcode
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Aucune version du paquet intel-microcode n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'
il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Le paquet « intel-microcode » n'a pas de version susceptible d'être installée



Sur le site Debian il y a bien un microcode pour Bullseye: "intel-microcode_3.20220510.1~deb11u1_amd64.deb"
Si j'essaye de l'installer (apt-get install) la réponse est : "Impossible de trouver le paquet microcode...."
Pourtant Sources.list correctes.

Je l'ai donc téléchargé sur le site, ma question est puis-je l'installer avec Gdebi par exemple sans risques ?
Ou alors je ne fais rien, devise de mon père bricoleur: Le mieux est l'ennemi du bien.
Merci.
P.S. Je ne comprends pas les couleurs de la 2ème commande, désolé.

Dernière modification par manet42 (11-12-2022 15:32:22)


PC bureau H81M-S1, Intel Pentium cpu: Bullseye  DDext et Win 7 DD int en dual boot.+ Portable HP Compaq avec Bullseye.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#2 11-12-2022 12:22:29

raleur
Membre
Inscription : 03-10-2014

Re : RESOLU Bullseye et microcode

Il faut ajouter les sections contrib et non-free aux dépôts dans sources.list pour pouvoir installer intel-microcode et ses dépendances via apt.

Il vaut mieux montrer que raconter.

Hors ligne

#3 11-12-2022 13:51:51

manet42
Membre
Lieu : Lorraine
Distrib. : Bullseye
Noyau : amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU Bullseye et microcode

C'est le cas, Comme dit au-dessus: mes sources correctes me semble-t-il.


# deb cdrom:[Debian GNU/Linux 11.5.0 _Bullseye_ - Official amd64 DVD Binary-1 20220910-10:40]/ bullseye contrib main

#deb cdrom:[Debian GNU/Linux 11.5.0 _Bullseye_ - Official amd64 DVD Binary-1 20220910-10:40]/ bullseye contrib main

deb http://ftp.fr.debian.org/debian/ bullseye main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ bullseye main contrib non-free

deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports
deb http://ftp.fr.debian.org/debian/ bullseye-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ bullseye-updates main contrib non-free


PC bureau H81M-S1, Intel Pentium cpu: Bullseye  DDext et Win 7 DD int en dual boot.+ Portable HP Compaq avec Bullseye.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#4 11-12-2022 14:24:34

raleur
Membre
Inscription : 03-10-2014

Re : RESOLU Bullseye et microcode

Après un update, le paquet n'est toujours pas disponible ? Dans ce cas qu'affiche la commande suivante ?

apt-cache policy


Il vaut mieux montrer que raconter.

Hors ligne

#5 11-12-2022 14:52:48

manet42
Membre
Lieu : Lorraine
Distrib. : Bullseye
Noyau : amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU Bullseye et microcode

Oui, fais "update" et "apt-get install intel-microcode_3202....etc" même réponse: impossible de trouver le paquet..

root@Linux:~# apt-cache policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.fr.debian.org/debian bullseye-updates/main amd64 Packages
     release v=11-updates,o=Debian,a=stable-updates,n=bullseye-updates,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
 500 http://security.debian.org/debian-security bullseye-security/non-free amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security bullseye-security/main amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian bullseye/non-free amd64 Packages
     release v=11.5,o=Debian,a=stable,n=bullseye,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian bullseye/contrib amd64 Packages
     release v=11.5,o=Debian,a=stable,n=bullseye,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian bullseye/main amd64 Packages
     release v=11.5,o=Debian,a=stable,n=bullseye,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
Paquets épinglés :
root@Linux:~#


PC bureau H81M-S1, Intel Pentium cpu: Bullseye  DDext et Win 7 DD int en dual boot.+ Portable HP Compaq avec Bullseye.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#6 11-12-2022 14:53:45

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : RESOLU Bullseye et microcode

Bonjour,
peut être un problème de mirroir ?
Essaie avec deb http://deb.debian.org/debian/ bullseye main contrib non-free
...pour voir ...

En ligne

#7 11-12-2022 15:17:05

manet42
Membre
Lieu : Lorraine
Distrib. : Bullseye
Noyau : amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU Bullseye et microcode

Bon je viens de recommencer (apt au lieu de apt-get !) et le fichier a été trouvé et installé:

root@Linux:~# apt-cache policy intel-microcode
intel-microcode:
  Installé : (aucun)
  Candidat : 3.20220510.1~deb11u1
 Table de version :
     3.20220510.1~deb11u1 500
        500 http://ftp.fr.debian.org/debian bullseye/non-free amd64 Packages
        500 http://security.debian.org/debian-security bullseye-security/non-free amd64 Packages

root@Linux:~# apt install intel-microcode
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcapi20-3 libfaudio0 libosmesa6 libstb0 libvkd3d1
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  iucode-tool
Les NOUVEAUX paquets suivants seront installés :
  intel-microcode iucode-tool........etc......
 


PC bureau H81M-S1, Intel Pentium cpu: Bullseye  DDext et Win 7 DD int en dual boot.+ Portable HP Compaq avec Bullseye.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#8 11-12-2022 15:20:40

raleur
Membre
Inscription : 03-10-2014

Re : RESOLU Bullseye et microcode

manet42 a écrit :

"apt-get install intel-microcode_3202....etc" même réponse: impossible de trouver le paquet..
Bon je viens de recommencer (apt au lieu de apt-get !)


Peu importe apt ou apt-get, c'est surtout le nom du paquet "intel-microcode" et pas le nom du fichier .deb qu'il fallait indiquer.

Dernière modification par raleur (11-12-2022 15:21:58)


Il vaut mieux montrer que raconter.

Hors ligne

#9 11-12-2022 15:30:26

manet42
Membre
Lieu : Lorraine
Distrib. : Bullseye
Noyau : amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU Bullseye et microcode

C'est bien ce que j'avais fait en premier:

root@Linux:~# apt-get install intel-microcode
Lecture des listes de paquets... Fait...etc


Et ça n'avait pas fonctionné ? D'où la deuxième tentative avec microcode3.202205.....deb
Bon il est installé, je marque résolu

demjc@Linux:~$ apt-cache policy intel-microcode
intel-microcode:
  Installé : 3.20220510.1~deb11u1
  Candidat : 3.20220510.1~deb11u1
 Table de version :
 *** 3.20220510.1~deb11u1 500
        500 http://ftp.fr.debian.org/debian bullseye/non-free amd64 Packages
        500 http://security.debian.org/debian-security bullseye-security/non-free amd64 Packages
        100 /var/lib/dpkg/status



Merci à vous.

Dernière modification par manet42 (11-12-2022 19:49:40)


PC bureau H81M-S1, Intel Pentium cpu: Bullseye  DDext et Win 7 DD int en dual boot.+ Portable HP Compaq avec Bullseye.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

Pied de page des forums