Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-01-2023 11:04:58

PizAdmin
Membre
Inscription : 26-01-2023

Mes paquets debian-secu../main/i18n/Translation-en ne s'installent pas

Bonjour à tous !
(Je n'arrive pas à utiliser la balise  pour mes photos... si quelqu'un peut m'aider

Pour mon entreprise qui a un réseau très lent, j'ai décidé de mettre en place un miroir Debian local pour la version 11 (bullseye) avec le package apt-mirror.

Voici la mirror.list du miroir :

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free

deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

Ce sont les paquets debian-security qui posent problème :

Le dossier i18n ne s'installe pas et tous ses fichiers translation qui vont avec ... Ce qui cause évidemment une erreur sur mes clients lors d'un apt update

https://imgur.com/DKR8jhG

Pourtant sur mon miroir debian simple, tout fonctionne !

https://imgur.com/A3JZPKj

Mais ducoup, pas de i18n dans mon miroir debian-security...

https://imgur.com/AzeRYmr


Au cas où, voici ma configuration du serveur :

############# config ##################
#
set base_path    /var/spool/apt-mirror
#
set mirror_path  $base_path/mirror
set skel_path    $base_path/skel
set var_path     $base_path/var
set cleanscript $var_path/clean.sh
#set defaultarch  amd64
set postmirror_script $var_path/postmirror.sh
set run_postmirror 0
set nthreads     100
set _tilde 0
#
############# end config ##############

# POUR DEBIAN 11 (Bullseye)
deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main


clean http://deb.debian.org/debian
clean http://security.debian.org/
 

Dernière modification par PizAdmin (26-01-2023 11:06:48)

Hors ligne

#2 26-01-2023 13:16:09

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : Mes paquets debian-secu../main/i18n/Translation-en ne s'installent pas

Bonjour

PizAdmin a écrit :



Voici la mirror.list du miroir :

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free

deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main




et comme ceci ?


deb http://deb.debian.org/debian/ bullseye main
#deb-src http://deb.debian.org/debian/ bullseye main

deb http://security.debian.org/debian-security bullseye-security main
#deb-src http://security.debian.org/debian-security bullseye-security main

deb http://deb.debian.org/debian/ bullseye-updates main
#deb-src http://deb.debian.org/debian/ bullseye-updates main
 


pourquoi "contrib non-free" sur le dépôt sécurité et pas sur les autres ?
tu a besoin des sources pour tes clients ? (deb-src)

il y a longtemps j'ai eu ce souci , mais je me souvient plus comment je l'ai résolu  roll

=> https://forums.debian.net/viewtopic.php?t=143604

=> https://bugs.debian.org/cgi-bin/bugrepo … bug=932379

Dernière modification par robert2a (26-01-2023 13:23:18)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD 5700X ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 26-01-2023 14:16:23

PizAdmin
Membre
Inscription : 26-01-2023

Re : Mes paquets debian-secu../main/i18n/Translation-en ne s'installent pas

J'avais vu ce problème là mais je pensais naïvement que depuis le temps le problème aurait été réglé kernal_panic.gif

J'ai modifié le binaire ducoup et c'est bon ! Tout marche nickel !

Merci beaucoup à toi en tout cas, t'as sauvé un IUT !

Hors ligne

Pied de page des forums