logo Debian Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés logo inclusivité

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-10-2023 15:20:13

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux trixie/sid
Noyau : Linux 6.6.15-amd64
(G)UI : Wayland
Inscription : 07-02-2018

Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

Bonjour,
Comme cela est indiqué, j'ai un Lenovo ThinkPad Edge E540 (version du micrologiciel : J9ET88WW. 2.08) que j'ai récupéré il y a plusieurs années, et qui fonctionne exclusivement (et très bien) avec une Debian 12 (trixie/sid). Je ne sais pas ce que j'ai tripatouillé dans les paramètres du BIOS, mais voici ce qui se passe au démarrage depuis quelques mois :
1. Apparition d'une page ThinkPad : normal
2. Un bip assez fort, et apparition d'une fenêtre correspondant au Boot Menu [cf. ci-dessous], indiquant ce sur quoi on veut lancer l'ordinateur. n onglet (App Menu) permet de paramétrer différents choses et d'accéder à celui du BIOS.
3. Je valide debian
4. Accès au Grub : lancement de la Debian.

Lors d'une récente réinstallation complète (le disque dur a été partionné et donc effacé), j'ai choisi de forcer l'utilisation de l'UEFI.

Là, j'en suis arrivé à me lasser (si, si) d'entendre ce bip et d'avoir à choisir debian à chaque fois, d'autant que je n'ai pas d'autres OS dans l'ordinateur.
J'ai regardé ce que je pouvais dans les paramètres du BIOS (ceux qui peuvent être modifiés), mais rien ne change.

Quelqu'un saurait-il me donner quelques conseils ?
Merci d'avance

Dernière modification par fred02840 (03-11-2023 14:32:09)


Lenovo ThinkPad Edge E540, année 2013 (Intel Core i3-4000M x 4. Carte Intel HD Graphics 4600 HSW GT2).

Hors ligne

#2 31-10-2023 15:50:42

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux trixie/sid
Noyau : Linux 6.6.15-amd64
(G)UI : Wayland
Inscription : 07-02-2018

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

Bon, je n'arrive pas à insérer ma capture d'écran, mais on trouvera la photo d'un Boot Menu sur ce forum. Mes paramètres sont différents. Dans l'ordre, j'ai :

- debian
- ATAPI CD0: HL-DT-ST DVDRAM G90N [le lecteur de DVD]
- ATA HDD0: HGST HTS725050A7E630
- PCI LAN [précédé d'une flèche]

Dernière modification par fred02840 (31-10-2023 15:52:09)


Lenovo ThinkPad Edge E540, année 2013 (Intel Core i3-4000M x 4. Carte Intel HD Graphics 4600 HSW GT2).

Hors ligne

#3 31-10-2023 17:46:37

mister_g
Membre
Distrib. : debian sid
Noyau : Linux 6.8.11
(G)UI : fluxbox
Inscription : 20-07-2022

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

on dirait que tu as activé le choix du périphérique de démarrage à faire par l'utilisateur plutôt qu'en mettre un par défaut et les autres en optionnel.
c'est comme quand je démarre et que j'appuie sur F12 pour choisir une clé USB de boot.

regarde dans la partie qui devrait contenir quelque chose comme boot order ou choix des disques au boot.
Tu as du enlever le disque par défaut ou cocher une case qui te demande à chaque démarrage.

Hors ligne

#4 31-10-2023 17:57:29

Croutons
Membre
Distrib. : Debian12
Noyau : Linux 6.1.0-13-amd64
(G)UI : Fluxbox(NakeDeb)
Inscription : 16-12-2016

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

hello
normalement il faut que tu passes ce paramètre a disable je crois bien
S56H0qX.png

par contre c'est étrange que le menu s'affiche direct, ta touche F12 serait pas bloqué?

Dernière modification par Croutons (31-10-2023 17:58:52)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<-- 
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#5 03-11-2023 13:48:53

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux trixie/sid
Noyau : Linux 6.6.15-amd64
(G)UI : Wayland
Inscription : 07-02-2018

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

mister_g a écrit :

on dirait que tu as activé le choix du périphérique de démarrage à faire par l'utilisateur plutôt qu'en mettre un par défaut et les autres en optionnel.
c'est comme quand je démarre et que j'appuie sur F12 pour choisir une clé USB de boot.


Merci pour ta réponse, Mister-G. Ton hypothèse correspond probablement à ce que j'ai fait, en effet.

regarde dans la partie qui devrait contenir quelque chose comme boot order ou choix des disques au boot.
Tu as du enlever le disque par défaut ou cocher une case qui te demande à chaque démarrage.


Le problème est que certains paramètres sont inactifs. Je pensais remettre le BIOS comme il était au départ (Load Setup Default dans la dernière rubrique (Restart), et l'option n'est pas disponible...
Dommage, car je pense avoir trouvé comment paramétrer correctement le BIOS.


Lenovo ThinkPad Edge E540, année 2013 (Intel Core i3-4000M x 4. Carte Intel HD Graphics 4600 HSW GT2).

Hors ligne

#6 03-11-2023 13:53:51

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux trixie/sid
Noyau : Linux 6.6.15-amd64
(G)UI : Wayland
Inscription : 07-02-2018

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

Bonjour Croutons,

Croutons a écrit :

hello
normalement il faut que tu passes ce paramètre a disable je crois bien
https://i.imgur.com/S56H0qX.png


En effet, c'est ce que la source que j'ai trouvée conseille de faire.
On dirait que tu as aussi des problèmes pour afficher une image... J'essaie un truc : mettre l'adresse dans la première balise : url=adresse
https://i.imgur.com/S56H0qX.png
Raté : elle n'apparaît pas...

par contre c'est étrange que le menu s'affiche direct, ta touche F12 serait pas bloqué?


C'est possible. Le clavier (en alu) est tombé, pile sur le coin supérieur gauche...
J'essaie... Non, c'est bon : la touche F12 fonctionne correctement.

Bon, écoutez, je vais tenter un redémarrage en appuyant sur la touche F2 pour accéder directement au BIOS sans passer par cette fenêtre qui bippe. Peut-être que je pourrais modifier les paramètres qui m'intéressent...

Dernière modification par fred02840 (03-11-2023 13:57:05)


Lenovo ThinkPad Edge E540, année 2013 (Intel Core i3-4000M x 4. Carte Intel HD Graphics 4600 HSW GT2).

Hors ligne

#7 03-11-2023 14:31:37

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux trixie/sid
Noyau : Linux 6.6.15-amd64
(G)UI : Wayland
Inscription : 07-02-2018

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

Croutons, tu es un dieu. Si, si. Ou un devin, quelque chose comme ça. Tu m'as mis sur la bonne piste, avec cette histoire de touche F12. J'ai débranché mon clavier Mac au coin déformé, que j'ai remplacé par un autre (tout en plastoc, touches qui font du bruit, mais bon...). Redémarrage, et bim : je tombe directement sur le Grub. La touche F12 est donc enfoncée, ce qui active le Boot Menu.
Eh bé, plus qu'à essayer de redresser le clavier en alu pour avoir quelque chose qui soit de meilleure qualité.
Merci encore !!

Lenovo ThinkPad Edge E540, année 2013 (Intel Core i3-4000M x 4. Carte Intel HD Graphics 4600 HSW GT2).

Hors ligne

#8 03-11-2023 15:34:06

raleur
Membre
Inscription : 03-10-2014

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

fred02840 a écrit :

Croutons, tu es un dieu. Si, si. Ou un devin


Non, il est simplement logique. “Lorsque vous avez éliminé l’impossible, ce qui reste, si improbable soit-il, est nécessairement la vérité.” (Arthur Conan Doyle)


Il vaut mieux montrer que raconter.

Hors ligne

#9 04-11-2023 16:21:03

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux trixie/sid
Noyau : Linux 6.6.15-amd64
(G)UI : Wayland
Inscription : 07-02-2018

Re : Lenovo. Se débarrasser du Boot Menu au démarrage [RÉSOLU]

Rhââââh... Quel rabat-joie, ce râleur...
Toutefois, « les maîtres sont ceux qui nous montrent ce qui est possible dans l'ordre de l'impossible » (Paul Valéry Mélanges, Gallimard, 1941). Ce qui revient, à peu de choses près, à la maxime de Conan Doyle...

Lenovo ThinkPad Edge E540, année 2013 (Intel Core i3-4000M x 4. Carte Intel HD Graphics 4600 HSW GT2).

Hors ligne

Pied de page des forums