Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-05-2008 15:04:39

devock
Membre
Inscription : 04-05-2008

Apache 2 : virtuals host : impossible d'accéder à phpmyadmin

Bonjour,

Voilà j'ai un serveur dédié (que je loue chez ovh) donc dessus y est installé debian et j'ai donc installé apache2, mysql-server enfin tout pour avoir un joli serveur web, j'ai des virtualhosts (car j'ai plusieurs sites sur le serveur) mais le problème est : je ne peux pas accéder à phpmyadmin quand les virtualhosts sont activés. J'avais suivi ce tuto : http://doc.ubuntu-fr.org/lamp me disant que cela devrait fonctionner car avant sur ubuntu j'avais juste à mettre le domaine/phpmyadmin et tout fonctionnait, faut croire que je me suis trompé.

Pour voir le message d'erreur retourné : http://emilien.devock.com/ et quand je désactive les virtualhosts et que je tape http://91.121.98.199/phpmyadmin je tombe bien sur phpmyadmin.

D'où pensez-vous que cela puisse venir ?

Merci d'avance pour vos réponses,
Devock

Hors ligne

#2 10-05-2008 17:16:34

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : Apache 2 : virtuals host : impossible d'accéder à phpmyadmin

Bonjour devock,

Et en accédant par http://91.121.98.199/phpmyadmin avec les vhosts activés, ça dit quoi?

Hors ligne

#3 10-05-2008 17:41:55

devock
Membre
Inscription : 04-05-2008

Re : Apache 2 : virtuals host : impossible d'accéder à phpmyadmin

Ca me dit :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch10 Server at 91.121.98.199 Port 80

Hors ligne

#4 30-05-2008 23:38:42

devock
Membre
Inscription : 04-05-2008

Re : Apache 2 : virtuals host : impossible d'accéder à phpmyadmin

UP j'ai toujours le même problème. Personnes ne peux m'aider ?

Hors ligne

#5 01-06-2008 17:23:09

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : Apache 2 : virtuals host : impossible d'accéder à phpmyadmin

Salut Devock,

Je pensais avoir le temps de faire quelques manips pour tester, mais non... hmm

Sinon, en lisant (en croix) le tuto dont tu parles, j'aurais tendance à croire qu'il doit manquer une déclaration d'un site par défaut, sans aucune certitude cependant.
Est-ce que tu peux accéder à http://91.121.98.199/ avec les virtualhosts actifs? Si erreur, ça irait dans le sens de ce que j'avance.

Pas d'autre idée pour le moment, je découvres avec toi. wink

Hors ligne

#6 08-03-2021 06:04:36

dereck2018
Membre
Inscription : 08-03-2021

Re : Apache 2 : virtuals host : impossible d'accéder à phpmyadmin

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
Options FollowSymLinks
DirectoryIndex index.php

<IfModule mod_php7.c>
AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
<IfModule mod_authn_file.c>
AuthType Basic
AuthName "phpMyAdmin Setup"
AuthUserFile /etc/phpmyadmin/htpasswd.setup
</IfModule>
Require valid-user
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
Order Deny,Allow
Deny from All
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
Order Deny,Allow
Deny from All
</Directory>

Hors ligne

#7 08-03-2021 06:06:16

dereck2018
Membre
Inscription : 08-03-2021

Re : Apache 2 : virtuals host : impossible d'accéder à phpmyadmin

mkdir /usr/share/phpmyadmin
mkdir /etc/phpmyadmin
mkdir -p /var/lib/phpmyadmin/tmp
chown -R www-data:www-data /var/lib/phpmyadmin
touch /etc/phpmyadmin/htpasswd.setup

Hors ligne

Pied de page des forums