Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-12-2014 22:38:34

kawer
Membre
Lieu : Earth
Distrib. : Debian Stable
Noyau : Current
(G)UI : Xfce
Inscription : 08-10-2013

[Résolu]-mod-evasive ne fait pas son travail

Bonjour à tous,

J'ai suivi le tuto sur le mod-evasive mais après avoir éffectué toutes les opérations à la lettre donc grossomodo :

- installation de libapache2-mod-evasive / ok
- chargement du module et vérification qu'il est bien chargé / ok
- ajout de la configuration basique dans mon vhost apache / ok
- création du répertoire et attribution des droits www-data pour fail2ban / ok
- redémarrage du serveur apache / ok

mon serveur est toujours vulnérable, j'ai donc testé le script test.pl fournis par l'installation du mod-evasive mais rien n'est interdit, "cat /var/log/syslog | grep evasive" me retourne rien. Voici mon vhost apache :

<VirtualHost *:80>
        ServerName librtm.fr
        ServerAdmin kawer@localhost

        DocumentRoot /var/www/public_html/librtm
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/kawer/public_html/librtm/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        <IfModule mod_evasive20.c>
                DOSHashTableSize 3097
                DOSPageCount 2
                DOSSiteCount 50
                DOSPageInterval 1
                DOSSiteInterval 1
                DOSBlockingPeriod 10
                DOSEmailNotify "root@localhost"
                DOSLogDir "/var/lock/mod_evasive"
        </IfModule>

<Directory /usr/share/phpmyadmin>
        Options FollowSymLinks
        DirectoryIndex index.php
        Order Deny,Allow
        Allow from 192.168.0.2
        Deny from All

        <IfModule mod_php5.c>
                AddType application/x-httpd-php .php
                        php_flag magic_quotes_gpc Off
                        php_flag track_vars On
                        php_flag register_globals Off
                        php_admin_flag allow_url_fopen Off
                        php_value include_path .
                        php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
                        php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/
                </IfModule>
        </Directory>

                ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>



Si vous avez des idées, elles sont les bienvenues wink

Dernière modification par kawer (20-12-2014 12:55:05)


Songez à ce que vous avez été, à ce que vous êtes, et à ce que vous serez un jour, et vous deviendrez humbles. Saint Vincent de Paul
La maladie la plus constante et la plus mortelle, mais aussi la plus méconnue de toute société, est l’indifférence. Abbé Pierre
Nous en sommes à la guerre du pétrole alors que la guerre de la faim a déjà commencé. Only Lovers Left Alive

Hors ligne

#2 20-12-2014 12:53:39

kawer
Membre
Lieu : Earth
Distrib. : Debian Stable
Noyau : Current
(G)UI : Xfce
Inscription : 08-10-2013

Re : [Résolu]-mod-evasive ne fait pas son travail

Bon finalement problème résolu après avoir changé DOSLogDir à /var/log/mod_evasive et mis <IfModule mod_evasive20.c> dans /etc/apache2/apache2.conf au lieu du vhost. Je passe en résolut smile

Dernière modification par kawer (20-12-2014 12:54:22)


Songez à ce que vous avez été, à ce que vous êtes, et à ce que vous serez un jour, et vous deviendrez humbles. Saint Vincent de Paul
La maladie la plus constante et la plus mortelle, mais aussi la plus méconnue de toute société, est l’indifférence. Abbé Pierre
Nous en sommes à la guerre du pétrole alors que la guerre de la faim a déjà commencé. Only Lovers Left Alive

Hors ligne

Pied de page des forums