Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-05-2018 10:01:03

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

[résolu] bug noyau 4.16 backport

bonsoir
je rencontre un "bug" étrange depuis la mise à jour vers le noyau 4.16 des backports
le système démarre bien, arrive à l'écran de login utilisateur (lightdm)
le mot de passe est bien accepté, mais l'écran reste sur le font d'écran de lightdm
si je ne fais rien (juste regarder l'écran les yeux dans le vague en comptant les moutons tongue) cet écran peut rester indefiniment
par contre si je bouge le curseur de la souris ou passe en mode tty pour me connecter à un utilisateur et lance quelques commande, la session utilisateur démarre

uname -svr


Linux 4.16.0-0.bpo.1-amd64 #1 SMP Debian 4.16.5-1~bpo9+1 (2018-05-06)


journalctl


[...]
mai 10 10:42:06 thot systemd-timesyncd[470]: Synchronized to time server 85.30.248.106:123 (2.debian.pool.ntp.org).
mai 10 10:44:16 thot kernel: nf_conntrack: default automatic helper assignment has been turned off for security reasons and CT-based  firewall rule no
mai 10 10:46:18 thot kernel: random: crng init done
mai 10 10:46:18 thot systemd[630]: Started D-Bus User Message Bus.
mai 10 10:46:19 thot dbus-daemon[697]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
mai 10 10:46:19 thot systemd[630]: Starting Virtual filesystem service...
mai 10 10:46:19 thot dbus-daemon[697]: Successfully activated service 'org.gtk.vfs.Daemon'
mai 10 10:46:19 thot systemd[630]: Started Virtual filesystem service.
mai 10 10:46:21 thot dbus[509]: [system] Activating via systemd: service name='org.freedesktop.UPower' unit='upower.service'
mai 10 10:46:21 thot systemd[1]: Starting Daemon for power management...
mai 10 10:46:21 thot dbus[509]: [system] Successfully activated service 'org.freedesktop.UPower'
mai 10 10:46:21 thot systemd[1]: Started Daemon for power management.
 


je pense que le soucis vient de mai 10 10:46:18 thot kernel: random: crng init done

avez vous rencontré ce soucis ?

Dernière modification par Severian (10-05-2018 15:17:20)

Hors ligne

#2 10-05-2018 10:42:56

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : [résolu] bug noyau 4.16 backport

Bonjour

ceci =>  https://debian-facile.org/viewtopic.php … 66#p264466

sur Mate sans backports aucun soucis (avec le 4.9 )
sur Mate sous buster aucun soucis (avec le 4.16 )

nota: le système met du temps a ouvrir le bureau après le logging ?

Dernière modification par robert2a (10-05-2018 10:44:19)

Hors ligne

#3 10-05-2018 11:31:02

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [résolu] bug noyau 4.16 backport

robert2a a écrit :

nota: le système met du temps a ouvrir le bureau après le logging ?


ce n'est pas que ça met du temps, enfin si ...
après avoir entré le mdp, j'ai l'écran de font de lightdm et le curseur de la souris qui sont affiché, si je ne fais rien (que je ne touche pas au pc) ça reste indéfiniment
il suffit de bouger la souris ou de passer en console tty et lancer un ou deux commandes pour que le bureau s'affiche

ça me fait penser à la génération aléatoire d'une clé gpg, lorsque l'on doit bouger la souris dans tous sens

Hors ligne

#4 10-05-2018 14:44:22

luluberlu
Membre
Distrib. : debian Stretch
Noyau : Linux 4.9.0-6-amd64
(G)UI : Gnome
Inscription : 14-09-2015

Re : [résolu] bug noyau 4.16 backport

Essayel installation de haveged, tu as un disque dur ssd?

Hors ligne

#5 10-05-2018 15:16:41

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [résolu] bug noyau 4.16 backport

effectivement haveged semble résoudre le soucis

par contre il doit y avoir un sacré changement dans le noyau s'il faut rajouter de "l'entropie" au système qui démarrent rapidement neutral

merci à vous deux smile

Dernière modification par Severian (10-05-2018 15:18:23)

Hors ligne

#6 10-05-2018 16:32:30

luluberlu
Membre
Distrib. : debian Stretch
Noyau : Linux 4.9.0-6-amd64
(G)UI : Gnome
Inscription : 14-09-2015

Re : [résolu] bug noyau 4.16 backport

Il y avait le probleme sur le noyau 4.9 une maj a corrigé le problème et plus besoin du paquet haveged. Plus qu'à attendre la maj sur les depots backports. :-)

Hors ligne

#7 11-05-2018 10:18:24

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : [résolu] bug noyau 4.16 backport

il y a plein de mise a jours sur les noyaux , même très vieux , je suppose pour la sécurité .
tant que tout ceci n'est pas bien en place ont risque d'avoir quelques désagréments . hmm

hier sur Jessie  roll

Hors ligne

Pied de page des forums