Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-07-2018 10:02:39

David5647
Membre
Distrib. : Debian Buster
Noyau : 4.17.0-3-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

[Résolu] Raspberry DAC i2s pas de son

Bonjour à tous
j'essaie de faire fonctionner un dac audio i2s (GY-PCM5102) sur mon raspberry,
Je ne sais pas si il s'agit d'un probelème inhérent au raspberry et ses sorties,
ou s'il s'agit d'un problème de pulse/alsa, peut-etre pouvez vous m'éclairer...

j'ai suivi le tuto suivant :
https://support.hifiberry.com/hc/en-us/ … -or-higher

le module semble reconnu :

aplay -l



**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
You have new mail in /var/mail/daguhh
 



mais une tentative de lecture me renvoie une erreur :

mplayer 01\ Adele\ -\ Rolling\ in\ the\ Deep.wav


MPlayer 1.3.0 (Debian), built with gcc-6.2.1 (C) 2000-2016 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing 01 Adele - Rolling in the Deep.wav.
libavformat version 57.56.101 (external)
Mismatching header version 57.56.100
libavformat file format detected.
[lavf] stream 0: audio (pcm_s16le), -aid 0
Clip info:
 title: Rolling in the Deep
 artist: Adele
 album: 21
 genre: Soul and R&B
 iaar: Adele
 track: 1
 itgl: -972
 irva: 99
 iagl: -993
 ITOC: B+96+43C3+852C+CE74+115B4+15C83+1ADF1+1F0CD+23799+29D99+2FA42+34E80
Load subtitles in ./
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 1411.2 kbit/100.00% (ratio: 176400->176400)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
[AO_ALSA] alsa-lib: pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM false
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa'
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO SDL] using aalib audio driver.
[AO SDL] Unable to open audio: No available audio device
Failed to initialize audio driver 'sdl:aalib'
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video
 



retour de la partie interessante de dmesg :

[   11.110561] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered - will retry
[   11.113935] snd-hifiberry-dac soc:sound: ASoC: CODEC DAI pcm5102a-hifi not registered - will retry
[   11.132580] snd-hifiberry-dac soc:sound: pcm5102a-hifi <-> 3f203000.i2s mapping ok
[   11.482918] smsc95xx 1-1.1:1.0 enxb827eba4b8a8: renamed from eth0
[   11.533383] sd 0:0:0:0: Attached scsi generic sg0 type 0
[   11.553512] brcmfmac: F1 signature read @0x18000000=0x1541a9a6
[   11.560113] brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43430-sdio.bin for chip 0x00a9a6(43430) rev 0x000001
[   11.560375] usbcore: registered new interface driver brcmfmac
[   12.040005] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f
[   12.040780] brcmfmac: brcmf_c_preinit_dcmds: CLM version = API: 12.2 Data: 7.11.15 Compiler: 1.24.2 ClmImport: 1.24.1 Creation: 2014-05-26 10:53:55 Inc Data: 9.10.39 Inc Compiler: 1.29.4 Inc ClmImport: 1.36.3 Creation: 2017-10-23 03:47:14
[   14.635787] uart-pl011 3f201000.serial: no DMA platform data
[   18.119926] Adding 102396k swap on /var/swap.  Priority:-2 extents:1 across:102396k FS
[   19.837018] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   19.837129] brcmfmac: power management disabled
[   20.243835] smsc95xx 1-1.1:1.0 enxb827eba4b8a8: hardware isn't capable of remote wakeup
 



Une idée?

Dernière modification par David5647 (03-07-2018 18:09:07)

Hors ligne

#2 03-07-2018 11:49:03

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Raspberry DAC i2s pas de son

Essaye ça ?

aplay /usr/share/sounds/alsa/Front_Center.wav



Tu as suivi leur tuto ? https://www.hifiberry.com/build/documen … iguration/

Dernière modification par otyugh (03-07-2018 11:51:25)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 03-07-2018 13:37:44

David5647
Membre
Distrib. : Debian Buster
Noyau : 4.17.0-3-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : [Résolu] Raspberry DAC i2s pas de son

Ok, j'ai suivi leur tuto, on avance!
j'ai du son, mais c'est E.T. qui chante...
merci!

par contre je ne peux pas lancer ton signal audio, ni sais vraiment ce que signifie le message d'erreur

aplay /usr/share/sounds/alsa/Front_Center.wav
 


Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1305: Channels count non available



edit : leur tuto dit qu'il n'est plus d'actualité et renvoie vers le lien que j'ai donné, (j'ai pu cependant avoir du son grace à l'ancien...)

Dernière modification par David5647 (03-07-2018 13:47:16)

Hors ligne

#4 03-07-2018 14:39:18

David5647
Membre
Distrib. : Debian Buster
Noyau : 4.17.0-3-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : [Résolu] Raspberry DAC i2s pas de son

Bon, fin de résolution par intervention divine,
il restait une petite masse flottante => raccordée => tout fonctionne

merci à toi

Hors ligne

#5 03-07-2018 15:52:29

nono47
Invité

Re : [Résolu] Raspberry DAC i2s pas de son

Salut,

David5647 a écrit :

Bon, fin de résolution par intervention divine,


Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.
trop bien l'intervention divine ! cool

#6 03-07-2018 18:08:47

David5647
Membre
Distrib. : Debian Buster
Noyau : 4.17.0-3-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : [Résolu] Raspberry DAC i2s pas de son

oups pardon, dans ma ferveur, j'ai oublié

Hors ligne

Pied de page des forums