Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-10-2018 12:27:06

Morgan88500
Membre
Inscription : 17-10-2018

[Clonezilla] Automatisation d'un restore depuis un partage Samba

Bonjour,

je voudrais automatiser le restore d'un image clonezilla (sur un serveur SMB) juste en choisissant une image dans le premier menu. Voici la commande que j'ai ajouter dans le grub.cfg :

menuentry "Restore 10.12.6 "{
  search --set -f /live/vmlinuz
  linux /live/vmlinuz boot=live config noswap nolocales edd=on ocs_live_keymap=NONE nomodeset noprompt ocs_postrun1="reboot" ocs_prerun1="sleep 5" ocs_prerun2="dhclient -v eth0"  ocs_prerun3="mount -t cifs //helios/helios_capture /home/partimag -o user=user,password=password,domain=domaine.org" ocs_live_run="ocs-sr -g auto -e1 auto -e2 -r -j2 -p true restoredisk 10.12.6_Opti_Soft_CTM sda"
ocs_live_extra_param= keyboard-layouts=NONE locales=en_US.UTF-8 vga=788 ip= nosplash ocs_postrun2="reboot"
  initrd /live/initrd.img
}

Mon problème est le suivant :
- Clonezilla me dis qu'il ne trouve pas l'interface "eth0" ... Alors que quand je fais le restore à la main, il trouve bien le DHCP via l'eth0 ..... J'ai ensuite mis une adresse IP à la place de  ocs_prerun2="dhclient -v eth0", mais il ne trouve toujours pas le chemin /home/partimag .... comme s'il ne se connect pas à mon réseau.

Dés idées ?
Bonne soirée à vous
Morgan

Hors ligne

#2 17-10-2018 14:28:13

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Bonjour
Je ne peux pas t'aider mais agir sur ce fichier n'est pas une bonne idée vu qu'il va être généré automatiquement lors de certaine mise a jour et tes réglages seront perdu

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 17-10-2018 15:33:19

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Morgan88500 a écrit :


Mon problème est le suivant :
- Clonezilla me dis qu'il ne trouve pas l'interface "eth0"


Ça le dit quand? quand il exécute la commande ocs_prerun2="dhclient -v eth0" ?
J'essaierais aussi (tout à la fois):
- à augmenter un peu le temps du premier sleep (peut-être il a besoin de quelques secondes de plus), par exemple 20/30 secondes.
- à substituer  //helios par une ip fixe, du genre //192.168.0.10
- à mètre un autre "sleep 20" avant la commande mount

Salut


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#4 17-10-2018 15:47:21

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Salut,

il me le dis une fois qu'il à passé la commande dhclient -v ....

j'ai essayé avec celle mais toujours pareil :
menuentry "Restore 10.12.6 probleme eth0"{
  search --set -f /live/vmlinuz
  linux /live/vmlinuz boot=live config noswap nolocales edd=on ocs_live_keymap=NONE nomodeset noprompt ocs_postrun1="reboot"  ocs_prerun1=“sleep 10” ocs_prerun2="dhclient -v eth0" ocs_prerun3=“sleep 10” ocs_prerun4="dhclient -v eth1"  ocs_prerun5=“sleep 10” ocs_prerun6="mount -t cifs //192.168.200.13/helios_capture /home/partimag -o user=user,password=password,domain=domaine.org" ocs_live_run="ocs-sr -g auto -e1 auto -e2 -r -j2 -p true restoredisk 10.12.6_Opti_Soft_CTM sda"
ocs_live_extra_param= keyboard-layouts=NONE locales=en_US.UTF-8 vga=788 ip= nosplash ocs_postrun2="reboot"
  initrd /live/initrd.img
}

Mais j'ai l'impression qu'il zap mes sleep ...

Hors ligne

#5 17-10-2018 16:01:20

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Morgan88500 a écrit :

Salut,

il me le dis une fois qu'il à passé la commande dhclient -v ....

j'ai essayé avec celle mais toujours pareil :
menuentry "Restore 10.12.6 probleme eth0"{
  search --set -f /live/vmlinuz
  linux /live/vmlinuz boot=live config noswap nolocales edd=on ocs_live_keymap=NONE nomodeset noprompt ocs_postrun1="reboot"  ocs_prerun1=“sleep 10” ocs_prerun2="dhclient -v eth0" ocs_prerun3=“sleep 10” ocs_prerun4="dhclient -v eth1"  ocs_prerun5=“sleep 10” ocs_prerun6="mount -t cifs //192.168.200.13/helios_capture /home/partimag -o user=user,password=password,domain=domaine.org" ocs_live_run="ocs-sr -g auto -e1 auto -e2 -r -j2 -p true restoredisk 10.12.6_Opti_Soft_CTM sda"
ocs_live_extra_param= keyboard-layouts=NONE locales=en_US.UTF-8 vga=788 ip= nosplash ocs_postrun2="reboot"
  initrd /live/initrd.img
}

Mais j'ai l'impression qu'il zap mes sleep ...



sleep est part de coreutils, je crois qu'il doit être installé sur Clonezilla, mais...on ne sait jamais si on ne vérifie pas


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#6 17-10-2018 16:04:17

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Desole mais comment puis-je vérifier cela ? Je suis une cle clonezilla bootable

Hors ligne

#7 17-10-2018 16:07:59

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Démarrer, aller à une terminal , et

dpkg -l|grep coreutils



ou même simplement exécuter

sleep 5


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#8 17-10-2018 18:23:49

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Je supprimerai le parametre "ip= "

ocs_live_extra_param= keyboard-layouts=NONE locales=en_US.UTF-8 vga=788 ip= nosplash ocs_postrun2="reboot"



ip= c'est vide , et selon Clonezilla live boot parameters :

ip=[DEVICE]:[CLIENT_IP]:[NETMASK]:[GATEWAY_IP]:[NAMESERVER]
       [,[DEVICE]:[CLIENT_IP]:[NETMASK]:[GATEWAY_IP]:[NAMESERVER]]
           Let you specify the name(s) and the  options  of  the  interface(s)
           that  should be configured at boot time. Do not specify this if you
           want to use dhcp (default). It will be changed in a future  release
           to   mimick   official   kernel   boot  param  specification  (e.g.
           ip=10.0.0.1::10.0.0.254:255.255.255.0::eth0,:::::eth1:dhcp).

       ip=[frommedia]
If this variable is set, dhcp and  static  configuration  are  just
           skipped  and  the system will use the (must be) media-preconfigured
           /etc/network/interfaces instead.


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#9 17-10-2018 18:32:25

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Alors c'est bon j'ai les "sleep" qui fonctionne bien !

J'ai également enlevé le paramètre IP=, mais j'ai toujours le même truc hmm ....

Hors ligne

#10 17-10-2018 20:45:45

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Alors là , je ne sais plus te dire. sad .
Peut-être essayer ip=eth0:x.x.x.x:y.y.y.y (x.x.x.x = IP ; y.y.y.y=netmask)

Si non j'espère que des autres membres peuvent t'aider.

Dernière modification par empanada (17-10-2018 20:48:30)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#11 18-10-2018 11:24:44

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

C'est pareil ... cannot find device "eth0"

Hors ligne

#12 18-10-2018 12:06:39

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Ce bizarre quand même. Il parait que le device eth0 n'est pas créé quand tu démarres avec ton menuentry custom.
Peux-tu poster les menuentry par défaut de ton iso/usb clonezilla pour voir les différences?

"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#13 18-10-2018 13:12:12

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Ou puis-je les trouver ?

Et je viens de faire un test avec un disque local et ça fonctionne ! Par contre avant dans lancer l'image, il fait un check de toutes les partitions ... donc cela prend deux fois plus de temps. Sais-tu quelle option faut t'il ajouter afin qu'il ne check pas les partitions avant de cloner ?

Hors ligne

#14 18-10-2018 18:22:16

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Morgan88500 a écrit :

Ou puis-je les trouver ?



Par example, pour le démarrage en mode UEFI, sur /EFI/boot/grub.cfg dans la ISO stable.

Pour démarrage BIOS, sur /syslinux/isolinux.cfg

En tout cas je vois que toutes les "menuentry" ont l'option    net.ifnames=0  , qui sert a maintenir les "vieux" noms d'interface réseau. C'est presque sur que le problème c'est ça: le nom d'interface réseau. Essais à ajouter

net.ifnames=0

à la ligne de démarrage

Explication du nouveau système de noms d'interfaces reseau:

For computers with multiple NICs, it is important to have fixed device names. Many configuration problems are caused by interface name changing. udev is responsible for which device gets which name. Systemd v197 introduced Predictable Network Interface Names, which automatically assigns static names to network devices. Interfaces are now prefixed with en (wired/Ethernet), wl (wireless/WLAN), or ww (WWAN) followed by an automatically generated identifier, creating an entry such as enp0s25. This behavior may be disabled by adding net.ifnames=0 to the kernel parameters.



Plus d'info ici https://www.freedesktop.org/wiki/Softwa … faceNames/

Dernière modification par empanada (18-10-2018 18:23:30)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#15 19-10-2018 12:31:55

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Top !! Il arrive à me donner une IP big_smile
Mais après il n'arrive pas à me monter le volume hmm

j'ai essayé :
ocs_prerun4="mount -t cifs //nomserveur.domaine.org/helios_capture /home/partimag -o user=user,password=password" ocs_live_run="ocs-sr -g auto -e1 auto -e2 -r -j2 -c -scr -p reboot restoredisk 10.13.6_Opti_Soft_CTM sda"

ocs_prerun4="mount -t cifs //IP/helios_capture /home/partimag -o user=user,password=password,domaine=domaine" ocs_live_run="ocs-sr -g auto -e1 auto -e2 -r -j2 -c -scr -p reboot restoredisk 10.13.6_Opti_Soft_CTM sda"

Hors ligne

#16 19-10-2018 14:29:28

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Mieux utiliser l'IP du serveur, pas le nom "nomserveur.domaine.org".

"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#17 19-10-2018 15:21:43

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

C'est ce que j'ai fait -> Regarde la deuxième commande, mais même avec l'ip ça ne fonctionne pas ... hmm

Hors ligne

#18 19-10-2018 17:11:44

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Est-ce que tu peux nous montrer une capture d'écran de l'erreur et/ou décrire avec plus de détail?

Clonezilla laisse aussi les sorties des commandes et les erreurs sur des logs. Les noms et chemins des logs son indiquées à la fin des commandes, même quand il y a échecs.

Selon man mount.cifs :

man mount.cifs | sed -n '/username=arg/,+8 p'



       username=arg
           specifies the username to connect as. If this is not given, then the environment variable USER is used.

           Earlier versions of mount.cifs also allowed one to specify the username in a "user%password" or "workgroup/user" or "workgroup/user%password"
           to allow the password and workgroup to be specified as part of the username. Support for those alternate username formats is now deprecated
           and should no longer be used. Users should use the discrete "password=" and "domain=" to specify those values. While some versions of the cifs
           kernel module accept "user=" as an abbreviation for this option, its use can confuse the standard mount program into thinking that this is a
           non-superuser mount. It is therefore recommended to use the full "username=" option name.



L'option recommandée est "username", et pas "user". Dans ma bécane sous Debian stretch les deux fonctionnent , mais dans le support Clonezilla que t'utilises peut-être non.

Quand au domaine... t'es sur que ton réseau local est un domaine? Peut-être un groupe de travail plutôt?
C'est un réseau maison ou boulot? C'est toi qui a créé le réseau?

t'es sur du chemin réseau? Quand tu montes l'emplacement réseau "à la main", après, si tu fais un :

cat /etc/mtab


la sortie est...?

Dernière modification par empanada (19-10-2018 17:15:19)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#19 19-10-2018 18:01:46

Morgan88500
Membre
Inscription : 17-10-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Alors je suis bien sur un domaine.
Dés que je remplace user par username -> le clonezilla ce coupe et il se log sur le debian en utilisateur username

Dans le terminal de la cle clonezilla, en tapant la même commande : linux /live/vmlinuz boot=live config noswap nolocales edd=on ocs_live_keymap=NONE nomodeset noprompt ocs_postrun1="reboot"  net.ifnames=0 ocs_prerun1=“sleep 5” ocs_prerun2="dhclient -v eth0"  ocs_prerun3=“sleep 3” ocs_prerun4="mount -t cifs //192.168.200.13/helios_capture /home/partimag -o user=user,password=password,domaine=domaine " ocs_live_run="ocs-sr -g auto -e1 auto -e2 -r -j2 -c -scr -p reboot restoredisk 10.13.6_Opti_Soft_CTM sda"
ocs_live_extra_param= keyboard-layouts=NONE locales=en_US.UTF-8 vga=788 ip= nosplash ocs_postrun2="reboot"
Il arrive à monter le volume ...

Le message d'erreur qu'il m'indique est : the directory .... for the input name does NOT exist! Alors que pourtant si ....

Hors ligne

#20 19-10-2018 18:20:12

Atys
Banni(e)
Distrib. : jessie + backports i386
Noyau : Linux 3.16.0-7-686-pae
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Salut, une sauvegarde est  la plus simple, j'ai du mal lire !
Tu te complique la vie.

Dernière modification par Atys (19-10-2018 18:21:44)


La liberté d’expression est un droit fondamental ouvert à tous les citoyens dans le respect des lois.

Hors ligne

#21 19-10-2018 19:46:37

empanada
Membre
Distrib. : Debian 11 (Bullseye)
Noyau : 5.10.0-13-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : [Clonezilla] Automatisation d'un restore depuis un partage Samba

Morgan88500 a écrit :

Alors je suis bien sur un domaine.
Dés que je remplace user par username -> le clonezilla ce coupe et il se log sur le debian en utilisateur username

Dans le terminal de la cle clonezilla, en tapant la même commande : linux /live/vmlinuz boot=live config noswap nolocales edd=on ocs_live_keymap=NONE nomodeset noprompt ocs_postrun1="reboot"  net.ifnames=0 ocs_prerun1=“sleep 5” ocs_prerun2="dhclient -v eth0"  ocs_prerun3=“sleep 3” ocs_prerun4="mount -t cifs //192.168.200.13/helios_capture /home/partimag -o user=user,password=password,domaine=domaine " ocs_live_run="ocs-sr -g auto -e1 auto -e2 -r -j2 -c -scr -p reboot restoredisk 10.13.6_Opti_Soft_CTM sda"
ocs_live_extra_param= keyboard-layouts=NONE locales=en_US.UTF-8 vga=788 ip= nosplash ocs_postrun2="reboot"
Il arrive à monter le volume ...

Le message d'erreur qu'il m'indique est : the directory .... for the input name does NOT exist! Alors que pourtant si ....



Mettre tout ces options dans la ligne de commande une fois démarré n'as pas de sens, parce que la plupart d'eux sont des options pour le noyau et/ou preseed, qui n'ont pas de sens en dehors du démarrage. Quand même, il parait qu'il a exécuté le mount:

Il arrive à monter le volume ... Le message d'erreur qu'il m'indique est : the directory .... for the input name does NOT exist


Vérifie le chemin

empanada a écrit :


t'es sur du chemin réseau? Quand tu montes l'emplacement réseau "à la main", après, si tu fais un :

cat /etc/mtab


la sortie est...?



Je dis quand tu fais un restore via samba en utilisant clonezilla sans les options de démarrage. T'as déjà essayé à faire un restore "à la main" avec ce répertoire samba?
Il me semble que c'est un erreur avec le chemin. Il manque ou il y a de plus un répertoire ou sous-répertoire, et la meilleure forme de vérifier le chemin c'est faire un restore "à la main".

Dernière modification par empanada (19-10-2018 19:57:13)


"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

Pied de page des forums