Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-11-2018 00:13:17

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

[Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Hello

J'ai debian stretch, et la carte graphique nvidia GeForce GTX 1050.
Lançant "apt-get install -t stretch-backports nvidia-driver" je reçois, entre autres choses plus normales
Loading new nvidia-current-390.87 DKMS files...
Building for 4.9.0-8-amd64
Module build for kernel 4.9.0-8-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.
Paramétrage de nvidia-driver (390.87-2~bpo9+1) ...

Que dois-je faire ? La résolution max est seulement de 1024x768, qui n'est pas ce que j'attends.

Dernière modification par evanescente~ondine (07-11-2018 17:12:56)

Hors ligne

#2 07-11-2018 00:43:39

MicP
Membre
Inscription : 29-02-2016

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Bonjour evanescente~ondine

…I ran apt-get install -t stretch-backports nvidia-driver…
…kernel headers for this kernel does not seem to be installed. …

Pour installer les fichiers d'en-tête du noyau backport, entre la ligne de commandes suivante avec les privilèges du compte root :

apt-get install -t stretch-backports linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')

Dernière modification par MicP (07-11-2018 15:19:16)

Hors ligne

#3 07-11-2018 00:57:49

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Ça dit: linux-headers-amd64 is already the newest version (4.18+98~bpo9+1).

Dernière modification par evanescente~ondine (07-11-2018 13:18:04)

Hors ligne

#4 07-11-2018 02:16:03

MicP
Membre
Inscription : 29-02-2016

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

…version (4.18+98~bpo9+1)…

La version (4.18+98~bpo9+1) du noyau utilisé par ton système semble être celle de debian buster.

EDIT : Je m'étais trompé, c'est bien la version stretch qui est utilisée.

J'utilise debian stretch mais je n'ai aucune expérience avec la version  testing de debian.

Désolé, je ne sais pas du tout que te conseiller.

Dernière modification par MicP (07-11-2018 18:05:02)

Hors ligne

#5 07-11-2018 03:15:50

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Mais j'ai seulement stretch...  Comment rétro-installer le noyau stretch ?

Dernière modification par evanescente~ondine (07-11-2018 13:18:36)

Hors ligne

#6 07-11-2018 07:44:23

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Bonjour smile
Mon anglais étant léger et comme tes autres fils sont en français je me permets de poursuivre en français.
Il me semble que la version du noyau ne semble pas être celle des backports alors que celle des linux-headers est celle des backports de stretch.
Quel est le retour de

uname -a



Pour installer le noyau des backports

apt -t stretch-backports install linux-image-amd64


Redémarrer le PC pour être sur cette version et installer les pilotes.
Il y aura peut-être d’autres firmwares à installer en provenance des backports, wifi ?

Hors ligne

#7 07-11-2018 08:40:16

MicP
Membre
Inscription : 29-02-2016

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Bonjour chalu

je n'ai aucune expérience dans l'utilisation des backports,
mais en relisant, dans son premier message,
le retour de la commande apt-get install -t stretch-backports nvidia-driver
je me demande si ce ne sont pas plutôt les fichiers d'en-tête
du kernel de stretch qui sont réclamés.

et dans ce cas là, il faudrait peut-être les installer
en lançant la ligne de commande suivante :

apt-get install linux-headers-amd64

Mais je n'ai pas osé proposer cette ligne de commande
vu que je n'ai aucune expérience concernant l'utilisation des backports.
Je n'ai d'ailleurs pas compris la nécessité d'utiliser les backports pour cette carte vidéo.

Dernière modification par MicP (07-11-2018 08:43:07)

Hors ligne

#8 07-11-2018 13:22:23

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Mince !! J'ai recommencé à mélanger anglais et français. Il faut me corriger quand je fais ça big_smile
Je teste l'un puis l'autre.

Mais il faut installer le noyau des backports juste pour UN driver ?! Heureusement qu'il me suffira de l'enlever si ça va pas. Mais je ne saurai pas enlever tout de seul les drivers supplémentaires si j'en ai à installer, et qu'ils ne servent à rien/compliquent tout plus tard.

Hors ligne

#9 07-11-2018 13:53:39

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Non tu peux installer les headers qui vont avec le noyau de stable pour voir si ça marche.
On enlève la version backports qui a été installé comme dépendance de nvidia-driver sans doute pour ensuite installer celle stable

apt remove linux-headers-amd64 && apt install linux-headers-amd64


D'après tes messages il semble que le noyau et les headers installés ne se correspondent pas.
Pour répondre à MicP, j’ai proposé l’installation du noyau backports qui va avec les headers installés en me disant que c’etait peut-être plus cohérent comme le driver Nvidia vient des backports.
Maintenant je ne sais pas si tu es obligé d’avoir le noyau backports ou si celui de stable peut être suffisant.
Comme MicP je ne sais pas si les backports sont vraiment utiles pour cette carte ?
Tu as essayé avec stable ?

Hors ligne

#10 07-11-2018 15:27:10

MicP
Membre
Inscription : 29-02-2016

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

evanescente~ondine a écrit :

…Mince !! J'ai recommencé à mélanger anglais et français. …

lol Et c'était la première fois que j'essayais de répondre en anglais à un message sur un forum lol

Dernière modification par MicP (07-11-2018 15:27:37)

Hors ligne

#11 07-11-2018 16:49:53

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Bonjour

la GTX1050 fonctionne avec le driver de stretch
il suffit de purger le noyau et les headers des backports
purger un éventuel driver nvidia des backports

installer (ou réinstaller ) le noyau et les headers par les méta-paquets


apt-get -reinstall install linux-image-amd64 linux-headers-amd64
 



puis installer le driver


apt-get install nvidia-driver
 



si tu a synaptic et un bureau fonctionnel c'est très simple a faire .
pas de reboot tant que tout n'est pas correct (a moins que tu ne soit pas sur le bon noyau de stretch )


uname -a
 



la version de nvidia-driver  =>  https://packages.debian.org/fr/stretch/nvidia-driver

le  384.130-1 est pas le plus récent, mais la carte tourne bien avec.

nota: je parle de la carte vidéo , pour la partie "système" je sais pas si tu a besoin d un noyau plus récent ou pas
testé sur un Q6600 (environ 2008)  avec une GTX1050

Hors ligne

#12 07-11-2018 17:12:26

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : [Résolu] problem with NVIDIA Corporation GP107 [GeForce GTX 1050]

Oui, tout à fait, purger. J'ai fait cela "apt remove linux-headers-amd64 && apt install linux-headers-amd64 " et après redémarrage, miracle. Ah ! Merci beaucoup, je trouvais ça fatiguant !!love.gifmerci.gif

Hors ligne

Pied de page des forums