Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-11-2018 23:14:50

redelap
Membre
Lieu : SAINTES 17
Distrib. : Buster en Xfce & Raspbian
Noyau : Linux 4.19.0.6 - amd64
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

[RESOLU] Update et upgrade

Bonjour
C'est là une question d'ordre général sans urgence et dont je n'ai pas trouvé de réponse.
A l'occasion d'un apt-get update, suivi d'un apt-get upgrade, il arrive parfois (sur ma machine de test) d'avoir un résultat dans le genre "0 mise à jour, 0 nouvellement iinstallé, 0 à enlever, et 3 non mis à jour"
Ces "3 non mis à jour" m'interpelle.
En effet j'ai testé la commande "apt-get upgrade.... nom des trois fichiers non mis à jour"

Le "apt-get upgrade" suivant mentionne un résultat "0 mise à jour, 0 nouvellement iinstallé, 0 à enlever,, 0 mis à jour"

Pourquoi ne fait-il pas de mise à jour de ces trois fichiers au précedent "upgrade"...
Est-ce dangereux de forcer la mise à jour des ces fichiers non mis à jour à l'occasion d'un upgrade ?
Merci de vos lumières

Dernière modification par redelap (23-11-2018 13:09:21)


Debian-10.2-Xfce buster sur Lenovo LEGION Y520- SSD128 + HD1000 - 8Go
Vieux MacBook X.6.8 - Raspbian Buster sur Raspberry Pi4

Hors ligne

#2 23-11-2018 01:05:43

Y316
Membre
Distrib. : stretch
Noyau : Linux 4.9.0-8-amd64
(G)UI : MATE 1.16.2
Inscription : 15-11-2012

Re : [RESOLU] Update et upgrade

man apt-get

upgrade
           La commande upgrade permet d'installer les versions les plus
           récentes de tous les paquets présents sur le système en utilisant
           les sources énumérées dans /etc/apt/sources.list. Les paquets
           installés dont il existe de nouvelles versions sont récupérés et
           mis à niveau. En aucun cas des paquets déjà installés ne sont
           supprimés ; de même, des paquets qui ne sont pas déjà installés ne
           sont ni récupérés ni installés. Les paquets dont de nouvelles
           versions ne peuvent pas être installées sans changer le statut
           d'installation d'un autre paquet sont laissés dans leur version
           courante. On doit d'abord exécuter la commande update pour que
           apt-get connaisse l'existence de nouvelles versions des paquets.

dist-upgrade
           La commande dist-upgrade effectue la fonction upgrade en y ajoutant
           une gestion intelligente des changements de dépendances dans les
           nouvelles versions des paquets ; apt-get possède un système
           « intelligent » de résolution des conflits et il essaye, quand
           c'est nécessaire, de mettre à niveau les paquets les plus
           importants avant les paquets les moins importants. Le fichier
           /etc/apt/sources.list contient une liste de sources où récupérer
           les paquets désirés. Voyez aussi apt_preferences(5) pour un
           mécanisme de remplacement des paramètres généraux pour certains
           paquets.
 



Pour mettre à jour ces trois paquets et l'ensemble de ta distribution lance la commande :

apt-get dist-upgrade


Debian 9 (stretch)  + la pire ICC que vous ayez probablement jamais rencontré.

Hors ligne

#3 23-11-2018 07:13:19

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [RESOLU] Update et upgrade

Tu peux tester aussi

apt upgrade


La mise à jour du paquet se fait même si ses dépendances ont été modifiées et une nouvelle dépendance sera par exemple installée ce qui n’est pas le cas avec apt-get upgrade.
A noter que c’est bien fait tout ça smile j’utilise virtualbox des backports le paquet des additions invités à été mis en version 22 avant le paquet virtualbox resté en version 18.
La mise à jour était signalée mais pas faite et heureusement puisqu’il n’y avait pas compatibilité mais dès que virtualbox a été disponible dans la même version, tout a été mis à jour.


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

En ligne

#4 23-11-2018 12:39:50

redelap
Membre
Lieu : SAINTES 17
Distrib. : Buster en Xfce & Raspbian
Noyau : Linux 4.19.0.6 - amd64
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Update et upgrade

Ah ok.. merci à vous...

Debian-10.2-Xfce buster sur Lenovo LEGION Y520- SSD128 + HD1000 - 8Go
Vieux MacBook X.6.8 - Raspbian Buster sur Raspberry Pi4

Hors ligne

Pied de page des forums