Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-11-2018 15:44:52

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[résolu] Des paquets « Garder en état » à remettre en gestion auto.

Bonjour,

j'ai deux soucis, mais je crois qu'ils sont liés à une même source.

D'abord, je veux (re)-installer OpenShot

apt-get install me retourne une erreur, alors je fais ceci

/etc/apt# apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  mariadb-client-10.1 mariadb-server-10.1 mariadb-server-core-10.1
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de apache2 (2.4.25-3+deb9u6) ...
info: Executing deferred '
a2enconf apache2-doc' for package apache2-doc
ERROR: Conf apache2-doc does not exist!
dpkg: erreur de traitement du paquet apache2 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'
état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)




afin de corriger la situation, je fais un aptitude du paquet mentionné ainsi:

aptitude install apache2-doc
apache2-doc est déjà installé avec la version demandée (2.4.25-3+deb9u6)
apache2-doc est déjà installé avec la version demandée (2.4.25-3+deb9u6)
Les paquets partiellement installés suivants seront configurés :
  apache2
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Paramétrage de apache2 (2.4.25-3+deb9u6) ...  
info: Executing deferred '
a2enconf apache2-doc' for package apache2-doc
ERROR: Conf apache2-doc does not exist!
dpkg: erreur de traitement du paquet apache2 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'
état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)
Paramétrage de apache2 (2.4.25-3+deb9u6) ...
info: Executing deferred '
a2enconf apache2-doc' for package apache2-doc
ERROR: Conf apache2-doc does not exist!
dpkg: erreur de traitement du paquet apache2 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'
état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apache2




Or, on me mentionne souvent que j'ai trois paquets étiquetés à « Garder dans l'état ».
Comment savoir quels sont ces trois paquets ?
Comment les remettre à leur état initial (automatiquement mis à jour comme les autres )  ?

Merci.

Dernière modification par Patriboom (26-11-2018 01:57:50)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 25-11-2018 18:48:48

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Patriboom a écrit :

on me mentionne souvent que j'ai trois paquets étiquetés à « Garder dans l'état ».


Bonjour,
c'est qui ce "on" ?

Patriboom a écrit :

Comment savoir quels sont ces trois paquets ?


avec la commande

apt-mark showhold


Patriboom a écrit :

Comment les remettre à leur état initial (automatiquement mis à jour comme les autres )  ?


avec la commande

apt-mark unhold nomdupaquet1 nomdupaqet2 nomdupaquet3


le retour indique

Annulation de l'état figé pour nomdupaquet1

et de même pour chaque paquet
Le wiki sur apt-mark est à faire mais il y a de bonnes pistes ici :


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#3 25-11-2018 19:42:40

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Merci chalu pour cette réponse complète!

apt-mark showhold



Ne me retourne aucun résultat.
Étrange!


J'ai forcé la note un peu:

apt-get update
apt-get upgrade
apt-get purge apache2
apt-get install apache2
 



et voici le résultat:

Created symlink /etc/systemd/system/multi-user.target.wants/apache2.service → /lib/systemd/system/apache2.service.
Created symlink /etc/systemd/system/multi-user.target.wants/apache-htcacheclean.service → /lib/systemd/system/apache-htcacheclean.service.
insserv: warning: current start runlevel(s) (empty) of script `apache-htcacheclean' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `apache-htcacheclean'
overrides LSB defaults (0 1 6).
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u6) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
 




Dois-je m'inquiéter des avertissements ?


Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 25-11-2018 19:48:34

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Patriboom a écrit :

j'ai deux soucis, mais je crois qu'ils sont liés à une même source.


Je ne vois pas de rapport entre eux.

Patriboom a écrit :

Or, on me mentionne souvent que j'ai trois paquets étiquetés à « Garder dans l'état ».
Comment savoir quels sont ces trois paquets ?


Si tu parles de ça :

3 non mis à jour


il suffit de lire :

Les paquets suivants ont été conservés :
  mariadb-client-10.1 mariadb-server-10.1 mariadb-server-core-10.1


Ce n'est pas forcément dû à un blocage de version de l'administrateur local (hold), cela peut aussi être dû à un changement de dépendances nécessitant l'installation ou la suppression d'autres paquets ; dans ce cas il faut mettre à jour avec apt-get dist-upgrade ou aptitude full-upgrade.

Pour le problème d'apache, le fichier /etc/apache2/conf-available/apache2-doc.conf est bien présent ?

Hors ligne

#5 25-11-2018 19:48:40

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Ce que je cherche à faire: installer OpenShot.
Ce que je suis arrivé à faire jusqu'à maintenant:  éliminer le message d'erreur selon lequel apache2 n'était que partiellement installé.

L'installation d'OpenShot semble être en conflit avec l'installation de Eclipse
Je désinstalle Eclipse puis vous reviendrai.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#6 25-11-2018 19:52:54

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Patriboom a écrit :

Dois-je m'inquiéter des avertissements ?


Non.

Hors ligne

#7 25-11-2018 20:02:12

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Merci raleur,

ta piste m'a conduit à trouver un nouveau paquet à installer en lien avec mariadb.
Le paquet cassé ou incomplet était apache2 qui est maintenant corrigé par la médecine de cheval que je lui ai servi (purge + install).

Après désinstallation de eclipse, openshot réclame encore des paquets pourtant déjà installés.

Voyez:

Les paquets suivants contiennent des dépendances non satisfaites :
openshot : Dépend: python-httplib2 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


/home/patrick/MesSites/Plongee# apt-get install python-httplib2
...

Les paquets suivants contiennent des dépendances non satisfaites :
 libdom4j-java : Dépend: libmsv-java mais ne sera pas installé
 php7.2-cgi : Dépend: php7.2-cli mais ne sera pas installé
              Dépend: php7.2-common (= 7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215) mais ne sera pas installé
              Dépend: php7.2-json mais ne sera pas installé
              Dépend: php7.2-opcache mais ne sera pas installé
              Dépend: libssl1.1 (>= 1.1.0) mais ne sera pas installé
 php7.2-sqlite3 : Dépend: php7.2-common (= 7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215) mais ne sera pas installé
 python-httplib2 : Dépend: python:any (< 2.8)
                   Dépend: python:any (>= 2.7.5-5~)
                   Dépend: ca-certificates mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'
état.

/home/patrick/MesSites/Plongee# apt-get install php7.2-cli php7.2-common php7.2-json php7.2-opcache php7.2-cgi php7.2-sqlite php7.2-common python ca-certificates
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Note : sélection de php7.2-sqlite3 pour l'expression rationnelle « php7.2-sqlite »
ca-certificates is already the newest version (20161130+nmu1+deb9u1).
python is already the newest version (2.7.13-2).
php7.2-cgi is already the newest version (7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215).
php7.2-cli is already the newest version (7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215).
php7.2-common is already the newest version (7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215).
php7.2-json is already the newest version (7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215).
php7.2-opcache is already the newest version (7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215).
php7.2-sqlite3 is already the newest version (7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 25-11-2018 20:19:58

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Je crois que j'ai trouvé une piste de réponse en tentant l'installation via aptitude.

Un paquet installé serait trop récent pour les paquets nécessaires à openshot.
C'est ce que je comprends de ceci

Les paquets suivants contiennent des dépendances non satisfaites :
 libssl1.1 : Casse: python-httplib2 (< 0.11.3-1) mais 0.9.2+dfsg-1 devra être installé
 php-cgi : Dépend: php7.2-cgi mais ne sera pas installé
 php7.2-sqlite3 : Dépend: php7.2-common (= 7.2.12-1+0~20181112102353.11+jessie~1.gbp55f215) mais ne sera pas installé
 python-httplib2 : Dépend: ca-certificates mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.


/home/patrick/MesSites/Plongee# apt-get install libssl1.1
Lecture des listes de paquets... Fait
Construction de l'
arbre des dépendances      
Lecture des informations d'état... Fait
libssl1.1 is already the newest version (1.1.1-2+0~20181105132532.5+jessie~1.gbp90eb86).



apt cherche un version 0.9 tandis que ma version installée est 1.1

Qu'en pensez-vous ?


Portez la paix
Patrick Allaire, ptre

Hors ligne

#9 25-11-2018 20:24:42

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Ton profil indique stretch mais dans tes retours on peut lire Jessie ?

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#10 25-11-2018 21:59:27

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

C'est bien vrai, mais mon sources.list est bien pointé vers stretch

deb http://ftp.ca.debian.org/debian/ stretch main
deb-src http://ftp.ca.debian.org/debian/ stretch main

deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main

deb http://ftp.ca.debian.org/debian/ stretch-updates main
deb-src http://ftp.ca.debian.org/debian/ stretch-updates main

Portez la paix
Patrick Allaire, ptre

Hors ligne

#11 25-11-2018 22:49:00

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

comment tu expliques la présence de jessie dans les retours ? c'est une migration jessie > stretch ? ou ?

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#12 26-11-2018 00:07:38

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Oui, migration faite en août ? ¿ juillet ?  Je ne sais trop quand, mais ça commence à dater.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#13 26-11-2018 02:00:10

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

J'indique ici « résolu », car j'ai trouvé le paquet défectueux:  jetty9 dont j'ignore la fonction.
J'ai aussi trouvé une autre source de problème:
Mes fichiers de config dans /etc/apt/sources.list.d n'avaient pas été modifiés et portaient encore la mention « Jessie »
Dans certains cas l'expression « stable » a été acceptée.  Quant aux autres il me fallut inscrire  « Stretch »

Merci à tous.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#14 26-11-2018 02:01:06

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Des paquets « Garder en état » à remettre en gestion auto.

Ah oui!

J'ai ainsi pu retrouver mon cher « OpenShot »  smile

Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums