Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-01-2019 19:06:49

damdam
Membre
Distrib. : Debian 9 (Stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome 3.22.2
Inscription : 11-01-2019

Problème multitouch touchpad Asus debian 9

Bonjour,
Je vous écrit aujourd'hui suite à un problème avec mon touchpad sur mon asus R558UV qui tourne sous Debian 9 Stretch.
Ce problème de touchpad comme d'autres erreurs ACPI qui ma valu de passer (il y a 4 jours ^^) à Ubuntu, c'est révélé inutile car l'identité même qui fait de Debian Debian (communauté, démocratie...) me convient tellement plus!

J'expose mon problème:
Après plusieurs heures de recherche et de manipulation sans succès je n'arrive pas à avoir le multitouch si pratique sur mon PC.

j'ai suivie ce tuto : https://wiki.debian.org/fr/SynapticsTouchpad

J'ai remarqué qu'avec la commande suivant

egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices

rien ne s'affiche. J'ai regardé avec nano ce qu'il y avais dans ce fichier et rien de "synap,alps,etps ou elan" n'est affiché.

Fichier /proc/bus/input/devices

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input0
U: Uniq=
H: Handlers=sysrq kbd leds event0
B: PROP=0
B: EV=120013
B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0003 Vendor=04d9 Product=a09f Version=0110
N: Name="E-Signal USB Gaming Mouse"
P: Phys=usb-0000:00:14.0-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/0003:04D9:A09F.0001/input/input1
U: Uniq=
H: Handlers=mouse0 event1
B: PROP=0
B: EV=17
B: KEY=1f0000 0 0 0 0
B: REL=143
B: MSC=10

I: Bus=0003 Vendor=04d9 Product=a09f Version=0110
N: Name="E-Signal USB Gaming Mouse"
P: Phys=usb-0000:00:14.0-1/input1
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.1/0003:04D9:A09F.0002/input/input2
U: Uniq=
H: Handlers=sysrq kbd event2
B: PROP=0
B: EV=10001f
 



D'après ce que je vois (je suis novice) mon touchpad n'est pas présent pourtant il fonctionne mais pas en multitouch.

J'ai essayer d'installer les paquets suivants: xserver-xorg-input-libinput, xserver-xorg-input-evdev et xserver-xorg-input-mouse et le touchpad ne fonctionne toujours pas.
J'ai même essayer de réinstaller synaptic sans succès.


Avez vous la solution à mon problème?

Merci d'avance pour vos réponses !

Dernière modification par damdam (12-01-2019 22:12:27)

Hors ligne

#2 12-01-2019 09:47:12

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : Problème multitouch touchpad Asus debian 9

Bonjour

le nom du paquet est xserver-xorg-input-synaptics avec un "s" (synaptic est l 'utilitaire graphique de gnome pour la gestion des paquets)

Ce paquet fournit un pilote pour le serveur X.Org qui permet d'utiliser les
fonctionnalités les plus élaborées des pavés tactiles Synaptics :

- mouvement avec vitesse et accélération non linéaire réglables ;
- simulation de clics par frappe courte sur le pavé tactile ;
- simulation de double-clic par double frappe sur le pavé tactile ;
- déplacement par frappe courte et maintien du doigt sur le pavé tactile ;
- simulation de clic droit et central sur les coins inférieur et
    supérieur du pavé tactile ;
- défilement vertical (événements de bouton 4 et 5) par déplacement du
    doigt sur le bord droit du pavé tactile ;
- les boutons haut et bas simulent les événements de bouton 4 et 5 d'une
    souris ;
- défilement horizontal (événements de bouton 6 et 7) par déplacement du
   doigt sur le bord inférieur du pavé tactile ;
- les boutons multiples simulent les événements de bouton 4 et 5,
    et 6/7 pour un défilement horizontal, d'une souris ;
- détection des doigts configurable ;
- frappe à plusieurs doigts : 2 doigts pour simuler le bouton central et
   3 doigts pour le bouton droit (tous les modèles ne gèrent pas cette
    fonctionnalité) ;
- configuration en temps-réel, utilisant la mémoire partagée, sans avoir
    besoin de redémarrer le serveur X (voir synclient(1)) ;
- démon permettant de désactiver le pavé tactile durant la frappe au
    clavier, ce qui évite les déplacements de souris ou clics involontaires
    (voir syndaemon(1)).



je sais pas si installé sur ta machine ( il utilise evdev )

tu a aussi celui ci

Ce pilote d’entrées pour le serveur X fournit la gestion des mouvements pour
les pavés tactiles multitouch, en particulier ceux avec un bouton intégré.



xserver-xorg-input-multitouch

nota: je suis pas trop portable  roll

par contre tu peu enlever le xserver-xorg-input-mouse qui ne te sert sûrement a rien

xserver-xorg-input-mouse
Ce paquet fournit le pilote de souris. Il est principalement utilisé sur
les systèmes d'exploitation non linux tels que BSD ou Solaris. La plupart
des configurations sur Linux utiliseront evdev, le mécanisme de
distribution
d'événements du noyau, et n’ont pas besoin de ce paquet.



ps: tu a des informations dans le log de X pour les périphériques d'entrées (si tu trouve rien sur le syslog )

tu a quoi comme bureau ? (ton profil est vide )

Dernière modification par robert2a (12-01-2019 09:51:05)

Hors ligne

#3 12-01-2019 18:17:14

bonyred
Membre
Distrib. : Debian buster
Noyau : 4.14.0-3-686
(G)UI : mate
Inscription : 15-05-2015

Re : Problème multitouch touchpad Asus debian 9

Bonjour,

Sur debian 9 c'est le paquet libinput qui commande le touchpad

https://wiki.debian.org/LibinputTouchpad

https://wiki.debian.org/SynapticsTouchpad

Surement un début de solution

https://debian-facile.org/viewtopic.php?id=22237


A plus.

Dernière modification par bonyred (12-01-2019 18:18:27)

Hors ligne

#4 12-01-2019 19:16:37

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : Problème multitouch touchpad Asus debian 9

Bonjour

merci pour la réponse , oui sur ton dernier lien , on dirait que cela a résolu le problème.

Hors ligne

#5 12-01-2019 22:07:53

damdam
Membre
Distrib. : Debian 9 (Stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome 3.22.2
Inscription : 11-01-2019

Re : Problème multitouch touchpad Asus debian 9

Merci pour vos réponses !
Effectivement c'est libinput qui gère mon touchpad.
Donc j'ai suis vos instructions robert2a

robert2a a écrit :

Bonjour [...] tu a quoi comme bureau ? (ton profil est vide )


j'ai installer les paquet : xserver-xorg-input-libinput et xserver-xorg-input-multitouch sans aucun résultat.
j'ai voulue voir du coté du log mais X (ou Xorg) n'y est pas.

~$ ls /var/log
alternatives.log  debug           installer          syslog
apt               dpkg.log        kern.log           syslog.1
auth.log          faillog         lastlog            unattended-upgrades
btmp              fontconfig.log  messages           user.log
daemon.log        gdm3            speech-dispatcher  wtmp
 



J'ai donc regardé du coté config de libinput comme supposé par bonyred

bonyred a écrit :

Bonjour [...]A plus.


voilà mon fichier de config : /usr/share/X11/xorg.conf.d/40-libinput.conf

# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
       MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection
 



j'ai rajouté dans la "section" identifier par libinput keyboard catchall comme le wiki de Debian le préconise les éléments suivant:

        Option          "TapButton2"            "2"     # multitouch
        Option          "TapButton3"            "3"     # multitouch
        Option          "VertTwoFingerScroll"   "1"     # multitouch
        Option          "HorizTwoFingerScroll"  "1"     # multitouch


et/ou

        Option          "EmulateTwoFingerMinZ"  "35"
        Option          "EmulateTwoFingerMinW"  "8"


mais toujours sans résultat sad

j'ai aussi rajouter ces lignes sur /usr/share/X11/xorg.conf.d/50-multitouch.conf. Toujours sans résultat sad

Comment faire ?

ps: je suis sous gnome 3.22.2 (jvais changer mon profil)

Dernière modification par damdam (12-01-2019 22:23:07)

Hors ligne

#6 13-01-2019 17:17:11

bonyred
Membre
Distrib. : Debian buster
Noyau : 4.14.0-3-686
(G)UI : mate
Inscription : 15-05-2015

Re : Problème multitouch touchpad Asus debian 9

Comment faire ?



As tu redémarrer ta machine après avoir modifier  /usr/share/X11/xorg.conf.d/40-libinput.conf

Sur gnome

Paramétres,  periphériques, souris et pavé tactile.

Hors ligne

#7 13-01-2019 17:50:00

damdam
Membre
Distrib. : Debian 9 (Stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome 3.22.2
Inscription : 11-01-2019

Re : Problème multitouch touchpad Asus debian 9

bonyred a écrit :

Comment faire ?



As tu redémarrer ta machine après avoir modifier  /usr/share/X11/xorg.conf.d/40-libinput.conf

Sur gnome

Paramétres,  periphériques, souris et pavé tactile.




Oui j'ai redémarrer à chaque fois (si il y a un moyen de redémarrer juste Xorg je suis preneur!)
Et quand je vais en mode graphique dans les paramètres souris pavée tactile je n'est pas d'options pour mon touchpad (aucun titre présentent mon pavée tactile).
J'ai comme titre d'option : 1)Général et 2)Souris

Hors ligne

#8 13-01-2019 18:25:48

bonyred
Membre
Distrib. : Debian buster
Noyau : 4.14.0-3-686
(G)UI : mate
Inscription : 15-05-2015

Re : Problème multitouch touchpad Asus debian 9

Je te donne ma confifiguration pour

/usr/share/X11/xorg.conf.d/40-libinput.conf



# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection
 



/usr/share/X11/xorg.conf.d/60-touchpad.conf



Section "InputClass"
        Identifier "MyTouchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
EndSection



Peux pas dire mieux.

Bon courage.

Dernière modification par bonyred (13-01-2019 18:26:15)

Hors ligne

#9 13-01-2019 22:12:47

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Problème multitouch touchpad Asus debian 9

Il faut que tu édites comme le post #3 de https://debian-facile.org/viewtopic.php?id=22237.
Lien déjà fourni par bonyred et qui au final revient au même que son dernier post ici a peu de choses prêt, tu peux regarder ce qu'il a mis,
comme ça tu saura que tu aura bien fais la bonne modif au bon endroit.

Dernière modification par naguam (13-01-2019 22:15:04)

En ligne

#10 14-01-2019 04:57:18

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : Problème multitouch touchpad Asus debian 9

Bonjour

Une question , sur Wayland (gnome) il y a le même souci avec ce matériel ?
ps: il faut utiliser un driver vidéo libre et utiliser un bureau compatible wayland

Hors ligne

#11 Aujourd'hui 15:05:28

damdam
Membre
Distrib. : Debian 9 (Stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome 3.22.2
Inscription : 11-01-2019

Re : Problème multitouch touchpad Asus debian 9

Merci pour vos réponse!

robert2a a écrit :

Une question [...] wayland


naguam a écrit :

Il faut que tu édites[...]bonne modif au bon endroit



j'ai beau faire mettre

Option "Tapping" "on"


sur 50-multitouch.conf et/ou 40-libinput.conf (en redémarrant bien-sur)
mon multitouch ne fonctionne toujours pas!
j'ai aussi choisie de démarrer gnome avec Wayland toujours rien hmm

Note: les recherches que j'ai entrepris me fait établir un bilan : il y a un problème récurrent avec certain touchpad assus concernant le multitouche avec debian 9. De plus, quand j'avais installer Ubuntu je n'avait pas de problème de multitouch donc ce n'est pas un problème récurant de mon touchpad. Il y aurait t'il moyen d'installer le driver d'ubuntu sur ma Debian? (je sais qu'Ubuntu est basé sur Debian).

Hors ligne

#12 Aujourd'hui 18:32:16

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : Problème multitouch touchpad Asus debian 9

Bonjour,
Peut-être essayer le noyau de stretch-backports ? Pour voir s’il prend mieux en charge ton touchpad

Hors ligne

#13 Aujourd'hui 23:23:10

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Problème multitouch touchpad Asus debian 9

Alors pour faire simple j'avais pas compris que tu était sous gnome hmm donc ça doit plutôt pouvoir se régler a coups de gsettings, mais faut que j'aille checker comment.

En ligne

Pied de page des forums