Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-01-2019 10:18:28

Al57
Membre
Distrib. : Debian GNU/Linux stable updates (SID)
Noyau : Linux 4.9.0-7-amd64
(G)UI : ??
Inscription : 15-01-2019

[Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Bonjour

Après la suppression de quelque logiciel dans Discover mon gestionnaire de session (SSDM) et celui de mon bureau (KDE) ne marche plus. (Écran Noir)
J'ai remplacé SSDM par lightdm, ce qui me permet de me connecter mais après cela je ne peux rien faire. L'écran reste noir. (Avec quand même la présence du curseur spécifique de KDE)

En essayant d'installer d'autres paquets pour résoudre le problème je suis tombé sur plusieurs erreurs.
Il serait impossible d'installer les paquets puisqu'ils n'auraient pas les dépendances suffisante ...
C'est le cas par exemple de KDE PLasma, de Gnome, de LFX ...

Je ne vois pas vraiment quoi faire.

Des suggestion ?

Merci

Dernière modification par Al57 (16-01-2019 22:53:12)

Hors ligne

#2 15-01-2019 10:53:48

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Al57 a écrit :

Des suggestion ?


Salut et bienvenue sur df !

Afin de nous permettre de vous communiquer les meilleurs réponses, ou d'entendre au mieux tes interventions, il est bon de renseigner de manière permanente sous ton avatar ou ton pseudo la configuration du (des) PC que tu utilises.
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Force et courage


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 15-01-2019 19:46:40

Al57
Membre
Distrib. : Debian GNU/Linux stable updates (SID)
Noyau : Linux 4.9.0-7-amd64
(G)UI : ??
Inscription : 15-01-2019

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Bonsoir,

Merci de m'aider , voici quelque informations :

*******************************

Version de Debian :

lsb_release -d


Debian GNU/Linux stable updates (SID)

=

cat /etc/issue


Debian GNU/Linux buster/SID \n  \1

  =

cat /etc/debian_version


buster/sid

=

cat /etc/os-release | grep ^PRETTY | cut -d"\"" -f2


Debian GNU/Linux buster/SID

=

lsb_release -a


Debian GNU/Linux stable updates (SID)

=

GUI :
basename $(

cat /etc/X11/default-display-manager


lightdm

) =

Gestionnaire de bureau :

env | grep DESK


= ??? Ne donne rien ...

echo $DESKTOP_SESSION


= ??? Une ligne vide dans ce cas

Noyau :

uname -a


Linux PC 4.9.0-7-amd64 #1 SMP Debian 4.9.110-3+deb9u2 (2018-08-13) x86_64 GNU/Linux

=

uname -sr


Linux 4.9.0-7-amd64

=

***********************************

Liste Sources :

#deb cdrom:[debian GNU/LINUX 9.5.0 _Stretch_  -Official am64 NETINST 20180714-10:25]/ stretch main

#deb cdrom:[debian GNU/LINUX 9.5.0 _Stretch_  -Official am64 NETINST 20180714-10:25]/ stretch main

# Debian Stretch , dépôt principal
deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

# Debian Stretch, mises a jour de sécurité
deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security/ stretch/updates main contrib non-free

# Stretch-Updates, previously know as 'volatiles'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# Stretch-backports
deb http://ftp.fr.debian.org/debian/ stretch-backports main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-backports main contrib non-free



Edit à toto : Modif faite - Mise en ordre des commandes et de leurs retours séparées en utilisant le BBCode du forum.

Hors ligne

#4 15-01-2019 22:28:57

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Bonsoir et bienvenue sur df !
Il est surprenant que tu aies du buster et du sid là où il n'y en a pas les sources.
N'as-tu rien dans les sources ajoutées ,
Que donne la commande :

ls /etc/apt/sources.list.d/


Des fois que tu en aurais là... big_smile

Force et courage


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 15-01-2019 22:51:59

Al57
Membre
Distrib. : Debian GNU/Linux stable updates (SID)
Noyau : Linux 4.9.0-7-amd64
(G)UI : ??
Inscription : 15-01-2019

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Non malheuresement la commande ne donne rien sad

Hors ligne

#6 16-01-2019 18:23:42

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Bonjour,
Vu les retours qui parlent de Buster et sid à mon avis tu as activé à un moment les dépots de buster et/ou sid pour installer un logiciel peut-être
et ça a mis des paquets système à jour sur la version de buster.
Tu ne te souviens pas ? plus tu es précis plus tu pourras avoir de l'aide wink
j'imagine que tu as deux options :
1) passer tous les paquets actuellement installés sur buster
2) rétrograder tous les paquets actuellement installés à stretch
il y a un risque vu la situation donc sauvegarde bien tous les documents

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#7 16-01-2019 18:54:54

Al57
Membre
Distrib. : Debian GNU/Linux stable updates (SID)
Noyau : Linux 4.9.0-7-amd64
(G)UI : ??
Inscription : 15-01-2019

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Bonsoir,

Voici ce dont je me rappelle :
* J'ai effectivement activer les dépôts de Buster/Sid pour essayer de régler un problème de police graphique (Etrangement ca l'avait réglé)
* J'ai ensuite "supprimé" dans le logiciel Discover la Source Buster/Sid. J'imagine que c'est a partir de là que c'est le problème est apparru ...

Concernant les options, je préfererais prendre la moins risqué si possible.
Je suppose que c'est l'option 1 ?  Passer tous a Buster/Sid ? Quelles seraient les modifications a faire ?

Dernière modification par Al57 (16-01-2019 19:38:47)

Hors ligne

#8 16-01-2019 21:28:08

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Il faut bien mettre ta stretch à jour puis changer ton sources.list pour mettre Buster au lieu de stretch et ensuite tu refais une mise à jour complète

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#9 16-01-2019 22:52:09

Al57
Membre
Distrib. : Debian GNU/Linux stable updates (SID)
Noyau : Linux 4.9.0-7-amd64
(G)UI : ??
Inscription : 15-01-2019

Re : [Résolu] Ecran Noir + Paquet ne pouvant plus s'installer

Merci beacoup, tout remarche

Hors ligne

Pied de page des forums