Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-01-2019 11:17:25

phil45190
Membre
Distrib. : debian 11
Noyau : 5.10.0.4-amd64
(G)UI : xfce
Inscription : 16-02-2017

resolu debian buster x server lost

Bonjour,
je viens d'installer buster pour la 3° fois avec le même phénomène et mes recherches ne m'ont pas permis de trouver une solution
essai 1 : installation de buster avec xfce : après le redemarrage écran noir. CTRL+ALT+F1 m'ouvre un mode console. startx message erreur x server lost
essai 2 : upgrade d'une stretch vers buster avec dist-upgrade. même résultat
essai 3 : installation de buster sans environnement graphique.
puis installation des paquets qui vont bien lightdm xorg xfce4 wmaker et quelques autres (stellarium, firefox-esr, freetuxtv, thunar).
redemarrage : pas de problèmes
installation de cups et samba
redemarrage : ecran noir
passage en mode console
connexion au compte utilisateur ou en root
startx : réponse xinit x server lost

Une solution ?
Merci

Dernière modification par phil45190 (01-07-2019 13:17:39)

Hors ligne

#2 26-01-2019 11:19:33

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : resolu debian buster x server lost

phil45190 a écrit :

je viens d'installer buster


Tu peux indiquer avec quelle iso et d'où provient-elle ? smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 26-01-2019 12:19:32

phil45190
Membre
Distrib. : debian 11
Noyau : 5.10.0.4-amd64
(G)UI : xfce
Inscription : 16-02-2017

Re : resolu debian buster x server lost

site debian
debian amd64 net-install

Hors ligne

#4 26-01-2019 12:28:35

phil45190
Membre
Distrib. : debian 11
Noyau : 5.10.0.4-amd64
(G)UI : xfce
Inscription : 16-02-2017

Re : resolu debian buster x server lost

problème résolu en installant le driver nvidia qui va bien via nvidia-detect

Hors ligne

#5 26-01-2019 17:11:58

phil45190
Membre
Distrib. : debian 11
Noyau : 5.10.0.4-amd64
(G)UI : xfce
Inscription : 16-02-2017

Re : resolu debian buster x server lost

En définitive non ce n'est pas résolu
Au cours de mes essais en plus de cups eet samba j'ai installé slim à la place de lightdm.
arrêt redémarrage impeccable.
modification du fichier de configuration de slim pour avoir une connexion automatique
arrêt redémarage écran noir
remplacement de slim et lightdm par gdm3 ou wdm sans modif du fichier de configuration (donc pas de connexion automatique)
Tout fonctionne impeccablement (sauf peut-être une ouverture du compte un peu longue)

Pourquoi les gestionnaires de connexions lightdm et slim planteraient le serveur graphique si on met en connexion automatique ?

Pour l'instant j'ai gdm3 mais comme j'utilise XFCE je n'ai pas trouvé le moyen de modifier à la main la configuration pour une connexion automatique, les seules réponses que j'ai trouvé paraissent utiliser gnome et GDM et utilisant les outils graphiques

Merci

Hors ligne

Pied de page des forums