Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-11-2018 21:21:19

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

[Résolu] MOC / Pulseaudio - Bluetooth

Bonjour,

j'utilise MOC (Music on console) pour écouter de la musique on console, sur ma debian testing.
Pour emmerder les voisins, je fais sortir le son dans ma chaîne via la bluetooth.

Depuis peu, j'ai le problème suivant : je suis connecté à ma chaîne via bluetooth :
- si j'utilise MPV ou VLC, le son sort sur la chaîne.
- Mais si j'utilise MOC, ça ne sort sur l'ordinateur. Ça ne veut pas aller sur la bluetooth, et pas moyen de gérer ça avec Pavucontrol.

Si vous avez des pistes. Je ne sais plus quoi faire. ESt-ce un problème avec MOC, pulseaudio, les deux, d'autres ? Je ne sais.

Merci !

Dernière modification par tramberlimpe (24-11-2018 13:35:51)


Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#2 12-11-2018 18:33:41

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Je confirme : tous les logiciels de son/vidéo font sortir le son par la voie du bluetooth, sauf MOC.

Oaille ô ouaille ?????

Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#3 12-11-2018 18:50:32

Nsyo
Invité

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Salut !

tramberlimpe a écrit :

Pour emmerder les voisins



lol

J'utilise pas le bluetooth mais il y a peut-être un début de réponse ici : https://debian-facile.org/viewtopic.php?id=14969

#4 12-11-2018 22:14:13

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

J'ai essayé les solutions proposées
...

enfin je crois mais je n'ai pas réussi à trouver un index pour l'application MOC
:-/

Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#5 12-11-2018 23:58:27

Nsyo
Invité

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Trouvé ! Il faut installer le paquet moc-ffmpeg-plugin

pacmd list-sink-inputs


pacmd list-sink-inputs
1 sink input(s) available.
    index: 194
  driver: <protocol-native.c>
  flags:
  state: RUNNING
  sink: 0 <alsa_output.pci-0000_00_1b.0.analog-stereo>
  volume: front-left: 12058 /  18% / -44,11 dB,   front-right: 10090 /  15% / -48,76 dB
          balance -0,16
  muted: no
  current latency: 221,02 ms
  requested latency: 74,99 ms
  sample spec: s16le 2ch 44100Hz
  channel map: front-left,front-right
               Stéréo
  resample method: (null)
  module: 8
  client: 434 <ALSA plug-in [mocp]>
  properties:
    media.name = "ALSA Playback"
    application.name = "ALSA plug-in [mocp]"
    native-protocol.peer = "UNIX socket client"
    native-protocol.version = "32"
    application.process.id = "3279"
    [...]
 



wink

Dernière modification par Nsyo (13-11-2018 00:03:17)

#6 13-11-2018 01:00:53

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Salut,

moi, il dit qu'y rien !


~/ pacmd list-sink-inputs
0 sink input(s) available.
 



On avance ! Mais je ne sais pas vers où...

edit : je précise que Moc est en train de lire un morceau !


Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#7 13-11-2018 15:02:51

Nsyo
Invité

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Tu es sur i3 non ? Quel config pour le son as-tu ? J'ai installé les paquets pulseaudio, pavucontrol et alsa-utils, c'est ma config par défaut.
Si on a bien les mêmes paquets, je ne vois pas pourquoi "pacmd list-sink-inputs" ne te retourne rien

Finalement le paquet moc-ffmpeg-plugin ne sert à rien dans le contexte. J'avais lu qu'il le fallait je sais plus où, mais sur packages.debian.org est indiqué :

moc-ffmpeg-plugin is an additional plugin to play soundfiles out of the ffmpeg libs like WMA, RealAudio, MP4 and AAC.



pacmd list-sink-inputs

me retourne bien

1 sink input(s) available.
    index: 4
  driver: <protocol-native.c>
  flags:
  state: RUNNING
  sink: 0 <alsa_output.pci-0000_00_1b.0.analog-stereo>
 



Tu peux peut-être t'inspirer de ce script trouvé ici https://gist.github.com/honzajavorek/7299300

#!/bin/bash
# A script to connect my SAMSUNG SBH-650 BLUETOOTH HEADSET (I use it for remote speakers)

# address of the device (hcitool scan ... Samsung SBH650)
address="00:21:D2:A4:7B:E7"

# stop && shutdown moc
mocp -s
mocp -x

# restart service
sudo /etc/init.d/bluetooth restart

# start bluetooth
status=`/etc/init.d/bluetooth status | grep "is not running"`
if [ -n "$status" ]; then
  echo "Bluetooth is stopped."
  sudo /etc/init.d/bluetooth start
  echo "Now bluetooth is running."
else
  echo "Bluetooth is running."
fi

# find the device
found=`hcitool scan | grep "$address"`
if [ -n "$found" ]; then
  echo "Device found."
else
  echo "Device is not present."
  zenity --error --text "Device is not present."
  exit
fi

# restart the fucking menu
killall bluetooth-applet > /dev/null 2> /dev/null && bluetooth-applet &

# connect
zenity --info --text "Now please connect the device."

# restart the fucking menu
killall bluetooth-applet > /dev/null 2> /dev/null && bluetooth-applet &

# set sound output
index=`pacmd "list-sinks" | grep "index: [1-9]" | sed 's/\s*index:\s*//' | sed -e 's/\s*$//'`
pacmd "set-default-sink" "$index"

# start mocp
mocp -S

 



Ou de cette discussion : https://askubuntu.com/questions/187097/ … n-moc-alsa

Bonne chance pour la suite lol

#8 13-11-2018 17:27:45

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Non, mais c'est ça qu'est dingue : ça marchait très bien avant. Et ça c'est mis à ne plus marcher depuis une mise à jour la semaine dernière (je crois).
Est-ce un bug ? Je ne sais pas...

Merci pour l'info, j'essaie ce soir.

Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#9 15-11-2018 10:17:09

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Bonjour,

Quand je lance MOC, la commande suivante et son retour :


~/ pacmd list-sink-inputs
0 sink input(s) available.
 



Et pourtant y'a du son sur mon ordi, mais impossible de le faire sortir en bluetooth.


Des idées ?
Merci

Dernière modification par tramberlimpe (15-11-2018 11:46:02)


Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#10 20-11-2018 12:34:47

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Hello, hello !!

Quelqu'un a une idée, du coup ?

Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#11 24-11-2018 12:45:52

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Re bonjour,

Je galère et ne trouve rien.
Sur le site de moc, ils disent que c'est un problème Alsa...

si quelqu'un...
Merci !!!

Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#12 24-11-2018 13:35:02

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Hello !

J'ai fini par trouver une solution : en m'aidant de l'info sur cette page du forum dédiée à MOC : https://moc.daper.net/node/360

Dans ma version de Debian testing, le paquet "alsa-bluez" n'est plus dispo, du coup, ALSA ne gère plus le bluetooth. Pour que MOC sorte sur du/dela (?) bluetooth, il doit uitiliser (passer par ?) Pulseaudio.  Il semblerait qu'ALSA qui gère le son des speakers du PC et de la sortie casque mais pas le BT.  J'ai pas tout compris en détail, mais ça m'a l'air un peu comme ça. 

Pour régler le problème, il m'a fallu faire les modifications suivantes, pour faire en sorte que MOC utilise OSS, qui est lui-même "compris/pris en charge" par Pulseaudio :

1 - Dans le fichier de configuration de moc (~/.moc/config/ ou autre), je modifie l'option SoundDriver pour mettre OSS en premier :


SoundDriver = OSS:ALSA:JACK
 



2 - Démarrer MOC avec la commande suivante :

padsp mocp



Et ça marche !

Après, on peut faire des alias dans le fichier ~/.bashrc ou ~/.zshrc ou ...

alias mocp="padsp mocp"



Mais ça, c'est une autre histoire...

Pour finir et comprendre ce qu'il se passe : padsp permet de rediriger les programmes compatibles OSS vers un server Pulseaudio. Petite citation du retour de la commande

man padsp

:

padsp - PulseAudio OSS Wrapper
[…]
padsp starts the specified program and redirects its access to OSS compatible audio devices (/dev/dsp and auxiliary devices) to a PulseAudio sound server.


Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#13 30-11-2018 18:34:33

tramberlimpe
Membre
Distrib. : Debian testing/sid
Noyau : Linux 5.10.0-4-amd64
(G)UI : i3
Inscription : 24-09-2012

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Je reviens car il y a eu des soucis mais j'ai fini par les régler (par hasard).

La solution avec ce code

 padsp mocp

fonctionne, mais il y avait un (gros) hic :
à chaque fois qu'un morceau finissait, au moment de passer au suivant, le serveur crashait avec ce message :

  FATAL_ERROR: Can't receive value from the server!



J'ai incidemment trouvé une meilleure configuration.

J'ai d'abord installé les paquets : oss-compat et osspd

apt install oss-compat osspd



Si je veux une sortie en bluetooth, je démarre moc avec la commande suivante

mocp --sound-driver OSS


(Attention : si aucune enceinte bluetooth n'est connectée, il n'y a pas de son)

Si je veux une sortie sur les speakers de mon PC, je démarre moc avec la commande suivante :

mocp --sound-driver ALSA



Il ne reste plus qu'à faire des alias, si je veux aller plus vite, dans ~/.bashrc, ~/.zshrc ou ~/.bash_aliases, etc. :

 
alias mocp="mocp --sound-driver ALSA"
alias mocpbt="mocp --sound-driver OSS"
etc.
 



Si ça peut aider.
À bientôt


Ni dieu, ni maître, ni slogan !

Je pense donc Jessie.
Dura Stretch, sed Stretch.

Hors ligne

#14 01-02-2019 16:05:02

sakul
Membre
Inscription : 01-02-2019

Re : [Résolu] MOC / Pulseaudio - Bluetooth

Bonjour,

Ca faisait un moment que je cherchais a régler ce problème aussi.

Suite au message précédant, et si vous utilisez PulseAudio, il convient d'installer les paquets suivants et tout rentre dans l'ordre ( debian stable )

apt-get install osspd osspd-pulseaudio




cordialement et merci pour la piste de recherche.

Hors ligne

Pied de page des forums