Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-02-2019 10:32:23

Allain
Membre
Distrib. : Jessie 8.11 (VM) / Stretch 9.7 (VM) / Jessie 8.5 (
Noyau : Il changera encore
(G)UI : Gnome 3
Inscription : 30-07-2016

Installation de thonny/sid (IDE Python) -> my Stretch is dead :(

Bonjour a tous

Avant de "péter" mon Debian 9.7/Stretch pour la 3ème fois, pouvez-vous jeter un coup d'oeuil à cette procédure ?
Il s'agit d'installer le paquet thonny qui ferait partie uniquement des paquets Testing pour la version 3.1.0
https://packages.debian.org/sid/thonny
Et de Backports pour la version 3.05 https://packages.debian.org/stretch-backports/thonny
Ce serait sympa de trouver la solution aujourd'hui, je vais me retrouver sans internet a partir de ce soir
J'ai suivi les conseils du wiki de Debian pour le fichier preferences, en attendant je relis la doc de DF

L'installation est fraîche de hier soir
Les seules modifications faites sont les configurations des fichiers sudoers et sources.list
et les installations de open-vm-tools, open-vm-tools-desktop, numlockx

sources.list

deb http://deb.debian.org/debian/ stretch main contrib non-free
# deb-src http://httpredir.debian.org/debian/ stretch main

deb http://security.debian.org/ stretch/updates main contrib non-free
# deb-src http://security.debian.org/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://httpredir.debian.org/debian/ stretch-updates main

# stretch instead of stable would be better ???
deb http://deb.debian.org/debian stretch-proposed-updates main contrib non-free

####### DEBIAN Backports #######
deb http://deb.debian.org/debian stretch-backports main contrib non-free

####### DEBIAN testing #######
deb http://deb.debian.org/debian stretch main contrib non-free
#deb http://ftp.us.debian.org/debian stretch main contrib non-free
 



preferences :

Package: *
Pin: release a=testing
Pin-Priority: 900

Package: *
Pin: release o=Debian
Pin-Priority: -10

 



Sans avoir fait l'update (je veux installer thonny mais garder Stretch en version stable :

apt-cache policy thonny


thonny:
  Installed: (none)
  Candidate: 3.0.5-1~bpo9+1
  Version table:
     3.0.5-1~bpo9+1 100
        100 [url]http://deb.debian.org/debian[/url] [b]stretch-backports[/b]/main amd64 Packages



apt-get update


apt-get upgrade


apt-get dist-upgrade



Si j'exécute l'installation de thonny sans avoir fait l'update/upgrade qui precede j'obtiens :

he following packages have unmet dependencies:
 thonny : Depends: python3-jedi (>= 0.10.1~) but 0.10.0~git1+f05c071-1 is to be installed
          Recommends: xsel but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Si je fais l'update il me dit qu'il me manque des dependances ou que leur version n'est pas correcte
Suite a cela il m'installe plein de paquets KDE et me vire Gnome (sans sommation, le cochon), au redemarrage je me trouve devant un ecran de login gris sans possibilite de revenir à Gnome
Sinon il ne me reste que la console si je passe en mode "sans echec" au demarrage de Grub

Edit à toto : Modif faite - réarrangement du BBCode du forum en modifiant les quote (Citation par code (Code) et séparer la Commande user de son retour. Ainsi tous les débutants peuvent mieux suivre les posts.

Dernière modification par Allain (08-02-2019 10:55:05)

Hors ligne

#2 08-02-2019 17:21:25

Allain
Membre
Distrib. : Jessie 8.11 (VM) / Stretch 9.7 (VM) / Jessie 8.5 (
Noyau : Il changera encore
(G)UI : Gnome 3
Inscription : 30-07-2016

Re : Installation de thonny/sid (IDE Python) -> my Stretch is dead :(

Modification de /etc/apt/preferences :


Package: *
Pin: release a=stable
Pin-Priority: 900

Package: *
Pin: release a=testing
Pin-Priority: 700

Package: *
Pin: release a=unstable
Pin-Priority: 500

Package: *
Pin: release o=Debian
Pin-Priority: -10
 



Suivi d'un update/upgrade
Mon systeme n'est pas mort, ouf smile

Je vais devoir laisser tomber...
Au plus j'avance en installant les dependances manuellement, il me demande d'installer des dependances a tire-larigot
J'ai fait un snapshot
Il me reste a faire marche-arriere lol

Edit à toto : BBCode du forum - Modification de quote (Citation) en code (Autre code)

Dernière modification par Allain (08-02-2019 17:29:46)

Hors ligne

#3 09-02-2019 00:03:36

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Installation de thonny/sid (IDE Python) -> my Stretch is dead :(

Bonsoir,
Ta ligne du sources.list n’est pas pour testing (=buster) mais stretch qui est la version stable .
Pour installer depuis les backports sans problème de dépendances

apt -t stretch-backports install thonny

Hors ligne

#4 09-02-2019 09:15:06

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Installation de thonny/sid (IDE Python) -> my Stretch is dead :(

Écriture et utilisation des backports :
https://debian-facile.org/https:debian- … -backports wink

Dernière modification par smolski (09-02-2019 09:32:47)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 09-02-2019 09:30:35

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Installation de thonny/sid (IDE Python) -> my Stretch is dead :(

Lien à corriger tu as déplacé le wiki wink

Hors ligne

#6 09-02-2019 09:33:12

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Installation de thonny/sid (IDE Python) -> my Stretch is dead :(

Oups corrigé le lien également. smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums