Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-04-2019 13:59:06

Mak-chan
Membre
Inscription : 15-06-2018

[Résolu] Cryptage SSL (CertBot) sur Projet PHP 7.0 -Debian 8-

Bonjour à tous,
J'ai  développé une Application Web sur une Debian 8 qui joue le rôle de serveur LAMP,
Et j'ai la volonté d'encrypter ce dernier en SLL via Certbot, seulement l'installation de ce service boucle sur une erreur que j'ai du mal à comprendre...

Je tente de suivre un tutoriel de MemoInfo pour cette installation.
Impossible pour moi d'aller très loin dans celle ci car si le téléchargement du paquet se passe bien :

wget https://dl.eff.org/certbot-auto
chmod a+x certbot-auto



L’exécution du Script lui, me renvois une erreur de Python/Urllib2 :

./certbot-auto



[...]
Paramétrage de python3-virtualenv (1.11.6+ds-1) ...
Paramétrage de virtualenv (1.11.6+ds-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u10) ...
WARNING: unable to check for updates.
Creating virtual environment...
Installing Python packages...
Traceback (most recent call last):
  File "/tmp/tmp.TfnQuw0IV2/pipstrap.py", line 177, in <module>
    sys.exit(main())
  File "/tmp/tmp.TfnQuw0IV2/pipstrap.py", line 158, in main
    for path, digest in PACKAGES]
  File "/tmp/tmp.TfnQuw0IV2/pipstrap.py", line 117, in hashed_download
    response = opener(using_https=parsed_url.scheme == 'https').open(url)
  File "/usr/lib/python2.7/urllib2.py", line 431, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 449, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 409, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 1240, in https_open
    context=self._context)
  File "/usr/lib/python2.7/urllib2.py", line 1197, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error [Errno 101] Network is unreachable>
 



Je crois comprendre, qu'UrlLib2 à du mal à passé au travers du Proxy .. ?
Le Serveur est pourtant bien en droit d’interroger le WAN et je lance bien le tout en Root ...
J'ai la même erreur en renseignant les options telles que :

./certbot-auto certonly --webroot --webroot-path /srv/www/domain.tld/ --domain domain.tld --domain www.domain.tld --email mon@email.com


(Comme j'héberge mon Appli' en Local (Intranet), je n'ai pas de domain à renseigner, mais ça ne change rien)

Alors voilà, je me doute que ce problème est assez .. Spécifique !
J'ai farfouillé dans les fichiers de configurations de Python 2.7 sans grand succès ..

Une recherche sur l'erreur renvoyée par urllib2 tends à me confirmer mes doutes quant-au rôle du Proxy dans celle-ci..
J'essaie de l'ajouter au dernier fichier Python définissant la configuration urllib2 :

nano /usr/lib/python2.7/urllib2.py
# set up authentication info
authinfo = urllib2.HTTPBasicAuthHandler()
authinfo.add_password(realm='PDQ Application',
                      uri='https://mahler:8092/site-updates.py',
                      user='klem',
                      passwd='geheim$parole')

proxy_support = urllib2.ProxyHandler({"http" : "http://mon.ip.proxy:port", "http" : "http://ahad-haam:3128"})

# build a new opener that adds authentication and caching FTP handlers
opener = urllib2.build_opener(proxy_support, authinfo, urllib2.CacheFTPHandler)
 



Mais rien n'y fait, et je ne trouve pas cela normal que de devoir modifier les configurations à la main pour renseigner un Proxy connu du système ..
Les infos "https://mahler:8092/site-updates.py" & "http://ahad-haam:3128" étaient présentes de base.

Bref, j'ignore si quelqu'un pourra m'aider, mais je l'espère grandement =)

Dernière modification par Mak-chan (24-04-2019 08:20:31)

Hors ligne

#2 24-04-2019 08:20:10

Mak-chan
Membre
Inscription : 15-06-2018

Re : [Résolu] Cryptage SSL (CertBot) sur Projet PHP 7.0 -Debian 8-

Je m'auto réponds et passe en résolu, car le forum de Certbot m'as apporté la Solution et que j'estime qu'elle peut toujours servir.. !

Le problème venait de la configuration du Proxy sur mon Serveur !

Dans “/etc/profile.d/proxy.sh”, il fallait ajouter la variable "https_proxy" ->

export http_proxy=http://my.proxy.ip:port
export https_proxy=http://my.proxy.ip:port


(Avec une url en http)

Aucune autre modif' n'était nécessaire .. ^^"

Dernière modification par Mak-chan (24-04-2019 10:41:30)

Hors ligne

Pied de page des forums