Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-04-2019 14:38:50

Steph_7888
Membre
Inscription : 25-04-2019

apt-get update impossible, installation de nouveau package impossible

Bonjour à tous !

Voici mon problème :
Je n'arrive plus à update mon apt-get depuis quelques jours, et j'ai cherché partout en modifiant mon sources.list mais rien à faire, je n'arrive pas à le faire marcher.
J'ai désinstallé récemment certbot sur ma machine, et impossible de le réinstaller via apt-get pour je suppose des raisons similaires.

apt-get update :

W: Impossible de récupérer http://httpredir.debian.org/debian/dists/jessie-updates/InRelease  Impossible de trouver l'entrée « main/binary-amd64/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu

W: Impossible de récupérer http://httpredir.debian.org/debian/dists/jessie-backports/main/binary-amd64/Packages  404  Not Found

W: Impossible de récupérer http://httpredir.debian.org/debian/dists/jessie-backports/contrib/binary-amd64/Packages  404  Not Found

W: Impossible de récupérer http://httpredir.debian.org/debian/dists/jessie-backports/non-free/binary-amd64/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.



Voici mon sources.list :

# Debian Jessie, dépôt principal + paquets non libres
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
## le contenu de votre sources.list non-libre doit précéder
# Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free



Auriez-vous une idée de la raison?

J'ai essayé de changer plusieurs fois le sources.list avec d'autres, j'ai tenté de vider le dossier /var/lib/apt/lists/, j'ai tenté de passer par aptitude également plutôt que apt-get, mais rien n'a marché.

Lorsque j'essaie un apt-get install certbot, j'obtiens :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Package certbot is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'certbot' has no installation candidate



Lorsque je passe par certbot-auto, j'obtiens :

L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libffi-dev : Dépend: libffi6 (= 3.1-2+deb8u1) mais 3.2.1-9 devra être installé
 libssl-dev : Dépend: libssl1.0.0 (= 1.0.1t-1+deb8u11) mais 1.0.2l-1~bpo8+1 devra être installé
              Dépend: zlib1g-dev mais ne sera pas installé


(C'était une des premières erreurs que j'avais avant de tenter de faire un apt-get update)

Merci d'avance pour votre aide,

Stephane

Hors ligne

#2 25-04-2019 14:47:38

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : apt-get update impossible, installation de nouveau package impossible

Cet article va t'aider je pense, ils donnent la raison et la solution <3

https://carlchenet.com/depots-debian-ca … t-reparer/

Merci au flux RSS de l'April.

Les versions Debian Wheezy et Jessie vieillissent et certains de leurs dépôts ont moins besoin d’être hébergés sur le réseau principal de miroirs Debian et sont seulement accessibles désormais via archive.debian.org ou ont été supprimés.

Lors de l’exécution de la commande apt-get update (ou apt update), les dépôts manquants sont tout simplement ignorés. Bien sûr il est indispensable de mettre à jour votre liste si vous souhaitez installer un paquet contenu dans un dépôt Apt ayant changé d’adresse ou ayant disparu.

Dernière modification par otyugh (25-04-2019 14:49:45)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 25-04-2019 15:09:28

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : apt-get update impossible, installation de nouveau package impossible

Bonjour,
C’est effectivement indiqué sur le wiki Debian https://wiki.debian.org/fr/StableUpdates

Pour Debian 8 « Jessie », jessie-updates n'existe désormais plus, car elle ne reçoit plus de mises à jours depuis le 17-05-2018.


Le wiki DF a été modifié en conséquence : https://debian-facile.org/doc:systeme:a … st-de-base
(Y sont trop forts les membres DF qui tiennent à jour le wiki woohoo.gif , merci à eux smile )

Lorsque j'essaie un apt-get install certbot,


Il ne semble pas y avoir de version de ce paquet pour Jessie
Que donne

ls /etc/apt/sources.list.d


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#4 25-04-2019 15:19:27

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

Merci pour l'aide !
Alors concernant le /etc/apt/sources.list.d , j'avais mis de côté les fichiers qui s'y trouvaient, et je n'ai du coup pas eu d'erreurs après l'apt-get update suite à la modification que j'ai apporté à mon sources.list comme me l'a indiqué otyugh ! Merci !

J'ai du coup remis les fichiers qui étaient présents dans /etc/apt/sources.list.d :

backports.list  mod-pagespeed.list  nodesource.list  testing.list



Et l'apt-get update me donne :

W: Impossible de récupérer http://ftp.debian.org/debian/dists/jessie-backports/main/binary-amd64/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.



Je suppose que je dois en supprimer quelques uns (ou tous) ?

Hors ligne

#5 25-04-2019 15:46:28

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

Petite update sur le ls /etc/apt/sources.list.d :
root [/etc/apt/sources.list.d] >

ls


backports.list  mod-pagespeed.list  nodesource.list  testing.list


root [/etc/apt/sources.list.d] >

cat backports.list


deb http://ftp.debian.org/debian jessie-backports main


root [/etc/apt/sources.list.d] >

cat mod-pagespeed.list


### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/mod-pagespeed/deb/ stable main


root [/etc/apt/sources.list.d] >

cat nodesource.list


deb https://deb.nodesource.com/node_7.x jessie main
deb-src https://deb.nodesource.com/node_7.x jessie main


root [/etc/apt/sources.list.d] >

cat testing.list


deb http://http.debian.net/debian testing main

Hors ligne

#6 25-04-2019 15:57:49

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : apt-get update impossible, installation de nouveau package impossible

@Steph : le lien donné par Chalu répond à cette question, cherche à "backport", j'ai trouvé en dix secondes wink

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#7 25-04-2019 16:01:45

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : apt-get update impossible, installation de nouveau package impossible

J'ai séparé les retours des commandes pour que ce soit plus clair wink
testing.list est un peu inquiétant pour la stabilité d'une jessie si tu as fait des installations sur ce dépôt, ce qui semble être le cas d'après le retour que tu as donné plus haut :

Les paquets suivants contiennent des dépendances non satisfaites :
 libffi-dev : Dépend: libffi6 (= 3.1-2+deb8u1) mais 3.2.1-9 devra être installé
 libssl-dev : Dépend: libssl1.0.0 (= 1.0.1t-1+deb8u11) mais 1.0.2l-1~bpo8+1 devra être installé
              Dépend: zlib1g-dev mais ne sera pas installé


La version de libffi6 en 3.2.1-9 est disponible dans Buster (testing) mais ni dans jessie ni dans stretch

Donne nous le retour de :

apt policy libc6


pour voir s'il ne serait pas plus simple de migrer vers stretch puis buster


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#8 25-04-2019 16:42:20

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

Hmm..

E: L'opération policy n'est pas valable



Je ne sais pas si je dois installer qqchose?

Ah oui merci Otyugh pour l'info sur les backports

Hors ligne

#9 25-04-2019 16:43:06

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : apt-get update impossible, installation de nouveau package impossible

ah oui zut sur jessie c'est

apt-cache policy libc6


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#10 25-04-2019 17:05:57

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://http.debian.net/debian/ testing/main Translation-fr
 500 http://http.debian.net/debian/ testing/main Translation-en
 500 http://http.debian.net/debian/ testing/main amd64 Packages
     origin http.debian.net
 500 https://deb.nodesource.com/node_7.x/ jessie/main amd64 Packages
     origin deb.nodesource.com
 500 http://dl.google.com/linux/mod-pagespeed/deb/ stable/main amd64 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main
     origin dl.google.com
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
     release v=8.11,o=Debian,a=oldstable,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
Paquets épinglés :

Hors ligne

#11 25-04-2019 19:26:29

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : apt-get update impossible, installation de nouveau package impossible

Il nous faudrait l'intégralité du retour de la commande, là tu as supprimé le début qui donne la version installée et celle canddate
comme ceci par exemple chez moi :

libc6:
  Installé : 2.24-11+deb9u4
  Candidat : 2.24-11+deb9u4
 Table de version :
 *** 2.24-11+deb9u4 500
        500 https://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     2.24-11+deb9u1 500
        500 https://deb.debian.org/debian-security stretch/updates/main amd64 Packages
 


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#12 25-04-2019 19:35:35

raleur
Membre
Inscription : 03-10-2014

Re : apt-get update impossible, installation de nouveau package impossible

Il faudrait surtout exécuter la bonne commande, car j'ai l'impression qu'il s'agit de la sortie (complète) de

apt-cache policy


tout court et non

apt-cache policy libc6


comme tu l'as demandé.

Une chose est sûre : ce mélange de sources entre jessie (oldstable) et testing ne peut que causer des problèmes.

Dernière modification par raleur (25-04-2019 19:37:04)

Hors ligne

#13 26-04-2019 10:35:57

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

libc6:
  Installé : 2.19-18+deb8u10
  Candidat : 2.28-8
 Table de version :
     2.28-8 0
        500 http://http.debian.net/debian/ testing/main amd64 Packages
 *** 2.19-18+deb8u10 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
        500 http://security.debian.org/ jessie/updates/main amd64 Packages
        100 /var/lib/dpkg/status



Merci beaucoup pour votre aide encore une fois !

Hors ligne

#14 26-04-2019 11:31:47

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : apt-get update impossible, installation de nouveau package impossible

Tu as peut-être de la chance, la version de libc6 est restée en jessie.
A ta place, je ferais ainsi :
je désactive/commente en ajoutant # devant chaque ligne tous les dépôts qui sont dans /etc/apt/sources.list.d ainsi que le dépôt jessie-backports qui est dans /etc/apt/sources.list


# deb http://ftp.debian.org/debian jessie-backports main



# deb http://dl.google.com/linux/mod-pagespeed/deb/ stable main
 



# deb https://deb.nodesource.com/node_7.x jessie main
# deb-src https://deb.nodesource.com/node_7.x jessie main



deb http://http.debian.net/debian testing main
 



# Debian Jessie, dépôt principal + paquets non libres
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
# deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
## le contenu de votre sources.list non-libre doit précéder
# Debian Jessie, dépôt de rétroportages ("backports")
# deb http://httpredir.debian.org/debian jessie-backports main contrib non-fre


Si tu as déjà modifié httpredir par ftp.fr comme semble l'indiquer ton retour dans le message précédent, c'est très bien pas la peine de repasser à httpredir
ensuite tu fais

apt-get update


Tu peux nous donner le retour de cette commande pour vérifier que tout est ok
puis

apt-get dist-upgrade


ensuite on passe de jessie à stretch en modifiant le fichier /etc/apt/sources.list pour remplacer partout jessie par stretch et en enlevant le # de stretch-update mais pas encore de stretch-backports. On peut mettre aussi deb.debian.org à la place de httpredir ou ftp.fr


# Debian Stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian Stretch, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
# Debian Stretch, dépôt de rétroportages ("backports")
# deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
 


Ensuite tu fais

apt-get update


apt-get upgrade


apt-get dist-upgrade


ensuite donne le retour de :

cat /etc/debian_version


ou si le paquet lsb-release est installé de

lsb_release -d


Tu devrais avoir

Description:  Debian GNU/Linux 9.8 (stretch)


Tu redémarres le PC pour être sur le noyau 4.9.x
Ensuite, donne nous le retour de

apt update && apt install certbot


Tu devrais toujours avoir le problème de dépendances avec libffi6 mais ce sera espérons le plus facile à régler depuis une stretch
ou alors tu continues et tu migres de stretch vers buster qui sera stable vers juin-juillet environ


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#15 26-04-2019 12:45:34

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

Alors après le premier apt-get dist-upgrade :

Fichier de configuration « /etc/nginx/nginx.conf »
 ==> Modifié (par vous ou par un script) depuis l'installation.
 ==> Le distributeur du paquet a fourni une version mise à jour.
   Que voulez-vous faire ? Vos options sont les suivantes :
    Y ou I  : installer la version du responsable du paquet
    N ou O  : garder votre version actuellement installée
      D     : afficher les différences entre les versions
      Z     : suspendre ce processus pour examiner la situation
 L'action par défaut garde votre version actuelle.
*** nginx.conf (Y/I/N/O/D/Z) [défaut=N] ? N

Fichier de configuration « /etc/nginx/sites-available/default »
 ==> Modifié (par vous ou par un script) depuis l'installation.
 ==> Le distributeur du paquet a fourni une version mise à jour.
   Que voulez-vous faire ? Vos options sont les suivantes :
    Y ou I  : installer la version du responsable du paquet
    N ou O  : garder votre version actuellement installée
      D     : afficher les différences entre les versions
      Z     : suspendre ce processus pour examiner la situation
 L'action par défaut garde votre version actuelle.
*** default (Y/I/N/O/D/Z) [défaut=N] ? N
Installation de la nouvelle version du fichier de configuration /etc/nginx/snippets/fastcgi-php.conf ...
Removing obsolete conffile /etc/init/nginx.conf ...
Paramétrage de libnginx-mod-stream (1.14.2-2) ...
Paramétrage de libnginx-mod-mail (1.14.2-2) ...
Paramétrage de libnginx-mod-http-xslt-filter (1.14.2-2) ...
Paramétrage de libnginx-mod-http-upstream-fair (1.14.2-2) ...
Paramétrage de libnginx-mod-http-subs-filter (1.14.2-2) ...
Paramétrage de libnginx-mod-http-image-filter (1.14.2-2) ...
Paramétrage de libnginx-mod-http-geoip (1.14.2-2) ...
Paramétrage de libnginx-mod-http-echo (1.14.2-2) ...
Paramétrage de libnginx-mod-http-dav-ext (1.14.2-2) ...
Paramétrage de libnginx-mod-http-auth-pam (1.14.2-2) ...
Paramétrage de libuv1:amd64 (1.24.1-1) ...
Paramétrage de nodejs-doc (10.15.2~dfsg-2) ...
Paramétrage de python-asn1crypto (0.24.0-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u10) ...



Après le passage à stretch du sources.list :
apt-get update s'est bien passé
apt-get upgrade :

dpkg: boucle détectée durant le traitement des actions différées :
 listes des paquets qui en sont responsables (normalement) :
  systemd -> libc-bin
 paquets bloqués par le traitement impossible d'actions différées requises :
  systemd: /etc/init.d
  libc-bin: ldconfig
dpkg: erreur de traitement du paquet systemd (--unpack) :
 bloqué en boucle sur le traitement des actions différées (« triggers »), abandon
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u10) ...
Des erreurs ont été rencontrées pendant l'exécution :
 systemd
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#16 26-04-2019 12:51:05

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

J'ai quand même fait le dist-upgrade derrière

cat /etc/debian_version

buster/sid



lsb_release -d

Description:    Debian GNU/Linux stable-updates (sid)

Hors ligne

#17 26-04-2019 12:58:37

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

De plus j'ai nginx qui maintenant n'a plus l'air d'être bien installé, dois-je refaire un dist-upgrade en laissant modifier les fichiers de conf que je sauvegarde à côté?

Hors ligne

#18 26-04-2019 13:02:05

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : apt-get update impossible, installation de nouveau package impossible

C’est encore le méli-mélo entre les dépöts
Tu as bien sauvegardé tes données ? J’ai oublié de te le dire.
Il a donné quoi le deuxième dist-upgrade ?
je n’ai aucune idée des difficultés et problèmes liés au message d’erreur de dpkg pour systemd.

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#19 26-04-2019 13:16:57

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

Le 2ème dist-upgrade s'est passé à peu près correctement en sachant que j'ai validé certaines installations que je ne connaissais pas, mais le fait que nginx ne soit plus actif me pose quelques problèmes liés à mon site malheureusement, je suis en train d'essayer de remettre le service en route, je suis reparti sur les dépôts de base et réutilisé un dist-upgrade avec le source.list des dépôts jessie.

root [/home] > apt install nginx
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 nginx : Dépend: nginx-full (>= 1.6.2-5+deb8u6) mais ne sera pas installé ou
                  nginx-light (>= 1.6.2-5+deb8u6) mais ne sera pas installé ou
                  nginx-extras (>= 1.6.2-5+deb8u6) mais ne sera pas installé
         Dépend: nginx-full (< 1.6.2-5+deb8u6.1~) mais ne sera pas installé ou
                  nginx-light (< 1.6.2-5+deb8u6.1~) mais ne sera pas installé ou
                  nginx-extras (< 1.6.2-5+deb8u6.1~) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Je ne sais pas pourquoi mais nginx n'est plus actif, lorsque je tente de lancer le service je me retrouve avec :

root [/home] > systemctl status nginx.service
● nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2019-04-26 13:16:40 CEST; 2s ago
     Docs: man:nginx(8)
  Process: 31940 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=203/EXEC)

avril 26 13:16:40 webhost-1 systemd[1]: Starting A high performance web server and a reverse proxy server...
avril 26 13:16:40 webhost-1 systemd[31940]: nginx.service: Failed to execute command: No such file or directory
avril 26 13:16:40 webhost-1 systemd[31940]: nginx.service: Failed at step EXEC spawning /usr/sbin/nginx: No such fi
avril 26 13:16:40 webhost-1 systemd[1]: nginx.service: Control process exited, code=exited, status=203/EXEC
avril 26 13:16:40 webhost-1 systemd[1]: nginx.service: Failed with result 'exit-code'.
avril 26 13:16:40 webhost-1 systemd[1]: Failed to start A high performance web server and a reverse proxy server.

Hors ligne

#20 26-04-2019 13:45:44

Steph_7888
Membre
Inscription : 25-04-2019

Re : apt-get update impossible, installation de nouveau package impossible

Concernant la sauvegarde des données, j'ai une sauvegarde datant du début du mois dont je viens de me servir pour maintenir le site le temps que je règle ce problème.
J'ai tout en sauvegardé du coup ça ira !

Hors ligne

#21 26-04-2019 13:48:09

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : apt-get update impossible, installation de nouveau package impossible

A mon avis tu devrais migrer vers Buster pour espérer avoir un ensemble de paquets cohérents.
Remettre le sources.list sur Jessie ne t’avancera pas.
Ou alors il faudrait lister les paquets qui ne sont pas en version stretch pour les mettre dans cette version stretch et tu aurais un ensemble de paquets cohérents sur stretch.
Comme dit par raleur plus haut avec un sources.list ayant des dépôts de Jessie à testing, tu ne pouvais que rencontrer des problèmes hmm

Que donne

apt-cache policy nginx


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

Pied de page des forums