Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-07-2019 16:05:51

Daff
Membre
Lieu : France
Distrib. : Debian 10 Buster
Noyau : 4.19 (Amd64)
(G)UI : Xfce
Inscription : 12-07-2019

Gmic dans Gimp ne se lance pas

Bonjour à tous, sous Debian 10 Xfce Amd64 Stable fraîchement installé, Gmic dans gimp ne démarre pas (pas de message d'erreur, rien ne se passe).
J'ai installé le paquet : gimp-gmic avec : apt install gimp-gmic
Gmic est bien présent dans gimp (dossier et plugin installé).
Si une personne a des infos à propos de ce problème ( avez-vous ce problème?), oublie ou bug merci d'avance.

Hors ligne

#2 12-07-2019 17:06:21

Daff
Membre
Lieu : France
Distrib. : Debian 10 Buster
Noyau : 4.19 (Amd64)
(G)UI : Xfce
Inscription : 12-07-2019

Re : Gmic dans Gimp ne se lance pas

Bon, j'ai installé Debian 10 sur une autre machine et là Gmic dans Gimp fonctionne mais toujours pas sur mon Laptop kernal_panic.gif. Avant d'installer Debian sur mon Laptop il y avait Manjaro 18 et là aussi Gmic fonctionnait. Where is the problem ?

Hors ligne

#3 12-07-2019 17:51:27

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Gmic dans Gimp ne se lance pas

Désolé, j'ai jamais utilisé ça.

Peut-être que tu as besoin des drivers propriétaires si ça utilise l'accélération 3D pour les rendus ? Ça expliquerai la différence entre deux ordis. Juste une piste, hein ; j'en sais rien tongue

Sinon en général, essaye de trouver un message d'erreur, en lançant gimp dans un terminal avec --verbose en général, ça permet d'avoir plus de pistes que "ça marche pas il est méchant" ^^'

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#4 12-07-2019 18:30:02

Daff
Membre
Lieu : France
Distrib. : Debian 10 Buster
Noyau : 4.19 (Amd64)
(G)UI : Xfce
Inscription : 12-07-2019

Re : Gmic dans Gimp ne se lance pas

Lol "il est méchant".
Je n'utilise pas de pilotes non-libres sur mon laptop.

Avec --verbose sa donne :
(gmic_gimp:1178): GLib-GObject-WARNING **: 18:17:42.564: cannot register existing type 'GtkWidget'

(gmic_gimp:1178): GLib-GObject-CRITICAL **: 18:17:42.564: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:1178): GLib-GObject-WARNING **: 18:17:42.564: cannot register existing type 'GtkBuildable'

(gmic_gimp:1178): GLib-GObject-CRITICAL **: 18:17:42.564: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(gmic_gimp:1178): GLib-CRITICAL **: 18:17:42.564: g_once_init_leave: assertion 'result != 0' failed

(gmic_gimp:1178): GLib-GObject-CRITICAL **: 18:17:42.564: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:1178): GLib-GObject-CRITICAL **: 18:17:42.564: g_type_register_static: assertion 'parent_type > 0' failed

scratchhead.gif

Hors ligne

#5 12-07-2019 18:34:24

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Gmic dans Gimp ne se lance pas

Je ne vois rien de fatal (à mes yeux hein). Tu n'a pas de texte particulier qui apparaît quand tu essayes d'utiliser Gmic ?

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#6 12-07-2019 18:41:59

Daff
Membre
Lieu : France
Distrib. : Debian 10 Buster
Noyau : 4.19 (Amd64)
(G)UI : Xfce
Inscription : 12-07-2019

Re : Gmic dans Gimp ne se lance pas

A part les messages d'erreur avec --verbose cité précédemment il n'y a rien d'autre.

Hors ligne

#7 12-07-2019 19:16:13

Daff
Membre
Lieu : France
Distrib. : Debian 10 Buster
Noyau : 4.19 (Amd64)
(G)UI : Xfce
Inscription : 12-07-2019

Re : Gmic dans Gimp ne se lance pas

J'ai trouvé le problème.
Il y a un conflit avec Gmic dans le paquet : qt5-style-plugins ( pour : qt5ct)
Dans Paramètres Qt5, Apparence, Style si on choisit gtk2, Gmic de démarre pas (dommage pour le thème sombre) donc obligé de mettre un autre style qui pique les yeux. Pareil sur l'autre machine.
Peut-être le problème sera fixé sur Debian 11.

Dernière modification par Daff (12-07-2019 19:37:13)

Hors ligne

#8 12-07-2019 19:40:34

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Gmic dans Gimp ne se lance pas

Tu ne peux pas choisir gtk3 dans les paramètres ? il semble que l'on puisse personnaliser

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
Bien débuter sur openSUSE :
->le site officiel + le wiki frle forum fr sur alionet

Hors ligne

#9 13-07-2019 02:16:48

charles
Membre
Lieu : Drummondville, Québec
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Gnome 3.30
Inscription : 20-06-2019

Re : Gmic dans Gimp ne se lance pas

Même problème avec G'mic dans Gnome, mais j'ai été chercher le greffon gmic de leur site web
qt5-style-plugins c'est pour avoir un thème uniforme avec les programmes en Qt

Debian Buster, Ubuntu Bionic et une partition de teste Debian/Ubuntu (windows 10 et facebook supprimé depuis février 2019)

Hors ligne

#10 13-07-2019 08:54:59

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Gmic dans Gimp ne se lance pas

Oui mais gtk2 c’est en voie de disparition non ? En choisissant autre chose ....
Assures toi de choisir un thème gtk3

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
Bien débuter sur openSUSE :
->le site officiel + le wiki frle forum fr sur alionet

Hors ligne

#11 13-07-2019 10:00:40

Daff
Membre
Lieu : France
Distrib. : Debian 10 Buster
Noyau : 4.19 (Amd64)
(G)UI : Xfce
Inscription : 12-07-2019

Re : Gmic dans Gimp ne se lance pas

Pas de Gtk3 dans Style de Qt5, chalu.

Exactement Charles, c'est pour la cohérence des thèmes, est-ce qu'avec qt5-style-plugins récupérer du site tu peux mettre Gtk2 sans conflit ? Sur mon autre machine sa fait carrément planter l'outil de config Qt5 quand je met Gtk2. Je sais que dans d'autre distribution GNU Linux il n'y a pas ou plus ce problème avec style de Qt5 : Gtk2.

Hors ligne

#12 13-07-2019 17:59:42

charles
Membre
Lieu : Drummondville, Québec
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Gnome 3.30
Inscription : 20-06-2019

Re : Gmic dans Gimp ne se lance pas

l’installation de qt5-style-plugins avec cet commande

echo "export QT_QPA_PLATFORMTHEME=gtk2" >> ~/.profile

https://www.linuxuprising.com/2018/05/g … le-in.html

Gmic du dépôts Debian ne fonctionne pas
mais le Gmic du site officiel fonctionne (Linux (tested with Debian Sid): .zip archive) https://gmic.eu/download.shtml

avec Ubuntu je n'ai pas ce problème

je ne sais pas si sa répond à ta question scratchhead.gif

Dernière modification par charles (13-07-2019 18:02:37)


Debian Buster, Ubuntu Bionic et une partition de teste Debian/Ubuntu (windows 10 et facebook supprimé depuis février 2019)

Hors ligne

#13 13-07-2019 20:28:37

Daff
Membre
Lieu : France
Distrib. : Debian 10 Buster
Noyau : 4.19 (Amd64)
(G)UI : Xfce
Inscription : 12-07-2019

Re : Gmic dans Gimp ne se lance pas

Oui sa répond à la question. C'est un moyen de contourner ce problème pour avoir absolument le style "Gtk2". Je préférerai évidemment que Debian fixe ce conflit directement dans "qt5-style-plugins" et ou autres.
J'ai choisi le style "plastique" c'est pas cohérent avec le reste mais tant pis au moins Gmic du dépôt officiel de Debian fonctionne.

Dernière modification par Daff (13-07-2019 20:29:28)

Hors ligne

#14 21-07-2019 17:25:00

charles
Membre
Lieu : Drummondville, Québec
Distrib. : Buster
Noyau : Linux 4.19.0-5-amd64
(G)UI : Gnome 3.30
Inscription : 20-06-2019

Re : Gmic dans Gimp ne se lance pas

tu utilises Xfce, avec Gnome les thèmes son tous uniforme Gtk 3/2 et Qt

Debian Buster, Ubuntu Bionic et une partition de teste Debian/Ubuntu (windows 10 et facebook supprimé depuis février 2019)

Hors ligne

Pied de page des forums