Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-07-2019 14:34:52

sizy458
Membre
Distrib. : Debian Stretch
Noyau : 4.9.0-11-amd64
(G)UI : gnome
Inscription : 16-06-2018

urgent : Installer le pilote 'NVIDIA-Linux-x86_64-390.87.run'

Bonjour,

J'ai driver nvidia 390.87 installé.



nvidia-smi
Fri Jul  5 15:22:01 2019      
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.87                 Driver Version: 390.87                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GT 620      Off  | 00000000:01:00.0 N/A |                  N/A |
| 35%   39C    P8    N/A /  N/A |    280MiB /  1985MiB |     N/A      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0                    Not Supported                                       |
+-----------------------------------------------------------------------------+
 




uname -r
4.9.0-8-amd64
 





Je vais faire les mises à jours debian y compris noyau.
Aprés mise à jour ,le mode graphique risque de ne plus s'initilialiser car c'est un driver propriétaire.

Quelle sont les procedures à suivre aprés mise à jour noyau linux pour l'installation à nouveau de ce driver nvidia ?

Si je boot debian en mode 'dépannage' et que j'execute ce fichier .run , je repond oui 'opengl 32 64 .....', est ce que cela va marcher ?

Le fichier .run à l'autorisation d'execution.

Je l'avais déja fais mais je ne m'en souviens plus comment.


Merci ;

Hors ligne

#2 05-07-2019 15:25:35

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 10
(G)UI : KDE
Inscription : 21-09-2016

Re : urgent : Installer le pilote 'NVIDIA-Linux-x86_64-390.87.run'

Bonjour,
en quoi la mise à jour va impacter ton driver ? Je ne comprends pas.

Acer Aspire 5733 - Debian 10 KDE

Hors ligne

#3 20-07-2019 15:14:57

sizy458
Membre
Distrib. : Debian Stretch
Noyau : 4.9.0-11-amd64
(G)UI : gnome
Inscription : 16-06-2018

Re : urgent : Installer le pilote 'NVIDIA-Linux-x86_64-390.87.run'

J'ai mis à jour le noyau et executer en mode dépannage le fichier .run , c'est bon.

Hors ligne

#4 21-07-2019 16:22:26

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : urgent : Installer le pilote 'NVIDIA-Linux-x86_64-390.87.run'

Bonjour
il y a une commande avec dkms pour réinstaller le driver en .run sans relancer l'executable (.run)
mais pourquoi tu n'utilise pas celui de debian pour une carte GT 620 et une version 390.87
avec le .run il faut passer je suppose par : --uninstall pour retirer l'ancien , puis --install

renseigne toi , il me semble que c'est le membre éfpè qui a donné cette info

Hors ligne

#5 21-07-2019 17:19:59

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Buster/Sid/Rc-Buggy
Noyau : Linux (≥ 4.12)
(G)UI : i3-wm (≥ 4.13)
Inscription : 07-07-2008
Site Web

Re : urgent : Installer le pilote 'NVIDIA-Linux-x86_64-390.87.run'

Bonjour,
Pour info, je rappelle qu'installer le .run nvidia n'est pas la bonne manière d'installer les pilotes propriétaires nvidia sous debian. Pour cela, il y a le paquet nvidia-driver qui s'occupe de tout… et qui est « propre » (donc ne pose pas de problème à l'upgrade).

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.
Je suis parrain linux !

Hors ligne

Pied de page des forums