Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-09-2019 11:53:25

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

[Abandonné]5.1 sur un système stéréo... c'est pénible.

Bonjour,

si vous avez un système 5.1 mais avec que deux front ou comme moi un ordi sur un amplificateur avec deux enceintes, il devient vite pénible de constamment monter/baisser le son lors du visionnage d'un film avec une bande audio 5.1

Ce qui fonctionne bien chez moi, c'est de créer un fichier .asoundrc dans mon home et d'y coller ceci :


pcm.films {
  type route
  slave.pcm surround51
  slave.channels 6

  ttable.0.0 0.75
  ttable.1.1 0.75
  ttable.2.0 0.75
  ttable.3.1 0.75
  ttable.4.0 0.8
  ttable.4.1 0.8
  ttable.5.0 0.675
  ttable.5.1 0.675
}
 



dans la config mplayer ou mpv, on pourra laisser maintenant 5.1 au lieu de 2 pour l'option audio-channels
Le son fonctionne bien au visionnage d'une vidéo sur Youtube.
Je n'utilise pas pulseaudio.

Source :

https://artisan.karma-lab.net/mixer-51-20-alsa

Dernière modification par golgot200 (17-09-2019 14:40:31)

Hors ligne

#2 17-09-2019 13:37:07

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Abandonné]5.1 sur un système stéréo... c'est pénible.

Bonjour,

en fait cette méthode ne fonctionne pas. Bien sûr on a du son de partout, mais en montant les niveaux sur le fichier ci-dessous rien ne varie.

si on remplace

pcm.films {

  par

pcm.!default {

est bien là, on peut jouer sur les niveaux et ainsi rapprocher les voix lointaines dû au manque d'enceintes.
Mais voilà, firefox n'aura pas la possibilité d'émettre le moindre son sur par exemple une vidéo Youtube. Il faut donc juste installer le paquet pulseaudio. Il y a des combines sur le net, mais elles ne fonctionnent pas chez moi.
Compiler Firefox avec disable pulseaudio et enable alsa, trop chia...
Je trouve bizarre, c'est que pulseaudio n'est pas une dépendance pour firefox mais sans, c'est un canard boiteux pour moi.

Donc le .asoundrc qui va bien est donc :


# 5.1 To Stereo Downmix
# Pour Firefox, intaller pulseaudio pour le son
# des vidéos Youtube etc ...

pcm.!default {
  slave.pcm front
  slave.channels 2
  type route
  ttable.0.0 1      # FRONT   LEFT
  ttable.1.1 1      # FRONT   RIGHT
  ttable.2.0 1      # REAR    LEFT
  ttable.3.1 1      # REAR    RIGHT
  ttable.4.0 0.5    # CENTER  LEFT
  ttable.4.1 0.5    # CENTER  RIGHT
  ttable.5.0 0.5    # LFE     LEFT
  ttable.5.1 0.5    # LFE     RIGHT
}

 



Donc, comme d'habitude, je me suis trop précipité smile

Dernière modification par golgot200 (17-09-2019 13:38:06)

Hors ligne

#3 17-09-2019 14:37:12

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 4.19.77-1-lts & 5.3.1-arch1-1-ARCH
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Abandonné]5.1 sur un système stéréo... c'est pénible.

Bon, définitivement abandonné.
Ce pulse, décidement, je ne mis ferais vraiment jamais.
Refaire tout mes scripts, passe encore, mais au niveau du "tu veux du dé-réglage de son" et ben tiens en voilà . Donc stop.
J'avais oublié pourquoi j'avais viré ce truc mais il ne m'a fallu que 5 minutes pour me rafraichir la mémoire.
Le jour ou je pourrais plus faire sans lui, je trouverai encore un moyen... Le PC à la benne et le bonhomme ensuite big_smile

Dernière modification par golgot200 (17-09-2019 14:39:49)

Hors ligne

Pied de page des forums