Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-11-2019 19:54:54

Oswald
Membre
Inscription : 01-11-2018

TOR ne se lance pas après mise à jour ( résolu)

bonjour,:)

     Je suis sur Handylinux Debian à jour, pc 32 bits I386 en dual-boot avec W7 Pro car pour moi, la plupart des manipulations bureautiques sont plus faciles a effectuer avec W7 alors qu'avec Linux il faut être informaticien et je ne suis pas de la génération des ordinateurs .

     J'ai installé l'anti-virus Clamav ; je ne comprends toujours pas comment j'ai pu y arriver après une multitudes de manipulations intempestives, incohérentes, à partir du terminal et de recherche sur internet .
     Bizarre cet anti-virus qui trouve des dizaines de menaces possibles notamment dans le dossier Clamav . est-il vraiment efficace, utile ?

    En ce qui concerne le sujet TOR, la version tor-browser-linux32-8.0.3_fr.tar fonctionne parfaitement ; mais après la mise à jour, une fenêtre m'annonce qu'il va repartir dans un moment ...sans succès ; TORBrowser  ne redémarre plus, ne se lance plus . L'installation  tor-browser-linux32-9.0.1_fr.tar ne se lance pas non plus ; rien ne se passe .
    J'aurais bien mis un pdf avec photos ou images jpg mais je ne sais pas faire .

Pouvez-vous , s'il vous plait, m'indiquer la procédure à suivre, pas à pas, la solution pour remédier à ce problème ?!

Avec mes remerciements anticipés .

Oswald

Dernière modification par Oswald (04-12-2019 11:33:22)

Hors ligne

#2 23-11-2019 23:32:28

Slyfox
Membre
Distrib. : Debian Sid
Noyau : Linux 5.10.0-6-amd64
(G)UI : Mate 1.24.1
Inscription : 15-12-2013

Re : TOR ne se lance pas après mise à jour ( résolu)

Salut les ami(e)s smile

@ Oswald
Même problème que toi.

J'ai essayé d'aller voir sur le site officiel: https://www.torproject.org/fr/ malheureusement chez moi le site "semble en panne".

Ce qui peut expliqué peut-être les problèmes de mise à jour ou de fonctionnement de Tor.

NB:
Si quelqu'un à une info là dessus merci de nous donner des info.

Dernière modification par Slyfox (23-11-2019 23:33:19)

Hors ligne

#3 24-11-2019 01:51:02

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

Salut,
Pour une réponse très rapide : je vous conseillerais de simplement effacer le dossier contenant le tor browser, puis de récuperer la dernière version :

Pour GNU/linux 32bits : https://www.torproject.org/dist/torbrow … _fr.tar.xz

Pour GNU/linux 64bits : https://www.torproject.org/dist/torbrow … -IE.tar.xz

Il s'agit ici des versions « françaises », à savoir que pour se noyer plus facilement dans la masse les versions « anglaises » sont recommandées.

32bits : https://www.torproject.org/dist/torbrow … -US.tar.xz

64bits : https://www.torproject.org/dist/torbrow … -US.tar.xz

À savoir qu'il existe également un paquet Debian facilitant le téléchargement et l'installation de ce navigateur : torbrowser-launcher.
https://packages.debian.org/fr/sid/torbrowser-launcher
Qui basiquement va s'occuper de télécharger la version adaptée à votre architecture et votre langue ainsi qu'ajouter une icone de lancement dans le menu.

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#4 24-11-2019 23:33:20

Slyfox
Membre
Distrib. : Debian Sid
Noyau : Linux 5.10.0-6-amd64
(G)UI : Mate 1.24.1
Inscription : 15-12-2013

Re : TOR ne se lance pas après mise à jour ( résolu)

Salut framend smile

Le problème quand je clique sur tes 4 premiers liens j'ai le message sur Firefox "La connexion a échoué" comme si le site de Torproject était inactif. sad

Dernière modification par Slyfox (24-11-2019 23:33:39)

Hors ligne

#5 24-11-2019 23:47:41

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : TOR ne se lance pas après mise à jour ( résolu)

salut slyfox

  t'as peut etre un probleme de connexion ou avec firefox ou avec ...?
  Moi, quand je clique sur les 4 liens, j'ai la proposition de telecharher le fichier tar direct..
  et j'ai une tres mauvaise connection;
et en essayant de joindre le torproject ca marche, le site n'est pas inactif....

Hors ligne

#6 25-11-2019 00:01:13

hybridemoineau
Membre
Inscription : 21-02-2016

Re : TOR ne se lance pas après mise à jour ( résolu)

Pour le problème de départ :

https://debian-facile.org/viewtopic.php?id=25484

Hors ligne

#7 25-11-2019 01:53:19

Slyfox
Membre
Distrib. : Debian Sid
Noyau : Linux 5.10.0-6-amd64
(G)UI : Mate 1.24.1
Inscription : 15-12-2013

Re : TOR ne se lance pas après mise à jour ( résolu)

C'est bon le problème semble résolu pour moi. (il semble que la protection parental sur Firefox était activée, ce qui m’interdisait d’accéder au site torproject)

Merci pour votre aide (j’espère que Oswald pourra aussi résoudre son problème.)

Hors ligne

#8 25-11-2019 02:42:01

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

Merci hybridemoineau pour ce rappel sur apparmor.

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#9 26-11-2019 19:19:31

Oswald
Membre
Inscription : 01-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

Bonjour à tous

       J'ai désinstallé Clamav ; malgré cela TOR ne se lance pas .

      J'ai installé et essayé , comme conseillé par framend, les versions linux 32 BITS françaises, puis au cas ou...US, puis ES,de tor-browser-linux32-9.0_fr.tar.xz, tor-browser-linux32-9.0.1_fr.tar.xz .

      Seules les versions tor-browser-linux32-8.0.3_fr.tar.xz ou tor-browser-linux32-8.5_fr.tar permettent à TOR de se lancer sans problème si ce n'est que le petit oignon en haut à gauche de TOR clignote pour me signaler qu'il faut faire la mise à jour ; il ne semble pas recommandé d'aller sur internet avec TOR pas mis à jour .

       Même problème sur mon deuxième ordinateur de secours I386 32 bits .

   Pour ce qui est de faire des "ajouts" dans e dossier local de apparmor.d comme j'ai pu le voir sur une discussion concernant TOR, cela m'est impossible car dans propriétés et permissions le propriétaire et le Groupe sont root , il m'est donc impossible d'ajouter quoique ce soit .

    Merci à tous d'avoir essayé de résoudre ce problème, particulièrement framend .

     Je suis contrarié de ne plus pouvoir , pour le moment, utiliser TOR .

     Au revoir et encore merci à tous .

   Oswald

Hors ligne

#10 26-11-2019 21:59:34

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

@Oswald. As tu tenté la mise à jour ? Je n'ai aucun souvenir d'avoir installé un torbrowser et qu'il ait pu demander une mise à jour au premier lancement, mais aprés tout pourquoi pas ?

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#11 27-11-2019 10:28:45

hybridemoineau
Membre
Inscription : 21-02-2016

Re : TOR ne se lance pas après mise à jour ( résolu)

Maj ce matin des backports, qui règlent peut-être le problème sans manipulation particulière autre qu'ouvrir ces dépôts dans son sources.list pour installer torbrowser-launcher amd64 0.3.2-3~bpo10+1

puis

apt-get install -t buster-backports torbrowser-launcher

Dernière modification par hybridemoineau (27-11-2019 10:29:22)

Hors ligne

#12 27-11-2019 17:16:39

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : TOR ne se lance pas après mise à jour ( résolu)

Non, malgré la m.a.j ca ne regle pas le probleme de bug ....

Hors ligne

#13 27-11-2019 20:34:00

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

Lors de la mise à jour de tor-browser tout se passe-t-il bien (message d'erreur ou autre) ? Après la mise à jour redémarre-t-il ?

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#14 27-11-2019 22:12:19

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : TOR ne se lance pas après mise à jour ( résolu)

salut framend
voila le message lors de la mise a jour (avec la ligne supplementaire pour le debug dans /etc/apparmor/........deja inclue et le torbrowser qui marche) :

Paramétrage de torbrowser-launcher (0.3.2-3~bpo10+1) ...
Installation de la nouvelle version du fichier de configuration /etc/apparmor.d/torbrowser.Browser.firefox ...
AppArmor parser error for /etc/apparmor.d/torbrowser.Browser.firefox in /etc/apparmor.d/local/torbrowser.Browser.firefox at line 3: syntax error, unexpected TOK_END_OF_RULE, expecting TOK_MODE



apres la mise a jour, le torbrowser fonctionnait me semble-t-il me souvenir...
cf post https://debian-facile.org/viewtopic.php … 24#p317324

Dernière modification par ubub (27-11-2019 23:34:39)

Hors ligne

#15 27-11-2019 23:15:37

framend
Modo-Moule zébrée
Lieu : /home/framend
Distrib. : Sid
Noyau : 5.7.0-2-amd64
(G)UI : i3-wm/tty
Inscription : 17-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

J'avoue ne pas me servir du tor-browser et utiliser tor différement (via privoxy et un routage iptables dans certains cas). Mais si la version « portable » téléchargée sur le site ne fonctionne pas sur cette config je risque de ne pas en savoir plus.

“It is not daily increase but daily decrease, hack away the unessential. The closer to the source, the less wastage there is.” - Bruce Lee (philosophe)

Hors ligne

#16 27-11-2019 23:28:31

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : TOR ne se lance pas après mise à jour ( résolu)

désolé mais je parlais pas de la version téléchargeable sur le site du torproject mais de celle des backports pour repondre au post d' hybridemoineau...
j'ai pas testé la version du site de torproject, pas assez de debit d'internet pour tester..

on se melange là ..

Hors ligne

#17 28-11-2019 00:23:35

hybridemoineau
Membre
Inscription : 21-02-2016

Re : TOR ne se lance pas après mise à jour ( résolu)

@ubub
De mon côté, pas de problème de MAJ  des backports après avoir fait la même manip dans apparmor que celle indiquée dans ton post il y a quelques semaines, je viens de tester, mise à jour de Tor et lancement impec. Peut-être ces corrections là :

https://github.com/micahflee/torbrowser … /issues/76

https://askubuntu.com/questions/995810/ … nd-of-rule

Edit : je viens de voir ton post https://debian-facile.org/viewtopic.php?id=25499

Ca semble venir d'une manip exotique de ta part, au début....

Dernière modification par hybridemoineau (28-11-2019 00:26:06)

Hors ligne

#18 28-11-2019 00:58:07

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : TOR ne se lance pas après mise à jour ( résolu)

j'ai pas pigé le msg d'erreur, la ligne 3 du dossier c'etait la ligne préconisée pour réparer le bug..
mais bah j'ai resolu le probleme en suivant ce fil:

https://bugs.debian.org/cgi-bin/bugrepo … =942901#31

mais ca me refait un bip rouge sur le apparmor profiles lors des messages du boot;
je verrais ca plus tard, p'tet l'occase d'ouvrir un nouveau post..

Hors ligne

#19 28-11-2019 16:33:13

Oswald
Membre
Inscription : 01-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

Bonjour à tous


       Etant en dual-boot W7/Handylinux Debian à jour, pc 32 bits I386 ; j'ai constaté qu'avec W7 la mise à jour de TOR s'est faite sans problème, que TOR se lance et qu'il m'est donc possible de naviguer sur internet ; mais je ne souhaite naviguer sur internet que par l'intermédiaire de Handylinux/Débian .
        Quel peut-être le problème pour qu'à partir de Handylinux/Débian, les versions tor-browser-linux32-8.0.3 et tor-browser-linux32-8.5.5 permettent à TOR de se lancer et d'accéder à l'internet, alors que si je fais la mise à jour demandée par ces deux versions, le chargement s'effectue, une fenêtre annonce en anglais que TOR va redémarrer et rien ne se passe même en installant directement la version tor-browser-linux32-9.0.1_fr.tar.xz et  en cliquant sur l'icone ronde mauve Tor Browser ??? 

        J'ai essayé la manip de ubub/bosolo, https://debian-facile.org/viewtopic.php … 24#p317324, https://debian-facile.org/viewtopic.php?id=25499... réponse du terminal  sudo: /etc/apparmor.d/local/torbrowser.Browser.firefox: command not found  ; les permissions propriétaires et groupes sont root ..impossible d'écrire dans torbrowser.Browser.firefox :"owner /{dev,run}/shm/org.mozilla.*.* rw, "

  A vous lire pour , j'espère, une solution au problème du lancement et accès à internet de browser-linux32 sous Handylinux/Débian 32 bits

merci à tous

   Oswald

Hors ligne

#20 28-11-2019 17:11:34

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : TOR ne se lance pas après mise à jour ( résolu)

salut oswald

réponse du terminal  sudo: /etc/apparmor.d/local/torbrowser.Browser.firefox: command not found


ce n(est pas une commande comme le dis ton ordi, il faut que tu le fasse avec un editeur de texte.. t'en as plusieurs, nano, vim, emac etc...
je te conseille de  lire et essayer d'abord https://debian-facile.org/doc:editeurs: … -l-exemple  pour le faire avec nano  ou de t'entrainer un tout petit peu avec vimtutor si vim est installé sur ta machine

apt policy vim
 


ensuite:

vimtutor



j'ai jamais utilisé nano alors c'est pas moi qui vais te conseiller sur comment l'utiliser

ensuite tu tapes au choix de l'editeur choisi

sudo nano /etc/apparmor.d/local/torbrowser.Browser.firefox


ou


sudo vim /etc/apparmor.d/local/torbrowser.Browser.firefox



si tu utilises vim, une fois le fichier ouvert, t'appuis sur la touche i , y'aura ecrit insertion en bas de l'ecran
tu tapes ce que tu veux . une fois fait, tu appuie sur la touche esc pour quitter le mode insertion et tu enregistre en tapant :wq!
tu fais

sudo reboot



et tu regardes si ca marche...
bon j'espere ne pas avoir fait de fautes en t'expliquant et que ca marche...

Hors ligne

#21 01-12-2019 16:28:52

Oswald
Membre
Inscription : 01-11-2018

Re : TOR ne se lance pas après mise à jour ( résolu)

Bonjour à tous  love.gif

        Après formatage de ma partition Handylinux puis réinstallé la version 2.5 de Handylinux que j'utilisais réactualisée .; mise à jour effectuée et torbrowser32-9.1.0 réinstallé, je n'ai pu que constater que cette dernière version de TOR ne se lançait toujours  pas sous pc 32 bits i386 alors que la version 8.5.5 fonctionnait .
        Redémarrage du PC sur la clef USB qui contient la version 9 de DebianFacile que j'avais essayée l'année de mon inscription sur votre site .
       J'opte pour la version "test" de DF , récupère sur mon dualboot W7 torbrowser32 linux -9.1.0 qui ne voulait pas démarrer sur Handylinux, l'installe et, oh merveille....TOR se lance et accède très rapidement à l'internet ...Immédiatement , je formate à nouveau ma partition Linux et installe Debian Facile version 9 et déclenche  les 426 mises à jour proposées .
      Installation programmée de Debian Facile à la place de Handylinux 2.5 sur mon ordinateur 32 bits i386. de secours .

      Pour info, la dernière version torbrowser64 fonctionne sur Handylinux installé sur un PC AMD64 .

      Debian Facile est une merveille ; je suis époustouflé, enthousiasmé par la qualité de Debian Facile , soulagé e heureux de pouvoir aller sur internet avec TOR et grace à votre version, votre création Linux, être protégé des virus , trojans et autres .

           Comment puis-je ajouter au titre (résolu) ?
          Merci et bravo à tous les bénévoles qui ont participé à la création de ce bijoux .
          Merci encore à tous ceux qui ont essayé de m'aider .

        Oswald

Hors ligne

Pied de page des forums