Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-01-2020 15:59:59

lowfab
Membre
Inscription : 25-01-2020

[résolu] script client openvpn : via bash ok via systemctl nok

Bonjour,

sous une debian 9.11 j'ai un client openvpn et un serveur rtorrent.

quand je lance le client par la terminal ($ openvpn client.conf) toute se passe comme programmé :
Le client établit une connexion avec le serveur et lance rtorrent en lui indiquant l'adresse du serveur vpn (10.*.*.*) 

-> le fichier de configuration du client openvpn contient les commandes suivantes :
up /etc/openvpn/up.sh
down /etc/openvpn/down.sh

-> le script up.sh est le suivant
#! /bin/sh
sed s/IP_ADDRESS/$4/ /home/fablow/.rtorrent_template.rc > /home/fablow/.rtorrent.rc
/etc/init.d/fablow-rtorrent start

-> le fichier .rtorrent_template.rc contient la commande network.bind_address.set = IP_ADDRESS afin que les flux rtorrent ne transite que par le vpn

J'ai trouvé cette solution en m'inspirant de ce tuto (openvpn + transmission) : http://blog.idleman.fr/billet-invite-cr … pberry-pi/
et après pas mal de recherches pour l'adapter à rtorrent

Comme indiqué dans le titre, tout se passe bien quand je lance openvpn par le terminal, mais le script ne n’exécute que partiellement quand je veux que cela s'automatise en cas de reboot du serveur : l'adresse ne se met pas à jour et l'execution de la commande systemctl status openvpn@client.service indique ceci :

openvpn@client.service - OpenVPN connection to client
   Loaded: loaded (/lib/systemd/system/openvpn@.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2020-01-25 15:20:05 CET; 9min ago
     Docs: man:openvpn(8)
           https://community.openvpn.net/openvpn/w … n23ManPage
           https://community.openvpn.net/openvpn/wiki/HOWTO
  Process: 461 ExecStart=/usr/sbin/openvpn --daemon ovpn-client --status /run/openvpn/client.status 10 --cd /etc/openvpn --config /etc/openvpn/client.conf --writepid /run/openvpn/cli
Main PID: 485 (openvpn)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/system-openvpn.slice/openvpn@client.service
           └─485 /usr/sbin/openvpn --daemon ovpn-client --status /run/openvpn/client.status 10 --cd /etc/openvpn --config /etc/openvpn/client.conf --writepid /run/openvpn/client.pid

janv. 25 15:20:11 debian ovpn-client[485]: /etc/openvpn/up.sh tun0 1500 1553 10.25.252.157 255.255.255.0 init
janv. 25 15:20:11 debian su[834]: Successful su for fablow by root
janv. 25 15:20:11 debian su[834]: + ??? root:fablow
janv. 25 15:20:11 debian su[834]: pam_limits(su:session): Could not set limit for 'nproc' to soft=31331, hard=31331: Operation not permitted; uid=0,euid=0
janv. 25 15:20:11 debian su[834]: pam_limits(su:session): Could not set limit for 'nofile' to soft=1024, hard=1048576: Operation not permitted; uid=0,euid=0
janv. 25 15:20:11 debian su[834]: pam_unix(su:session): session opened for user fablow by (uid=0)

janv. 25 15:20:16 debian ovpn-client[485]: /sbin/ip route add 213.152.161.238/32 via 192.168.1.1
janv. 25 15:20:16 debian ovpn-client[485]: /sbin/ip route add 0.0.0.0/1 via 10.25.252.1
janv. 25 15:20:16 debian ovpn-client[485]: /sbin/ip route add 128.0.0.0/1 via 10.25.252.1
janv. 25 15:20:16 debian ovpn-client[485]: Initialization Sequence Completed

et la ... je sèche

Dernière modification par lowfab (29-03-2020 20:21:41)

Hors ligne

#2 31-01-2020 09:27:55

lowfab
Membre
Inscription : 25-01-2020

Re : [résolu] script client openvpn : via bash ok via systemctl nok

un idée ?

Hors ligne

#3 29-03-2020 20:21:11

lowfab
Membre
Inscription : 25-01-2020

Re : [résolu] script client openvpn : via bash ok via systemctl nok

Ayant pu faire des essais j'ai trouvé la solution

Il faut que les droits du fichier .rtorrent.rc soit root:root

Hors ligne

Pied de page des forums