Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-02-2020 19:00:50

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

[Résolu] Wifi non automatique

Sur une même station Buster Xfce, 2 utilisateurs.
. moi, le Wifi se lance automatiquement lors de l'ouverture de la session -> OK
. mon épouse, le Wifi ne se lance pas, il faut l'activer "manuellement" en passant par l'icône de connexion réseau ?
Bizarre, bizarre !
Il y a peut-être quelque chose à faire côté ~/.bashrc ?
Merci si quelqu'un a une idée.

Dernière modification par gargamel79 (17-02-2020 16:53:14)

Hors ligne

#2 15-02-2020 20:01:10

nlancien
Membre
Distrib. : Debian Stable
Noyau : Linux 4.19.0-12-amd64
(G)UI : Openbox
Inscription : 17-07-2019

Re : [Résolu] Wifi non automatique

Bonsoir,

Sur xfce l'icone de connexion reseau lance wicd? Le gestionnaire de connexion reseau est le premier lieu ou j'irais fouiner pour trouver ton problème.

Hors ligne

#3 15-02-2020 20:13:11

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [Résolu] Wifi non automatique

nlancien a écrit :

Sur xfce l'icone de connexion reseau lance wicd?

Qui te dit que c'est wicd ? Et non pas NetworkManager ?


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#4 15-02-2020 21:00:19

nlancien
Membre
Distrib. : Debian Stable
Noyau : Linux 4.19.0-12-amd64
(G)UI : Openbox
Inscription : 17-07-2019

Re : [Résolu] Wifi non automatique

Rien ne me dit... Je pose une question. gargamel n'est pas très loquace sur sa configuration.

EDIT
Si c'est wicd, il y a une case a cocher "Se connecter automatiquement a ce réseau"

Dernière modification par nlancien (15-02-2020 21:02:27)

Hors ligne

#5 15-02-2020 21:10:56

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [Résolu] Wifi non automatique

xfce c'est NetworkManager si je ne m'abuse non ?

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#6 15-02-2020 21:12:27

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Wifi non automatique

En workaround "fast 'n dirty" (=ce n'est pas la bonne manière de régler le problème, mais ça a de bonnes chance de marcher si on a la flemme de chercher) je suppose que tu pourrai créer un service systemd qui active la wifi.

La commande

rfkill unblock all




Ce qui donne :

echo "[Unit]
Description=Forcer l'activation de la wifi au démarrage
After=network-online.target

[Service]
Type=simple
ExecStart=/usr/sbin/rfkill unblock all

[Install]
WantedBy=multi-user.target
"
> /etc/systemd/system/rfkill-on.service
systemctl daemon-reload
systemctl enable rfkill-on
 

Dernière modification par otyugh (16-02-2020 00:47:40)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#7 16-02-2020 11:11:43

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Wifi non automatique

la commande:

# rfkill list


me donne:

0: phy0: Wireless LAN
  Soft blocked: yes
  Hard blocked: no


la commande:

# rfkill unblock all



laisse: Soft blocked: yes

Si l'utilisateur active "manuellement" le Wifi,  Soft blocked: no

Merci pour vos réponses, le problème semble bien du côté d'Xfce

Hors ligne

#8 16-02-2020 11:33:15

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Wifi non automatique

le problème semble bien du côté d'Xfce


Sauf que j'ai pas ce problème, moi. Et rfkill fonctionne très bien (j'utilise xfce buster) é_è

$ rfkill unblock all
$ rfkill
ID TYPE DEVICE           SOFT      HARD
0 wlan acer-wireless unblocked unblocked
$ rfkill block all
$ rfkill
ID TYPE DEVICE           SOFT      HARD
0 wlan acer-wireless blocked unblocked



...Ça me fait m'apercevoir d'un truc. Ma sortie de rfkill n'a rien à voir avec toi, donc à priori tu n'utilises pas Buster, ou alors, pas une Buster propre... Détail important : donne la sortie de

cat /etc/debian_version
cat /etc/apt/sources*

Dernière modification par otyugh (16-02-2020 11:36:55)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#9 16-02-2020 12:14:39

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Wifi non automatique

Les commandes "rfkill" et "rfkill list" donnent des retours différents, cela n'a rien de surprenant ...
De plus, je rappelle, que sur une même station, le comportement /Wifi est différent selon l'utilisateur !
Donc la station, en elle-même, ne semble pas en cause.

Hors ligne

#10 16-02-2020 12:34:39

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Wifi non automatique

Gah, je viens de comprendre.

De plus, je rappelle, que sur une même station, le comportement /Wifi est différent selon l'utilisateur !


Pour ça, je n'ai aucune explication, les préférences réseau de network-manager ne sont pas "utilisateur spécifique" mais globale, dans  /etc/NetworkManager/system-connections. - Que je sache.

En possibilité utilisateur spécifique tu as... Ahm. Un autre logiciel gestionnaire de réseau d'installé ? Genre wicd ?

Dernière modification par otyugh (16-02-2020 12:37:48)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#11 16-02-2020 16:50:25

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Wifi non automatique

Non pas de wicd installé.
J'ai essayé de supprimer le .Xauthority (spécifique de l'utilisateur) pour quil soit recréé au login; mais cela n'a rien donné...
Je ferais peut-être mieux de poster dans Xfce.
De toute façon, ce n'est pas un problème bloquant, juste un peu désagréable !

Hors ligne

#12 16-02-2020 17:07:35

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Wifi non automatique

L'état de la Wifi est stockée ici par nm : /var/lib/NetworkManager/NetworkManager.state
Sans que tu ne touches à rien, il est différent selon le profil auquel tu te connectes ?

Dernière modification par otyugh (16-02-2020 17:08:13)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#13 16-02-2020 18:28:50

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Wifi non automatique

{je vais tenter une réponse, malgré les nombreuses coupures d'électricité; je ne sais pas comment c'est en Bretagne mais dans le Baugeois, c'est pas la joie }
user avec Pb, après lancement Wifi
/var/lib/NetworkManager# cat NetworkManager.state
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
-------------------
user avec Pb, avant lancement Wifi
/var/lib/NetworkManager# cat NetworkManager.state
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
***********************
user sans problème Wifi, après lancement Wifi
/var/lib/NetworkManager# cat NetworkManager.state
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

Mais maintenant, l'utilisateur qui n'avais pas le problème rencontre le même problème /Wifi  kernal_panic.gif

Dernière modification par gargamel79 (16-02-2020 18:30:31)

Hors ligne

#14 16-02-2020 19:10:10

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Wifi non automatique

Je passe sur une autre station : Debian 10, Xfce, même compte utilisateur. La connexion au Wifi se fait normalement, à l'ouverture de la session...
Je passe à l'état [Suspendu] car ce problème semble indiquer qu'Xfce fonctionne "sur des têtes d'épingles" vis à vis de la connexion Wifi  mad

Hors ligne

#15 16-02-2020 19:25:38

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Wifi non automatique

Ça n'a rien à voir avec Xfce - je ne crois pas que Xfce ait développé le moindre utilitaire qui touche au réseau (le projet gnome a développé un petit GUI qu'on utilise le plus souvent).
Et je pense que ça n'a rien à voir non plus avec network-manager, vu que les configurations sont partagées entre les utilisateurs (et d'après tes extraits de config, c'est... Bien configuré).

Moi je concluerai que la plus grand probabilité c'est un driver wifi (ou un matériel wifi) pas fiable - ça voudrait dire que tu t'es trompé et que la connexion ne dépend pas de avec "quel compte tu te connecte" mais est en réalité totalement aléatoire. Ça serait intéressant de confirmer. Et si c'est pas ça, j'ai aucune autre idée x)

Idée : un workaround qui marcherait sinon, vu que rfkill te fait la gueule, c'est d'utilliser la ligne de commande de network manager au démarrage pour te connecter à la wifi. Vu que tu dis que ça marche en le faisant manuellement, ça devrait marcher si tu le fais du terminal.

nmcli radio wifi on


Si ça marche, il te reste plus qu'à automatiser cette commande au démarrage via

xfce4-session-settings


...ou de créer un service systemd (mais pour le coup ça me semble se faire chier pour rien).

Dernière modification par otyugh (16-02-2020 19:34:21)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#16 17-02-2020 10:45:51

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Wifi non automatique

Ça maaarche !!
Pour l'instant j'ai mis dans mon .bashrc :
nmcli radio wifi on
J'ai regardé dans

xfce4-session-settings


Mais je ne sais pas trop pour la suite dans quelle rubrique taper...
Je pense que tu as raison, j'utilise une clé Wifi avec le driver fourni par le paquet "firmware-realtek" (non-free). Il doit se lancer avec plus ou moins de bonheur.
Je suis intéressé pour savoir comment lancer un service à partir de Wfce; peut-être qu'il existe un tutoriel.
Merci pour ton aide. Je vais passer en [Résolu] ce qui est quand même plus glorieux que [Suspendu] !!!  smile

Dernière modification par gargamel79 (17-02-2020 11:05:39)

Hors ligne

#17 17-02-2020 12:02:30

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Wifi non automatique

gargamel79 a écrit :

Pour l'instant j'ai mis dans mon .bashrc


Le souci avec ça, c'est que ça va s'executer tout le temps. Dès que tu ouvres le moindre terminal dans ta session, dès que de tu loggues... En faisant ça tu t'empêche de désactiver la wifi, quoi, vu qu'elle se réactivera toute seule très souvent.

La suggestion que j'évoque ci-dessous est plus propre, la wifi ne sera activé qu'une seule fois de force au démarrage.

xfce4-session-settings


Mais je ne sais pas trop pour la suite dans quelle rubrique taper...


Je pensais que c'était trop évident pour devoir l'expliquer ^^'

* Onglet "Démarrage automatique d'application"
* Bouton "Ajouter"

Nom "Ce-que-je-veux"
Description "Ce-que-je-veux2"
Commande "nmcli radio wifi on"


* Bouton "Valider"

Et c'est fini.

Dernière modification par otyugh (17-02-2020 12:08:43)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#18 17-02-2020 16:52:19

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Wifi non automatique

Effectivement c'est beaucoup plus propre. smile
J'ai appris quelque chose sur Xfce. Merci encore, je pense que cela pourra être utile à d'autres...
Je passe en [Résolu]

Hors ligne

Pied de page des forums