Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-02-2020 14:09:32

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

[résolu]sudo ne demande plus de mot de passe

salut a tous
quand je tape sudo su dans terminale ou je tape sudo gparted ou synaptic ou nautilus ou caja
je n ai plus de demande de mot de passe
pour info j ai installer une q4os minimale une iso de q4os-3.10-x64-instcd.r2.iso de 494 mo
je n ai rien touché et meme avec l os originale j ai eu ca
je dis originale car j ai viré TDE trinity et j ai installer mate
neofetch/neo'
       _,met$$$$$gg.          kakou@q4os-desktop
    ,g$$$$$$$$$$$$$$$P.       ------------------
  ,g$$P"     """Y$$.".        OS: Debian GNU/Linux 10 (buster) x86_64
,$$P'              `$$$.     Host: OptiPlex GX520
',$$P       ,ggs.     `$$b:   Kernel: 4.19.0-8-amd64
`d$$'     ,$P"'   .    $$$    Uptime: 2 hours, 53 mins
$$P      d$'     ,    $$P    Packages: 1693 (dpkg)
$$:      $$.   -    ,d$$'    Shell: bash 5.0.3
$$;      Y$b._   _,d$P'      Resolution: 1360x768
Y$$.    `.`"Y$$$$P"'         DE: MATE
`$$b      "-.__              WM: Metacity (Marco)
  `Y$$                        WM Theme: Mojave-dark-solid
   `Y$$.                      Theme: Blue-Submarine [GTK2/3]
     `$$b.                    Icons: eOS-Y [GTK2/3]
       `Y$$b.                 Terminal: mate-terminal
          `"Y$b._             Terminal Font: Monospace 13
              `"""            CPU: Intel Pentium 4 3.40GHz (2) @ 3.391GHz
                              GPU: Intel 82945G/GZ
                              Memory: 1512MiB / 1984MiB

Dernière modification par malmsteen (26-02-2020 23:10:31)

Hors ligne

#2 26-02-2020 14:17:47

jarek
Membre
Lieu : Haute Loire
Distrib. : bullseye
Noyau : linux 5.6.0
(G)UI : Xfce4 - LightDM
Inscription : 24-06-2014

Re : [résolu]sudo ne demande plus de mot de passe

Quelle commande exactement ?

Le Diable a inventé l'Administration afin que les Hommes perdent tout espoir à jamais.
Ryzen3 3200G - Asrock B450

Hors ligne

#3 26-02-2020 14:41:32

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu]sudo ne demande plus de mot de passe

juste sudo dans un terminale ou sudo suivi d une application comme expliquer plus haut
avant quand je veux avoir un accès root depuis un terminale je tape sudo su, je rentre mon mot de passe et j ai l accès en root

root@q4os:#


maintenant il ne me demande pas le mot de passe

Hors ligne

#4 26-02-2020 14:52:12

jarek
Membre
Lieu : Haute Loire
Distrib. : bullseye
Noyau : linux 5.6.0
(G)UI : Xfce4 - LightDM
Inscription : 24-06-2014

Re : [résolu]sudo ne demande plus de mot de passe

Je ne connais que

su -


ou

sudo xxx


Lorsqu'on fait une commande sudo + mdp, il ne redemande pas le mdp au sudo suivant, c'est normal.

Tu es sous buster ou jessie ?


Le Diable a inventé l'Administration afin que les Hommes perdent tout espoir à jamais.
Ryzen3 3200G - Asrock B450

Hors ligne

#5 26-02-2020 14:55:00

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu]sudo ne demande plus de mot de passe

Debian GNU/Linux 10 (buster) x86_64
je n ai pas de compte su -
meme la preiere fois il ne demande pas de mdp

Hors ligne

#6 26-02-2020 16:45:18

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce/cwm
Inscription : 12-02-2020

Re : [résolu]sudo ne demande plus de mot de passe

Salut !

As-tu essayé de fermer la session sudo actuellement ouverte ?

sudo -k



Si tu indiques le retour des commandes suivantes, ça pourrait informer sur la nature du problème :

sudo cat /etc/sudoers
sudo cat /etc/sudoers.d/*
groups




Je me permets de corriger quelques comportements dangereux :

malmsteen a écrit :

sudo su


Tu risques d'avoir de très mauvaises surprises un jour. sad
À la place, Il faut utiliser

sudo -i



malmsteen a écrit :

sudo gparted


Il ne faut pas exécuter d'application graphique avec sudo. Si celle-ci comporte un bug, c'est dangereux. Mieux vaut utiliser pkexec justement prévu pour ça.

pkexec gparted


Cela dit, je ne connais pas les différences entre une Debian pure et Q4os. Tu nous diras si ça fonctionne nativement.

Dernière modification par Cauryl (26-02-2020 17:03:22)

Hors ligne

#7 26-02-2020 17:00:13

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu]sudo ne demande plus de mot de passe

voila

$ sudo cat /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# Please consider adding local content in /etc/sudoers.d/ instead of
# directly modifying this file.
#
# See the man page for details on how to write a sudoers file.
#
Defaults  env_reset
Defaults  mail_badpass
Defaults  secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root  ALL=(ALL:ALL) ALL

# Allow members of group sudo to execute any command
%sudo ALL=(ALL:ALL) ALL

# See sudoers(5) for more information on "#include" directives:

#includedir /etc/sudoers.d
 


sudo cat /etc/sudoers.d/*
Defaults timestamp_timeout=30
Defaults !tty_tickets
Defaults lecture=never

#Defaults env_reset
Defaults env_keep += "DISPLAY XAUTHORITY XDG_CONFIG_DIRS XDG_DATA_DIRS GTK_RC_FILES GTK2_RC_FILES QAPTDISTR QDSK_SESSION QT_QPA_PLATFORMTHEME Q4DESKTOP KDE_SESSION_VERSION"

Defaults env_keep += "ftp_proxy http_proxy https_proxy no_proxy"

#q4os passwordless helper
%sudo    ALL = NOPASSWD: /bin/dash /usr/share/apps/q4os_system/bin/q4sudo.sh *

#tde path
Defaults secure_path=/usr/local/sbin:/usr/local/bin:/opt/trinity/sbin:/usr/sbin:/opt/trinity/bin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
# apt commands
%sudo    ALL = NOPASSWD: /usr/bin/apt-get *
%sudo    ALL = NOPASSWD: /usr/bin/apt-key *
%sudo    ALL = NOPASSWD: /usr/bin/dpkg *
%sudo    ALL = NOPASSWD: /usr/lib/q4os/qapt-get *
%sudo    ALL = NOPASSWD: /usr/lib/q4os/qapt-key *
%sudo    ALL = NOPASSWD: /usr/lib/q4os/qapt-mark *
%sudo    ALL = NOPASSWD: /usr/lib/q4os/qdpkg *

Defaults env_keep += "DEBCONF_FRONTEND DEBIAN_FRONTEND"
# appsetup2 sudo helper
%sudo    ALL = NOPASSWD: /bin/dash /usr/share/apps/q4os_system/bin/appsetup2_helper.sh *
# for the first login installs, ie langpack, then remove this file
%sudo    ALL = NOPASSWD: ALL
#
# As of Debian version 1.7.2p1-1, the default /etc/sudoers file created on
# installation of the package now includes the directive:
#
#   #includedir /etc/sudoers.d
#
# This will cause sudo to read and parse any files in the /etc/sudoers.d
# directory that do not end in '~' or contain a '.' character.
#
# Note that there must be at least one file in the sudoers.d directory (this
# one will do), and all files in this directory should be mode 0440.
#
# Note also, that because sudoers contents can vary widely, no attempt is
# made to add this directive to existing sudoers files on upgrade.  Feel free
# to add the above directive to the end of your /etc/sudoers file to enable
# this functionality for existing installations if you wish!
#
# Finally, please note that using the visudo command is the recommended way
# to update sudoers content, since it protects against many failure modes.
# See the man page for visudo for more information.
#
Defaults secure_path=/usr/local/sbin:/usr/local/bin:/opt/trinity/sbin:/usr/sbin:/opt/trinity/bin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 


 groups
kakou cdrom floppy sudo audio dip video plugdev users netdev lpadmin autologin
 

Hors ligne

#8 26-02-2020 17:10:15

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce/cwm
Inscription : 12-02-2020

Re : [résolu]sudo ne demande plus de mot de passe

Je crois que le coupable est démasqué.

%sudo    ALL = NOPASSWD: ALL



Si quelqu'un qui a l'habitude de tripatouiller le fichier sudoers peut confirmer ou infirmer.

Dernière modification par Cauryl (26-02-2020 17:16:05)

Hors ligne

#9 26-02-2020 17:31:36

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [résolu]sudo ne demande plus de mot de passe

Cauryl a écrit :

Si quelqu'un qui a l'habitude de tripatouiller le fichier sudoers


Oui, le wiki df, là :
https://debian-facile.org/doc:systeme:sudo big_smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#10 26-02-2020 17:42:20

Coconuts
Membre
Lieu : Ici dans un Rucher d'abeilles
Distrib. : Debian GNU/Linux bullseye/sid
Noyau : Linux debian 5.4.0-4-amd64
(G)UI : Gnome
Inscription : 29-06-2014

Re : [résolu]sudo ne demande plus de mot de passe

smolski a écrit :

Cauryl a écrit :

Si quelqu'un qui a l'habitude de tripatouiller le fichier sudoers


Oui, le wiki df, là :
https://debian-facile.org/doc:systeme:sudo big_smile



Oui ici également  https://wiki.debian.org/fr/sudo
C’est une très mauvaise idée
Si vous voulez que les membres du groupe sudo exécutent des commandes sans mot de passe, ajoutez la ligne :

%sudo ALL=(ALL) NOPASSWD: ALL


kernal_panic.gif out.gif

Hors ligne

#11 26-02-2020 18:19:12

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu]sudo ne demande plus de mot de passe

j ai suivi le tuto j ai ajouter les lignes

Defaults        timestamp_timeout=0
 Defaults:mon_nom tty_tickets
 badaboum ALL=(ALL:ALL) ALL
 


mais rien n a changé

Hors ligne

#12 26-02-2020 21:27:29

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [résolu]sudo ne demande plus de mot de passe

Remplacer mon_nom et badaboum par le nom de l'user...
Je le précise dans le tuto immédiatement... wink

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 26-02-2020 21:32:05

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce/cwm
Inscription : 12-02-2020

Re : [résolu]sudo ne demande plus de mot de passe

smolski a écrit :

Oui, le wiki df, là :
https://debian-facile.org/doc:systeme:sudo big_smile


Très juste wink

malmsteen a écrit :

j ai suivi le tuto j ai ajouter les lignes

Defaults        timestamp_timeout=0
Defaults:mon_nom tty_tickets
badaboum ALL=(ALL:ALL) ALL


Pourquoi avoir ajouté ces lignes ?

Teste si commenter la ligne suivante résout ton problème :

%sudo ALL=(ALL) NOPASSWD: ALL

Hors ligne

#14 26-02-2020 21:35:14

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [résolu]sudo ne demande plus de mot de passe

sudo ALL=(ALL) NOPASSWD: ALL


N'est pas conseillé, cela signifie que toute personne est autorisée à entrer dans le système et y faire ce qu'il veut...
Le libre apporte de la responsabilité dans nos configurations.


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#15 26-02-2020 23:09:58

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu]sudo ne demande plus de mot de passe

merci a vous tous
problème résolu

Hors ligne

Pied de page des forums